linux----centos7 yum安装lnmp+zabbix
安装yum utils工具包,若不安装则会找不到命令yum-config-manager
yum -y install yum-utils
启用yum仓库
yum-config-manager --enable rhel-7-server-optional-rpms
使用yum直接安装php,php-gd,php-mysql,php-fpm php-mbstring php-xml
yum install -y php php-gd php-mysql php-fpm
编辑/etc目录下php.ini文件
post_max_size = 16M
max_execution_time = 300
max_input_time = 300
date.timezone = "Asia/Shanghai"
开机启动php-fpm
systemctl enable php-fpm.service
启动php-fpm
systemctl start php-fpm
配置MySQL源,此处系统是Centos7,如果系统是Centos6,则用第二条命令
Cnetos7
yum install https://dev.mysql.com/get/mysql-community-release-el7-5.noarch.rpm
Centos6
yum install http://dev.mysql.com/get/mysql-community-release-el6-5.noarch.rpm
激活MySQL5.7的源
#配置yum-config-manager命令
yum install yum-utils
#关闭MySQL5.6的源
yum-config-manager --disable mysql56-community
#激活MySQL5.7的源
yum-config-manager --enable mysql57-community-dmr
安装MySQL
yum install mysql mysql-devel mysql-server mysql-utilities
#vi /etc/my.cnf
#在mysqld字段下添加
#skip-grant-tables
#重启MySQL
#systemctl restart mysqld
#执行此条语句将密码临时设置为123456
#update mysql.user set authentication_string=password(123456) where user='root' and Host = 'localhost';
#由于MySQL5.7强制密码复杂程度,因此,此时退出MySQL,然后注释掉#skip-grant-tables,
#systemctl restart mysqld
#SET PASSWORD FOR 'root'@'localhost' = PASSWORD('1234@Mfg');
#FLUSH PRIVILEGES;
设置开机启动并启动mysql
systemctl enable mysqld
systemctl start mysqld
在命令行输入以下命令进入mysql
mysql -uroot -p
输入以下命令修改登录密码
SET password for 'root'@'localhost'=password('newpassword');
添加Nginx的yum源
在/etc/yum.repo.d下新增文件nginx.repo
在文件中写入以下代码:
[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/centos/$releasever/$basearch/
gpgcheck=0
enabled=1
使用以下代码安装nginx
yum install nginx
设置开机启动并启动nginx
systemctl enable nginx
systemctl start nginx
在命令行输入以下命令来开启80端口
firewall-cmd --zone=public --add-port=80/tcp --permanent
systemctl restart firewalld.service
关闭SELinux
编辑/etc/selinux下的config文件
SELINUX=disabled
source /etc/selinux/config
测试nginx 是否安装成功
配置Nginx
编辑/etc/nginx目录下nginx.conf文件
去掉gzip on的注释
编辑/etc/nginx/conf.d目录下的default.conf文件
修改
location /{
...
...
...
}
模块中的路径和首页未zabbix的路径为:
root /usr/share/zabbix;
index index.php;
取消
location ~ \.php${
...
...
...
}
模块的注释,并且修改
Fastcgi_param SCRIPT_FILENAME /usr/share/zabbix$fastcgi_script_name;
添加(增大nginx 缓存,否则web页面会出错)
fastcgi_buffers 8 128k;
fastcgi_buffer_size 128k;
3 安装Zabbix
安装软件仓库配置包,这个包包含了 yum(软件包管理器)的配置文件
rpm -ivh http://repo.zabbix.com/zabbix/4.0/rhel/7/x86_64/zabbix-release-4.0-1.el7.noarch.rpm
安装Zabbix Server
yum install zabbix-server-mysql zabbix-web-mysql zabbix-java-gateway
由于需要监控自己,还需要安装zabbix-agent
yum install zabbix-agent
创建zabbix数据库
create database zabbix;
修改配置文件
vim /etc/zabbix/zabbix_server.conf
#修改内容如下:
DBHost=localhost
DBName=zabbix
DBUser=zabbix
DBPassword=Zabbix@123
同步zabbix数据库,并进行web配置
同步sql到MySQL数据库
#sql文件的目录
/usr/share/doc/zabbix-server-mysql-4.0.9/create.sql.gz
#解压改文件
gunzip create.sql.gz
#进入MySQL,然后source
mysql -uroot -p1234@Mfg
use zabbix;
source /usr/share/doc/zabbix-server-mysql-4.0.9/create.sql;
#给zabbix用户权限
grant all privileges on zabbix.* to zabbix@'%' identified by 'Zabbix@123';
FLUSH PRIVILEGES;
启动zabbix-server
systemctl start zabbix-server
systemctl enable zabbix-server
进行zabbix的web配置
如果在第二步时候报错,PHP bcmath extension missing (PHP configuration parameter --enable-bcmath).
vim /etc/php.ini
#添加如下内容
extension=bcmath.so
systemctl restart nginx
systemctl restart php-fpm
成功后进入登录界面,用户名密码:admin/zabbix
linux----centos7 yum安装lnmp+zabbix的更多相关文章
- centos7 yum 安装lnmp
centos7 yum 安装lnmp 安装7.2把7.1改成7.2就行 使用第三方扩展epel源安装php7.2 #移除旧版php [root@web02 ~]# yum remove php-m ...
- Centos7 yum安装LNMP
1.Centos7系统库中默认是没有nginx的rpn包的,所以我们需要先更新下rpm依赖库 (1):使用yum安装nginx,安装nginx库 rpm -Uvh http://nginx.org/p ...
- Linux(CentOS7)yum安装卸载命令,离线下载安装包
一.Linux版本 二.yum安装 比如安装vim编辑器,y是自动应答,即默认一路确认,不用中途确认 yum install -y vim 三.yum卸载 比如卸载掉刚刚安装的vim yum eras ...
- Linux(Centos7)yum安装最新redis
正如我们所知的那样,Redis是一个开源的.基于BSD许可证的,基于内存的.键值存储NoSQL数据库.Redis经常被视为一个数据结构服务器,因为Redis支持字符串strings.哈希hashes. ...
- linux centos7.3安装lnmp,nginx-1.11.12 ,php7.0.2 ,
#更新源 yum -y update #添加用户和组 adduser www groupadd www usermod -G www www #初始化目录 mkdir -p /data/app/php ...
- (转) Linux(Centos7)yum安装最新mysql
原文:http://blog.csdn.net/gebitan505/article/details/54613549 环境 CentOS 7.1 (64-bit system) MySQL 5.6. ...
- Linux(Centos7)yum安装最新mysql
环境 CentOS 7.1 (64-bit system) MySQL 5.6.24 CentOS 安装 参考:http://www.waylau.com/centos-7-installation- ...
- CentOS7使用yum安装LNMP环境以后无法打开php页面
CentOS7使用yum安装LNMP环境以后无法打开php页面 页面提示为File not found 查看nginx错误日志/var/log/nginx/error.log提示如下 原因分析 ngi ...
- centos7 yum搭建lnmp环境及配置wordpress超详细教程
yum安装lnmp环境是最方便,最快捷的一种方法.源码编译安装需要花费大量的人类时间,当然源码编译可以个性化配置一些其它功能.目前来说,yum安装基本满足我们搭建web服务器的需求. 本文是我根据近期 ...
随机推荐
- [转载] HashMap的工作原理-hashcode和equals的区别
目录 前言 为什么需要使用Hashcode,可以从Java集合的常用需求来描述: 更深入的介绍 先来些简单的问题 HashMap的0.75负载因子 总结 我在网上看到的这篇文章,介绍的很不错,但是我看 ...
- Qt5.编译错误.error: C2338: The slot requires more arguments than the signal provides.
1.Qt563x86vs2015,遇到如下 编译错误: error: C2338: The slot requires more arguments than the signal provides. ...
- Swoole练习 Web
WEB 服务端代码 $http = new swoole_http_server("0.0.0.0", 9501); $http->on('request', functio ...
- 关于Form、ModelForm的一些操作(持续更新)
1.前端循环:后端传到前端的form是可以循环的,以此获得想要展示的元素 <form method="post" class="form-horizontal&qu ...
- Extjs GridField 总结
此代码为完整代码,其中包含定位.使用 Enter 键,来实现 Tab 键. Ext.define('xxx.recordBook.view.EditGrid', { extend: 'Ext.form ...
- [转]PHP程序员的技术成长规划
转自:http://blog.leanote.com/post/darker/PHP%E7%A8%8B%E5%BA%8F%E5%91%98%E7%9A%84%E6%8A%80%E6%9C%AF%E6% ...
- 【剑指offer】面试题 42. 连续子数组的最大和
面试题 42. 连续子数组的最大和 NowCoder 题目描述 输入一个整型数组,数组里有正数也有负数.数组中一个或连续的多个整数组成一个子数组.求所有子数组的和的最大值. 示例: 输入: [-2,1 ...
- 最详细的maven教程
转载 https://blog.csdn.net/wymrdjm/article/details/78695956 所有用Maven管理的真实的项目都应该是分模块的,每个模块都对应着一个pom.x ...
- python 之 面向对象(多态性、装饰器方法 内置函数补充)
7.6 多态性 1 什么是多态性 多态指的是同一种事物多种形态,在程序中用继承可以表现出多态.多态性:可以在不用考虑对象具体类型的前提下而直接使用对象下的方法 2.为什要用多态 用基类创建一套统一的规 ...
- Model 的使用
1. 设计数据结构 问题表Question:作用存放问题 id 主键 自增 question_text 题目 varchar120 created 创建时间 datetime 选项表Choice: ...