挂载nfs提示:mount.nfs: access denied by server while mounting...
出现此类错误原因大致为:
- 权限问题
- 防火墙机制问题
- 共享配置文件问题
搭建好nfs服务后,在client端进行挂载时,提示:
[root@web1 media]# mount -t nfs 192.168.0.124:/server/tools/repo /media/centos/
mount.nfs: access denied by server while mounting 192.168.0.124:/server/tools/repo
查看了一下client端是否被占用了:
[root@web1 media]# mount -t nfs 192.168.0.124:/server/tools/repo /media/centos/
mount.nfs: access denied by server while mounting 192.168.0.124:/server/tools/repo
[root@web1 media]# mount
/dev/sda3 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=,mode=)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
发现并没有,然并卵。
接着就上server端查看/etc/exports配置文件:
[root@fenfa scripts]# cat /etc/exports
exporting 192.168..*:/server/tools/repo
exporting 192.168..*:/data
把192.168.0.24的/server/tools/repo共享给同一个网段的所有服务器,把IP格式规范为192.168.0.0/24或192.168.0.0/255.255.255.0
[root@fenfa scripts]# vim /etc/exports
[root@fenfa scripts]# exportfs -rv
exporting 192.168.0.0/:/server/tools/repo
exporting 192.168.0.0/:/data
[root@fenfa scripts]# showmount -e 127.0.0.1
Export list for 127.0.0.1:
/server/tools/repo 192.168.0.0/
/data 192.168.0.0/
我们再从client端上从新挂载:
[root@web1 media]# mount -t nfs 192.168.0.124:/server/tools/repo /media/centos/
[root@web1 media]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda3 19G .8G 16G % /
tmpfs 491M 491M % /dev/shm
/dev/sda1 194M 29M 155M % /boot
192.168.0.124:/server/tools/repo 19G .7G 11G % /media/centos
is ok!
如果卸载的时候提示: umount:/mnt:device is busy;解决方法:需要退出挂载目录再进行卸载,或者是否NFS server宕机了
[root@web1 nginx-1.6.]# umount -t nfs 192.168.0.124:/server/tools/rep /media/centos/
umount: 192.168.0.124:/server/tools/rep: not found
umount.nfs: /media/centos: device is busy
[root@web1 nginx-1.6.]# umount -t nfs 192.168.0.124:/server/tools/rep /media/centos/
[root@web1 nginx-1.6.]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda3 19G .9G 16G % /
tmpfs 491M 491M % /dev/shm
/dev/sda1 194M 29M 155M % /boot
需要强制卸载:mount –lf /mnt
此命令也可以:fuser –km /mnt 不建议用
挂载nfs提示:mount.nfs: access denied by server while mounting...的更多相关文章
- mount.nfs: access denied by server while mounting localhost:/home/xuwq/minilinux/system
在执行命令如下: mount -t nfs localhost:/home/xuwq/minilinux/system /mnt 出现的错误: mount.nfs: access denied by ...
- OS + RedHat 6.3 x64 NFS / mount.nfs: access denied by server while mounting
s Linux mount/unmount命令(转) https://www.cnblogs.com/xd502djj/p/3809375.html 问题2:NFS配置项no_root_squash和 ...
- 解决mount.nfs: access denied by server while mounting错误
环境:oraclelinux6.7 以前在centos服务器上安装nfs.挂载NFS都没出现问题,今天在oraclelinux上安装后,在客户端mount的时候报mount.nfs: access d ...
- nfs mount 故障 mount.nfs: access denied by server while mounting 10.0.100.208:/backup_usb
生产环境: 服务端centos7.2,客户端:ubuntu16.04 挂载出现的故障: root@HDCtrl100:/mnt# mount -t nfs 10.0.100.208:/backup_u ...
- 解决mount.nfs: access denied by server while mounting
在linux下进行挂载时突然出现: mount.nfs: access denied by server while mounting 第一感觉是读取文件权限不够,准备去更改一下挂载点的权限,但又考 ...
- mount.nfs: access denied by server while mounting <SERVER IP>:<SERVER PATH>
root@hipchat:~# mount -t nfs 192.168.10.220:/hipchat/share /home/share/nfs mount.nfs: access denied ...
- Ubuntu 出现access denied by server while mounting
3516cv500板端nfst调试时如此配置 虚拟机: #vi /etc/exports 添加 /home/"待分享文件路径" *(rw,sync,no_root_squas ...
- nfs挂载出错:mount.nfs: access denied by server while mounting
这个问题就是服务器不允许客户端去挂载,那么修改服务端的权限 $ sudo vi /etc/hosts.deny 文本末添加 ### NFS DAEMONS portmap: ALL lockd: AL ...
- mount.nfs: access denied by server while mounting
在利用centos7系统搭建NFS服务时出现如下问题,百度后才解决 因为当时在服务器端vim /etc/exports 时, 我只写了 这一行 /home/wjs-nfs *(ro) (没想到偷懒出 ...
随机推荐
- k8s 传参给docker env command、args和dockerfile中的entrypoint、cmd之间的关系
[k8s]args指令案例-彻底理解docker entrypoint 需求: 搞个镜像,可以运行java -jar xxx.jar包,xxx.jar包名称要用参数传 思路1: 打对应运行ja ...
- 用Java和Nodejs获取http30X跳转后的url
用Java和Nodejs获取http30X跳转后的url 转 https://calfgz.github.io/blog/2018/05/http-redirect-java-node.html 30 ...
- Python之schedule用法,类似linux下的crontab
# -*- coding: utf-8 -*- # author:baoshan import schedule import time def job(): print("I'm work ...
- 小数末尾是0的,不显示0,有值才显示 StringFormat
JAVA public static void main(String[] args) { DecimalFormat df = new DecimalFormat("###.##" ...
- shell 数学计算的N个方法
let使用方法 root@172-18-21-195:/tmp# n1=5 root@172-18-21-195:/tmp# n2=10 root@172-18-21-195:/tmp# let re ...
- 导入一个eclipse的java项目到IDEA报Cannot find JDK '1.7' for module 'TEST'
解决办法: 右键你的项目--------------->OPen module settings 将dependencies里面的module sdk改成你安装的java版本就可以了(比如我电脑 ...
- [LeetCode] 280. Wiggle Sort 摆动排序
Given an unsorted array nums, reorder it in-place such that nums[0] <= nums[1] >= nums[2] < ...
- 【视频开发】【CUDA开发】ffmpeg nvenc编码
花时间研究了一些ffmpeg的nvenc,本来想我已经有了cuvid,然后又搞出来了nvenc,应该可以做个全套的英伟达的转码了,没想到ffmpeg官网下载的动态库没有cuvid,windows上编译 ...
- JAVAWEB实现增删查改(图书信息管理)之修改功能实现
首先通过点击index.jsp页面的修改按钮,获取该行的id:↓ 其次,跳转到updateBooks.jsp页面进行修改信息,页面代码如下:↓ <%@ page import="Boo ...
- Linux系统下Redis单机版的安装详细教程
Linux系统下Redis单机版的安装详细教程 1.下载软件安装包并上传到root目录 这里以旧版本的3.0进行安装,比较成熟稳定,具体软件可以通过qq群534073451文件下载