JVM参数MetaspaceSize的误解
前言
昨天谢照东大神在群里提出一个问题:怎么查看Metaspace里具体包含的是什么,起因是他的某个服务设置了-XX:MetaspaceSize=512m -XX:MaxMetaspaceSize=512m,但是通过jstat -gcutil pid查看M的值为98(M的=MU/MC),即Metaspace区的使用量达到了512m*98%。遗憾的是,这个推算是错误的;
推理
以笔者测试环境上某个服务为例,配置了-XX:MetaspaceSize=256m -XX:MaxMetaspaceSize=256m,通过jstat -gcutil pid查看M的值为98.32,即Meta区使用率也达到了98.32%:

然后,再通过jstat -gc 4210 2s 3命名查看,结果如下图所示,计算MU/MC即Meta区的使用率确实达到了98.32%,但是MC,即Metaspace Capacity只有55296k,并不是参数MetaspaceSize指定的256m:

那么-XX:MetaspaceSize=256m的含义到底是什么呢?其实,这个JVM参数是指Metaspace扩容时触发FullGC的初始化阈值,也是最小的阈值。这里有几个要点需要明确:
- 如果没有配置
-XX:MetaspaceSize,那么触发FGC的阈值是21807104(约20.8m),可以通过jinfo -flag MetaspaceSize pid得到这个值; - 如果配置了
-XX:MetaspaceSize,那么触发FGC的阈值就是配置的值; - Metaspace由于使用不断扩容到
-XX:MetaspaceSize参数指定的量,就会发生FGC;且之后每次Metaspace扩容都会发生FGC; - 如果Old区配置CMS垃圾回收,那么扩容引起的FGC也会使用CMS算法进行回收;
- 如果MaxMetaspaceSize设置太小,可能会导致频繁FGC,甚至OOM;
任何一个JVM参数的默认值可以通过java -XX:+PrintFlagsFinal -version |grep JVMParamName获取,例如:
java -XX:+PrintFlagsFinal -version |grep MetaspaceSize
验证
笔者的环境,服务启动后,MU的值稳定在55296k,那么设置-XX:MetaspaceSize=50m -XX:MaxMetaspaceSize=256m,按照上面的推理,会发生一次CMS GC,事实也确实如此,部分gc日志如下所示:
... ...
12.863: [GC (Allocation Failure) 2018-03-20T11:28:34.733+0800: 12.863: [ParNew: 114680K->10355K(118016K), 0.0222201 secs] 165666K->64213K(249088K), 0.0224408 secs] [Times: user=0.06 sys=0.00, real=0.02 secs]
[Times: user=0.06 sys=0.00, real=0.02 secs]
14.813: [GC (Allocation Failure) 2018-03-20T11:28:36.683+0800: 14.813: [ParNew: 115315K->10436K(118016K), 0.0263959 secs] 169173K->68441K(249088K), 0.0266341 secs] 169173K->68441K(249088K), 0.0266341 secs] [Times: user=0.08 sys=0.00, real=0.03 secs]
14.841: [GC (CMS Initial Mark) [1 CMS-initial-mark: 58004K(131072K)] 70447K(249088K), 0.0055264 secs] [Times: user=0.01 sys=0.00, real=0.00 secs]
14.847: [CMS-concurrent-mark-start]
14.931: [CMS-concurrent-mark: 0.084/0.084 secs] [Times: user=0.20 sys=0.01, real=0.09 secs]
14.931: [CMS-concurrent-preclean-start]
14.933: [CMS-concurrent-preclean: 0.002/0.002 secs] [Times: user=0.00 sys=0.00, real=0.00 secs]
14.933: [CMS-concurrent-abortable-preclean-start]
15.378: [CMS-concurrent-abortable-preclean: 0.434/0.445 secs] [Times: user=1.47 sys=0.01, real=0.45 secs]
15.379: [GC (CMS Final Remark) [YG occupancy: 69119 K (118016 K)]2018-03-20T11:28:37.249+0800: 15.379: [GC (CMS Final Remark) 2018-03-20T11:28:37.249+0800: 15.379: [ParNew: 69119K->5190K(118016K), 0.0214183 secs] 127124K->66735K(249088K), 0.0216553 secs] [Times: user=0.06 sys=0.00, real=0.02 secs]
15.401: [Rescan (parallel) , 0.0066413 secs]2018-03-20T11:28:37.278+0800: 15.407: [weak refs processing, 0.0001017 secs]2018-03-20T11:28:37.278+0800: 15.408: [class unloading, 0.0001017 secs]2018-03-20T11:28:37.278+0800: 15.408: [class unloading, 0.0184354 secs]2018-03-20T11:28:37.296+0800: 15.426: [scrub symbol table, 0.0126010 secs]2018-03-20T11:28:37.309+0800: 15.439: [scrub string table, 0.0020576 secs][1 CMS-remark: 61544K(131072K)] 66735K(249088K), 0.0638636 secs] [Times: user=0.15 sys=0.00, real=0.06 secs]
15.444: [CMS-concurrent-sweep-start]
15.479: [CMS-concurrent-sweep: 0.035/0.035 secs] [Times: user=0.14 sys=0.00, real=0.04 secs]
15.479: [CMS-concurrent-reset-start]
15.483: [CMS-concurrent-reset: 0.004/0.004 secs] [Times: user=0.01 sys=0.01, real=0.00 secs]
... ...
通过
14.841: [GC (CMS Initial Mark) [1 CMS-initial-mark: 58004K(131072K)] 70447K(249088K), 0.0055264 secs] [Times: user=0.01 sys=0.00, real=0.00 secs]这行日志可知:Old区还远远达不到70%(-XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=70)触发CMS GC的条件。所以,这次CMS GC是Metaspace区扩容达到-XX:MetaspaceSize=50m触发的。
建议
MetaspaceSize和MaxMetaspaceSize设置一样大;- 具体设置多大,建议稳定运行一段时间后通过
jstat -gc pid确认且这个值大一些,对于大部分项目256m即可。
JDK7的PermSize
JDK8+移除了Perm,引入了Metapsace,它们两者的区别是什么呢?Metasace上面已经总结了,无论-XX:MetaspaceSize和-XX:MaxMetaspaceSize两个参数如何设置,随着类加载越来越多不断扩容调整,直到MetaspaceSize(如果没有配置就是默认20.8m)触发FGC,上限是-XX:MaxMetaspaceSize,默认是几乎无穷大。而Perm的话,我们通过配置-XX:PermSize以及-XX:MaxPermSize来控制这块内存的大小,jvm在启动的时候会根据-XX:PermSize初始化分配一块连续的内存块,这样的话,如果-XX:PermSize设置过大,就是一种赤果果的浪费。很明显,Metapsace比Perm好多了^^;
JDK7 Perm 验证如下--设置-XX:PermSize=64m -XX:MaxPermSize=64m,那么PC初始化就是64m:

JVM参数MetaspaceSize的误解的更多相关文章
- jvm参数优化
一.HotSpot JVM 提供了三类参数 现在的JVM运行Java程序(和其它的兼容性语言)时在高效性和稳定性方面做的非常出色.例如:自适应内存管理.垃圾收集.及时编译.动态类加载.锁优化等.虽然有 ...
- JVM基础系列第11讲:JVM参数之堆栈空间配置
JVM 中最重要的一部分就是堆空间了,基本上大多数的线上 JVM 问题都是因为堆空间造成的 OutOfMemoryError.因此掌握 JVM 关于堆空间的参数配置对于排查线上问题非常重要. tips ...
- jvm参数及分析工具
-Xmx4G 设置堆的最大内存大小为4GB,也可通过-XX:MaxHeapSize=4GB进行设置 -Xms256m 设置堆的初始内存大小为256兆,如果未设置此选项,则初始大小将设置为新生代和年老代 ...
- Intellij IDEA 设置启动JVM参数
目录 采用CMS垃圾回收配置: 采用G1垃圾回收配置: 参数说明: 通用参数: CMS机制才有的参数: G1机制才有的参数: 参考: 打开 IDEA 安装目录,看到有一个 bin 目录,其中有两个 v ...
- jvm参数与GC
一.JVM的新生代.老年代.与永久代 JVM中的堆,一般分为三大部分:新生代.老年代.永久代: 1.新生代:主要是用来存放新生的对象,一般占据堆的1/3空间.由于频繁创建对象,所以新生代会频繁触发Mi ...
- weblogic基本目录介绍,位数查看,启动与发布项目,修改JVM参数,设置项目为默认项目
这里的基本目录%base%表示安装目录,如我的目录为:E:/weblogic就是%base% 1.weblogic目录介绍 weblogic主要的目录介绍: 1.日志目录: 每个domain(域)都有 ...
- JVM参数配置&&命令工具
JVM参数配置 大致方向:JVM调优的目的是保证在一定吞吐量的情况下尽可能的减少GC次数,从而减少系统停顿时间,提高服务质量和效率. 其中减少GC次数的原则: 将新生代转换成老年代的数量降至最少(及时 ...
- SpringBoot项目配置Tomcat和JVM参数
设置Tomcat端口号和连接数等 使用application.properties配置文件有一些参数无法设置,所以推荐创建一个类文件来配置,如下: package com.qipai.springbe ...
- JVM参数及调优
## 3.2.1 JVM参数及调优 ### 调优基本概念 在调整JVM性能时,通常有三个组件需要考虑:1. 堆大小调整2. 垃圾收集器调整3. JIT编译器 大多数调优选项都与调整堆大小和选择合适的垃 ...
随机推荐
- errno , perror,strerror
1. 简介 很多系统函数在错误返回时将错误原因记录在libc定义的全局变量errno中,每种错误原因对应一个错误码. errno在头文件errno.h中声明,是一个整型变量,所有错误码都是正整数. 然 ...
- spinner自定义,效果如腾讯QQ账号选择时候的下拉列表
下拉列表在android中自带spinner的有时候不太适合我们的界面,我们希望有自己的一种显示方法,那怎么办?自定义Spinner.效果如QQ账号选择一样.如图所以. 这种效果,如果你喜欢 ...
- os.waitpid()无法获取sys.exit()退出时的status code
[目的] 父进程使用os.waitpid()等待子进程退出,并检测子进程的exit code,以决定是否重启子进程. (常见的应用场景是:子进程接收外部命令,收到"stop"时退出 ...
- 爪哇国新游记之十三----XML文件读写
/** * XML读写示例 * @author hx * */ public class XmlReaderWriter{ /** * 读取一个XML文件,返回一个雇员链表 * @param file ...
- ASP.NET WEB API处理流程
前言:大图请看 http://www.asp.net/posters/web-api/ASP.NET-Web-API-Poster.pdf Web Api Hosting 我们不仅可以通过Web应用程 ...
- JavaScript Map 实现
//定义map function Map() { this.container = {}; } //将key-value放入map中 Map.prototype.put = function(key, ...
- Springmvc UPDATE 数据时 ORA-01858:a non-numeric character was found where a numeric was expected
ORA-01858:a non-numeric character was found where a numeric was expected 异常. 我的代码: 主要是绑定变量带出来的问题. 出错 ...
- ClientViaBehavior行为
ClientViaBehavior行为: 紧接红框:方式,也支持配置的应用方式
- js - 关于this、new、原型
1.this误区 # 第三方学习 http://www.cnblogs.com/wangfupeng1988/p/3988422.html - this不是函数自身的引用,this实际上是在函数被调用 ...
- FreeSWITCH技巧:如何向通话的另一方号码发送dtmf?
注:这里的文章都是本人的日常总结,请尊重下个人的劳动成果,转载的童鞋请注明出处,谢谢. 如您转载的文章发生格式错乱等问题而影响阅读,可与本人联系,无偿提供本文的markdown源代码. 联系邮箱:ji ...