虽然网上有很多关于这个问题的解决方案,但是我还是决定自己再次重复写一下这个解决的方案,重在更新知识和了解VMware workstation 15新功能。

在使用VMware workstation克隆CentOS7.X系列系统的虚拟机时,不管是链接克隆还是完整克隆,极可能出现下面网卡无法启动问题:

注:目前亲测VMware workstation 15不存在这种问题,在文章后面我会解释为什么不会以及我写这篇文章的目的。

1 ifup ens33
2
3 Error:Connection activation failed: No suitable device found for this connection

这个问题出现的原因是:MAC地址相同,导致冲突

克隆虚拟机,默认它的网卡MAC地址依然是以前模板机的MAC,这样MAC地址就会冲突,当系统使用NetworkManager来管理网卡时

NetworkManager就不允许MAC地址相同,就导致网卡直接起不来,但是CentOS6.X就不会,因为它用的是network来管理。

解决方案:

1、如果不打算用NetworkManager,那么就直接关闭NetworkManager即可

1 systemctl stop NetworkManager      # 停止NetworkManager
2 systemctl mask NetworkManager    # 禁用NetworkManager,类似Windows的禁用
3 systemctl disable NetworkManager # 开机不启动

2、更改MAC地址

1)通过VMware workstation 的虚拟机管理界面,直接删除以前的网卡,重新添加,或者点击高级,修改MAC地址和模板机不一样,如下图:

2)然后启动系统,修改网卡配置文件/etc/sysconfig/network-scripts/ifcfg-XXX

中的参数HWADDR=新的网卡MAC

3)如果/etc/udev/rules.d/目录下面存在70-persistent-net.rules这个文件,那么就将里面的网卡MAC地址改为新的网卡MAC

为什么说如果/etc/udev/rules.d/目录下面存在70-persistent-net.rules这个文件呢?

因为如果安装CentOS7系统的时候就在内核中启用了net.ifnames=0 biosdevname=0,即表示不用CentOS7的网卡命名规则,而用传统的

eth0...ethn的网卡规则,那么就默认在系统中就没有这个文件,其他方式安装的系统,尽管是安装以后再次更改为传统网卡命名规则,这个文件依然还是有的。

重要:以上是VMware workstation 15 以前才会出现的问题,在VMware workstation 15中,这个问题已经不会出现了

因为在VMware workstation 15中克隆虚拟机,不管是链接克隆还是完整克隆,都会自动生成并替换网卡的MAC地址,那么上面的问题就不会出现了。

至于VMware workstation 15以前哪些版本可以支持克隆时自动更改网卡MAC,目前还没有亲测,但是VMware workstation 15本人亲测是没问题的。

我写这篇文章的目的:主要在于更新网上很多比较旧的解决方案文章(虽然很多),也许有点给VMware workstation 15打广告的嫌疑,

但是重点还是让知识能够更新一下。

 

Error:Connection activation failed: No suitable device found for this connection 问题最新解决方案的更多相关文章

  1. Error:Connection activation failed: No suitable device found for this connection

    原文链接: https://blog.csdn.net/baiboya/article/details/80452822 ens33这个网卡一直无法激活,在网上找了半天,找到这个博主的文章,才解决,虽 ...

  2. linux7,一台物理机上使用VM装多个虚拟机,始终只有一个虚拟机网络正常,其他虚拟机报错Error: Connection activation failed: No suitable device found for this connection.

    今天在VM新装了一个虚拟机,结果发现原来的虚拟机连不上了,重启网络服务后报错 Error: Connection activation failed: No suitable device found ...

  3. CentOS6.5 重启网络报错:Bringing up interface eth0: Error: Connection activation failed: Device not managed by NetworkManager or unavailable

    CentOS6.5 重启网络报错: Bringing up interface eth0: Error: Connection activation failed: Device not manage ...

  4. linux中启动网卡报错:Bringing up interface eth1: Error: Connection activation failed

    在重启linux网络服务的时候提示: Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/2 并且产生报错 ...

  5. centos 7:network: 正在打开接口 ens33: 错误:激活连接失败:No suitable device found for this connection.

    Mar :: localhost systemd: Starting LSB: Bring up/down networking... Mar :: localhost network: 正在打开环回 ...

  6. Bringing up interface eth0: Error:Connection activation failed:Device not managed by NetworkManager

    Just follow the below steps and everything will be ok...   1. Remove Network Manager from startup Se ...

  7. Connection activation failed Device not managed by NetworkManager

    1)查看NetworkManager服务是否启动 ps aux |grep NetworkManager 使用service NetworkManager start 命令启动该网络管理程序 2) 一 ...

  8. Centos7没有IP地址,查看网络状态显示No suitable device found for this connection (devint match))

    今天打开虚拟机,使用 ifconfig 命令时,没有显示出 IP 地址 (更好的阅读体验可访问 这里 ) 使用 systemctl status network 命令查看网络状态 显示没有合适的网络装 ...

  9. 如何解决虚拟机克隆导致"Bringing up interface eth0: Error: No suitable device found: no device found for connection 'System eth0'."

    在VMware的虚拟机中克隆CentOS,在重启网卡的时候报错: Bringing up interface eth0:  Error: No suitable device found: no de ...

随机推荐

  1. Linkerd 2.10(Step by Step)—4. 如何配置外部 Prometheus 实例

    Linkerd 2.10 系列 快速上手 Linkerd v2 Service Mesh(服务网格) 腾讯云 K8S 集群实战 Service Mesh-Linkerd2 & Traefik2 ...

  2. python 日期与字符串之间的转换

    1.str转换为datetime >>> from datetime import datetime >>> cday = datetime.strptime('2 ...

  3. k8s-记一次安全软件导致镜像加载失败

    近期在现场项目中遇到了一个镜像加载失败的问题,相关报错如下: Error processing tar file(exit status 1): symlink . /usr/bin/X11: per ...

  4. 想自己写框架?不了解Java注解机制可不行

    无论是在JDK还是框架中,注解都是很重要的一部分,我们使用过很多注解,但是你有真正去了解过他的实现原理么?你有去自己写过注解么? 概念 注解(Annotation),也叫元数据.一种代码级别的说明.它 ...

  5. 微信订阅号中获取openid以及个人信息

    采用的方式是利用另一个服务号获取用户信息. 其中有一个问题就是不关注这个服务号获取不了用户头像等信息.

  6. Centos7搭建内网DNS服务器

      一.配置阿里云yum源 执行脚本配置阿里云的yum源,已配置yum源的可以忽略 #!/bin/bash # ******************************************** ...

  7. jquery鼠标移入移出事件

    <!DOCTYPE html><html> <head>    <meta http-equiv="Content-type" conte ...

  8. 仅使用JsonUtility和File类实现Json数据读写

    using System.Collections; using System.Collections.Generic; using UnityEngine; using System; using S ...

  9. 05 jumpserver权限管理

    5.权限管理: 在同一个组下的用1户之间,资产是共享的. (1)为10.0.0.121_slavenode1资产授权: (2)为10.0.0.201_lc-pc资产授权: (3)查看授权列表:

  10. js 对json数据进行检索 插件 linq.js

    有时界面需要很多数据.但是多次访问服务器效率很低,所以需要检索json数据,最好是像sql查询语句那种 linq.js 插件 LINQ,语言集成查询(Language Integrated Query ...