今天在测试大商创后台系统时,打开店铺结算,查看店铺对应的订单列表时,该列表自动跳转到502,查看线上和测试环境都能正常打开,唯独我的电脑上打开是502,

查询nginx的error.log日志,记录了如下错误

2019/11/26 10:38:55 [error] 328604#333604: *10 upstream sent too big header while reading response header from upstream, client: 127.0.0.1, server: myshop.cn, request: "GET /admin/merchants_commission.php?act=commission_amount&seller=1,2,4,65,69,70,71,72,73,76,81,82,83,85,162&1574735928782782 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "myshop.cn", referrer: "http://myshop.cn/admin/merchants_commission.php?act=list"
2019/11/26 10:38:59 [error] 328604#333604: *3 upstream sent too big header while reading response header from upstream, client: 127.0.0.1, server: myshop.cn, request: "GET /admin/merchants_commission.php?act=commission_amount&type=all&cycle=-1&1574735928776776 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "myshop.cn", referrer: "http://myshop.cn/admin/merchants_commission.php?act=list"
2019/11/26 10:39:00 [error] 328604#333604: *15 upstream sent too big header while reading response header from upstream, client: 127.0.0.1, server: myshop.cn, request: "GET /admin/merchants_commission.php?act=order_list&id=1 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "myshop.cn", referrer: "http://myshop.cn/admin/merchants_commission.php?act=edit&id=1"
2019/11/26 10:39:00 [error] 328604#333604: *15 CreateFile() "D:/phpstudy_pro/WWW/youhou/admin/error/502.html" failed (3: The system cannot find the path specified), client: 127.0.0.1, server: myshop.cn, request: "GET /admin/error/502.html HTTP/1.1", host: "myshop.cn", referrer: "http://myshop.cn/admin/merchants_commission.php?act=edit&id=1"
2019/11/26 10:39:00 [error] 328604#333604: *15 CreateFile() "D:/phpstudy_pro/WWW/youhou/error/404.html" failed (3: The system cannot find the path specified), client: 127.0.0.1, server: myshop.cn, request: "GET /admin/error/502.html HTTP/1.1", host: "myshop.cn", referrer: "http://myshop.cn/admin/merchants_commission.php?act=edit&id=1"

百度了一下,找到了解决方法,再此记录一下

在 nginx.conf 的http段,加入下面的配置:

proxy_buffer_size 128k;

proxy_buffers  32 32k;

proxy_busy_buffers_size 128k;

重启后一般就可以解决, 如果还是报502,再在host配置的php段加入下面配置:

fastcgi_buffer_size 128k;

fastcgi_buffers 4 256k;

fastcgi_busy_buffers_size 256k;

重启nginx即可。

参考:https://www.jianshu.com/p/389f45d0e7a2

  

今天测试大商创,遇到了 upstream sent too big header while reading response header from upstream的更多相关文章

  1. nginx 错误502 upstream sent too big header while reading response header from upstream

    查看nginx的错误日志,得到以下错误信息:upstream sent too big header while reading response header from upstream按字面意思理 ...

  2. 修复Nginx 502错误:upstream sent too big header while reading response header from upstream

    原文出处:https://www.cnblogs.com/jpfss/p/10237463.html 便于以后参考我复制了过来! cookies的值超出了范围我是说 看看了一下日志 错误502 ups ...

  3. nginx log 错误502 upstream sent too big header while reading response header from upstream

    cookies的值超出了范围我是说 看看了一下日志 错误502 upstream sent too big header while reading response header from upst ...

  4. 出现upstream sent too big header while reading response header from upstream错误

    一个POS系统,出现upstream sent too big header while reading response header from upstream错误. 1.反向代理端,可以放到se ...

  5. nginx 502错误 upstream sent too big header while reading response header from upstream

    原本的设置是 proxy_buffer_size 4k; proxy_buffers 4 32k; proxy_busy_buffers_size 64k; 在这种配置下,使用fiddler进行抓包分 ...

  6. Nginx 502错误:upstream sent too big header while reading response header from upstream

    原因: 在使用Shiro的rememberMe功能时,服务器返回response的header部分过大导致. 解决方法: https://stackoverflow.com/questions/238 ...

  7. 修复Nginx报错:upstream sent too big header while reading response header from upstream

    在 nginx.conf 的http段,加入下面的配置: proxy_buffer_size 128k; proxy_buffers 32k; proxy_busy_buffers_size 128k ...

  8. Nginx" upstream prematurely closed connection while reading response header from upstream"问题排查

    问题背景 我们这边是一个基于Nginx的API网关(以下标记为A),最近两天有调用方反馈,偶尔会出现502错误,我们从Nginx的error日志里看,就会发现有" upstream prem ...

  9. upstream timed out (110: Connection timed out) while reading response header from upstream, client:

    遇到的问题 之前没配置下面这段,访问时候偶尔会出现 504 gateway timeout,由于偶尔出现,所以不太好排查 proxy_connect_timeout 300s;proxy_read_t ...

随机推荐

  1. 如何检测域名是否被微信屏蔽 微信域名检测接口API是如何实现

    微信域名检测技术的主要用户是微信域名防封,大家知道拼多多这种网站,靠诱导分享方式在微信里面摇身一变已经估值160亿美元,身价仅次于京东了 ,这是何等的速度,简直是惊为天人,but 如果你想玩微信病毒营 ...

  2. codeforces gym #101161H - Witcher Potion(状压DP)

    题目链接: http://codeforces.com/gym/101161/attachments 题意: 总共有n瓶药可供选择 每瓶药可以增加$e_i$点体力,和$p_i$点毒性 每分钟消耗1点毒 ...

  3. matlab 计算灰度图像的一阶矩、二阶矩、三阶矩

    ​   一阶矩,定义了每个颜色分量的平均强度 ​  二阶矩,反映待测区域颜色方差,即不均匀性 ​  三阶矩,定义了颜色分量的偏斜度,即颜色的不对称性 close all;clear all;clc; ...

  4. CoreText学习(二)之Hello world

    最后更新:2017-08-10 部分内容丢失,后续补上 相关配置: Xcode 8.3.3 Swift 3.0 macOS Sierra 一.CoreText 简介 CoreText 是用于处理文字和 ...

  5. 修改tomcat控制台的标题

    Tomcat的bin目录下,创建一个名为setenv.bat的文件. setenv.bat  编辑内容 : set TITLE = 想要命名的标题名称  保存修改.重新启动. 第二种. 修改tomca ...

  6. UVA 12501 Bulky process of bulk reduction ——(线段树成段更新)

    和普通的线段树不同的是,查询x~y的话,给出的答案是第一个值的一倍加上第二个值的两倍一直到第n个值的n倍. 思路的话,就是关于query和pushup的方法.用一个新的变量sum记录一下这个区间里面按 ...

  7. Windows 10 共享需要网络凭据的问题

    如果Windows在资源管理器的网络中双击其他的网络设备,提示要输入网络凭据的解决办法: 打开"网络共享中心" -> "更改高级共享设置"->&qu ...

  8. 本地访问weblogic控制台无反应,关闭linux操作系统防火墙

    有时候,我们在Linux操作系统上成功启动了weblogic,也查看了7001端口的状态是开启的.但是访问weblogic控制台没有反应,也没有报错. 使用 netstat -ano | grep 7 ...

  9. Python中调用shell

    1 简单调用shell命令 os.system(command) 在一个子shell中运行command命令, 并返回command命令执行完毕后的退出状态. 这实际上是使用C标准库函数system( ...

  10. 黑马vue---19、v-for中key的使用注意事项

    黑马vue---19.v-for中key的使用注意事项 一.总结 一句话总结: 必须 在使用 v-for 的同时,指定 唯一的 字符串/数字 类型 :key 值 <p v-for="i ...