linux虚拟主机管理系统wdcp系列教程之三
我们安装了网站服务管理系统wdcp之后,在使用过程中可能会出现这样或那样的疑问,下面给大家整理几点出来,方便大家学习。还有不懂的可以到wdlinux论坛寻找相关教程。
1、wdcp后台访问安全设置即限制域名/IP访问设置及清除方法
wdcp后台默认是用到8080端口的(可自行修改)
但搜索引擎的强大,有些连这个也给收录进来了
所以,之前就人反馈,如何限制这个后台的访问
wdcp从2.4开始,支持这个限制,只需要在后台上操作下就可以支持来路的IP限制,及服务端上的域名访问限制两种方式
具体如下
在后台 > 系统设置
后台访问IP,是指限制可以访问后台的来路IP,可以设置某个IP或IP段
比如,我的IP是固定的,如192.168.1.100,那就可以在这里设置为192.168.1.100,这样其它的所有IP都是打不开的
同时也可以是IP段
但如果是用ADSL上网的用户,最好不要设置这个,因为IP是经常变的
可以用后台访问域名来设置,同样可以达到效果
后台访问域名,是指可以打开后台的域名,默认是8080端口,是所有的域名及服务器IP都是可以打开的
比如,我要限制为只有某个域名可以打开,如admin.wdcp.cn
那就在这里填上admin,wdcp.cn
保存即可
以后,就可以直接用
http://admin.wdcp.cn:8080
来打开,而用IP或其它域名,就打不开了
清除方法
如因某些原因设置错误或域名不能使用等,如何清除这设置?
只要ssh登录服务器
执行
sh/www/wdlinux/tools/wdcp_login_cbip.sh
即可
2、后台升级后,网站打不开的解决方法
时会有人遇到这问题,就是在后台点升级后,然后重起,网站就打不开了,这个问题并不是因为升级原因引起,也说过好多遍了
这里再说明一下
后台升级wdcp,是不会影响到前端网站的访问和运行的,这个升级只是后台升级,跟前端网站没有关联的
那是什么原因呢?
很可能的原因,是在此之前操作过站点(新建|编辑)等操作过站点,但由于重起服务没生效,所以没发现问题
但重启机器后,就发现问题了
这里,怎么处理?
在后台进程里看,有没80端口,如是N+A的环境,看有没80和88两个端口
可以在后台命令运行器里运行
servicenginxd restart
servicehttpd restart
看有没什么提示,根据相应提示进行修改就可以
可是ssh里连接到服务器里运行上述命令来看
备注:
此问题,99%的原因,都是由于错误地操作了站点的伪静态规则原因或伪规则文件不存在等原因
所以,注意检查这里了
3、 用IP也打不开默认首页
1 确定是否安装成功,主要是在安装过程中是否有中断或错误信息
2 检查是否有80端口
可以系统管理 》端口管理 看是否有80端口
如果没有80端口, 在 启动服务 列表页里找到相应的nginxd或httpd,点击后面的启动
或者
系统管理 》命令运行里执行
servicenginxd restart
servicehttpd restart
注意看提示信息
或者用ssh连接到服务器上执行service nginxd restart
servicehttpd restart
把错误信息贴上来
说明:
1 如果是新安装完就打不开,应该是没安装完成
2 如果是在新建站点或操作站点后打不开,99%都是伪静态规则问题,也就是伪静态规则导致nginx或apache无法启动
此时可以取消刚添加的站点的伪静态,再重起下服务,然后进一步检查伪静态规则
本文教程摘自wdlinux论坛 http://www.wdlinux.cn/bbs/forum-4-1.html,转载请注明!
linux虚拟主机管理系统wdcp系列教程之三的更多相关文章
- Linux虚拟主机管理系统---wdcp
关于WDCP这款虚拟主机管理系统,是疯子使用的第二款Linux虚拟主机管理系统,使用是挺简单的,以前好像是因为编码问题而放弃这款面板. WDCP功能比较完善,基本上需要的功能都能满足,例如:在线下载. ...
- Linux虚拟主机通过FTP软件创建目录时提示550 Create Directory Operation Failed
更新时间:2017-06-07 13:26:11 分享: 问题描述 通过FTP软件连接Linux虚拟主机,在尝试创建新目录时,服务器返回错误提示:550 Create Directory Oper ...
- RabbitMQ系列教程之三:发布/订阅(Publish/Subscribe)(转载)
RabbitMQ系列教程之三:发布/订阅(Publish/Subscribe) (本教程是使用Net客户端,也就是针对微软技术平台的) 在前一个教程中,我们创建了一个工作队列.工作队列背后的假设是每个 ...
- N点虚拟主机管理系统如何使用?
有朋友问起N点虚拟主机管理系统怎么用呢?下面大概整理下他的使用方法,咱们来看看吧. 在讲如何使用N点虚拟主机管理系统之前,我们先来了解一下N点虚拟主机管理系统的介绍. N ...
- linux虚拟主机wdcp系列教程之四
当我们安装了网站服务管理系统wdcp之后,在使用过程中可能会出现这样或那样的疑问,下面给大家整理几点出来,方便大家学习. 1.wdcp支持的在线解压 有时小文件数据量,但整个目录上传会比较慢,如果打包 ...
- 网站服务管理系统wdcp系列教程之九
在我们安装了网站服务管理系统wdcp之后,在使用过程中可能会出现这样或那样的疑问,下面给大家整理几点出来,方便大家学习.还有不懂得话,可以去wdlinux论坛找找相关教程. 1.wdcp如何拒绝或阻止 ...
- ESXi5 中克隆Linux虚拟主机的网络配置
虚拟化技术果然非常方便,尤其是windows主机,克隆后在网络管理中改一下IP即可. 但对于Linux来说就有点麻烦,只修改IP还不行,还有MAC地址,网卡指定等,这个规程对应新手来说没有大半天搞不定 ...
- Linux虚拟主机通过程序实现二级域名绑定到子目录
虚拟主机中CP控制台不支持将二级域名绑定到子目录的功能,用户可以通过程序实现将二级域名绑定到子目录. 有两种方法将二级域名绑定到子目录: 1. 配置.htaccess, 通过伪静态代码实现.具体实现方 ...
- LNMP添加、删除虚拟主机及伪静态使用教程
一般情况下每个虚拟主机就是一个网站,网站一般通过域名进行访问.LNMP 1.2的网站添加过程和LNMP 1.1的基本类似,但是增加了FTP和数据库的创建.LNMP1.2的防跨目录也由原来在php.in ...
随机推荐
- jquery倒计时(仿团购)转至 http://justcoding.iteye.com/blog/2210962
倒计时一般是用来表示未来某一时刻距现在时刻还剩多少时间.倒计时在WEB上应用非常广泛,如考试系统倒计时,团购网站中的优惠活动倒计时等等.今天,我们来使用jQuery实现一个简单的倒计时功能.
- 45 个非常有用的 Oracle 查询语句(转)
这里我们介绍的是 40+ 个非常有用的 Oracle 查询语句,主要涵盖了日期操作,获取服务器信息,获取执行状态,计算数据库大小等等方面的查询.这些是所有 Oracle 开发者都必备的技能,所以快快收 ...
- uva11624 - Fire!
uva11624 - Fire! 火在蔓延,人在走.火会蔓延,不会熄灭,我们可以确定某个点着火的时间(广搜).对于J来说,要是他走到某点的时间比火蔓延到该点的时间要短,那么他走到该点的时候,火还没蔓延 ...
- ASP.NET内核几大对象、ASP.NET核心知识(7)--转载
本文的学习流程是这样安排的. 一个简单的GDI小案例 1.说明 如果你想思考如何生成验证码,那么您第一个要解决的问题,一定是.NET动态生成图片问题. //GDI:.Net程序中进行绘图的一些类. 2 ...
- jquery滚动到指定元素,模仿锚点
html <div class="pd-nav"> <div class="n-item active"> 保险服务 <i> ...
- java Object 类
Object o=new Object(); 其中有两个受保护的方法: 1.protected void finalize() 2.protected ...
- struts 学习之问一
今天在进行struts全局类型和局部类型转换时,发现一个问题,如下: 当输入一个点的坐标时,我使用全局转换提示错误,找不到类,当改变成局部类型转换时,可以成功转换,不知道这个是什么原因,难道全局不可以 ...
- VS代码清理批处理
批处理清理VS工程 del /f /q /s *.ncb del /f /q /s *.sdf del /f /q /s /A H *.suo del /f /q /s *.ipch del /f / ...
- http://python3-cookbook.readthedocs.io/zh_CN/latest/c14/p01_testing_output_sent_to_stdout.html
http://python3-cookbook.readthedocs.io/zh_CN/latest/c14/p01_testing_output_sent_to_stdout.html draw. ...
- checkbox 实现单选效果(html)
note:在html <input> 标签类中的checkbox实现单选效果. 在最近的开发项目中,客户要求使用小方格子实现“单选”功能,显然圆点的radio被out了,只能选择chckb ...