当前环境

Oracle环境:Oracle 10.2.0.5 RAC

VIP地址为:172.31.0.75,172.31.0.76

priave IP:172.31.0.77,172.31.0.78

通过ifconfig -a可以看到:

172.31.0.78对应VIP地址:172.31.0.76

172.31.0.77对应VIP地址:172.31.0.75

1.通过[srvctl config]确认当前VIP地址.

[oracle@arprac02 ~]$ srvctl config nodeapps -n arprac01 -a
VIP exists.: /arprac01-vip/172.31.0.75/255.255.255.0/eth0
[oracle@arprac02 ~]$ srvctl config nodeapps -n arprac02 -a
VIP exists.: /arprac02-vip/172.31.0.76/255.255.255.0/eth0

上述可以看到:172.31.0.75 是节点1的VIP,172.31.0.76是节点2的VIP.

2.关闭dbconsole[对应的em]

有的RAC没有装,可选操作

$ emctl stop dbconsole (每个节点停止dbconsole)

3.关闭数据库实例

$ srvctl stop database -d servdb
$ srvctl stop database -d managedb
$ srvctl stop database -d irc3db

4.关闭asm实例

$ srvctl stop asm -n arprac01
$ srvctl stop asm -n arprac02

5.关闭结点服务

$ srvctl stop nodeapps -n arprac01 (停节点1服务)
$ srvctl stop nodeapps -n arprac02 (停节点2服务)

上述操作,可以发现172.31.0.75/76已经没有绑定在网卡上面了。

查看集群命令,发现RAC关闭。

[oracle@arprac01 ~]$ crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application OFFLINE OFFLINE
ora....01.lsnr application OFFLINE OFFLINE
ora....c01.gsd application OFFLINE OFFLINE
ora....c01.ons application OFFLINE OFFLINE
ora....c01.vip application OFFLINE OFFLINE
ora....SM2.asm application OFFLINE OFFLINE
ora....02.lsnr application OFFLINE OFFLINE
ora....c02.gsd application OFFLINE OFFLINE
ora....c02.ons application OFFLINE OFFLINE
ora....c02.vip application OFFLINE OFFLINE
ora.irc3db.db application OFFLINE OFFLINE
ora....b1.inst application OFFLINE OFFLINE
ora....b2.inst application OFFLINE OFFLINE
ora....gedb.db application OFFLINE OFFLINE
ora....b1.inst application OFFLINE OFFLINE
ora....b2.inst application OFFLINE OFFLINE
ora.servdb.db application OFFLINE OFFLINE
ora....b1.inst application OFFLINE OFFLINE
ora....b2.inst application OFFLINE OFFLINE

6.修改两个节点的/etc/hosts文件。

主要修改【arprac01-vip】和【arprac01-vip】

[root@arprac01 ~]# vi /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
172.31.0.95 arprac01-vip
172.31.0.96 arprac02-vip

7.srvctl修改VIP

[root@arprac01 ~]# cd /u01/app/oracle/product/10.2.0/db_1/bin/
[root@arprac01 ~]# export ORACLE_BASE=/u01/app/oracle
[root@arprac01 ~]# export ORACLE_HOME=$ORACLE_BASE/product/10.2.0/db_1
#./srvctl modify nodeapps -n arprac01 -A 172.31.0.95/255.255.255.0/eth0
#./srvctl modify nodeapps -n arprac02 -A 172.31.0.96/255.255.255.0/eth0

8.启动ASM

$ srvctl start asm -n arprac01
$ srvctl start asm -n arprac02

9.启动nodeapps

$ srvctl start nodeapps -n arprac01
$ srvctl start nodeapps -n arprac02

10.启动数据库实例

$ srvctl start database -d servdb

11.若local_listener参数HOST使用IP,修改local_listener参数

在RAC1上执行下面语句
SQL> alter system set local_listener='(ADDRESS=(PROTOCOL=TCP)(HOST=172.31.0.95)(PORT=1521))';
在RAC2上执行下面语句
SQL> alter system set local_listener='(ADDRESS = (PROTOCOL = TCP)(HOST=172.31.0.96)(PORT=1521))';

最后,可以再次查看集群消息:

[oracle@arprac01 ~]$ crs_stat -t
Name Type Target State Host
------------------------------------------------------------
ora....SM1.asm application ONLINE ONLINE arprac01
ora....01.lsnr application ONLINE ONLINE arprac01
ora....c01.gsd application ONLINE ONLINE arprac01
ora....c01.ons application ONLINE ONLINE arprac01
ora....c01.vip application ONLINE ONLINE arprac01
ora....SM2.asm application ONLINE ONLINE arprac02
ora....02.lsnr application ONLINE ONLINE arprac02
ora....c02.gsd application ONLINE ONLINE arprac02
ora....c02.ons application ONLINE ONLINE arprac02
ora....c02.vip application ONLINE ONLINE arprac02
ora.irc3db.db application OFFLINE OFFLINE
ora....b1.inst application OFFLINE OFFLINE
ora....b2.inst application OFFLINE OFFLINE
ora....gedb.db application OFFLINE OFFLINE
ora....b1.inst application OFFLINE OFFLINE
ora....b2.inst application OFFLINE OFFLINE
ora.servdb.db application ONLINE ONLINE arprac01
ora....b1.inst application ONLINE ONLINE arprac01
ora....b2.inst application ONLINE ONLINE arprac02

也能看到,虚拟网卡确实是172.31.0.95了。如下:

oracle@arprac01 ~]$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 6C:3B:E5:A5:8D:04
inet addr:172.31.0.77 Bcast:172.31.0.255 Mask:255.255.255.0
inet6 addr: fe80::6e3b:e5ff:fea5:8d04/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1574130270 errors:0 dropped:0 overruns:0 frame:0
TX packets:205160002 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:191736588245 (178.5 GiB) TX bytes:93077811782 (86.6 GiB)
Interrupt:170 Memory:d0a00000-d0a10000 eth0:1 Link encap:Ethernet HWaddr 6C:3B:E5:A5:8D:04
inet addr:172.31.0.95 Bcast:172.31.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:170 Memory:d0a00000-d0a10000

RAC修改VIP地址的更多相关文章

  1. oracle 11g rac 修改VIP、scan VIP、priv IP

    11GR2 RAC modify vip,public ip,private ip,scan vip实施步骤1 修改目的    根据业务的需求,需要由原来的临时IP改为生产ip,以下为调整前后对应的I ...

  2. Oracle 11g RAC 修改各类IP地址

    Oracle 11g RAC 修改各类IP地址 首先,我们都知道Oracle 11g RAC中的IP主要有:Public IP.VIP.SCAN VIP.Private IP这几种. 一般这类改IP地 ...

  3. oracle 11.2.0.4 rac 修改 ip vip scan ip

    修改前host文件 198.27.73.21 ht-d01 198.27.73.22 ht-d02 198.27.73.25 ht-d01-vip 198.27.73.26 ht-d02-vip 19 ...

  4. 转载:细说oracle 11g rac 的ip地址

    本文转载自:细说oracle 11g rac 的ip地址 http://blog.sina.com.cn/s/blog_4fe6d4250102v5fa.html 以前搭建oracle rac的时候( ...

  5. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.7.Oracle 11G R2 RAC修改public网络IP

    问题:Linuxrac2节点的public网IP被占用,导致集群节点2无法访问 1.禁止相关CRS资源的启动,停止这些资源(vip,listener,scan,scan_listener,databa ...

  6. CentOS(RedHat)命令行永久修改IP地址、网关、DNS

    1.修改IP地址vim /etc/sysconfig/network-scripts/ifcfg-eth0DEVICE=eth0 #网卡名称BOOTPROTO=static #获取ip的方式(stat ...

  7. Linux下如何修改ip地址

    在Linux的系统下如何才能修改IP信息 以前总是用ifconfig修改,重启后总是得重做.如果修改配置文件,就不用那么麻烦了- A.修改ip地址 即时生效: # ifconfig eth0 192. ...

  8. 嵌入式 Linux下修改MAC地址

    Linux下修改MAC地址 方法一: 1.关闭网卡设备ifconfig eth0 down2.修改MAC地址ifconfig eth0 hw ether MAC地址3.重启网卡ifconfig eth ...

  9. 怎么修改路由器地址的默认IP

    参考文章:http://jingyan.baidu.com/article/4b52d7026e14effc5c774b30.html  一.怎么修改路由器地址的默认IP 目前绝大多数品牌有线或无线路 ...

随机推荐

  1. 分布式消息队列Apache Pulsar

    Pulsar简介 Apache Pulsar是一个企业级的分布式消息系统,最初由Yahoo开发并在2016年开源,目前正在Apache基金会下孵化.Plusar已经在Yahoo的生产环境使用了三年多, ...

  2. cs231n spring 2017 lecture16 Adversarial Examples and Adversarial Training

    (没太听明白,以后再听) 1. 如何欺骗神经网络? 这部分研究最开始是想探究神经网络到底是如何工作的.结果人们意外的发现,可以只改变原图一点点,人眼根本看不出变化,但是神经网络会给出完全不同的答案.比 ...

  3. css - 原生变量及使用函数 var()

    零.序言 前两天在逛 blog 的时候看见一些内联样式新奇的写法时很纳闷,虽然说不上多么熟练,但是从来没见过  --color: brown 这样的写法,百度一番之后仍然没啥头绪,今天偶然看到一篇文章 ...

  4. python可变类型和不可变类型,深拷贝vs浅拷贝

    转载:https://www.cnblogs.com/huamingao/p/5809936.html 核心提示: 可变类型 Vs 不可变类型 可变类型(mutable):列表,字典 不可变类型(un ...

  5. c/c++ main 函数命令行参数的使用

    C程序最大的特点就是所有的程序都是用函数来装配的.main()称之为主函数,是所有程 序运行的入口.其余函数分为有参或无参两种,均由main()函数或其它一般函数调用,若调用的是有参函数,则参数在调用 ...

  6. 整合SSM遇到的错误,数据库连接失败问题集合

    Could not get JDBC Connection; nested exception is java.sql.SQLException: Connections could not be a ...

  7. SQL语言分为四类,每类分别是?各包括什么?

    sqlserver(T_SQL):DDL—数据定义语言(CREATE,ALTER,DROP,DECLARE) DML—数据操纵语言(SELECT,DELETE,UPDATE,INSERT) DCL—数 ...

  8. tomcat启动后access error[730048]的解决方法

    安装了JDK... 配置了系统变量... 解压了tomcat... 配置了系统变量... 点击startup.bat启动了以后,打开浏览器,出现access error 404错误. 仔细看过控制台输 ...

  9. 在dataframe添加1行(首行,或者尾部),且不覆盖

    如果直接用下面的代码添加第1行,则会覆盖掉原来的第1行. #指定位置增加一行: df.loc[0]={'a':1,'b':2} 正确方法: 新建一个同样的 dataframe, 然后合并两个dataf ...

  10. 从又一家外卖被Uber收购,看美团打车未来

    别以为Uber在中国失利,连优步中国都被滴滴收购了,就认为Uber已经不行了.其实从全球范围内来看,Uber还是相当强势的--创始人的那些破事儿不算在内.此外,更重要的是Uber已经不单单是在打车业务 ...