CentOS开发环境LAMP搭建
CentOS开发环境搭建
-------------------------------------------------------------------------准备工作---------------------------------------------------------------------------------
1.配置防火墙,开启80端口、3306端口
->vim /etc/sysconfig/iptables
#将以下两行配置,加到22端口的下面
-A INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT#允许80端口通过防火墙
-A INPUT -m state --state NEW -m tcp -p tcp --dport 3306 -j ACCEPT#允许3306端口通过防火墙
->/etc/init.d/iptables restart#配置完成,重启防火墙
2.关闭SELINUX(Linux内核安全机制)
->vim /etc/selinux/config
#注释以下两行配置
SELINUX=enforcing
SELINUXTYPE=targeted
#新增配置
SELINUX=disabled
:wq!#保存,关闭
shutdown -r now#重启系统
-------------------------------------------------------------------------安装---------------------------------------------------------------------------------
1.安装Apache服务器
->yum install httpd#根据提示信息,一路输入Y即可安装成功
->/etc/init.d/httpd start#启动Apache
#不出意外,会报错:httpd:httpd:Could not ...省略... for ServerName
#OK是ServerName
#解决办法:
->vim /etc/httpd/conf/httpd.conf#vim编辑
#找到 #ServerName www.example.com:80
#修改为 #ServerName localhost:80#这里设置为本机,或者可以是你的域名
->:wq!#保存,关闭
->chkconfig httpd on#设为开机启动
->/etc/init.d/httpd restart#重启Apache
2.安装MySql
->yum install mysql mysql-server#根据提示信息,一路输入Y即可安装成功
->/etc/init.d/mysqld start#启动MySql
->chkconfig mysqld on#设为开机启动
->cp /usr/share/my-medium.cnf /etc/my.cnf#拷贝配置文件,若提示存在,直接覆盖
#为root账户设置密码,默认密码为空,根据提示输入2次密码,一路输入Y即可
->mysql_secure_installation
#直到出现Thanks for using MySQL!
#MySql密码设置完成,重新启动 MySQL:
->/etc/init.d/mysqld restart #重启
3.安装PHP5
#根据提示输入Y直到安装完成
->yum install php
#安装PHP组件,使 PHP5 支持 MySQL
#这里选择以下安装包进行安装,一路输入Y即可
yum install php-mysql php-gd libjpeg* php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc php-mbstring php-mcrypt php-bcmath php-mhash libmcrypt
/etc/init.d/mysqld restart #重启MySql
/etc/init.d/httpd restart #重启Apche
-------------------------------------------------------------------------配置---------------------------------------------------------------------------------
1.配置Apache
->vim /etc/httpd/conf/httpd.conf #编辑文件
ServerTokens OS 修改为:ServerTokens Prod (在出现错误页的时候不显示服务器操作系统的名称)
ServerSignature On 修改为:ServerSignature Off (在错误页中不显示Apache的版本)
Options Indexes FollowSymLinks 修改为:Options Includes ExecCGI FollowSymLinks(允许服务器执行CGI及SSI,禁止列出目录)
#AddHandler cgi-script .cgi 修改为:AddHandler cgi-script .cgi .pl (允许扩展名为.pl的CGI脚本运行)
AllowOverride None 修改为:AllowOverride All (允许.htaccess)
AddDefaultCharset UTF-8 修改为:AddDefaultCharset UTF-8 (添加UTF-8为默认编码)
Options Indexes MultiViews FollowSymLinks 修改为: Options MultiViews FollowSymLinks(不在浏览器上显示树状目录结构)
DirectoryIndex index.html index.html.var 修改为:DirectoryIndex index.html index.htm Default.html Default.htm index.php Default.php index.html.var
KeepAlive Off 修改为:KeepAlive On (允许程序性联机)
MaxKeepAliveRequests 100 修改为:MaxKeepAliveRequests 1000 (增加同时连接数)
:wq! #保存退出
->/etc/init.d/httpd restart #重启
->rm -f /etc/httpd/conf.d/welcome.conf /var/www/error/noindex.html 删除默认测试页
2.php配置
->vim /etc/php.ini #编辑
date.timezone = PRC 把前面的分号去掉,改为date.timezone = PRC
disable_functions = 列出PHP可以禁用的函数,如果某些程序需要用到这个函数,可以删除,取消禁用。
expose_php = Off 禁止显示php版本的信息
magic_quotes_gpc = On 打开magic_quotes_gpc来防止SQL注入
short_open_tag = ON 支持php短标签
open_basedir = .:/tmp/ 设置表示允许访问当前目录(即PHP脚本文件所在之目录)和/tmp/目录,可以防止php木马跨站,如果改了之后安装程序有问题(例如:织梦内容管理系统),可以注销此行,或者直接写上程序的目录/data/ www.osyunwei.com/:/tmp/
:wq! #保存退出
->/etc/init.d/mysqld restart #重启MySql
->/etc/init.d/httpd restart #重启Apche
CentOS开发环境LAMP搭建的更多相关文章
- linux应用之php开发环境lamp搭建(centos)
搭建linux+apache+mysql+php环境 1.安装apache: yum install httpd httpd-devel 启动apache: /etc/init.d/httpd ...
- vmware安装CentOS开发环境搭建
CentOS开发环境搭建 一.安装系统 新建虚拟机 2.选择“自定义(高级)”,并点击[下一步] 3.选择虚拟机硬件兼容性,并点击[下一步] 4.选择“稍后安装操作系统”,并点击[下一步] 5.选 ...
- python flask构建小程序订餐系统--centos下项目开发环境的搭建
1.项目开发环境的搭建(Linux环境) 1)软件的安装 我们搭建整个项目的过程中,我们需要用到下面的一些软件,但是这些软件的安装过程我们在这里不用说明.(因为windows软件的安装比较的简单,类似 ...
- Idea开发环境中搭建Maven并且使用Maven打包部署程序
1.配置Maven的环境变量 a.首先我们去maven官网下载Maven程序,解压到安装目录,如图所示: b.配置M2_HOME的环境变量,然后将该变量添加到Path中 备注:必须要有JAVA_HOM ...
- Ubuntu系统Java开发环境的搭建
操作系统:Linux x64 / Ubuntu 14.04 Java JDK版本:jdk-8u65-linux-x64.tar.gz 声明:转载请注明出处及本文链接 本文原文地址:Ubuntu系统Ja ...
- 生产环境LAMP搭建 - 基于 fastcgi
生产环境LAMP搭建 - 基于 fastcgi 由于在module模式,php只是已http的模块形式存在,无形中加重了http的服务负载,通常在企业架构中,使用fastcgi的模式,将所有的服务都设 ...
- 转】[1.0.2] 详解基于maven管理-scala开发的spark项目开发环境的搭建与测试
场景 好的,假设项目数据调研与需求分析已接近尾声,马上进入Coding阶段了,辣么在Coding之前需要干马呢?是的,“统一开发工具.开发环境的搭建与本地测试.测试环境的搭建与测试” - 本文详细记录 ...
- 总结:Mac前端开发环境的搭建(配置)
新年新气象,在2016年的第一天,我入手了人生中第一台自己的电脑(大一时好友赠送的电脑在一次无意中烧坏了主板,此后便不断借用别人的或者网站的).macbook air,身上已无分文...接下来半年的房 ...
- Linux学习心得之 Linux下命令行Android开发环境的搭建
作者:枫雪庭 出处:http://www.cnblogs.com/FengXueTing-px/ 欢迎转载 Linux学习心得之 Linux下命令行Android开发环境的搭建 1. 前言2. Jav ...
随机推荐
- 各种HTTP错误消息含义
错误代码 错误消息 400 无法解析此请求. 401.1 未经授权:访问由于凭据无效被拒绝. 401.2 未经授权: 访问由于服务器配置倾向使用替代身份验证方法而被拒绝. 401.3 未经授权:访问由 ...
- NGUI所见即所得之UIAtlasMaker , UIAtlas (2)
本文的重点就是要将NGUI把多张图片打成一个图集(Atlas)的原理和过程研究下,学习下Unity提供的api和NGUI写的功能以及设计思想. (原文链接) 其它链接:NGUI所见即所得之UIRoot ...
- 使用智遥工作流,优化SAP请购流程
传统请购流程,都是用户在SAP系统中填写请购单,然后再打印出来,递交给上级领导审批.领导审批完了,再到SAP系统中更新release标识.若中途请购单内容需要变更,则需要重新打印,审批. 智遥工作流, ...
- 【HDOJ】1254 推箱子
来一发搜索.数据量比较小,这么玩儿都能ac.搞个优先队列.先扫描从起点可以到达箱子的上下左右中哪些位置,并针对这些位置进行bfs.所谓推,就是箱子和人同向移动一个单位.bfs的时候注意一些限制条件就好 ...
- 确保客户端可以接收到服务端的异常serviceDebug includeExceptionDetailInFaults="true"
1.为了确保客户端可以接收到服务端反馈的异常 在服务端的配置文件中需要有 <system.serviceModel> <behaviors> <serviceBehavi ...
- Eclipse全屏及插件下载
Eclipse全屏插件下载 解压下载的压缩包,将 plugins 文件夹中的 cn.pande.eclipsex.fullscreen_1.0.7.jar 文件拷贝到Eclipse安装目录下的 ...
- 函数lock_mode_stronger_or_eq 锁权限等级
row代表lock HashTable的权限 column代表预加锁的权限 ulint lock_mode_stronger_or_eq( /*=====================*/ e ...
- bzoj2506
不知道该给这题贴什么标签了,但是这是一道好题1.注意这道题的询问是满足区间减法的,我们可以把一个询问拆成两个询问离线搞搞,这个思想在后面会见到2.分类的思想,这道题的求相同余数看似很烦,实际上我们发现 ...
- ☀【移动】UC极速模式
UC浏览器的部分版本默认是“极速”模式,有何办法能控制UC自动改变其浏览模式? √http://www.zhihu.com/question/20582949 关于UC极速模式下访问网站错乱 √htt ...
- 深入理解c语言_从编译器的角度考虑问题_纪念Dennis Ritchie先生
开源中国: Dennis Ritchie教授过世了,他发明了C语言,一个影响深远并彻底改变世界的计算机语言.一门经历40多年的到今天还长盛不训的语言,今天很多语言都受到C的影 响,C++,Java,C ...