ORA-00845 : MEMORY_TARGET not supported on this system(调大数据库内存无法启动)
问题描述:调大数据库内存后,启动数据库报 ORA-00845 : MEMORY_TARGET not supported on this system 。
-- 调大数据库内存后,数据库启动报错
[root@jcdydb1 bin]# ./srvctl start database -d jcdydb
PRCR-1079 : Failed to start resource ora.jcdydb.db
CRS-5017: The resource action "ora.jcdydb.db start" encountered the following error:
ORA-00845: MEMORY_TARGET not supported on this system
. For details refer to "(:CLSN00107:)" in "/oracle/app/11.2.0/grid/log/jcdydb1/agent/crsd/oraagent_oracle//oraagent_oracle.log".
CRS-5017: The resource action "ora.jcdydb.db start" encountered the following error:
ORA-00845: MEMORY_TARGET not supported on this system
. For details refer to "(:CLSN00107:)" in "/oracle/app/11.2.0/grid/log/jcdydb2/agent/crsd/oraagent_oracle//oraagent_oracle.log".
CRS-2674: Start of 'ora.jcdydb.db' on 'jcdydb1' failed
CRS-2674: Start of 'ora.jcdydb.db' on 'jcdydb2' failed
CRS-2632: There are no more servers to try to place resource 'ora.jcdydb.db' on that would satisfy its placement policy
-- 查看服务器内存,132103588k /1024/1024 = 125G
top - 19:32:11 up 7:21, 7 users, load average: 1.13, 1.16, 1.16
Tasks: 2089 total, 1 running, 2088 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.3%us, 0.5%sy, 0.0%ni, 99.2%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 132103588k total, 31130024k used, 100973564k free, 216416k buffers
Swap: 67108856k total, 0k used, 67108856k free, 26919636k cached
-- 查看针对数据库的内核参数,发现没有问题
[root@jcdydb1 bin]# cat /etc/sysctl.conf
#add for oracle 11gR2 rac
kernel.shmmni = 4096
kernel.shmmax = 277439000000
kernel.shmall = 4294967296
kernel.aio-max-nr = 1048576
net.ipv4.ip_local_port_range = 9000 65500
net.core.rmem_default = 262144
net.core.rmem_max = 4194304
net.core.wmem_default = 262144
net.core.wmem_max = 1048576
net.ipv4.conf.default.rp_filter = 2
net.ipv4.conf.all.rp_filter = 2
kernel.sem = 3010 427420 3010 142
[root@jcdydb1 bin]#
说明:
kernel.shmmax 共享内存段的大小,设置大小超过SGA大小才不不会造成性能问题。
kernel.shmall 共享内存页总数,设置大小为物理理内存大小/内存页大小。
通过getconf命令来获取内存页大小:
[root@rac01 ~ ]# getconf PAGE_SIZE
4096
[root@rac02 ~ ]# getconf PAGE_SIZE
4096
-- 查看 /dev/shm 大小, 发现只有内存的一半,小于数据库内存为服务器内存的80%,不符合要求。
[root@jcdydb1 bin]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/osvg-lv_root
99G 488M 93G 1% /
/dev/sda1 504M 45M 434M 10% /boot
/dev/mapper/osvg-lv_data
50G 3.7G 44G 8% /data
/dev/mapper/osvg-lv_home
9.9G 3.9G 5.5G 42% /home
/dev/mapper/osvg-lv_ora
99G 12G 82G 13% /oracle
/dev/mapper/osvg-lv_tmp
32G 9.5G 21G 32% /tmp
/dev/mapper/osvg-lv_usr
20G 7.4G 12G 40% /usr
/dev/mapper/osvg-lv_var
9.9G 508M 8.9G 6% /var
/data/soft/rhel-server-6.4-x86_64-dvd.iso
3.5G 3.5G 0 100% /media/rhel64
tmpfs 62G 0G 65G 0% /dev/shm
说明:/dev/shm的容量默认最大为内存的一半大小,使用df -h命令可以看到。但它并不会真正的占用这块内存,
如果/dev/shm/下没有任何文件,它占用的内存实际上就是0字节。
-- 查看 /dev/shm 被谁占用,快速加大 /dev/shm ,确认无重要进程使用/dev/shm后,需要 kill 文件使用者。
[root@jcdydb1 bin]# lsof /dev/shm
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
pulseaudi 27716 grid mem REG 0,16 67108904 11057360 /dev/shm/pulse-shm-863193574
gnome-ter 42214 grid mem REG 0,16 67108904 11057310 /dev/shm/pulse-shm-3660319902
[root@jcdydb1 bin]# kill -9 27716 42214
-- 再次查看,发现无占用。
[root@jcdydb1 bin]# lsof /dev/shm
[root@jcdydb1 bin]#
-- umount /dev/shm
[root@jcdydb1 bin]# umount /dev/shm
-- 编辑 /etc/fstab , 加大 /dev/shm 。
[root@jcdydb1 bin]# vi /etc/fstab 修改
tmpfs /dev/shm tmpfs defaults,size=110G 0 0
[root@jcdydb1 bin]# mount /dev/shm
-- 查看 /dev/shm 大小。
[root@jcdydb1 bin]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/osvg-lv_root
99G 488M 93G 1% /
/dev/sda1 504M 45M 434M 10% /boot
/dev/mapper/osvg-lv_data
50G 3.7G 44G 8% /data
/dev/mapper/osvg-lv_home
9.9G 3.9G 5.5G 42% /home
/dev/mapper/osvg-lv_ora
99G 12G 82G 13% /oracle
/dev/mapper/osvg-lv_tmp
32G 9.5G 21G 32% /tmp
/dev/mapper/osvg-lv_usr
20G 7.4G 12G 40% /usr
/dev/mapper/osvg-lv_var
9.9G 508M 8.9G 6% /var
/data/soft/rhel-server-6.4-x86_64-dvd.iso
3.5G 3.5G 0 100% /media/rhel64
tmpfs 110G 0 110G 0% /dev/shm
--启动数据库。
[root@jcdydb1 bin]# ./srvctl start database -d jcdydb >成功!
ORA-00845 : MEMORY_TARGET not supported on this system(调大数据库内存无法启动)的更多相关文章
- memory_target not supported on this system
- ORA-00845 MEMORY_TARGET not supported on this system 的解决
本文来源:宁静致远 的<ORA-00845 MEMORY_TARGET not supported on this system 的解决> oracle11g数据库在执行dbca或者调整s ...
- ORA-00845 MEMORY_TARGET not supported on this system解决办法
ORA-00845: MEMORY_TARGET not supported on this system报错解决 Oracle 11g数据库修改pfile参数后启动数据库报错ora-00845 SQ ...
- startup ORA-00845: MEMORY_TARGET not supported on this system
一台虚拟机跑多个实例时,由于/dev/shm空间不够导致如下报错> startupORA-00845: MEMORY_TARGET not supported on this system解决方 ...
- Oracle 11g ORA-00845: MEMORY_TARGET not supported on this system
启动Oracle 11gR2后报错:ORA-00845 rac1:/home/oracle> sqlplus / as sysdba; SQL*Plus: Release 11.2.0.3.0 ...
- ORA-00845: MEMORY_TARGET not supported on this system
cd $ORACLE_HOME cd dbs cat init.ora cat spfilematedata.ora 查看MEMORY_TARGET设置的大小 修改系统,设置shm的大小大于MEMOR ...
- 在Linux上的虚拟机上启动Oracle上报ORA-00845: MEMORY_TARGET not supported on this system的问题解决
解决办法: 1.将当前虚拟机的内容调整大一些(以下转载:http://jingyan.baidu.com/article/414eccf67b8baa6b421f0a60.html) VMware虚拟 ...
- Oracle的memory_max_target和memory_target修改和ORA-00845: MEMORY_TARGET not supported on this system错误解决
https://blog.csdn.net/sunny05296/article/details/56495599
- ORA-00845: MEMORY_TARGET not supported
Enabling Automatic Memory Management alter system set memory_max_target=50G scope=spfile; alter syst ...
随机推荐
- 配置windows qt开发环境
1.解压缩MinGW-gcc440_1.zip.将解压后的文件夹复制至C盘根目录下.2.安装qt-creator-win-opensource-2.5.2.3.安装qt-win-opensource- ...
- AtCoder Regular Contest 099
AtCoder Regular Contest 099 C - Minimization 题意 题意:给出一个n的排列.每次操作可以使一段长度为K的连续子序列变成该序列的最小数.求最少几次使得整个数列 ...
- Cacti的基本安装配置
////////////////////cacti///////////////////////////常用的监控软件有:cacti.nagios.zabbix等 cacti 重图形.有数据历史.需要 ...
- 从Activity中返回数据
从Activity中返回数据 一.简介 这里也就是使用intent方式返回数据. 二.具体步骤 在MainActivity通过一个button访问Activity01页面,然后将Activity01页 ...
- 七 web爬虫讲解2—urllib库爬虫—状态吗—异常处理—浏览器伪装技术、设置用户代理
如果爬虫没有异常处理,那么爬行中一旦出现错误,程序将崩溃停止工作,有异常处理即使出现错误也能继续执行下去 1.常见状态吗 301:重定向到新的URL,永久性302:重定向到临时URL,非永久性304: ...
- spring boot MongoDB的集成和使用
前言 上一章节,简单讲解了如何集成Spring-data-jpa.本章节,我们来看看如何集成NoSQL的Mongodb.mongodb是最早热门非关系数据库的之一,使用也比较普遍.最适合来存储一些非结 ...
- iptables(三)iptables规则管理(增、删、改)
上一篇文章中,我们已经学会了怎样使用iptables命令查看规则,那么这篇文章我们就来总结一下,怎样管理规则. 之前,我们把查看iptables规则的操作比作"增删改查"当中的&q ...
- 利用pycharm远程调试openstack代码
1.安装pycharm专业版 本文安装pycharm 2016.2.3专业版.网上教程较多,这里不做详细介绍,只要到pycharm官网上下载应用程序进行安装即可. 2.pycharm配置 (1)首先按 ...
- dga 分析
02n-0iy6gn3ozzwmyu.7i43n9qil1g1z2-.com0e527eaf_5ec5_4623_9fe9_e459583acd72.com0fmgm1cuu7h1279dghgka0 ...
- 【machine learning通俗讲解code逐行注释】之线性回归实现
现在机器学习算法在分类.回归.数据挖掘等问题上运用的十分广泛,对于初学者来说,可能一听到'算法'或其他的专属名词都感觉高深莫测,以致很多人望而却步,这让很多人在处理很多问题上失去了一个很有用的工具.机 ...