主从同步,从库报错代码:1141 ,错误信息如下:

                  Master_Port: 3306
Connect_Retry: 60
Master_Log_File: binlog.000086
Read_Master_Log_Pos: 596130762
Relay_Log_File: mysql-relay-bin.000486
Relay_Log_Pos: 212230586
Relay_Master_Log_File: binlog.000086
Slave_IO_Running: Yes
Slave_SQL_Running: No
Replicate_Do_DB:
Replicate_Ignore_DB: information_schema,performance_schema,undolog,for_nagios
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table: information_schema.%,performance_schema.%
Last_Errno: 1141
Last_Error: Coordinator stopped because there were error(s) in the worker(s). The most recent failure being: Worker 1 failed executing transaction '510f1fe6-aeba-4334-b18b-3c2043b52ff2:125151353' at master log binlog.000086, end_log_pos 547512983. See error log and/or performance_schema.replication_applier_status_by_worker table for more details about this failure or others, if any.
Skip_Counter: 0
Exec_Master_Log_Pos: 547458856
Relay_Log_Space: 261211881
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: NULL
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 1141
Last_SQL_Error: Coordinator stopped because there were error(s) in the worker(s). The most recent failure being: Worker 1 failed executing transaction '510f1fe6-aeba-4334-b18b-3c2043b52ff2:125151353' at master log binlog.000086, end_log_pos 547512983. See error log and/or performance_schema.replication_applier_status_by_worker table for more details about this failure or others, if any.
Replicate_Ignore_Server_Ids:
Master_Server_Id: 33
Master_UUID: 41f96eda-0f5a-11e9-ad75-00163e00d868
Master_Info_File: mysql.slave_master_info
SQL_Delay: 0
SQL_Remaining_Delay: NULL
Slave_SQL_Running_State:
Master_Retry_Count: 86400
Master_Bind:
Last_IO_Error_Timestamp:
Last_SQL_Error_Timestamp: 190704 19:57:28
Master_SSL_Crl:
Master_SSL_Crlpath:
Retrieved_Gtid_Set: 510f1fe6-aeba-4334-b18b-3c2043b52ff2:25836646-125206230
Executed_Gtid_Set: 0b117566-0b1e-11e9-a8b4-00163e001495:1-3087343,
2479bd1b-1271-11e9-8c68-005056bd8639:1-81,
2d748950-c0fd-11e7-81f8-0050569175d7:35404018-35647968,
510f1fe6-aeba-4334-b18b-3c2043b52ff2:1-5363955:5393677-125151352,
db981f90-01f5-11e9-8d52-00163e008b14:1-4218,
e66adda1-ff8d-11e8-9d3d-00163e008b14:1-25261
Auto_Position: 0
Replicate_Rewrite_DB:
Channel_Name:
Master_TLS_Version:

解决方法:

根据上述的主从同步信息,

Relay_Log_File: mysql-relay-bin.000486
Relay_Log_Pos: 212230586

在从库上使用mysqlbinlog将日志文件解析出来,命令如下:

mysqlbinlog  --no-defaults -v -v --base64-output=DECODE-ROWS mysql-relay-bin.000486 > /tmp/mysql-relay-bin.000486

在解析出来的文件中找到对应的POS点: 212230586

#190704 13:47:32 server id 1  end_log_pos 547458856     Xid = 4140969095
COMMIT/*!*/;
# at 212230586
#190704 13:47:32 server id 1 end_log_pos 547458917 GTID last_committed=1230803 sequence_number=1230804 rbr_only=no
SET @@SESSION.GTID_NEXT= '510f1fe6-aeba-4334-b18b-3c2043b52ff2:125151281'/*!*/;
# at 212230647
#190704 13:47:32 server id 1 end_log_pos 547459084 Query thread_id=469641862 exec_time=0 error_code=0
SET TIMESTAMP=1562219252/*!*/;
SET @@session.sql_mode=1436549152/*!*/;
REVOKE GRANT OPTION ON `f_common`.* FROM 'f_common'@'172.20.73.%'
/*!*/;
# at 212230814

发现在执行 revoke语句 删除用户权限。

查看从库上的用户库,发现没有用户 f_common。 所以就出现问题了。

问题原因已经清楚了,后续就自己处理了。

Mysql 主从报错:1141的更多相关文章

  1. MySQL主从报错1594

    一.主从报错 Relay log read failure 问题原因,MySQL主从使用的是kvm虚拟机,物理机超分严重,在负载高的情况下会kill掉占用资源最多的虚拟机,再启动后导致主从失败 mys ...

  2. MySQL主从报错解决:Failed to initialize the master info structure

    大清早收到一个MySQL的自定义语言告警 :replication interrupt,看来是主从同步报错了. 登陆MySQL,执行 show slave status \G 发现salve已经停止了 ...

  3. mysql主从报错截图

    1.首先确认报错的binlog和last event. 2.然后去主的机器上查看该报错的内容和报错的的位置,如果是结尾报错的,可以直接从新的binlog进行同步. #/mysql/logs# ../b ...

  4. MySQL主从-报错

    安装: 环境: 系统:centos7 x3 master:192.168.220.133 slave1:192.168.220.136 slave2:192.168.220.137 mysql服务器, ...

  5. 线上MYSQL同步报错故障处理总结(转)

    前言 在发生故障切换后,经常遇到的问题就是同步报错,数据库很小的时候,dump完再导入很简单就处理好了,但线上的数据库都150G-200G,如果用单纯的这种方法,成本太高,故经过一段时间的摸索,总结了 ...

  6. python 3.5.2安装mysql驱动报错

    python 3.5.2安装mysql驱动报错 python 3.5.2安装mysql驱动时出现如下异常: [root@localhost www]# pip install mysql-connec ...

  7. Loadrunner参数化连接oracle、mysql数据源报错及解决办法

    Loadrunner参数化连接oracle.mysql数据源报错及解决办法 (本人系统是Win7 64,  两位小伙伴因为是默认安装lr,安装在 最终参数化的时候,出现连接字符串无法自动加载出来: 最 ...

  8. 连接mysql数据库报错java.sql.SQLException: The server time zone value '�й���׼ʱ��' is unrecognized...解决方法

    今天连接mysql数据库报错如下: java.sql.SQLException: The server time zone value '�й���׼ʱ��' is unrecognized or r ...

  9. MYSQL—— 启动MYSQL 57 报错“The service MYSQL57 failed the most recent........等”的问题解决方式!

    每天开机之后,启动MYSQL Notifier就报错,第一次出现重启电脑后解决,后面的几天老是出现,重启电脑好几次都没有解决,感觉很烦人,一定要搞定这个问题找到原因,于是有了下文....... 启动M ...

随机推荐

  1. 12-numpy笔记-莫烦基本操作2

    代码 import numpy as np A = np.arange(3,15) print('-1-') print(A) print('-2-') print(A[3]) A = np.aran ...

  2. Python 包:

    分享一波油藏描述方面的Python开源包 前一阵去捷克参加了数学地质年会(IAMG2018),听完汇报,发现在数学地质领域用python的越来越多了,他们的很多成果都是用python做出来的.不管喜不 ...

  3. LG2598/BZOJ1412 「ZJOI2009」狼和羊的故事 最小割

    问题描述 LG2598 BZOJ1412 题解 看到要把狼和羊两个物种分开 自然想到最小割. 发现\((x,y)\)可以向上下左右走以获得贡献,所以建边:\((x,y),(x-1,y)\),\((x, ...

  4. CSP2019许愿贴

    CSP2019RP++

  5. Log-Structured Merge Tree (LSM Tree)

    一种树,适合于写多读少的场景.主要是利用了延迟更新.批量写.顺序写磁盘(磁盘sequence access比random access快). 背景 回顾数据存储的两个“极端”发展方向 加快读:加索引( ...

  6. Spring事物隔离级别及事物传播行为@Transactional实现

    阅读本篇文章前,请先阅读如下文章: 四种事物隔离级别详解 先看下@Transactional可以配制那些参数及以其所代表的意义. isolation 枚举org.springframework.tra ...

  7. google 镜像

    google 镜像 http://scholar.hedasudi.com/ http://ac.scmor.com/

  8. 向github项目push代码后,Jenkins实现其自动构建

    配置Jenkins(添加Github服务器) 1.进入[系统管理] --> [系统设置] ,找到[Github] 2.添加Github服务器 这里需要github提供一个密钥文本,我们去gith ...

  9. Ansible16:Playbook高级用法

    目录 本地执行 任务委托 任务暂停 滚动执行 只执行一次 设置环境变量 交互式提示 本地执行 如果希望在控制主机本地运行一个特定的任务,可以使用local_action语句. 假设我们需要配置的远程主 ...

  10. Deep Learning专栏--FFM+Recurrent Entity Network的端到端方案

    很久没有写总结了,这篇博客仅作为最近的一些尝试内容,记录一些心得.FFM的优势是可以处理高维稀疏样本的特征组合,已经在无数的CTR预估比赛和工业界中广泛应用,此外,其也可以与Deep Networks ...