关于SQL Server 无法生成 FRunCM 线程(不完全)
在五一的前一天,准备启动数据库完成我剩下的项目代码时,数据库配置管理器出现了一个让人蛋疼的问题
sqlserv配置管理器出现请求失败或服务器未及时响应
关于这个问题的处理方法,经过我两个小时的百度,网上对这个问题的解决方法有两种,
一、禁用SQL Server网络配置中的 MSSQLSERVER协议里的VIA协议
二、关闭TCP/IP协议
然而两个小时,无数帖子的求索告诉了我一个事实,这些东西都解决不了我现在的问题
在计算机右键管理点击事件查看器找到应用程序,SQL详细错误日志,虽然在网上可以找到
大概,但是仍然对我当前遇见的问题无用
错误详细原因如下:
错误日志一:{
日志名称: Application
来源: MSSQLSERVER
日期: 2017/4/30 10:56:58
事件 ID: 17120
任务类别: 服务器
级别: 错误
关键字: 经典
用户: 暂缺
计算机: DESKTOP-LA0ONVD
描述:
SQL Server 无法生成 FRunCM 线程。请查看 SQL Server 错误日志和 Windows 事件日志,获取有关可能发生的相关问题的信息。
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MSSQLSERVER" />
<EventID Qualifiers="49152">17120</EventID>
<Level>2</Level>
<Task>2</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-04-30T02:56:58.568064600Z" />
<EventRecordID>12134</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-LA0ONVD</Computer>
<Security />
</System>
<EventData>
<Data>FRunCM</Data>
<Binary>E042000010000000100000004400450053004B0054004F0050002D004C00410030004F004E0056004400000000000000</Binary>
</EventData>
</Event>
}
错误日志二:{
日志名称: Application
来源: MSSQLSERVER
日期: 2017/4/30 10:56:58
事件 ID: 17826
任务类别: 服务器
级别: 错误
关键字: 经典
用户: 暂缺
计算机: DESKTOP-LA0ONVD
描述:
由于网络库中存在内部错误,所以无法启动网络库。要确定原因,请查看错误日志中紧位于此错误之前的那些错误。
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MSSQLSERVER" />
<EventID Qualifiers="49152">17826</EventID>
<Level>2</Level>
<Task>2</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-04-30T02:56:58.568064600Z" />
<EventRecordID>12133</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-LA0ONVD</Computer>
<Security />
</System>
<EventData>
<Binary>A245000012000000100000004400450053004B0054004F0050002D004C00410030004F004E0056004400000000000000</Binary>
</EventData>
</Event>
}
错误日志三:{
日志名称: Application
来源: MSSQLSERVER
日期: 2017/4/30 10:56:58
事件 ID: 17182
任务类别: 服务器
级别: 错误
关键字: 经典
用户: 暂缺
计算机: DESKTOP-LA0ONVD
描述:
TDSSNIClient 初始化失败,出现错误 0x5,状态代码 0x1。原因: 初始化失败,出现基础结构错误。请检查以前的错误。 拒绝访问。
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MSSQLSERVER" />
<EventID Qualifiers="49152">17182</EventID>
<Level>2</Level>
<Task>2</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-04-30T02:56:58.568064600Z" />
<EventRecordID>12132</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-LA0ONVD</Computer>
<Security />
</System>
<EventData>
<Data>5</Data>
<Data>1</Data>
<Data>初始化失败,出现基础结构错误。请检查以前的错误。</Data>
<Data>拒绝访问。
</Data>
<Binary>1E43000010000000100000004400450053004B0054004F0050002D004C00410030004F004E0056004400000000000000</Binary>
</EventData>
</Event>
}
错误日志四:{
日志名称: Application
来源: MSSQLSERVER
日期: 2017/4/30 10:56:58
事件 ID: 17182
任务类别: 服务器
级别: 错误
关键字: 经典
用户: 暂缺
计算机: DESKTOP-LA0ONVD
描述:
TDSSNIClient 初始化失败,出现错误 0x5,状态代码 0x51。原因: 无法在注册表中配置与 MDAC 兼容的 Named Pipes 协议管道名称。 拒绝访问。
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MSSQLSERVER" />
<EventID Qualifiers="49152">17182</EventID>
<Level>2</Level>
<Task>2</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-04-30T02:56:58.552507600Z" />
<EventRecordID>12131</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-LA0ONVD</Computer>
<Security />
</System>
<EventData>
<Data>5</Data>
<Data>51</Data>
<Data>无法在注册表中配置与 MDAC 兼容的 Named Pipes 协议管道名称。</Data>
<Data>拒绝访问。
</Data>
<Binary>1E43000010000000100000004400450053004B0054004F0050002D004C00410030004F004E0056004400000000000000</Binary>
</EventData>
</Event>
}
最终解决方法:重装数据库
关于SQL Server 无法生成 FRunCM 线程(不完全)的更多相关文章
- SQL Server 无法生成 FRunCM 线程。请查看 SQL Server 错误日志和 Windows 事件日志
1.IP地址配置不正确: 打开 Microsoft SQL Server 2005配置工具下的SQL Server Configuration Manager,选择MSSQLSERVER协议, 然后双 ...
- SQL Server中生成测试数据
原文:SQL Server中生成测试数据 简介 在实际的开发过程中.很多情况下我们都需要在数据库中插入大量测试数据来对程序的功能进行测试.而生成的测试数据往往需要符合特定规则.虽然可以自己写 ...
- Powerdesigner逆向工程从sql server数据库生成pdm【转】
Powerdesigner逆向工程从sql server数据库生成pdm 第一步:打开"控制面板"中的"管理工具" 第二步:点击"管理工具" ...
- 如何在SQL Server中生成和使用CRUD存储过程
在本文中,请参阅如何在SQL Server中生成和使用CRUD存储过程. 大多数数据库系统基于缩写CRUD调用的最简单的4种数据操作操作进行操作. 此首字母缩写词代表CREATE,READ,UPDAT ...
- SQL Server 动态生成数据库所有表Insert语句
一. 背景 SQL Server,如果我们需要把数据库A的所有表数据到数据库B中,通常我们会怎么做呢?我会使用SSMS的导入导出功能,进行表数据的导入导出,无可厚非,这样的导入非常简单和方便: 但是, ...
- SQL Server存储过程中防止线程重入处理方式
对于线程重入,在C#中有lock关键字锁住一个SyncObject,而SQL Server也可用一个表来模拟实现. 先创建一个同步表,相当于C#中的SyncObject,并插入一条记录(初始值为1) ...
- SQL SERVER 批量生成编号
开始: 在testing中,为了模拟orders,有个要求给数据库dba,如何通过后台数据库脚本快速批量生成orders. 分析 站在数据库角度,批量生成orders,也就是批量生成表中的行数据. s ...
- sql server中的工作线程
/*在SQL SERVER 2005 及以后版本中, 使用'MAXworker thread' 来配置可用的线程数,默认设置为0 ,即自动控制线程数 计算最大工作线程数: 对于32 位系统:逻辑CPU ...
- SQL Server 存储过程生成流水号
SQL Server利用存储过程生成流水号 USE BiddingConfig SET QUOTED_IDENTIFIER ON SET ANSI_NULLS ON GO -- =========== ...
随机推荐
- HDU 6063 17多校3 RXD and math(暴力打表题)
Problem Description RXD is a good mathematician.One day he wants to calculate: ∑i=1nkμ2(i)×⌊nki−−−√⌋ ...
- 2016 多校联赛7 Joint Stacks (优先队列)
A stack is a data structure in which all insertions and deletions of entries are made at one end, ca ...
- Python 正则 —— 捕获与分组
\n:表示第 n 个捕获: >> s = "<html><h1>what the fuck!</h1></html>" ...
- mysql时间日期函数总结(转)
DAYOFWEEK(date) 返回日期date是星期几(1=星期天,2=星期一,……7=星期六,ODBC标准)mysql> select DAYOFWEEK('1998-02-03'); ...
- Linux audit安全审计工具
/********************************************************************** * Linux audit安全审计工具 * 说明: * ...
- 20155208 实验四 Android开发基础
20155208 实验四 Android开发基础 实验内容 1.基于Android Studio开发简单的Android应用并部署测试; 2.了解Android.组件.布局管理器的使用: 3.掌握An ...
- 20155208徐子涵 2016-2017-2 《Java程序设计》第5周学习总结
20155208徐子涵 2016-2017-2 <Java程序设计>第5周学习总结 教材学习内容总结 第八章 异常处理 8.1 语法与继承结构 Java中所有错误都会被打包为对象,运用tr ...
- C语言--第一周作业评分和总结(5班)
作业链接:https://egdu.cnblogs.com/campus/hljkj/CS2017-5/homework/963 一.评分要求 * 要求1 (5分):博客中给出安装软件的截图(得分点1 ...
- 【HDOJ1045】【DFS】
http://acm.hdu.edu.cn/status.php?user=MekakuCityActors&pid=1045&status=5 Fire Net Time Limit ...
- D. The Fair Nut and the Best Path 树形dp (终于会了)
#include<bits/stdc++.h> #define int long long using namespace std; ; int a[maxn]; int dp[maxn] ...