前些天安装蓝鲸的测试环境频繁出现You have new mail in /var/spool/mail/root,查看发现是/usr/local/gse/agent/bin/gsectl: line 19: ip: command not found,查了下报错频率基本上是每分钟报错一次。

[root@rbtnode1 install]#
You have new mail in /var/spool/mail/root
[root@rbtnode1 install]#
[root@rbtnode1 install]# tail -20f /var/spool/mail/root
id D85A730F67A5; Sun, 8 Mar 2020 16:51:02 +0800 (CST)
From: "(Cron Daemon)" <root@rbtnode1.localdomain>
To: root@rbtnode1.localdomain
Subject: Cron <root@rbtnode1> /usr/local/gse/agent/bin/gsectl watch
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
Precedence: bulk
X-Cron-Env: <XDG_SESSION_ID=3138>
X-Cron-Env: <XDG_RUNTIME_DIR=/run/user/0>
X-Cron-Env: <LANG=en_US.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>
Message-Id: <20200308085102.D85A730F67A5@rbtnode1.localdomain>
Date: Sun, 8 Mar 2020 16:51:01 +0800 (CST) /usr/local/gse/agent/bin/gsectl: line 19: ip: command not found ^C

看下目前为止的报错次数:

[root@rbtnode1 install]# grep "line 19: ip: command not found" /var/spool/mail/root |wc -l
15748
[root@rbtnode1 install]#
You have new mail in /var/spool/mail/root
[root@rbtnode1 install]# grep "line 19: ip: command not found" /var/spool/mail/root |wc -l
15750

查看/usr/local/gse/agent/bin/gsectl文件,vi定位到19行:

     17 get_lan_ip  () {
18 #
19 ip addr | \
20 awk -F'[ /]+' '/inet/{
21 split($3, N, ".")
22 if ($3 ~ /^192.168/) {
23 print $3
24 }
25 if (($3 ~ /^172/) && (N[2] >= 16)) {
26 print $3
27 }
28 if ($3 ~ /^10\./) {
29 print $3
30 }
31 }'
32 return $?
33 }
34 export LAN_IP=$(get_lan_ip | head -1)

使用which ip 查看系统ip命令的路径:

[root@rbtnode1 install]# which ip
/usr/sbin/ip

尝试修改第19行,ip命令的调用改为绝对路径:/usr/sbin/ip

     19    /usr/sbin/ip addr | \

再次查看报错次数和最近的报错时间:

[root@rbtnode1 install]# grep "line 19: ip: command not found" /var/spool/mail/root |wc -l
15755 [root@rbtnode1 install]# tail -20f /var/spool/mail/root
id 9647530F67A5; Sun, 8 Mar 2020 16:58:03 +0800 (CST)
From: "(Cron Daemon)" <root@rbtnode1.localdomain>
To: root@rbtnode1.localdomain
Subject: Cron <root@rbtnode1> /usr/local/gse/agent/bin/gsectl watch
Content-Type: text/plain; charset=UTF-8
Auto-Submitted: auto-generated
Precedence: bulk
X-Cron-Env: <XDG_SESSION_ID=3279>
X-Cron-Env: <XDG_RUNTIME_DIR=/run/user/0>
X-Cron-Env: <LANG=en_US.UTF-8>
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
X-Cron-Env: <USER=root>
Message-Id: <20200308085803.9647530F67A5@rbtnode1.localdomain>
Date: Sun, 8 Mar 2020 16:58:02 +0800 (CST) /usr/local/gse/agent/bin/gsectl: line 19: ip: command not found

后续观察没再发现这个报错计数增长,也没有16:58:03之后的报错信息,说明改动有效。

蓝鲸:主机频繁提示“You have new mail in /var/spool/mail/root” 定位解决的更多相关文章

  1. 解决Centos关闭You have new mail in /var/spool/mail/root提示

    昨天搬到阿里云了. 装的系统是Centos 6.3的加固版 今天查看内存的时候 出现一天奇怪的提示 You have new mail in /var/spool/mail/root 有的时候每敲一下 ...

  2. 解决Centos关闭You have new mail in /var/spool/mail/root提示(转)

    今天查看内存的时候 出现一天奇怪的提示 You have new mail in /var/spool/mail/root 有的时候每敲一下回车,就出来You have new mail in /va ...

  3. Linux关闭You have new mail in /var/spool/mail/root提示

    终端远程登陆Linux后经常提示You have new mail in /var/spool/mail/root 这个提示是LINUX会定时查看LINUX各种状态做汇总,每经过一段时间会把汇总的信息 ...

  4. You have new mail in /var/spool/mail/root消除提示的方法

    有时在进入系统的时候经常提示You have new mail in /var/spool/mail/root 你觉得烦人---解决方法: 修改系统配置文件/etc/profile,告诉系统不要去检查 ...

  5. You have new mail in /var/spool/mail/root 解决烦琐提示的方法

    今天写定时任务时,出现奇怪的提示,有的时候每敲一下回车,也出现奇怪的提示 You have new mail in /var/spool/mail/root 阿西吧........表示很烦...究竟是 ...

  6. 禁止Centos系统You have new mail in /var/spool/mail/root提示

    禁止Centos系统You have new mail in /var/spool/mail/root提示 https://blog.csdn.net/oyym_mv/article/details/ ...

  7. 解决You have new mail in /var/spool/mail/root提示

    终端远程登陆后经常提示You have new mail in /var/spool/mail/root 这个提示是LINUX会定时查看LINUX各种状态做汇总,每经过一段时间会把汇总的信息发送的ro ...

  8. Linux出现You have new mail in /var/spool/mail/root提示,关闭邮件提示清理内容的解决方案

    Linux出现You have new mail in /var/spool/mail/root提示,关闭邮件提示的解决方案 有的时候敲一下回车,就出来You have new mail in /va ...

  9. You have new mail in /var/spool/mail/root 烦不烦你(转)

    转自(http://blog.csdn.net/yx_l128125/article/details/7425182) 有时在进入系统的时候经常提示You have new mail in /var/ ...

  10. you have new mail in /var/spool/mail/root !

    今天开发的同事告诉我,他在登录系统时老是提示you have new mail in /var/spool/mail/root ! 我一猜就知道他们肯定又自己写定时任务了,这样的事已经发生过好几回了, ...

随机推荐

  1. hbulider 运行微信开发者工具 Enable IDE Service (y/N) 

    问题:hbulider 运行微信开发者工具 出现如下页面,没有输入y的交互界面  解决办法:先安装微信开发者工具,然后打开微信开发者工具 再次运行:

  2. C语言基础之基础的输入输出

    前言 学一门编程语言,不能编写让用户输入数据然后输出处理后的数据的程序那么就等于没学,而在C语言中可以用printf() 和 scanf() 函数进行输入和输出操作.这两个函数是内置的库函数,定义在 ...

  3. go Print 和 反射

    0. 前言 在 小白学标准库之反射 reflect 篇中介绍了反射的三大法则.但并未给出具体示例介绍反射,感觉还是少了点什么.这里进一步通过fmt.Println 源码,查看反射如何使用的,算是对前文 ...

  4. Guava缓存工具类封装和使用

    本文为博主原创,未经允许不得转载: Guava是谷歌提供的一款强大的java工具库,里面包含了很多方便且高效的工具,在项目开发中有业务场景需要保存数据到内存当中, 且只需要保存固定时间就可以,该数据只 ...

  5. spring启动流程 (1) 流程概览

    本文将通过阅读AnnotationConfigApplicationContext源码,分析Spring启动流程. 创建AnnotationConfigApplicationContext Annot ...

  6. Spring Cloud 系列:Seata 中TCC模式具体实现

    概述 https://seata.io/zh-cn/docs/dev/mode/tcc-mode https://seata.io/zh-cn/docs/user/mode/tcc TCC模式与AT模 ...

  7. iframe访问页面,出现 ERR_BLOCKED_BY_RESPONSE

    那是因为服务器输出了 X-Frame-Options 头,只要把这个头删除掉,就没问题了

  8. linux-介绍

  9. [转帖]Kafka中Topic级别配置

    https://www.cnblogs.com/moonandstar08/p/6139502.html 一.Kafka中topic级别配置 1.Topic级别配置 配置topic级别参数时,相同(参 ...

  10. [转帖]TiKV 内存调优

    TiDB试用 来源:TiDB  浏览 87 扫码 分享 2023-05-09 09:02:19 TiKV 内存参数性能调优 参数说明 TiKV 内存使用情况 TiKV 机器配置推荐 TiKV 内存参数 ...