1.Use the database access client to connect to the database server as the root user:
$ mysql -u root -p

2.Create the glance database:
CREATE DATABASE glance;

3.Grant proper access to the glance database:
GRANT ALL PRIVILEGES ON glance.* TO 'glance'@'localhost' IDENTIFIED BY '123456';
GRANT ALL PRIVILEGES ON glance.* TO 'glance'@'%' IDENTIFIED BY '123456';

4.Exit the database access client.

5.切换到管理员身份
source admin-openrc.sh 我保存的位置:/etc/keystone

6.创建glance用户
$ keystone user-create --name glance --pass 123456


7.为glance用户添加admin角色:
$ keystone user-role-add --user glance --tenant service --role admin


8.创建 glance 服务实体:
keystone service-create --name glance --type image --description "OpenStack Image Service"


9.创建Image Service API 端点:
keystone endpoint-create --service-id $(keystone service-list | awk '/ image / {print $2}') --publicurl http://controller:9292 --internalurl http://controller:9292 --adminurl http://controller:9292 --region regionOne


10. 安装包
# apt-get install glance python-glanceclient

11.编辑/etc/glance/glance-api.conf 加入下面的内容
[database]#connection = mysql://glance:GLANCE_DBPASS@controller/glance(不行)
connection = mysql://glance:GLANCE_DBPASS@10.0.0.11/glance...[keystone_authtoken]#Note:Comment out any auth_host, auth_port, and auth_protocol options because the identity_uri
option replaces them.auth_uri = http://controller:5000/v2.0identity_uri = http://controller:35357admin_tenant_name = serviceadmin_user = glanceadmin_password = GLANCE_PASS...[paste_deploy]flavor = keystone...[glance_store]...default_store = filefilesystem_store_datadir
= /var/lib/glance/images/[DEFAULT]...notification_driver = noop[DEFAULT]...verbose = True
在本文中GLANCEDBPASS和GLANCEPASS都为123456

12.编辑 /etc/glance/glance-registry.conf 加入下面的内容:
[database]...#connection = mysql://glance:GLANCE_DBPASS@controller/glance(不行)
connection = mysql://glance:GLANCE_DBPASS@10.0.0.11/glance[keystone_authtoken]...auth_uri = http://controller:5000/v2.0identity_uri = http://controller:35357admin_tenant_name
= serviceadmin_user = glanceadmin_password = GLANCE_PASS[paste_deploy]...flavor = keystone[DEFAULT]...notification_driver = noopverbose = True

13.Restart the Image Service services:
# service glance-registry restart
# service glance-api restart

14.Create and change into a temporary local directory:
$ mkdir /tmp/images

15.Download the image to the temporary local directory:(注:手册上的镜像地址有变化)
wget -p /tmp/images http://download.cirros-cloud.net/0.3.3/cirros-0.3.3-x86_64-disk.img

16.Source the admin credentials to gain access to admin-only CLI commands:
$ source admin-openrc.sh

17.Upload the image to the Image Service:
glance image-create --name "cirros-0.3.3-x86_64" --file /tmp/images/cirros-0.3.3-x86_64-disk.img --disk-format qcow2 --container-format bare --is-public True --progress
注:
(如果在安装镜像服务(Image Service)时,在Verify the Image Service installation这一步,上传镜像到镜像服务时(Upload the image to the Image Service)提示如标题所示的错误:Request returned
failure status. HTTPInternalServerError (HTTP 500).

解决方法:(参见16.Source the admin credentials to gain access to admin-only CLI commands:
$ source admin-openrc.sh)后重启glance-registry和glance-api两个服务,即在命令行输入 service
glance-registry restart和service glance-api restart  运行,问题迎刃而解!原因是重启Linux(ubuntu),导致以上两个服务被关闭。其实这只是一个低级错误,有很多人也遇到过这个错误。)

18.查询映像以确认数据是否正确
$ glance image-list

19.删除临时目录
$ rm -r /tmp/images

查找文件位置:locate 文件名
例:locate cirros-0.3.3-x86_64-disk.img

openstack镜像服务(glance)的更多相关文章

  1. 云计算管理平台之OpenStack镜像服务glance

    一.glance简介 openstack中的glance服务是用来存储在openstack上启动虚拟机所需镜像:它主要用于发现.注册及检索虚拟机镜像:它通过提供RESTful风格的api对外提供服务: ...

  2. OpenStack 镜像服务 Glance部署(六)

    Glance介绍 创建虚拟机我们需要有glance的支持,因为glance是提供镜像的服务. Glance有两个比较重要的服务: Glance-api:接受云系统镜像的构建.删除.读取请求 Glanc ...

  3. OpenStack 镜像服务 Glance部署(七)

    创建虚拟机我们需要有glance的支持,因为glance是提供镜像的服务. Glance有两个比较重要的服务: Glance-api:接受云系统镜像的构建.删除.读取请求 Glance-Registr ...

  4. 【openstack N版】——镜像服务glance

    一.openstack镜像服务glance 1.1 glance介绍 glance主要是由三部分组成 glance-api:接收云系统镜像的创建,删除,读取请求,类似nova-api,通过其他模块(g ...

  5. Centos7 install Openstack - (第三节)添加镜像服务(Glance)

    Centos7 install Openstack - (第三节)添加镜像服务(Glance) 我的blog地址:http://www.cnblogs.com/caoguo 该文根据openstack ...

  6. OpenStack实践系列③镜像服务Glance

    OpenStack实践系列③镜像服务Glance 3.5 Glance部署 修改glance-api和glance-registry的配置文件,同步数据库 [root@node1 ~]# vim /e ...

  7. Openstack(八)部署镜像服务glance

    8.1glance镜像服务介绍 Glance是OpenStack镜像服务组件,glance服务默认监听在9292端口,其接收REST API请求,然后通过其他模块(glance-registry及im ...

  8. [ Openstack ] OpenStack-Mitaka 高可用之 镜像服务(glance)

    目录 Openstack-Mitaka 高可用之 概述    Openstack-Mitaka 高可用之 环境初始化    Openstack-Mitaka 高可用之 Mariadb-Galera集群 ...

  9. 探索 OpenStack 之(10):深入镜像服务Glance

    本篇博文来探讨下镜像服务Glance. 0.  基本概念 0.1 基本功能 Glance提供REST API来支持以下镜像操作: 查询 注册 上传 获取 删除 访问权限管理 0.2 Glance RE ...

  10. OpenStack入门篇(八)之镜像服务Glance

    一.Glance的概述 Glance是为虚拟机的创建提供镜像的服务,我们基于Openstack是构建基本的IaaS平台对外提供虚拟机,而虚拟机在创建时必须为选择需要安装的操作系统,Glance服务就是 ...

随机推荐

  1. ES6---new Promise()讲解(尤其注意里面的参数resolve、reject)

    直接打印出来看看吧,console.dir(Promise). 这么一看就明白了,Promise是一个构造函数,自己身上有all.reject.resolve这几个眼熟的方法,原型上有then.cat ...

  2. Python 3标准库课件

    开课前的一些讲话: 一.大家晚上好,首先非常的荣幸能够在网易云平台开设讲解Python的这门课程,我也是第一次讲解哦,下面说说我讲解课程的原因,1.因为我发现市场上讲解Python的课程很多,不过,大 ...

  3. Nginx模块开发实验

    工作原理: 当nginx接到 一个http请求之后,会找通过查找配置文件,并在配置文件中找到相应的地址映射,该地址也叫location block,而location中配置的文件会启动 相应的bloc ...

  4. 部署jumpserver

    参考:https://jumpserver.readthedocs.io/zh/master/setup_by_centos7.html yum update -y systemctl start f ...

  5. Python爬虫十六式 - 第四式: 使用Xpath提取网页内容

    Xpath:简单易用的网页内容提取工具 学习一时爽,一直学习一直爽 !   Hello,大家好,我是Connor,一个从无到有的技术小白.上一次我们说到了 requests 的使用方法.到上节课为止, ...

  6. luogu P1352 没有上司的舞会 x

    P1352 没有上司的舞会 题目描述 某大学有N个职员,编号为1~N.他们之间有从属关系,也就是说他们的关系就像一棵以校长为根的树,父结点就是子结点的直接上司.现在有个周年庆宴会,宴会每邀请来一个职员 ...

  7. android之实现上下左右翻页效果

    如果实现上下或者左右翻页效果,我们借助下这个开源项目:https://github.com/openaphid/android-flip Aphid FlipView是一个能够实现Flipboard翻 ...

  8. 类锁和对象锁,synchronized修饰static方法与非static方法的区别

    当synchronized修饰一个static方法时,多线程下,获取的是类锁(即Class本身,注意:不是实例), 作用范围是整个静态方法,作用的对象是这个类的所有对象. 当synchronized修 ...

  9. linux系统安装Oracle11g详细步骤

    快速安装指引 ■Reviewing Information About This Guide■Logging In to the System as root 以root用户登录系统■Checking ...

  10. ES排序值相同顺序随机的问题

    ES排序值相同顺序随机的问题 code[class*="language-"] { padding: .1em; border-radius: .3em; white-space: ...