表或视图不存在

原因:1.表或视图真的不存在 2.用户没有访问该表的权限。

ORA-01078: 处理系统参数失败

ORA-01438: value larger than specified precision allows for this column

ORA-01441: cannot decrease column length because some value is too big

ORA-01536: space quota exceeded for tablespace 'ODS'

ORA-01555: snapshot too old: rollback segment number 1 with name "_SYSSMU1$" too small

对ORA-01555的精彩解释

1、在1点钟,有个用户A发出了select * from table1;此时不管将来table1怎么变化,正确的结果

应该是用户A会看到在1点钟这个时刻的内容。这个是没有疑问的。

2、在1点30分,有个用户B执行了update命令,更新了table1表中的第4000万行的这条记录,这时,

用户A的全表扫描还没有到达第4000万条。毫无疑问,这个时候,第4000万行的这条记录是被写

到了回滚段里去了的,我假设是回滚段RBS1,如果用户A的全表扫描到达了第4000万行,是应该

会正确的从回滚段RBS1中读取出1点钟时刻的内容的。

3、这时,用户B将他刚才做的操作commit了,但是这时,系统仍然可以给用户A提供正确的数据,

因为那第4000万行记录的内容仍然还在回滚段RBS1里,系统可以根据SCN来到回滚段里找到正确的

数据,但是大家注意到,这时记录在RBS1里的第4000万行记录已经发生了一点重大的改变:就是

这个第4000万行的在回滚段RBS1里的数据有可能随时被覆盖掉,因为这条记录已经被提交了!!!

4、由于用户A的查询时间漫长,而业务在一直不断的进行,RBS1回滚段在被多个不同的tracnsaction

使用着,这个回滚段里的extent循环到了第4000万行数据所在的extent,由于这条记录已经被标记

提交了,所以这个extent是可以被其他transaction覆盖掉的!

5、到了1点40分,用户A的查询终于到了第4000万行,而这时已经出现了第4条说的情况,需要到回滚

段RBS1去找数据,但是已经被覆盖掉了,于是01555就出现了。

以上只是我当初在看OCP书的时候,对这个01555的一个简单的理解,并同时可以理解书上说的解决

ora-01555的问题的办法,当然可能还有其他的情况导致,我只举个例子。

ORA-08180: no snapshot found based on specified time

ORA-27101: shared memory realm does not exist

解决方法

修改注册表中的键值LocalMechine\software\oracle\home0\ORACLE_SID为你的SID

ID                                       0

MSHELP_TOOLS                    D:\oracle\ora90\MSHELP

NLS_LANG                            SIMPLIFIED CHINESE_CHINA.ZHS16GBK

ORA_HNDSS_AUTOSTART       TRUE

ORA_HNDSS_PFILE                D:\oracle\ora90\database\initHNDSS.ora

ORA_HNDSS_SHUTDOWN       TRUE

ORA_HNDSS_SHUTDOWN_TIMEOUT      30

ORA_HNDSS_SHUTDOWNTYPE       i

ORACLE_BASE  D:\oracle

ORACLE_BUNDLE_NAME  Enterprise

ORACLE_GROUP_NAME          Oracle - OraHome90

ORACLE_HOME                     D:\oracle\ora90

ORACLE_HOME_KEY              Software\ORACLE\HOME0

ORACLE_HOME_NAME            OraHome90

ORACLE_SID                         hndss

RDBMS_ARCHIVE                   D:\oracle\ora90\DATABASE\ARCHIVE

RDBMS_CONTROL                  D:\oracle\ora90\DATABASE

SQLPATH                             D:\oracle\ora90\db

描述

刚在professionall装了9i,在sql*plus用system/manager连接能正常使用。

过了一会儿再用就报错如下:

SQL*Plus: Release 9.0.1.0.1 - Production on 星期三 2月 18 08:32:40 2004

(c) Copyright 2001 Oracle Corporation.??All rights reserved.

ERROR:

ORA-01034: ORACLE not available

ORA-27101: shared memory realm does not exist

记得当时重启后系统提示虚拟页面不足,重新分配了c和d盘的虚拟页面,难道这也有问题???

原因:

原因是在同一个服务器上,使用了不同的ORACLE_HOME

首先检查文件initSID.ora和listener.ora等,看ORACLE_SID和ORACLE_HOME设置的正确与否,ORACLE8.1.7是否用该参数值启动并运行。在UNIX环境中,字母大小写的意义是不一样的,这一点应当注意。如果ORACLE_HOME指向8.1.7版,而数据库是用8.1.6版或8.1.5版建立的,也可能出现该种错误信息。

在WINDOWS系统中,如果修改了机器名或IP地址,ORACLE8.1.7启动时使用的机器名或IP地址就不是真正的机器名或IP地址,就会出现该种错误。可以查看目录database下的文件oradim.log,根据内容确定原因    

oracle-ORA-00942错误的更多相关文章

  1. Oracle Ora 错误解决方案合集

    注:本文来源于 < Oracle学习笔记 --- Oracle ORA错误解决方案 > ORA-00001: 违反唯一约束条件 (.)错误说明:当在唯一索引所对应的列上键入重复值时,会触发 ...

  2. navicat cannot load oci dll||oracle 改字符集为GBK后 navicat 连不上||Ora-28547 ora net错误

    此段适用于 解决 navicat cannot load oci dll 环境 Navicat Premium  和 oracle 原因,navicat 32 和64 都只支持 32位的oci.dll ...

  3. oracle数据库登录连接很慢;kettle连接oracle 报 IO 错误,socket time out 问题解决记录

    问题描述: 1:oracle数据库连接登陆时突然变得很慢:sqldeveloper链接数据库很慢: 2:Kettle-spoon etl程序访问数据库,任务执行时报 :数据库连接 IO错误 :Sock ...

  4. Oracle的常见错误及解决办法

    ORA-12528: TNS:listener: all appropriate instances are blocking new connections ORA-12528问题是因为监听中的服务 ...

  5. Oracle LISTENER 主机名修改为IP地址后LISTENER无法监听到实例 oracle监听错误与hosts文件配置

    为什么listener.ora文件里面HOST后面到底应该输入IP地址还是主机名.我的经验告诉我,这边最好使用主机名.很多的时候,一个机器绑定的不只一个IP地址,如HOST后面是IP地址,那么ORAC ...

  6. Oracle ORA

    ORA-00001: 违反唯一约束条件 (.) 错误说明:当在唯一索引所对应的列上键入重复值时,会触发此异常. ORA-00017: 请求会话以设置跟踪事件 ORA-00018: 超出最大会话数 OR ...

  7. Oracle安装连接常见错误

    oracle安装注意:安装路径url不能带中文C:\app\59428\product\11.2.0\dbhome_1\sqldeveloper打开sqldeveloper的时候,需要输入java.e ...

  8. Oracle OCI-22053:溢出错误解决方法

    原文 Oracle OCI-22053:溢出错误解决方法 Oracle 数值数据类型最多可存储 38 个字节的精度.当将 Oracle 数值转换为公共语言运行库数据类型时,小数点后边的位数可能过多,这 ...

  9. 未指定的错误,发生了一个 Oracle 错误,但无法从 Oracle 中检索错误信息。数据类型不被支持。

    未指定的错误,发生了一个 Oracle 错误,但无法从 Oracle 中检索错误信息.数据类型不被支持. 博客分类: 雅芳生涯 .Net VB C# OracleMicrosoftSecurity  ...

  10. 关于oracle 11g导出数据时 报 ORA 1455错误的处理

    因为导出的该用户的表可能存在空数据表,那么可能就会出现此其异常. 首先:  查看:     SQL>show parameter deferred_segment_creation;  假设为T ...

随机推荐

  1. Spring注解驱动开发(六)-----spring容器创建【源码】

    Spring容器的refresh()[创建刷新] 1.prepareRefresh()刷新前的预处理 1).initPropertySources()初始化一些属性设置;子类自定义个性化的属性设置方法 ...

  2. 事务一致性理解 事务ACID特性的完全解答

    A  原子性 事务管理者多个小操作,他们同时完成或者同时不完成就是原子性 C 一致性 一致性,是一个很相对的,很主观的概念, 一致性 描述的是 事务 从一个一致的状态变成 另一个一致的状态. 一致性需 ...

  3. mysql中的字符集和校对规则(mysql校对集)

    1.简要说明介绍 字符集和校对规则 字符集是一套符号和编码.校对规则是在字符集内用于比较字符的一套规则. MySql在collation提供较强的支持,oracel在这方面没查到相应的资料. 不同字符 ...

  4. java记录CST时间类型的字符串转换问题

    下列代码可以实现把Java的CST格式的时间字符串转为为Date对象和所需要的日期时间格式! String dateStr = "Wed Sep 16 11:26:23 CST 2009&q ...

  5. Python学习之--数字转人民币读法(解决问题的方法很重要)

    效果图: 实现代码: money = float(input("Please input the money:"))cop = int(money)Num = ['零','壹',' ...

  6. Finalize什么时候被调用

    Finalize方法在垃圾回收结束时被调用,有五种一下情况会导致开始垃圾回收. 第0代已满  第0代满时,垃圾回收会自动开始.改时间是目前导致Finalize方法被调用的最常见的一种方式,因为随着应用 ...

  7. python-基础-字符串-列表-元祖-字典

    1 字符串 1.1 下标和切片 1.2 切片 1.3 字符串常见操作 如有字符串mystr = 'hello world itcast and itcastcpp',以下是常见的操作 <1> ...

  8. umask权限使用

    很显然,系统中各种文件的权限设置对特定用户的数据安全有很大影响.但是要求用户逐一明确设置系统中每个文件的权限也是不现实的,为此,需要使用umask命令,该命令可以为用户账号中新文件的创建进行缺省设置. ...

  9. textarea标签中多出的空格

    //这么写才能被正确渲染 <textarea></textarea> //这样就会有空格 <textarea> </textarea> 不能换行,涨姿势

  10. light oj 1149 Factors and Multiples(二分匹配)

    LightOJ1149 :Factors and Multiples 时间限制:2000MS    内存限制:32768KByte   64位IO格式:%lld & %llu 描述 You w ...