安装

如果原来安装过docker,先把原来的删掉,再安装(如果是首次安装docker忽略第一步,直接在第二步看起)

1.1先查看下已经安装了那些docker

yum list installed | grep docker

查看结果

docker.x86_64 2:1.13.1-94.gitb2f74b2.el7.centos
docker-client.x86_64 2:1.13.1-94.gitb2f74b2.el7.centos
docker-common.x86_64 2:1.13.1-94.gitb2f74b2.el7.centos

1.2 再删除已经安装的版本

yum -y remove docker.x86_64

把上面三个彻底删除

2、直接使用root安装

  

yum install -y docker-io

3.启动docker服务

systemctl start docker
systemctl enable docker.service

4.查看默认镜像源ngnix

docker search ngnix

5.docker拉取官方nginx镜像

docker pull nginx

6.等待下载完成后,我们就可以在本地镜像列表里查到 REPOSITORY 为 nginx 的镜像

docker images

REPOSITORY            TAG     IMAGE ID     CREATED SIZE
docker.io/nginx         latest   bb776ce48575    3 days ago 109 MB
docker.io/centos       latest   9f38484d220f     4 weeks ago 202 MB
docker.io/userxy2015/ngnix  latest   17a92fa0c614       2 years ago 182 MB

7.启动nginx

docker run  -d -P --name ngnix1 nginx

[root@localhost ~]# docker run -d -P --name ngnix1 nginx
3bd22c8f34030a7b12782b2cd023c63d64bcb6250546a60d86a709011f9d8f06

8.查看nginx详细信息

docker ps -l

[root@localhost ~]# docker ps -l
CONTAINER ID      IMAGE    COMMAND           CREATED       STATUS      PORTS           NAMES
3bd22c8f3403     nginx     "nginx -g 'daemon ..."    16 seconds ago    Up 15 seconds   0.0.0.0:32768->80/tcp    ngnix1

特别注意下PORTS项:

0.0.0.0:32768->80/tcp :通过tcp协议传输将docker容器里的nginx端口映射到物理机的32768端口,所有我们只需要访问该端口就能访问nginx服务了

出现下图nginx部署到docker完成

CentOS7上Docker简单安装及nginx部署的更多相关文章

  1. Centos7上docker的安装和基本使用

    Centos7上Docker的相关操作 Docker的安装 1.检查内核版本 docker使用linux的内核必须是3.10以上,首先需要 # uname -r 2.使用yum安装docker # y ...

  2. centos7上docker安装和使用教程

    Docker 是一个创建和管理 Linux 容器的开源工具.容器就像是轻量级的虚拟机,并且可以以毫秒级的速度来启动或停止.Docker 帮助系统管理员和程序员在容器中开发应用程序,并且可以扩展到成千上 ...

  3. Centos7上一次War包的部署与运行

    Centos7上一次War包的部署与运行 前言 由于前段时间第一次部署一个小型的项目,时间一长所以有些步骤有时候时间一长就忘了,在此做个简单的记录 一.原始系统开发环境 操作系统:Windows10: ...

  4. 使用 Browser-solidity 在 Go-Ethereum1.7.2 上进行简单的智能合约部署

    目录 目录 1.基本概念 1.1.什么是智能合约? 1.2.什么是Solidity? 1.2.1.Solidity的语言特性 1.3.什么是 Browser-solidity? 2.Browser-s ...

  5. 在CentOS7上通过RPM安装实现LAMP+phpMyAdmin过程全记录

    在CentOS7上通过RPM安装实现LAMP+phpMyAdmin过程全记录 时间:2017年9月20日 一.软件环境: IP:192.168.1.71 Hostname:centos73-2.sur ...

  6. Centos7上HBase的安装和配置

    注意事项 HBase配置必须使用主机名,不支持直接配置IP地址.我尝试过,如果不使用主机名直接用IP,会导致HBase连接zk超时. > 设置主机名 hostnamectl set-hostna ...

  7. CentOS7上Python3.5安装

    CentOS7上Python3.5安装 1.下载 https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz 2.上传到服务器 3. yum in ...

  8. centos7下docker的安装教程

    Centos7下docker安装教程以及踩过的那些坑 推荐在Centos下安装docker,在windows下安装docker可能会遇到很多的问题,而且docker官方推荐使用linux环境来使用do ...

  9. 在centos7上使用packstack安装openstack

    简介 Packstack主要是由Redhat推出的用于概念验证(PoC)环境快速部署的工具.Packstack是一个命令行工具,它使用Python封装了Puppet模块,通过SSH在服务器上部署Ope ...

随机推荐

  1. Asp.net 项目部署的两个问题

    1:关于MVC中BundleCollection压缩js css文件 发布后获取失败的问题 原因是: 默认本地vs里面调试的时候,因为web.config文件里面有一个debug属性,当有此属性时,默 ...

  2. RNN和LSTM

    一.RNN 全称为Recurrent Neural Network,意为循环神经网络,用于处理序列数据. 序列数据是指在不同时间点上收集到的数据,反映了某一事物.现象等随时间的变化状态或程度.即数据之 ...

  3. Linux启动activemq失败

    第一种情况: 在网上查找错误,通过./activemq console命令可以查看到activemq启动的错误信息,另外在data/activemq.log文件中可以查看到错误日志. java.io. ...

  4. CV code references

    转:http://www.sigvc.org/bbs/thread-72-1-1.html 一.特征提取Feature Extraction:   SIFT [1] [Demo program][SI ...

  5. Filebeat 启动关闭流程

    启动阶段: instance/beat.go #打印home路径.配置路径.数据路径和日志路径 seccomp #Syscall filter检查 instance/beat.go #beat inf ...

  6. find your present (2) hdoj 2095

    /* author:谦智 find your present (2) hdoj 2095 法一:用暴力 法二:用map 法三: 符号是^. 异或是个位运算符号,具体是怎么操作的请百度,这里有个特性使得 ...

  7. TableView+Button

    local MainScene = class("MainScene", cc.load("mvc").ViewBase) function MainScene ...

  8. docker简单介绍----Dockerfile命令

    DockerFile的组成部署: 下面优先介绍下Dcokerfile的基础指令 一.CMD指令:容器启动时要莫热门运行的命令,如果有多个CMD指定,最后一个生效 使用方法: CMD ["ex ...

  9. 1、Jenkins的安装与简单配置

    Jenkins安装 1.安装Jenkins之前先部署安装java环境(java环境安装另外参考安装文档) 注意:Jenkins 需要运行 Java 5以及以上的版本. 安装环境:CentOS7.3+J ...

  10. httpclient的封装完整版

    applicationContext-httpclient.xml <?xml version="1.0" encoding="UTF-8"?> & ...