ubuntu Error mounting /dev/sda6 at /media/xxx...
问题原因:可能是windows没有完全关机,详细请看我的另一博文: http://www.cnblogs.com/ediszhao/p/3794459.html
为了学习linux我装了双系统,因为我还不想放弃windows的软件兼容性,但是出现了不能读取其他盘的内容,这个问题在我刚刚开始接触linux的时候就已经出现过,那时傻傻的我不知所错,竟然重装系统,把windows给革掉了,但是现在想玩玩windowsphone的开发,所以装了双系统。
Error mounting /dev/sda6 at /media/xxx/xx: Command-line`mount -t "ntfs" -o"uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177""/dev/sda6" "/media/gaoyuan/文檔"' exited with non-zero exit status14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda6': Operation not permitted
The NTFS partition is in an unsafe state. Please resume
andshutdown
Windows fully (no hibernation or fast restarting), or mount
thevolume
read-only with the 'ro' mount option.
1-打开终端
2-sudo fdisk -l //查看分区挂载情况;一下是我的电脑的情况
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x000e8904
Device Boot Start End Blocks Id System
/dev/sda1 * 63 104857671 52428804+ 7 HPFS/NTFS/exFAT
Partition 1 does not start on physical sector boundary.
/dev/sda2 104857734 364904447 130023357 f W95 Ext'd (LBA)
Partition 2 does not start on physical sector boundary.
/dev/sda3 364904664 494928095 65011716 7 HPFS/NTFS/exFAT
/dev/sda4 494928096 625142447 65107176 7 HPFS/NTFS/exFAT
/dev/sda5 104857736 234881167 65011716 7 HPFS/NTFS/exFAT
/dev/sda6 234881232 306375597 35747183 7 HPFS/NTFS/exFAT
/dev/sda7 306376704 361259007 27441152 83 Linux
/dev/sda8 361261056 364904447 1821696 82 Linux swap / Solaris
可以看出3,4,5,6是windows的中可以看到的盘盘。
3.$sudo mkdir /media/xxx/yy //xxx为你的hostname,可以说是用户名吧,yyy是你要把挂载的文件名,可以是E,D,F ... 跟windows 相应,也可以其他的
4.$mount -t ntfs-3g /dev/sda4 /media/xxx/yy/ -o force // 参照网友意见而来
但是这个命令在我的机子会出现这样的错误:Windows is hibernated, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
然后把-o 改为 -ro;
就ok了
至于sda4 还是sda5 什么的,可以点一下你没有挂载的盘看看,上图:
完了:
可以进去了,在系统右边有个向上的什么什么图标,就ok了。
注意:
装有windows系统的盘最好不要挂载,否测可能会出现无法打开windows系统的惨剧!如果已经挂载了它,就用umount 撤销挂载!这样windows自我修复后就可以使用了,不过要花费些不必要的时间!
本文仅用于参考!
ubuntu Error mounting /dev/sda6 at /media/xxx...的更多相关文章
- Ubuntu访问window下的磁盘分区出现“Error mounting /dev/sda5 at/media”错误的解决方法
我装ubuntu之前,电脑上安装了windows 10,为了装ubuntu,在window 10下的磁盘工具分配了30G的磁盘空间.安装完Ubuntu之后,访问window 10的磁盘分区出现“Err ...
- 在ubuntu下访问windows硬盘出现错误:Error mounting /dev/sda7 at /media
在终端输入以下代码: sudo apt-get install ntfs-3g sudo ntfsfix /dev/sda7 运行完后: 这样就可以成功访问了.
- Error mounting / dev / sdb1 in Ubuntu
Uncommon users of Ubuntu OS, when connecting USB with NTFS file system, can observe the error: " ...
- mount: error mounting /dev/root on /sysroot as ext3: Invalid argument
/************************************************************************ * mount: error mounting /d ...
- [Ubuntu] Error: The disk drive for /media/sda2 is not ready yet or not present
After updated Ubuntu, and reboot, I got these error The disk drive for /media/sda2 is not ready yet ...
- 启动docker容器时的Error response from daemon: devmapper: Error mounting: invalid argument. 错误解决
错误出现 在一台物理机重启后,以前创建的容器无法启动了.一启动,则会报出错误. [root@217TN1V ~]# docker start e7e Error response from daemo ...
- clang: error: no such file or directory: xxx.pch
今天打开一个下载的例子 报clang: error: no such file or directory: xxx.pch的错 说一下解决方案 1.先在你的工程里找到这.pch文件- 2.把它现在的路 ...
- (转)ubuntu 12.04搭建Adobe Flash Media Server服务
破解版传送门:http://fms45.cuplayer.com/fms4download.html 福利:1462-5247-1705-7678-8379-5590 下载解压 cd进目录,./ins ...
- DataGrip:Error encountered when performing Introspect schema xxx 错误的解决方法
datagrip的问题,转载自: https://www.cnblogs.com/geb515/p/7995249.html 把Introspect using JDBC _metadata打上勾 然 ...
随机推荐
- Struts2标签--S:iterator----jsp页面遍历双层list
双层遍历,第一层list为classes,里面放的是班级class对象,第二层为班级class里的小组groups. <s:iterator value="classes&qu ...
- DDD创始人Eric Vans:要实现DDD原始意图,必须CQRS+Event Sourcing架构
http://www.infoq.com/interviews/Technology-Influences-DDD# 要实现DDD(domain drive design 领域驱动设计)原始意图,必 ...
- 《JAVASCRIPT高级程序设计》原生拖放和媒体元素
一.原生拖放 最早在网页中引入javascript拖放功能的是IE4,当时,网页中只有两种对象可以拖放:图像和某些文本.而现在,几乎网页中的任何元素都可以拖放以及作为放置目标.下面介绍一些与拖放相关的 ...
- Spring 中使用Quartz实现任务调度
前言:Spring中使用Quartz 有两种方式,一种是继承特定的基类:org.springframework.scheduling.quartz.QuartzJobBean,另一种则不需要,(推荐使 ...
- Windows程序员必须知道的字符编码和字符集
字符编码 (Character encoding) 在存储和传递文本过程中,为了使得所有电脑都能够正确的识别出文本内容,需要有一个统一的规则. 2. 字符集 (Character Set) ) 一般 ...
- [转]CentOS 6.3下Samba服务器的安装与配置
一.简介 Samba是一个能让Linux系统应用Microsoft网络通讯协议的软件,而SMB是Server Message Block的缩写,即为服务器消息块 ,SMB主要是作为Microsoft的 ...
- LVS的十种调度算法
LVS十种调度算法 1.静态调度: ①rr(Round Robin):轮询调度,轮叫调度 轮询调度算法的原理是每一次把来自用户的请求轮流分配给内部中的服务器,从1开始,直到N(内部服务器个数),然后重 ...
- 2017-2-19 C#基础 基本数据类型的转换,转义字符,常量
1.基本数据类型的转换分两种:自动转换(隐式转换)和强制转换(显式转换).自动转换是从只类型转换到引用类型.强制转换是最长用的,是从引用类型转换到值类型或者从浮点型转换到整形.强制转换主要有三种形式: ...
- 【openstack N版】——镜像服务glance
一.openstack镜像服务glance 1.1 glance介绍 glance主要是由三部分组成 glance-api:接收云系统镜像的创建,删除,读取请求,类似nova-api,通过其他模块(g ...
- 2017-2-28 C#基础 数组
1.什么是数组? 数组就是具有相同数据类型变量的集合. 2.数组的作用:操作大量数据. 3.数组的定义要求:(1)数组里面的内容必须是同一类型.(2)数组必须有长度限制. 4.数组分为一维数组,二维数 ...