今天买了一台阿里云服务器,Centos7.3系统,环境是LAMP。学生价9.8元是真的很实惠了。然后想修改一下mysql服务器的密码(mysql版本5.7),结果操作失误,密码给忘记了,导致新旧密码都不能登陆服务器,真是蛋疼。不过最终依靠自己的努力还是解决了问题。

错误案例演示

先来看一下我刚开始是怎么出错的(这是错误案例,大家不要照着这个例子敲,这里先演示了如何出错的,最后再修改):

1、先登陆服务器,use数据库“mysql”。然后修改user表里面的数据。毕竟mysql的密码是存在这个表里面的。

2、然后开始修改密码

结果报了一个错误,仔细一看是说mysql服务器是以安全模式启动的,因此我们不能修改密码,这个比较好解决,把mysql的保护关闭即可

设置为“0”表示关闭mysql的保护,开启的话就设置为“1”即可、

3、现在可以修改密码啦

  (这是错误的语法,不要这样做,我是为了演示)

然后再flush一下

结果成功了,我高兴的退出服务器重新登录,发现新密码不能登录服务器,真是头大。后来旧密码也不能登录服务器了,此时崩溃了。

成功案例演示

上面的例子导致我新旧密码都不能登陆服务器,后来没办法只能无密码登陆服务器然后再修改密码啦。不过问题出错的原因是修改密码的语法是错误的,虽然执行成功了,但是并没有真的修改密码成功,并且旧密码也失效了。既然知道了出错原因,接下来就好办了。

无密码登陆mysql演示

1、修改/etc/my.cnf文件加入“--skip-grant-tables”

然后重新启动mysql

结果出错了,意外,赶紧查看日志

发现刚刚加入的那句话出现了问题,想想不对呀,后来发现mysql5.7加入的这句话是“skip-grant-tables”。少了前面的两个横杠

继续修改

再启动

启动成功

然后无密码登陆

(这个才是真正修改密码的语法)

然后再刷新一下

最后退出mysql服务器,这个时候就可以使用新密码登录系统了。

总结:mysql5.7与之前的版本比较出现了一些变化,我们不懂要去网上问一下。最后mysql5.7修改密码的语法一定要记清楚。

有时候刚刚安装完MySQL服务要求我们立即修改密码:

ALTER USER 'root'@'localhost' IDENTIFIED BY '123456'

第一次编译安装mysql怎么修改密码?

今天安装mysql的这个版本“mysql-5.7.24-linux-glibc2.12-x86_64.tar.gz”。第一次安装成功后修改密码是不能使用上面的update语句来修改密码,因为系统强制要求修改密码才可以选mysql库然后再update语句。所以就不能使用上面的语句来修改密码了,下面是这个第一次安装mysql的密码修改方式:

mysql5.7如何修改密码以及密码如何忘记无密码登陆的更多相关文章

  1. mac mysql5.7.17修改root初始密码(知道初始密码)

    最近在mac上装个mysql可以说是麻烦死了,在这里就说说修改初始密码吧! 刚开始的时候不知道怎么修改,于是上网百度,网上几乎都是说要先执行命令mysqld_safe --skip-grant-tab ...

  2. mysql5.7.11修改root默认密码

    知道 MySQL 出了5.7了,并且网上说性能提高了一两倍,于是在虚拟机上安装了个 CentOS 7,在上面安装 MySQL 5.7 我使用的是 yum安装方式,要求虚拟机能够上网,因为它会在线下载安 ...

  3. mysql5.7系列修改root默认密码

    操作系统为centos7 64 1.修改 /etc/my.cnf,在 [mysqld] 小节下添加一行:skip-grant-tables=1 这一行配置让 mysqld 启动时不对密码进行验证 2. ...

  4. MySQL5.7下修改root密码

    本地安装了个mysql5.7,发现修改root密码和以往有区别了,特此记录下 进入mysql  更改密码: mysql> update mysql.user set authentication ...

  5. 安装Mysql5.7并修改初始密码

    Centos 安装MySQL可以参考之前写的一篇文章 Centos7.3 安装Mysql5.7并修改初始密码 windows安装mysql5.7有两种方式 1.下载.msi安装文件直接根据界面提示进行 ...

  6. Ubuntu16---安装mysql5.7未提示输入密码,安装后修改mysql密码默认密码

    Ubuntu16安装mysql5.7未提示输入密码,安装后修改mysql密码默认密码 mysql默认密码为空 但是使用mysql -uroot -p 命令连接mysql时,报错 ERROR 1045 ...

  7. CentOS7安装MySQL5.7以及修改密码

    CentOS7安装mysql [root@bd005 ~]# wget http://dev.mysql.com/get/mysql57-community-release-el7-8.noarch. ...

  8. Linux Mint,Ubuntu 18 ,Deepin15.7 安装mysql 没有提示输入密码,修改root用户密码过程

    刚刚装Deepin15.7 和 MySQL5.7 发现没有提示用户输入密码的过程(近日发现Linux Mint 和 Ubuntu18 也适用) 百度了一大堆如何修改root密码 也没什么卵用,终于这篇 ...

  9. MySQL5.7初始化后5种密码重置方法

    前言:由于好几次安装MySQL5.7后一直被重置密码所困扰,因此特意整理重置的方法 安装MySQL5.7 [root@node1 db]# ll 以下的rpm安装包可以随处下载 total 40235 ...

随机推荐

  1. Android并发编程 开篇

    该文章是一个系列文章,是本人在Android开发的漫漫长途上的一点感想和记录,我会尽量按照先易后难的顺序进行编写该系列.该系列引用了<Android开发艺术探索>以及<深入理解And ...

  2. IE不支持 Promise 解决办法

    引入 <script src = "https://cdn.polyfill.io/v2/polyfill.min.js"></script> 或 < ...

  3. win32编程简介

    win32编程简介 复习Win32整理下知识. 为什么学习win32? 我们要编写windos程序.都离不开API. 也就是我们所说的win32程序. 所以学好win32是你能不能再windows下编 ...

  4. Linux(CentOS6)系统安装Windows字体

    这里说个插曲,最近在linux(CentOS6)服务器上面发布了个Web项目,结果发现,有一处的汉字字体渲染不出来,显示的是“□□□□”.因为我的tomcat编码已经修改了URIEncoding为UT ...

  5. IceCTF 图片隐写

    blue monday 下载一个文件,知道是MIDI文件,后缀改为.mid可以直接播放 一开始以为是两种乐器构成摩斯密码,后来在winhex里看字符发现了每一段的第一个字母恰好有flag的形式,于是提 ...

  6. HAPRoxy(一):HAProxy基本配置、调度算法与tcp、http、heath模式配置示例

    一.HAProxy安装 1.HAProxy简单介绍 HAProxy虽然名字前有HA,但它并不是一款高可用软件,而是一款用于实现负载均衡的软件,可实现四层与七层的负载均衡. 2.yum安装HAProxy ...

  7. npm包

    https://www.cnblogs.com/xinxingyu/p/5736244.html     node - glob模块讲解 https://github.com/isaacs/node- ...

  8. jQuery 【选择器】【动画】

    jQuery 是一个快速.简洁的JavaScript框架,它封装JavaScript常用的功能代码,提供一种简便的JavaScript设计模式,优化HTML文档操作.事件处理.动画设计和Ajax交互. ...

  9. PowerDesigner 参照完整性约束(转载)

    PowerDesigner 参照完整性约束: 限制(Restrict):不允许进行修改或删除操作.若修改或删除主表的主键时,如果子表中存在子记录,系统将产生一个错误提示.这是缺省的参照完整性设置. 置 ...

  10. [日常] Go语言圣经-字节切片与字符串

    1.一个字符串是一个不可改变的字节序列2.文本字符串通常被解释为采用UTF8编码的Unicode码点(rune)序列3.内置的len函数可以返回一个字符串中的字节数目4.第i个字节并不一定是字符串的第 ...