搭建(192.168.1.10 -> 192.168.1.20)

1 master 上执行

阻塞 DML
flush tables with read lock;

记录 File 和 Position
show master status;

mysqldump -u root -p --all-databases > /data/dbbak/db.dmp

如果此 master 同时亦为 slave
mysqldump -u root -p --all-databases --dump-slave > /data/dbbak/db.dmp

unlock tables;

scp /data/dbbak/db.dmp mysql@192.168.1.20:/data/dbbak

2 slave 上执行

如果备份产生于 slave
mysqladmin -u root -p shutdown
/usr/local/mysql/bin/mysqld_safe --user=mysql --skip-slave-start &

mysql -u root -p < /data/dbbak/db.dmp

3 master 上执行

[mysqld]
server-id = 110
log-bin = /data/mysql/mysql-bin
binlog_format = MIXED
skip-slave-start = 1
#auto_increment_offset = 1
#auto_increment_increment = 1

create user 'repl'@'192.168.1.20' identified by 'xxxxxxxx';
grant replication slave on *.* to 'repl'@'192.168.1.20';

注明: 这里的IP指的从库的IP,如主库是192.168.1.10,这里加的连接用户是:192.168.1.20,不是1.10的IP。

4 slave 上执行

[mysqld]
server-id = 120
log-bin = /data/mysql/mysql-bin
binlog_format = MIXED
skip-slave-start = 1
relay-log = rep_relay_log
relay-log-index = rep_relay_log
read_only = 1
#sync_master_info = 0
#sync_relay_log = 0
#sync_relay_log_info = 0
#log-slave-updates = 1
#replicate-rewrite-db = cisdb -> newdb
#replicate-do-db = cisdb
#replicate-ignore-db = cisdb
#replicate-do-table = cisdb.t1
#replicate-ignore-table = cisdb.t1
#replicate-wild-do-table = cisdb.%
#replicate-wild-ignore-table = cisdb.%
#slave-skip-errors = xxxx,xxxx
#relay_log_purge
#relay_log_space_limit
#slave_exec_mode
#slave_compressed_protocol
#slave_parallel_workers

change master to
MASTER_HOST='192.168.60.202',
MASTER_USER='repl',
MASTER_PASSWORD='1',
MASTER_LOG_FILE='mysql-bin.000001',
MASTER_LOG_POS=120;

start slave;

5 salve 上执行

检查 Slave_IO_Running 和 Slave_SQL_Running 是否为 Yes
检查 Seconds_Behind_Master
show slave status\G;

检查 Slave_SQL_Running 线程的 Time 值(延时,单位为秒)
show processlist\G;

为方便主从切换:
create user 'repl'@'192.168.1.10' identified by 'xxxxxxxx';
grant replication slave on *.* to 'repl'@'192.168.1.10';

注明: 这里的IP指的从库的IP,如从库是192.168.1.20,切换后从库就是1.10,这里加的连接用户是:192.168.1.10,部署1.20的IP。

 新加的用户是,从库连接的IP,用户名和密码。

当用户权限中没有SUPER权限(ALL权限是包括SUPER的)时,从库的read-only生效!

使用start slave命令开启失败:

  mysql> start slave;

  ERROR 1872 (HY000): Slave failed to initialize relay log info structure from the repository

  使用reset slave命令解决:

  mysql> reset slave;

  Query OK, 0 rows affected (0.01 sec)

  mysql> start slave;

Mysql5.6主从复制的更多相关文章

  1. MySQL5.6主从复制最佳实践

    MySQL5.6     主从复制的配置  环境 操作系统:CentOS-6.6-x86_64 MySQL 版本:mysql-5.6.26.tar.gz 主节点 IP:192.168.31.57    ...

  2. mysql5.7 主从复制的正常切换【转】

    目前环境如下: master server IP:172.17.61.131 slave server IP:172.17.61.132 mysql version: mysql-5.7.21-lin ...

  3. mysql5.7主从复制--在线变更复制类型【转】

    这里说一下关于如何在线变更复制类型(日志复制到全局事物复制),参考课程:mysql5.7复制实战 先决条件     (1)集群中所有的服务器版本均高于5.7.6(2)集群中所有的服务器gtid_mod ...

  4. MySQL5.6主从复制方案

    MySQL5.6主从复制方案 1.主备服务器操作 环境:CentOS 6.3/6.4 最小化缺省安装,配置好网卡. 安装MySQL前,确认Internet连接正常,以便下载安装文件. # 新增用户组 ...

  5. MySQL5.7Gtid主从复制总是遇到日志被清等出现无法正常主从复制

    最近最是在MySQL5.7上的的gtid主从复制问题总是遇上下面问题: Last_Error: Coordinator stopped because there were error(s) in t ...

  6. Mysql5.6主从复制-基于binlog

    MySQL5.6开始主从复制有两种方式:基于日志(binlog):基于GTID(全局事务标示符). 此文章是基于日志方式的配置步骤 环境: master数据库IP:192.168.247.128sla ...

  7. MySQL5.6主从复制搭建基于日志(binlog)

    什么是MySQL主从复制 简单来说,就是保证主SQL(Master)和从SQL(Slave)的数据是一致性的,向Master插入数据后,Slave会自动从Master把修改的数据同步过来(有一定的延迟 ...

  8. MySQL5.7 主从复制配置

    一.主从复制原理 MySQL 主从复制是一个异步的复制过程,主库发送更新事件到从库,从库读取更新记录,并执行更新记录,使得从库的内容与主库保持一致.每一个主从复制的连接,都有三个线程.拥有多个从库的主 ...

  9. Centos7 下配置mysql5.6主从复制实例(一主两从)

    标签:mysql 数据库 原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 .作者信息和本声明.否则将追究法律责任.http://8941355.blog.51cto.com/89313 ...

  10. mysql5.7主从复制

    1.简介 1.1主从复制 是指建立一个和主数据库完全一样的数据库环境,称为从数据库:主数据库一般是实时的业务数据库,从数据库的作用和使用场合一般有几个: 一是作为后备数据库,主数据库服务器故障后,可切 ...

随机推荐

  1. 分享jQuery封装好的一些常用操作

    1. 禁止右键点击 $(document).ready(function(){   $(document).bind("contextmenu",function(e){      ...

  2. jQuery为动态生成的select元素添加事件的方法

    项目中需要在点击按钮时动态生成select元素,为防止每次点击按钮时从服务器端获取数据(因为数据都是相同的),可以这样写代码 1.首先定义全局js变量 var strVoucherGroupSelec ...

  3. 编译ros程序包--4

    编译程序包(原创博文,转载请标明出处--周学伟http://www.cnblogs.com/zxouxuewei/) 1.编译程序包: 一旦安装了所需的系统依赖项,我们就可以开始编译刚才创建的程序包了 ...

  4. 浅析Linux内核同步机制

    非常早之前就接触过同步这个概念了,可是一直都非常模糊.没有深入地学习了解过,最近有时间了,就花时间研习了一下<linux内核标准教程>和<深入linux设备驱动程序内核机制>这 ...

  5. VMware 12安装虚拟机Mac OS X 10.10(VMware12安装/共享文件夹)

    推荐电脑配置 1:Inter I5及以上 (A卡请自行百度大神解决方案) 必须开启CPU虚拟化:开机进入BIOS--->Intel Virtualization Technology---> ...

  6. resolution will not be reattempted until the update interval of nexus has elapsed or updates are forced

    Maven在执行中报错: - Failure to transfer org.slf4j:slf4j-api:jar:1.7.24 from http://localhost:8081/nexus/c ...

  7. iOS设计模式之类族(class cluster)

    类族模式在UIKit(user interface framework)使用的范围已经远远超过我们的想象,比如,UIButton,NSArray,NSString,NSNumber等, 例如NSNum ...

  8. MQTT的学习研究(十二) MQTT moquette 的 Future API 消息发布订阅的实现

    MQTT moquette 的Server发布主题 package com.etrip.mqtt.future; import java.net.URISyntaxException; import  ...

  9. MyBatis——Mapper XML 文件

    Mapper XML 文件 MyBatis 的真正强大在于它的映射语句,也是它的魔力所在.由于它的异常强大,映射器的 XML 文件就显得相对简单.如果拿它跟具有相同功能的 JDBC 代码进行对比,你会 ...

  10. Fluent Nhibernate Mapping for Sql Views

    Views are mapped the same way tables are mapped except that you should put Readonly() in the mapping ...