dialogic d300 驱动重装后 dlstart  报错解决

问题描述:dlstart  后如下报错

[root@BJAPQ091 data]#dlstop

Stopping Dialogic Services...

Stopping Clocking Daemon:[  纭畾  ]

Stopping ClockingServer:[  纭畾  ]

Stopping Telephony System Monitor:[  纭畾  ]

Stopping Dialogic(R) board(s).

Deleting SW devices ....

Deleting SW devices Done

genload[17226]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

Stopping Timeslot Doler:[  纭畾  ]

Stopping Device Mapper:[  纭畾  ]

Shutting Down OAM Event Service:[  纭畾  ]

Stopping Dialogic Runtime Tracing Server:[  纭畾  ]

[root@BJAPQ091 ~]# dlstart

Starting Dialogic Services...

Starting Dialogic Runtime Tracing Server:[  纭畾  ]

Warning: You have chosen a Springware board to be the Primary clock master

Clock fallback will not be supported in this configuration

Starting OAM Event Service:[  纭畾  ]

Starting Device Mapper:[  纭畾  ]

Starting Timeslot Doler:[  纭畾  ]

Starting Telephony System Monitor:[  纭畾  ]

Starting Clocking Server:[  纭畾  ]

Starting Dialogic(R) board(s).

Dialogic(R) Generic Downloader Version 6.00 (Build 1)

Copyright (C) 1992-2007 Dialogic Corporation.

Using /usr/dialogic/cfg/dialogic.cfg to configure Dialogic Boards

genload[18399]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

System Download ........

Warning: Clock signals not detected on sec. lines

..............................................................................

D/300JCT-E1 (PCI ID 0) Download .. spisctr4 Firmware Version 6.70 Build 0024

1 Dialogic?Board Successfully Installed

Dialogic(R) SCSA Transmit Timeslot Assignment Program

Copyright (c) 1997-2007 Dialogic Corporation.  All rights reserved

sctsassign:The Start TS is: 0 and Total Number of TS: 60

dxxxB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB2 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB3 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB4 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB5 : Failed open in sctsdtdxag.c: No such file or directory

dtiB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB6 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB7 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB8 : Failed open in sctsdtdxag.c: No such file or directory

Add SW Devices ....

REGVOX: #

REGVOX: # Dialogic Generic Configuration File

REGVOX: #

REGVOX: #

REGVOX: # Total number of virtual boards - 9

REGVOX: #

REGVOX:

REGVOX: #

REGVOX: # Board Type - D/300JCT-E1

REGVOX: #

REGVOX: dxxxB1    4  7000010   C         FBFE0000      2000       20        SPAN  50004

REGVOX: dxxxB2    4  7000010   C         FBFE2000      2000       20        SPAN  50005

REGVOX: dxxxB3    4  7000010   C         FBFE4000      2000       20        SPAN  50006

REGVOX: dxxxB4    4  7000010   C         FBFE6000      2000       20        SPAN  50007

REGVOX: dxxxB5    4  7000010   C         FBFE0000      2000        0        SPAN  50008

REGVOX: dtiB1    30  7000010   T         FBFE0000      2000        0        E1SPAN  50009

REGVOX: dxxxB6    4  7000010   C         FBFE2000      2000        0        SPAN  50010

REGVOX: dxxxB7    4  7000010   C         FBFE4000      2000        0        SPAN  50011

REGVOX: dxxxB8    2  7000010   C         FBFE6000      2000        0        SPAN  50012

Add SW Devices Done

Checking for unsupported Dialogic boards:

usbu[18448]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

Starting Clocking Daemon:[  纭畾  ]

Starting fault detection on all Dialogic boards:[  纭畾  ]

解决办法:

经过google,发现是因为语音卡驱动加载openib与streams有冲突

(1)关闭应用  epos用户下  grMain -t

(2)root检查是否有安装openib    rpm -qa | grep openib

(3)如果有,卸载openib     rpm -e openib

(4)检查是否卸载成功   rpm -qa | grep openib

(5)重启机器

(6)root用户下  dlstop

(7)root下    dlstart  查看是否启动成功

(8)epos下   grMain  -s -l5 -d5 -w -r 启动应用

参考文档:

Thought I would share this.  I recently ran into this issue when trying to start Dialogic on RHEL 4.  dlstart would produce the following.  Apparently version 6 and older of up2date will load an openib package which conflicts with streams.

SCREEN OUTPUT:

dxxxB1 : Failed open in sctsdtdxag.c: No such file or directory

dtiB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB2 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB3 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB4 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB5 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB6 : Failed open in sctsdtdxag.c: No such file or directory

RTF LOG:

#Timestamp              #PID   #TID        #Module      #Client    #Label       #Message

06/23/2009 09:20:55.754  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:55.755  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:55.755  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:56.249  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB1    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.258  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB2    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.259  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB3    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.261  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB4    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.262  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB5    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.264  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB6    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - ConfigTDMBus(): Cannot retrieve TDM bus attributes from Device Mapper for bus id 158570088; 100 returned from dm_getAttributes().

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - ConfigTDMBus(): FATAL CONFIGURATION ERROR.

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - Failed to configure the TDM bus; ConfigTDMBus() returned 0x0.

06/23/2009 09:20:58.956  21352  3061984160 OAMIPC                  Warning      OAMTransport - CSocketClientTransport::SendMessage() - m_ClientReceiveSocket.ShutAndCloseSocket failed

06/23/2009 09:20:58.955  21051  2892954528 OAMSYSLOG               ErrorEx      DLGSPWRFAULTDETECTOR - CNIStatus::init(): Failed to open the DTI device dtiB1

FIND AND FIX:

[root@ares cfg]# lsmod

Module                  Size  Used by

mercd                 281204  0

ctimod                 28916  1 mercd

streams_dvbmDriver    132616  0

streams_sctmrDriver    29104  0

streams_gpioDriver     21028  0

streams_gncfdDriver    19112  0

streams_dlgnDriver    418536  4 streams_dvbmDriver,streams_sctmrDriver,streams_gpioDriver,streams_gncfdDriver

streams               859756  5 streams_dvbmDriver,streams_sctmrDriver,streams_gpioDriver,streams_gncfdDriver,streams_dlgnDriver

parport_pc             28033  0

lp                     15661  0

parport                38153  2 parport_pc,lp

autofs4                26053  0

i2c_dev                14529  0

i2c_core               26305  1 i2c_dev

sunrpc                145061  1

ipt_REJECT             10689  1

ipt_state               5953  17

ip_conntrack           46085  1 ipt_state

iptable_filter          6977  1

ip_tables              23105  3 ipt_REJECT,ipt_state,iptable_filter

cpufreq_powersave       5953  0

ib_srp                 39005  0

ib_sdp                 61437  0

ib_ipoib               81769  0

inet_lro               13121  1 ib_ipoib

md5                     8129  1

ipv6                  244833  84 ib_ipoib

rdma_ucm               21189  0

rdma_cm                39937  2 ib_sdp,rdma_ucm

iw_cm                  13381  1 rdma_cm

ib_addr                12357  1 rdma_cm

ib_umad                21737  0

ib_ucm                 22213  0

ib_uverbs              41833  2 rdma_ucm,ib_ucm

ib_cm                  46521  4 ib_srp,ib_ipoib,rdma_cm,ib_ucm

ib_sa                  43213  4 ib_srp,ib_ipoib,rdma_cm,ib_cm

ib_mad                 39897  3 ib_umad,ib_cm,ib_sa

ib_core                66369  12 ib_srp,ib_sdp,ib_ipoib,rdma_ucm,rdma_cm,iw_cm,ib_umad,ib_ucm,ib_uverbs,ib_cm,ib_sa,ib_mad

button                 10705  0

battery                12997  0

ac                      8901  0

uhci_hcd               33241  0

e100                   36677  0

mii                     9281  1 e100

e1000                 122837  0

floppy                 58193  0

dm_snapshot            22633  0

dm_zero                 6337  0

dm_mirror              32969  0

ext3                  119753  4

jbd                    59865  1 ext3

dm_mod                 67049  12 dm_snapshot,dm_zero,dm_mirror

ata_piix               19909  2

libata                105629  1 ata_piix

sd_mod                 20801  3

scsi_mod              120525  3 ib_srp,libata,sd_mod

[root@ares cfg]# rpm -qa | grep openib

openib-1.4-1.el4

[root@ares cfg]# rpm -e openib

[root@ares cfg]# rpm -qa | grep openib

Then reboot and all is back to normal.  Hope this helps some one else out there.

北京行二号机  dlstart  报错解决

问题描述:dlstart  后如下报错

[root@BJAPQ091 data]#dlstop

Stopping Dialogic Services...

Stopping Clocking Daemon:[  纭畾  ]

Stopping ClockingServer:[  纭畾  ]

Stopping Telephony System Monitor:[  纭畾  ]

Stopping Dialogic(R) board(s).

Deleting SW devices ....

Deleting SW devices Done

genload[17226]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

Stopping Timeslot Doler:[  纭畾  ]

Stopping Device Mapper:[  纭畾  ]

Shutting Down OAM Event Service:[  纭畾  ]

Stopping Dialogic Runtime Tracing Server:[  纭畾  ]

[root@BJAPQ091 ~]# dlstart

Starting Dialogic Services...

Starting Dialogic Runtime Tracing Server:[  纭畾  ]

Warning: You have chosen a Springware board to be the Primary clock master

Clock fallback will not be supported in this configuration

Starting OAM Event Service:[  纭畾  ]

Starting Device Mapper:[  纭畾  ]

Starting Timeslot Doler:[  纭畾  ]

Starting Telephony System Monitor:[  纭畾  ]

Starting Clocking Server:[  纭畾  ]

Starting Dialogic(R) board(s).

Dialogic(R) Generic Downloader Version 6.00 (Build 1)

Copyright (C) 1992-2007 Dialogic Corporation.

Using /usr/dialogic/cfg/dialogic.cfg to configure Dialogic Boards

genload[18399]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

System Download ........

Warning: Clock signals not detected on sec. lines

..............................................................................

D/300JCT-E1 (PCI ID 0) Download .. spisctr4 Firmware Version 6.70 Build 0024

1 Dialogic?Board Successfully Installed

Dialogic(R) SCSA Transmit Timeslot Assignment Program

Copyright (c) 1997-2007 Dialogic Corporation.  All rights reserved

sctsassign:The Start TS is: 0 and Total Number of TS: 60

dxxxB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB2 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB3 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB4 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB5 : Failed open in sctsdtdxag.c: No such file or directory

dtiB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB6 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB7 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB8 : Failed open in sctsdtdxag.c: No such file or directory

Add SW Devices ....

REGVOX: #

REGVOX: # Dialogic Generic Configuration File

REGVOX: #

REGVOX: #

REGVOX: # Total number of virtual boards - 9

REGVOX: #

REGVOX:

REGVOX: #

REGVOX: # Board Type - D/300JCT-E1

REGVOX: #

REGVOX: dxxxB1    4  7000010   C         FBFE0000      2000       20        SPAN  50004

REGVOX: dxxxB2    4  7000010   C         FBFE2000      2000       20        SPAN  50005

REGVOX: dxxxB3    4  7000010   C         FBFE4000      2000       20        SPAN  50006

REGVOX: dxxxB4    4  7000010   C         FBFE6000      2000       20        SPAN  50007

REGVOX: dxxxB5    4  7000010   C         FBFE0000      2000        0        SPAN  50008

REGVOX: dtiB1    30  7000010   T         FBFE0000      2000        0        E1SPAN  50009

REGVOX: dxxxB6    4  7000010   C         FBFE2000      2000        0        SPAN  50010

REGVOX: dxxxB7    4  7000010   C         FBFE4000      2000        0        SPAN  50011

REGVOX: dxxxB8    2  7000010   C         FBFE6000      2000        0        SPAN  50012

Add SW Devices Done

Checking for unsupported Dialogic boards:

usbu[18448]: Warning - Insufficient power overriden for the PCI Express board at bus 7, slot 0.

Starting Clocking Daemon:[  纭畾  ]

Starting fault detection on all Dialogic boards:[  纭畾  ]

解决办法:

经过google,发现是因为语音卡驱动加载openib与streams有冲突

(1)关闭应用  epos用户下  grMain -t

(2)root检查是否有安装openib    rpm -qa | grep openib

(3)如果有,卸载openib     rpm -e openib

(4)检查是否卸载成功   rpm -qa | grep openib

(5)重启机器

(6)root用户下  dlstop

(7)root下    dlstart  查看是否启动成功

(8)epos下   grMain  -s -l5 -d5 -w -r 启动应用

感谢这位国外的和我一样的倒霉蛋。

参考文档:

Thought I would share this.  I recently ran into this issue when trying to start Dialogic on RHEL 4.  dlstart would produce the following.  Apparently version 6 and older of up2date will load an openib package which conflicts with streams.

SCREEN OUTPUT:

dxxxB1 : Failed open in sctsdtdxag.c: No such file or directory

dtiB1 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB2 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB3 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB4 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB5 : Failed open in sctsdtdxag.c: No such file or directory

dxxxB6 : Failed open in sctsdtdxag.c: No such file or directory

RTF LOG:

#Timestamp              #PID   #TID        #Module      #Client    #Label       #Message

06/23/2009 09:20:55.754  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:55.755  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:55.755  20988  3008342944 OAMSYSLOG               ErrorEx      DLGTIMESLOTDOLER - Fail to get TDMbus Attr error = 100

06/23/2009 09:20:56.249  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB1    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.258  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB2    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.259  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB3    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.261  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB4    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.262  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB5    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:56.264  21260  3086215392 spwrvoice               ERR1         dxmain                dxxxB6    ::::> dx_open() = -1, open(/dev/dlgn) = -1

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - ConfigTDMBus(): Cannot retrieve TDM bus attributes from Device Mapper for bus id 158570088; 100 returned from dm_getAttributes().

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - ConfigTDMBus(): FATAL CONFIGURATION ERROR.

06/23/2009 09:20:57.375  21327  3086096896 OAMSYSLOG               ErrorEx      dlgclockdaemon - Failed to configure the TDM bus; ConfigTDMBus() returned 0x0.

06/23/2009 09:20:58.956  21352  3061984160 OAMIPC                  Warning      OAMTransport - CSocketClientTransport::SendMessage() - m_ClientReceiveSocket.ShutAndCloseSocket failed

06/23/2009 09:20:58.955  21051  2892954528 OAMSYSLOG               ErrorEx      DLGSPWRFAULTDETECTOR - CNIStatus::init(): Failed to open the DTI device dtiB1

FIND AND FIX:

[root@ares cfg]# lsmod

Module                  Size  Used by

mercd                 281204  0

ctimod                 28916  1 mercd

streams_dvbmDriver    132616  0

streams_sctmrDriver    29104  0

streams_gpioDriver     21028  0

streams_gncfdDriver    19112  0

streams_dlgnDriver    418536  4 streams_dvbmDriver,streams_sctmrDriver,streams_gpioDriver,streams_gncfdDriver

streams               859756  5 streams_dvbmDriver,streams_sctmrDriver,streams_gpioDriver,streams_gncfdDriver,streams_dlgnDriver

parport_pc             28033  0

lp                     15661  0

parport                38153  2 parport_pc,lp

autofs4                26053  0

i2c_dev                14529  0

i2c_core               26305  1 i2c_dev

sunrpc                145061  1

ipt_REJECT             10689  1

ipt_state               5953  17

ip_conntrack           46085  1 ipt_state

iptable_filter          6977  1

ip_tables              23105  3 ipt_REJECT,ipt_state,iptable_filter

cpufreq_powersave       5953  0

ib_srp                 39005  0

ib_sdp                 61437  0

ib_ipoib               81769  0

inet_lro               13121  1 ib_ipoib

md5                     8129  1

ipv6                  244833  84 ib_ipoib

rdma_ucm               21189  0

rdma_cm                39937  2 ib_sdp,rdma_ucm

iw_cm                  13381  1 rdma_cm

ib_addr                12357  1 rdma_cm

ib_umad                21737  0

ib_ucm                 22213  0

ib_uverbs              41833  2 rdma_ucm,ib_ucm

ib_cm                  46521  4 ib_srp,ib_ipoib,rdma_cm,ib_ucm

ib_sa                  43213  4 ib_srp,ib_ipoib,rdma_cm,ib_cm

ib_mad                 39897  3 ib_umad,ib_cm,ib_sa

ib_core                66369  12 ib_srp,ib_sdp,ib_ipoib,rdma_ucm,rdma_cm,iw_cm,ib_umad,ib_ucm,ib_uverbs,ib_cm,ib_sa,ib_mad

button                 10705  0

battery                12997  0

ac                      8901  0

uhci_hcd               33241  0

e100                   36677  0

mii                     9281  1 e100

e1000                 122837  0

floppy                 58193  0

dm_snapshot            22633  0

dm_zero                 6337  0

dm_mirror              32969  0

ext3                  119753  4

jbd                    59865  1 ext3

dm_mod                 67049  12 dm_snapshot,dm_zero,dm_mirror

ata_piix               19909  2

libata                105629  1 ata_piix

sd_mod                 20801  3

scsi_mod              120525  3 ib_srp,libata,sd_mod

[root@ares cfg]# rpm -qa | grep openib

openib-1.4-1.el4

[root@ares cfg]# rpm -e openib

[root@ares cfg]# rpm -qa | grep openib

Then reboot and all is back to normal.  Hope this helps some one else out there.

dialogic d300语音卡驱动重装后启动报错问题解决方法的更多相关文章

  1. 初次安装hive-2.1.0启动报错问题解决方法

    首次安装hive-2.1.0,通过bin/hive登录hive shell命令行,报错如下: [hadoop@db03 hive-2.1.0]$ bin/hive which: no hbase in ...

  2. 安装mongodb后启动报错libstdc++

    安装mongo后启动报错如下图 显然说是libstdc++.so文件版本的问题,这种一般都是gcc版本太低了 接着查询gcc的版本    strings /usr/lib/libstdc++.so.6 ...

  3. eclipse tomcat路径更改后启动报错

      eclipse tomcat路径更改后启动报错 CreateTime--2018年5月3日14:48:22 Author:Marydon 1.情景还原 2.原因 本地的tomcat路径修改后,ec ...

  4. linux安装tomcat后启动报错Cannot find ./catalina.sh的解决方法

    linux安装tomcat后启动报错: Cannot find ./catalina.shThe file is absent or does not have execute permissionT ...

  5. 遇到的eclipse启动报错问题解决

    遇到的eclipse启动报错问题解决 一.启动时出现Java was started but returned exit code=13 可能原因: 1.eclipse与JDK的不是都64位或者32位 ...

  6. kafka启动报错&问题解决

    kafka启动报错&问题解决 一早上班,就收到运维同事通知说有一台物理机宕机,导致虚拟机挂了.只得重启kafka服务器. 1.启动 启动zookeeper bin/zkServer.sh st ...

  7. Eclipse中导入项目后js报错解决方法(转未解决问题)

    本文转自:http://blog.csdn.net/chenchunlin526/article/details/54666882 Eclipse中导入项目后js报错的原因与解决方法 在我们将项目导入 ...

  8. docker升级后启动报错400 Client Error: Bad Request ("Unknown runtime specified docker-runc")

    宝塔面板docker升级后启动容器时报错400 Client Error: Bad Request ("Unknown runtime specified docker-runc" ...

  9. docker安装后启动报错

    docker安装后启动不起来: 查看日志  /var/log/message    其中有一行为:  Your kernel does not support cgroup memory limit ...

随机推荐

  1. php代码运行提速的20个小技巧(转)

    用单引号代替双引号来包含字符串,这样做会更快一些.因为PHP会在双引号包围的字符串中搜寻变量,单引号则 不会,注意:只有echo能这么做,它是一种可以把多个字符串当作参数的“函数”(译注:PHP手册中 ...

  2. angularjs实现 checkbox全选、反选的思考

    之前做了一周的打酱油测试,其实感觉其实测试也是上辈子折翼的天使. 好长时间没写代码,感觉好多都不会了. 感谢这周没有单休,我能看熬夜看奥运了.我能有时间出去看个电影,我能有时间出去逛个商城,我能有时间 ...

  3. 获取body标签元素方法

    方法一 doucumnet.body 方法二 document.getElementsByTagName("body")[0]

  4. tcp协议-http协议-time-wait-close-wait必知

     前言:  tcp四次挥手过程中,谁主动断开,谁有time_wait,被动断开一方会有close_wait time_wait:保持端口占用2mls~4min,避免对方还有一些tcp片发往这个端口,新 ...

  5. android开发--(SimpleAdapter)运用

    SimpleAdapter的参数说明  第一个参数 表示访问整个android应用程序接口,基本上所有的组件都需要  第二个参数表示生成一个Map(String ,Object)列表选项    第三个 ...

  6. 也说virtualbox下安装centos7

    以前一直在VMware Workstation下安装虚拟机系统,这几天由于电脑被别人使用误升级为win10,而导致原来的LNMP不能使用,查找原因在于即使是最新的VM12.1.1也只是支持win8而已 ...

  7. COM符合名字对象建议使用的分隔符

  8. objective c, category 和 protocol 中添加property

    property的本质是实例变量 + getter 和 setter 方法 category和protocol可以添加方法 category 和 protocol中可以添加@property 关键字 ...

  9. avalon2的后端渲染实践

    avalon2为了提高性能,采用全新的架构,四层架构,其中一层为虚拟DOM. 虚拟DOM的一个好处是能大大提高性能,另一个好处是能过错整描述我们的页面结构.因此在非浏览器环境下,虚拟DOM也能正常运行 ...

  10. object-assign合并对象

    1. Object.assign() 对于合并对象操作, ECMAScript 6 中提供了一个函数: Object.assign(target, source); 这个方法会将所有可枚举 [1] 的 ...