谁掳走了 nginx.pid 文件?
1、重载配置
执行 nginx -s reload 命令,报错:找不到 nginx.pid 文件,无法打开。曾经屡试不爽的命令,此时,竟然失灵了? 刚开始,我一头雾水,有点丈二和尚摸不着头脑……
[root@127-0-0-1 nginx]# nginx -s reload
nginx: [error] open() "/var/run/nginx.pid" failed (2: No such file or directory)
[root@127-0-0-1 nginx]
问题一:为什么会报错?
答案: reload命令需要通过nginx.pid获取进程号,会去找/var/run.nginx.pid文件 ,如果不存在,就报错了。
2、进程文件
问题一:有关 pid(进程) 的配置在哪里?
[root@127-0-0-1 nginx]# vim nginx.conf user king;
worker_processes 4; error_log /var/log/nginx/error.log warn;
pid /var/run/nginx.pid;
答案:在 nginx.conf 文件中的 pid 参数。显然nginx.pid 文件,就应该存在 /var/run/ 目录下。
问题二:nginx.pid 的生存周期?
答案: 一般情况,重启nginx,就会在/var/run/下生成一个nginx.pid文件。关闭nginx 或 kill nignx的主进程后,nginx.pid就会消失……
[root@127-0-0-1 run]# cd /var/run
[root@127-0-0-1 run]# find -name nginx.pid
[root@127-0-0-1 run]#
奇怪,还真没有 nginx.pid 文件。那么问题就来了,为什么nginx在启动的状态下,nginx.pid竟丢失了? 它去哪了? 还是谁掳走了它?
3、陷入深思
nginx.pid 去哪了?怎么丢失的?
1、误删 rm -f nginx.pid
2、恶作剧 被哪个同事给耍了,还是城市套路深,我要回农村……
4、解决方案
1)创建 nginx.pid 文件 —— 不是找不到文件么,我给你创建一个不得了嘛^_^
nginx.pid存放的是nginx的master进程号。
问题一: nginx 主进程号是多少?怎么查?
[root@127-0-0-1 run]# ps -ef|grep nginx
king 11183 12666 0 14:45 ? 00:00:00 nginx: worker process
king 11184 12666 0 14:45 ? 00:00:00 nginx: worker process
king 11185 12666 0 14:45 ? 00:00:00 nginx: worker process
king 11186 12666 0 14:45 ? 00:00:00 nginx: worker process
root 11315 11042 0 15:43 pts/0 00:00:00 grep --color=auto nginx
root 12666 1 0 Jun14 ? 00:00:00 nginx: master process nginx
[root@127-0-0-1 run]#
答案:nginx 主进程(master process)号:12666
[root@127-0-0-1 run]# touch nginx.pid
[root@127-0-0-1 run]# echo "12666" > nginx.pid
[root@127-0-0-1 run]# cat nginx.pid
12666
[root@127-0-0-1 run]#
执行命令:nignx -s relaod 不报错了,问题解决了,喜悦心情油然而生……
[root@127-0-0-1 nginx]# nginx -s reload
[root@127-0-0-1 nginx]#
2)重启nginx —— 重启成功后,会生成一个nginx.pid文件。问题的克星——重启,是一把万能钥匙……
步骤一:杀掉进程
kill -9 master 和 worker 进程号
步骤二:重启nginx
方法一:nginx
方法二:nginx -c 指定目录的配置文件 例:nginx -c /etc/nginx/nginx.conf
步骤三:查看nginx.pid 文件
[root@127-0-0-1 nginx]# cd /var/run
[root@127-0-0-1 run]# find -name nginx.pid
./nginx.pid
[root@127-0-0-1 run]#
步骤四:重载配置
执行命令:nginx -s reload ,不报错,问题解决了……
5、一顿瞎操作
想法一:进程文件写入一个不存在的进程号,重载配置会怎么样?
[root@127-0-0-1 run]# echo "8888"> nginx.pid
[root@127-0-0-1 run]# cat nginx.pid
8888
[root@127-0-0-1 run]# nginx -s reload
nginx: [alert] kill(8888, 1) failed (3: No such process)
[root@127-0-0-1 run]#
想法二:不杀进程,直接重启 nginx 会报错么?
[root@127-0-0-1 run]# nginx
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()
[root@127-0-0-1 run]#
报错:80端口,被占用。不是别人,是自己(nginx)……
想法三:写错配置,会有什么影响?
[root@127-0-0-1 conf.d]# cat app.conf
server {
listen 80; king #wrong location
server_name 0.0.0.0:80;
首先测试配置,然后重载
[root@127-0-0-1 conf.d]# nginx -t
nginx: [emerg] unknown directive "king" in /etc/nginx/conf.d/HKIN-CRS.conf:3
nginx: configuration file /etc/nginx/nginx.conf test failed
[root@127-0-0-1 conf.d]# nginx -s reload
nginx: [emerg] unknown directive "king" in /etc/nginx/conf.d/HKIN-CRS.conf:3
[root@127-0-0-1 conf.d]#
谁掳走了 nginx.pid 文件?的更多相关文章
- Nginx pid文件找不到 nginx: [error] open() "/run/nginx/nginx.pid" failed (2: No such file or directory)
Nginx pid文件找不到 nginx: [error] open() "/run/nginx/nginx.pid" failed (2: No such file or dir ...
- nginx 启动报错找不到nginx.pid文件
这个问题的出现应该是系统找不到nginx的配置文件nginx.conf,所以,我们要告诉系统配置文件的位置:' --- 使用nginx -c /usr/local/nginx/conf/nginx.c ...
- nginx重启报找不到nginx.pid的解决方法
nginx被停止(nginx -s stop)或者直接杀掉了进程(kill -9 nginx的进程号)后,调用命令(nginx -s reload 或者 nginx -s reopen)会报错:无法找 ...
- 关于nginx.pid丢失的解决办法
在停掉nginx的过程中突然出现如下的提示:
- 解决Nginx: [error] open() "/usr/local/Nginx/logs/Nginx.pid
重新启动服务器,访问web服务发现无法浏览啦!登陆服务器之后进到nginx使用./nginx -s reload重新读取配置文件,发现报nginx: [error] open() "/usr ...
- linux之pid文件
在命令行中经常看到*.pid文件 其实这些文件是在启动进程的时候系统给这个进程的master进程分配的进程号 比如/usr/local/nginx/logs/nginx.pid文件 打开这个文件会发现 ...
- 解决nginx: [error] open() "/usr/local/nginx/logs/nginx.pid" failed错误
重新启动服务器,访问web服务发现无法浏览,登陆服务器之 后进到nginx使用./nginx -s reload重新读取配置文件,发现报nginx: [error] open() "/usr ...
- 解决linux重启后无法开启nginx问题“var/run/nginx/nginx.pid" no such file or directory问题
起因:每次重启虚拟机后,var/run/nginx/目录都会被删除,所以无法在这个目录创建nginx.pid文件, 可以自己创建var/run/nginx/目录,然后可以运行,但治标不治本,下次虚拟机 ...
- 重启nginx后丢失nginx.pid的解决方法
一,nginx的停止操作 停止操作是通过向nginx进程发送信号来实现的. 步骤1:查询nginx主进程号 复制代码 代码如下: ps -ef | grep nginx 在进程列表里 面找master ...
随机推荐
- 【Ruby on Rails 学习六】Ruby 类 的入门
1.什么是类 2.类与实例的区别 3.自定义简单的类 生活中的垃圾分类,是集合上的概念 比如数学上的 1 a 2 b c 4 5分类为数字1 2 4 5 ,字母 a b c ir ...
- Sqlserver2012 sa账户登录添加其他账户
1.添加admin账户的设置 2.另外 sa登录后,点击服务器名,右键->属性->安全性 的设置: 3.其次是Sqlserver配置管理器,SQL Server服务需要重启: SQL Se ...
- c++ xml 解析“后直接跟值问题
c++ xml库相关 要解析内容: <ITEM name="SLSJ"head="SLSJ"/> 代码: GetNodeAttri(subnodes ...
- HDU 1042 N!(高精度阶乘、大数乘法)
N! Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)Total Submi ...
- java实现稀疏数组压缩
package sparseArray; public class SparseArray { public static void main(String[] args) { // TODO Aut ...
- .Net Core 认证系统源码解析
不知不觉.Net Core已经推出到3.1了,大多数以.Net为技术栈的公司也开始逐步的切换到了Core,从业也快3年多了,一直坚持着.不管环境怎么变,坚持自己的当初的选择,坚持信仰 .Net Cor ...
- async 异步抓取 花瓣网高清大图 30s爬取500张
废话 不多说,直接上代码,不懂得看注释 先安装 pip install aiohttp "异步抓取花瓣网图片" # pip install aiohttp import requ ...
- Ubuntu安装openssh安装ssh、 免密登录、 创建新用户并免密登录
一.安装openssh sudo apt-get install openssh-server ssh localhost 二.免密登录 cd ~/.ssh ssh-keygen ...
- 32-第3章 数据链路层--抓包分析数据帧格式-ISO一图了然-小结
OSI理论模型 层级 名称 事物举例 功能 数据单位 别名 数据组成 协议举例 7 应用层 QQ.OA 网络通信 上层数据 上层数据 HTTP/FTP/DNS 6 表示层 web数据压缩.https加 ...
- 安装Python包报错——ReadTimeoutError
一.问题:安装python包的时候报错ReadTimeoutError——Read time out. 二.解决办法三种方法,一是切换下载源:二是下载相应平台的安装包后安装:三是下载源码编译安装: ...