重启了一次linux服务器后,weblogic启动莫名报错,查看日志发现说部署的项目有个bean类无法加载,

1、然后手动删除 已经部署的项目,先在

domais/servers/AdminServer/upload

删除上传的项目;启动报错

<Jul ,  :: AM CST> <Error> <Deployer> <BEA-> <Failed to create App/Comp mbeans for AppDeploymentMBean mmp. Error - weblogic.management.DeploymentException: .
weblogic.management.DeploymentException:
    at weblogic.servlet.)
    at weblogic.application.)
    at weblogic.application.)
    at weblogic.application.)
    at weblogic.management.deploy.)
    Truncated. see log file for complete stacktrace
Caused By: java.util.zip.ZipException: Error opening file - /domains/borzmmp/servers/AdminServer/upload/mmp.war Message - error in opening zip file
    at weblogic.servlet.utils.WarUtils.existsInWar(WarUtils.java:)
    at weblogic.servlet.utils.WarUtils.isWebServices(WarUtils.java:)
    at weblogic.servlet.)
    at weblogic.application.)
    at weblogic.application.)
    Truncated. see log file for complete stacktrace
> 

2.修改配置文件

/soft/Oracle/Middleware/user_projects/domains/borzmmp/config

此文件内删除以下代码
  <app-deployment>
    <name>yitong-mmc</name>
    <target>AdminServer</target>
    <module-type>war</module-type>
    <source-path>servers/AdminServer/upload/yitong-mmc.war</source-path>
    <security-dd-model>DDOnly</security-dd-model>
  </app-deployment>

3、启动还报错

<Jul ,  :: AM CST> <Emergency> <Security> <BEA-> <Server failed to bind to the configured Admin port. The port may already be used by another process.>
<Jul ,  :: AM CST> <Error> <Server> <BEA-> <Unable to create a server socket : java.net.BindException: Address already in use.> <Jul 13, 2016 10:05:22 AM CST> <Error> <Server> <BEA-002606> <Unable to create a server socket for listening on channel "Default[3]". The address 0:0:0:0:0:0:0:1 might be incorrect or another process is using port 7001: java.net.BindException: Address already in use.> <Jul 13, 2016 10:05:22 AM CST> <Error> <Server> <BEA-002606> <Unable to create a server socket for listening on channel "Default[1]". The address fe80:0:0:0:20c:29ff:fe93:a0f1 might be incorrect or another process is using port 7001: java.net.BindException: Address already in use.> <Jul 13, 2016 10:05:22 AM CST> <Critical> <WebLogicServer> <BEA-000362> <Server failed. Reason: Server failed to bind to any usable port. See preceeding log message for details.> <Jul 13, 2016 10:05:22 AM CST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FAILED> <Jul 13, 2016 10:05:22 AM CST> <Error> <WebLogicServer> <BEA-000383> <A critical service failed. The server will shut itself down> <Jul 13, 2016 10:05:22 AM CST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN> 

呵呵哒了

原来端口占用了

4、解决端口占用

[root@localhost bin]# netstat -apn | grep 7001
tcp               :::                     :::*                        LISTEN      /java          

万千人群中一眼就发现了它,让我瞅下这是个什么鬼

[root@localhost bin]# ps -aux|grep
root           pts/    S+   :   : grep
root         ?     Sl   Jun27  : /usr/java/jdk1..0_66/bin/java -Djava.util.logging.config.file=/root/.IntelliJIdea2016./system/tomcat/Unnamed_mmp-sdk/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -agentlib:jdwp=transport=dt_socket,address=,suspend=y,server=n -Dcom.sun.management.jmxremote= -Dcom.sun.management.jmxremote.port= -Dcom.sun.management.jmxremote.ssl=/endorsed -classpath /soft/apache-tomcat-/bin/bootstrap.jar:/soft/apache-tomcat-/bin/tomcat-juli.jar -Dcatalina./system/tomcat/Unnamed_mmp-sdk -Dcatalina.home=/soft/apache-tomcat- -Djava.io.tmpdir=/soft/apache-tomcat-/temp org.apache.catalina.startup.Bootstrap start

原来是之前服务器上装了intellij,启动后忘记关掉了。

怒关

kill -9

重启一切正常

weblogic启动报错的更多相关文章

  1. Weblogic 启动报错:java.lang.NoClassDefFoundError

    Weblogic 启动报错:java.lang.NoClassDefFoundError  ####<2015-6-17 下午03时30分47秒 CST> <Error> &l ...

  2. weblogic启动报错之建域时未指定AdminServer的监听IP的引起的子节点启动故障

    各子节点不能启动,查看日志,报错如下: Unable to establish JMX Connectivity with the Adminstration Server AdminServer a ...

  3. weblogic启动报错--com.octetstring.vde.backend.BackendRoot

    错误现象: 使用bea用户启动weblogic时报错,错误信息如下: <2014-7-29 下午07时47分23秒 CST> <Notice> <Log Manageme ...

  4. weblogic启动报错之WLS_DIAGNOSTICS000000.DAT

    查看控制台日志报错信息如下: <-- 下午04时46分42秒 CST> <Notice> <Log Management> <BEA-> <The ...

  5. weblogic启动报错之Unrecognized option: -jrockit

    报错如下: $ ./startWebLogic.sh . . JAVA Memory arguments: -Xms512m -Xmx512m . WLS Start Mode=Production ...

  6. weblogic启动报错之未修改hosts产生错误

    报错如下: Enter username to boot WebLogic server:weblogic Enter password to boot WebLogic server: <Ju ...

  7. Linux下weblogic启动报错unable to get file lock的问题

    非正常结束weblogic进程导致weblogic无法启动 由于先前服务器直接down掉了,所有进程都非正常的进行关闭了,也就导致了下次启动weblogic的时候报了以下错误:<2012-3-2 ...

  8. weblogic启动报错|unable to create new native threadjava

    问题描述: <-- 上午10时20分01秒 CST> <Critical> <WebLogicServer> <BEA-> <Server sub ...

  9. 【原创】大叔经验分享(67)spring boot启动报错

    spring boot 启动报错: Caused by: java.lang.IllegalArgumentException: LoggerFactory is not a Logback Logg ...

随机推荐

  1. ServiceStack.Redis 之 IRedisTypedClient 04_转

    IRedisTypedClient IRedisTypedClient类相当于IRedicClient的强类型版,其方法与属性大多数与IRedisClient类似. 它支持在Redis中使用Linq查 ...

  2. centos7.1-64bit延时截屏

    centos自带了截屏的软件,而且还能延时截屏. 在桌面左上角的应用程序菜单里: “应用程序”->“工具”->“截图” 设定延时秒数,点击“截图”按钮,开始截图. 完.

  3. PHP笔记随笔

    1.CSS控制页面文字不能复制: body{-webkit-user-select:none;}   2.[php过滤汉字和非汉字] $sc="aaad....##--__i汉字过滤&quo ...

  4. [PHP100] PHP如何防止注入及开发安全

    1.PHP注入的基本原理 程序员的水平及经验也参差不齐,相当大一部分程序员在编写代码的时候,没有对 用户输入数据的合法性进行判断,使应用程序存在安全隐患.用户可以提交一段数据 库查询代码,根据程序返回 ...

  5. C#:IText构造PDF文件

    IText构造PDF文件 1.1 生成Document Document是我们要生成的PDF文件所有元素的容器,因此要生成一个PDF文档,必须首先定义一个Document对象. Document有三种 ...

  6. js中RHS与LHS区别

    为什么区分RHS与LHS是一件重要的事情? 因为在变量没有声明(在任何作用域都找不到该变量的情况下),这两种查询的行为是不一样的. function foo (a) { console.log(a + ...

  7. [c++][语言语法]stringstream iostream ifstream

    c++中ifstream一次读取整个文件 读取至char*的情况 std::ifstream t; int length; t.open("file.txt"); // open ...

  8. JavaScript DOM 编程艺术(第2版)读书笔记(1)

    JavaScript 简史 JavaScript 是Netscape公司与Sun公司合作开发的.在 JavaScript 1.0发布时,Netscape Navigator主宰着浏览器市场.微软在推出 ...

  9. 天大acm 题号1002 Maya Calendar

    Description 上周末,M.A. Ya教授对古老的玛雅有了一个重大发现.从一个古老的节绳(玛雅人用于记事的工具)中,教授发现玛雅人使用了一个一年有365天的叫做Haab的历法.这 个Haab历 ...

  10. Network Saboteur 分类: 搜索 POJ 2015-08-09 19:48 7人阅读 评论(0) 收藏

    Network Saboteur Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 10147 Accepted: 4849 Des ...