IP Address Problems

  • IP Address Exhaustion

    • Class A, B, and C address structure inefficient
    • Class B too large for most organizations, but future proof
    • Class C too small
  • IP routing table size
    • Growth in # of networks in Internet reflected in # of table entries
    • Stress on router processing power and memory allocation
  • Short-term solution:
    • Classless Interdomain Routing (CIDR), RFC 1518
    • New allocation policy (RFC 2050)
    • Private IP Addresses set aside for intranets(企业内部网) (NAT)
  • Long-term: IPv6 with much bigger address space

Classless Interdomain Routing Scheme

  • CIDR uses an arbitrary(任意的) prefix length to indicate the network number

    • 205.100.0.0/22
    • /22 means mask: 11111111 11111111 11111100 00000000 - 255.255.252.0,means the mask is 22 bits long
  • Packets are routed according to the prefix w/o address classes
    • An entry in CIDR routing table contains 32-bit IP address and 32-bit mask
  • Enables supernetting to allow a single routing entry to cover a block of classful addresses

CIDR Aggregation(聚合)

  • A company is allocated the following four contiguous(相邻的) /24 networks. At some router, it is often true that all of the four networks use the same outgoing line. CIDR aggregation can be done to reduce the number of entry at the router.

    • 128.56.24.0/24; 10000000 00111000 00011000 00000000
    • 128.56.25.0/24; 10000000 00111000 00011001 00000000
    • 128.56.26.0/24; 10000000 00111000 00011010 00000000
    • 128.56.27.0/24. 10000000 00111000 00011011 00000000
      By Per-bit AND
    • 128.56.24.0/22 10000000 00111000 00011000 00000000
      (Instead of 4 entries in routing table, one entry is sufficient by CIDR)

CIDR Scheme and Range

  • CIDR deals with Routing Table Explosion Problem

    • Networks represented by prefix and mask
    • Summarize a contiguous group of class C addresses using variable-length mask, if all of them use the same outgoing line
  • Solution: Route according to prefix of address, not class
    • Routing table entry has <IP address, network mask>
    • Example: 192.32.136.0/21
    • 11000000 00100000 10001000 00000001 min address
    • 11111111 11111111 11111--- -------- mask
    • 11000000 00100000 10001--- -------- IP prefix
    • 11000000 00100000 10001111 11111110 max address
    • Eight C networks: 192.32.136.0/24 to 192.32.143.0/24

CIDR Supernetting Example (1)

  • Summarize a contiguous group of class C addresses using variable-length mask
  • Example: 150.158.16.0/20
    • IP Address (150.158.16.0) & mask length (20)
    • IP address = 10010110 10011110 00010000 00000000
    • Mask = 11111111 11111111 11110000 00000000
    • Contains 16 Class C blocks:
    • From 10010110 10011110 00010000 00000000
      i.e. 150.158.16.0/24
    • Up to 10010110 10011110 00011111 00000000
      i.e. 150.158.31.0/24

CIDR Supernetting Example (2)

  • A router has the following CIDR entries in its routing table:

    • Address/mask - - - - -Next hop
    • 128.56.24.0/22 - - - - - Interface 0
    • 128.56.60.0/22 - - - - -Interface 1
    • default - - - - -Router 2

    A packet comes with IP address of 128.56.63.10. What does the router do?

  • 128.56.63.10 and mask 22 bits
  • First, the address will be transform into binary, then use MASK by AND operation to get the prefix, finally it will match the table, if match a interface, go to it.
    • IP address = 10000000 00111000 01111111 00001010
    • Mask = 11111111 11111111 11111100 00000000
      By Per-bit AND
    • Prefix = 10000000 00111000 01111100 00001010
      i.e. 128.56.60
    • Router table lookup and match, should go to interface 1

New Address Allocation Policy

  • Class A & B assigned only for clearly demonstrated need
  • Consecutive(连续的) blocks of class C assigned (up to 64 blocks)
    • All IP addresses in the range have a common prefix, and every address with that prefix is within the range
    • Arbitrary prefix length for network ID improves efficiency
  • Address assignment should reflect the physical topology of the network
    • Facilitates the aggregation of logical packet flows into physical flows

Longest Prefix Match

  • By CIDR, multiple entries may match a given IP destination address ,but different prefix
  • Example: perform CIDR on the following three /24 IP addresses (but 128.56.24.0/24 to a different port)
    • 128.56.25.0/24;
    • 128.56.26.0/24;
    • 128.56.27.0/24;
    • By CIDR aggregation(Per-bits AND): 128.56.24.0/22
    • What if a packet with destination IP address 128.56.24.1 comes? It belongs to another port

Example of Longest Prefix Match

Classless Interdomain Routing (CIDR)的更多相关文章

  1. Netmask, 子网与 CIDR (Classless Interdomain Routing)

    Netmask, 子网与 CIDR (Classless Interdomain Routing) 我们前面谈到 IP 是有等级的,而设定在一般计算机系统上面的则是 Class A, B, C.现在我 ...

  2. [转]CIDR简介

    IP Subnetting and Variable Length Subnet Masks Subnetting Basics 子网划分(subnetting)的优点: 1.减少网络流量 2.提高网 ...

  3. IP协议

    因特网协议(Internet Protocol, IP)是Internet的核心协议之一, 工作在网络层.IP协议提供节点间的寻址,路由以及顺序控制, 流量控制等服务. IP协议分为IPv4和IPv6 ...

  4. (转) IPv6相关RFC

    转自http://blog.csdn.net/lucien_cc/article/details/12688477 IPv6 Spec RFC 2460 : Internet Protocol, Ve ...

  5. IPv6 tutorial 4 IPv6 address syntax

    https://4sysops.com/archives/ipv6-tutorial-part-4-ipv6-address-syntax/ Now that you know about the n ...

  6. How Network Load Balancing Technology Works--reference

    http://technet.microsoft.com/en-us/library/cc756878(v=ws.10).aspx In this section Network Load Balan ...

  7. wireshark filter manualpage

    NAME wireshark-filter - Wireshark filter syntax and reference SYNOPSIS wireshark [other options] [ - ...

  8. 【计算机网络】 一个小白的网络层学习笔记:总结下IP,NAT和DHCP

    前言:这篇文章是学习网络层协议时候总结的笔记,前面的主要部分介绍的都是IP协议, 后半部分介绍NAT协议和DHCP协议 参考书籍 <计算机网络-自顶向下>       作者 James F ...

  9. OSPF(Open Shortest Path First)

    1.概述 路由协议OSPF全称为Open Shortest Path First,也就开放的最短路径优先协议,因为OSPF是由IETF开发的,所以所有厂商都可以用. OSPF的流量使用IP协议号. O ...

随机推荐

  1. jquery echarts 饼状图

    var myChart = echarts.init(document.getElementById('myChart')); option = { title : { text: '某站点用户访问来 ...

  2. Java温故而知新(7)Object类及其方法讲解

    一.java.lang.Object java.lang包在使用的时候无需显示导入,编译时由编译器自动导入. Object类是类层次结构的根,Java中所有的类从根本上都继承自这个类. Object类 ...

  3. 怎样关闭占用80端口的pid为4的进程

    我也被这个问题给纠结了好几天.重装系统都三次了.终于找到原因了:我用的是sqlserver 2008;解决方法:window-sqlserver 2008-配置工具-sqlserver 配置管理器 找 ...

  4. The Willpower Instinct(自控力,意志力)

    下面是我这几天在读斯坦福大学麦格尼格尔教授的<自控力>这本书的过程中摘抄的部分经典句子,发人深思!有助于帮助我们更好的了解自己. 00 导言:欢迎进入意志力入门 意志力:控制自己的注意力. ...

  5. numpy用法介绍-未完待续

    简介 NumPy(Numerical Python简称) 是高性能科学计算和数据分析的基础包 为什么使用? 标准安装的Python中用列表(list)保存一组值,可以用来当作数组使用,不过由于列表的元 ...

  6. idea 出现 java.lang.OutOfMemoryError: PermGen space

    今天在项目启动时候,刚刚启动 就 报了 Exception in thread "http-bio-8080-exec-1" 之后 出现了 java.lang.OutOfMemor ...

  7. javascript模块化以及加载打包

    https://addyosmani.com/writing-modular-js/ 一些术语: 模块:可以理解为一个js文件,就像你以前需要import的那个文件一样:module不一定非要是一个外 ...

  8. mssql删除数据库、删除帐号错误解决方法

    1. 删除数据库或者恢复数据库时,一定要先将数据库离线,在执行删除.恢复操作. SQL代码如下: /*使数据库离线*/ ALTER DATABASE [数据库名] SET OFFLINE WITH R ...

  9. 【Leetcode】【Easy】Same Tree

    Given two binary trees, write a function to check if they are equal or not. Two binary trees are con ...

  10. jave web 监听器。

    https://www.imooc.com/video/5664 Web监听器由Servlet规范提供的,可以监听客户端的请求以及服务端的操作,即监听ServletContext.HttpSessio ...