Apache DS 配置与管理

 
LADP基本介绍
LDAP(轻量级目录访问协议)以目录的形式来管理资源(域用户,用户组,地址簿,邮件用户,打印机等等)。
 

特点:

1. LDAP是一种网略协议而不是数据库,而且LDAP的目录不是关系型的,没有RDBMS那么复杂,LDAP不支持数据库的Transaction机制,纯粹的无状态,请求-响应的工作模式。
2. LDAP不能存储BOLB,LDAP的读写操作是非对称的,读的方便,写的比较麻烦,LDAP支持复杂的查询过滤器。
3. LDAP使用树状结构,接近于公司组织结构,文件目录结构,域名结构等。
4. LDAP使用简单,接口标准,并支持SSL访问。

用途:

信息安全类:数字证书管理,授权管理,单点登陆
科学计算类:DCE(分布式计算环境),UDDI(统一描述,发现和集成协议)
网络资源管理类:MAIL系统,DNS系统,网络用户管理,电话号码簿。
电子政府资源管理类:内网组织信息服务,电子政务目录体系,人口基础库,法人基础库。

结构:

一颗目录信息树有若干条目(Entry)组成,每一个条目有唯一的标识名DN(Distingushed Name),条目可以用来描述用户账号,打印机和计算机等对象。一个条目是一个对象,每个条目有多个属性(Attribute)组成,每一属性有一个类型和一个到多个值组成,每个属性可以对应一个或多个值(Value);
在LDAP中,对象类,属性类型,语法和匹配规则统称为模式(schema),用来确定目录能存储的内容以及服务器和客户端在进行目录操作时如何对待数据。
构成schema的元素有
属性类型(attribute types)
对象类(obejct classes)
语法(syntaxes)
匹配规则(matching rules)
目录信息树内容规则(DIT content rules)
目录信息树结构规则(DIT structural rules)
命名形式(name forms)
Schema被各个LDAP组件包括服务器,客户端,应用程序,用来作为数据交换的标准,以保证对数据理解的正确性,从而保证了LDAP协议的开放性
schema也被用来作为目录中存储的数据的长度,范围和格式的强制约束,也用于目录中数据的规整和对访问者权限的控制。
 
 

安全认证:

LDAP定义了三种安全等级可供选择,其安全性依次增加:
1. 无认证(匿名)
2. 基本认证(简单密码)
3. SSL/TLS安全套接字层:安全套接字层可提高认证和数据的安全性,包括完整性和保密性,它封装了TCP/IP套接字,以便于每一个TCP/IP应用都能够使用它保证通讯的安全。
 

Apache DS配置与管理

在Apache DS里创建了一个server后,点击打开,出现的配置界面如下:这里默认的LDAP的服务器端口为10389,默认允许匿名连接,默认没有开启Kerberos认证,在里面已经自动创建了两个分区(partition). 此外我们还可以设置密码的构成以及分区策略。
 

Apache DS connection管理与操作实例

在启动Apache DS Server后,即可建立连接。
注:Apache DS默认的端口为10389,OpenLDAP的默认端口为389;

新建连接

1. 创建连接,设置连接地址,端口,连接加密方式,连接接口方式。
2. 设置登录的方式
3. 设置LDAP树的基本信息及浏览方式
4. 设置条目生成操作的默认属性

LDAP apacheds解决方案的更多相关文章

  1. LDAP个人理解

    在新的公司办公,所有的后台系统或文档系统都公用一个LDAP账号. 接触到这个新名词,就查了一下,谈谈个人理解: LDAP是个协议, 简单地说,可以把LDAP服务理解为一套存放你账户密码的数据库系统.市 ...

  2. 安装dcm4chee-arc-light-5.4.1-mysql步骤

    一.进入网址: https://github.com/dcm4che/dcm4chee-arc-light/wiki/Installation 这个是GitHub上面给的步骤,可能会比较难理解,按照所 ...

  3. [翻译]用 Puppet 搭建易管理的服务器基础架构(4)

    我通过伯乐在线翻译了一个Puppet简明教程,一共分为四部分,这是第四部分. 原文地址:http://blog.jobbole.com/89214/ 本文由 伯乐在线 - Wing 翻译,黄利民 校稿 ...

  4. INS-20802 Oracle Cluster Verification Utility failed解释说明

    背景:安装RAC,安装GI集群管理软件时,在最后快结束时,总是报如上INS-错误 #官方文档:error 说明;字符串解析失败 INS-20802: string failed. Cause: The ...

  5. openvpn通过ldap或ad统一认证解决方案思路分享

    原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 .作者信息和本声明.否则将追究法律责任.http://oldboy.blog.51cto.com/2561410/986933 缘起:成 ...

  6. Linux下LDAP统一认证解决方案

    Linux下LDAP统一认证解决方案 --http://www.cangfengzhe.com/wangluoanquan/3.html 转自:http://www.cnblogs.com/MYSQL ...

  7. [原创]django+ldap+memcache实现单点登录+统一认证

    前言 由于公司内部的系统越来越多,为了方便用户使用,通过django进行了单点登录和统一认证的尝试,目前实现了django项目的单点登录和非django项目的统一认证,中间波折挺多,涉及的技术包括dj ...

  8. LDAP注入与防御解析

    [目录] 0x1 LDAP介绍 0x2 LDAP注入攻击及防御 0x3 参考资料 0x1 LDAP介绍 1 LDAP出现的背景 LDAP(Lightweight Directory Access Pr ...

  9. #研发解决方案介绍#IdCenter(内部统一认证系统)

    郑昀 基于朱传志的设计文档 最后更新于2014/11/13 关键词:LDAP.认证.权限分配.IdCenter. 本文档适用人员:研发   曾经一个IT内部系统配一套帐号体系和授权   线上生产环境里 ...

随机推荐

  1. Linux系统默认权限之umask

    默认情况下,目录权限值为755, 普通文件权限值为644, 那么这个值是由谁规定的,追究其原因是 umask [root@adminx]# vim /etc/profile 1.假设umask值为:0 ...

  2. 原生jdbc操作mysql数据库详解

    首先给大家说一下使用JDBC链接数据库的步骤 1.加载链接数据库驱动 2.建立数据库链接 3.创建数据库操作对象 4.编写sql语句,执行sql语句 5.获取结果集 6.释放资源 我这边采用的是mav ...

  3. FTP站点设置

    0x00前言: 应老师今天教的和题目所需 有了今天的博文 0x01准备: windows server 2008 FTP服务 0x02正文: 1.先安装FTP服务 先打开--服务器管理 点击--添加角 ...

  4. The POM for ... is missing, no dependency information available

    今天在重温淘淘商城的项目,准备用idea重写次,换个bootstrap的前端框架,但是在用idea构建maven项目后编译时却报错了: 经再三确认,common工程自身并没有任何问题,引用这个工程的地 ...

  5. PHP自动测试框架Top 10

    对于很多PHP开发新手来说,测试自己编写的代码是一个非常棘手的问题.如果出现问题,他们将不知道下一步该怎么做.花费很长的时间调试PHP代码是一个非常不明智的选择,最好的方法就是在编写应用程序代码之前就 ...

  6. 关于在linux下安装git,以及在idea上将项目部署到码云上

    GIT 基于对linux感兴趣,并且也考虑到以后从事开发后也会用到linux,着实在闲余之际学学linux.最近在用VM虚拟机环境下学做一个项目,在git上卡了一点时间,但同时也收获  了不少,下面写 ...

  7. [Tarjan 学习笔记](无向图)

    今天考试因为不会敲 Dcc 的板子导致没有AK(还不是你太菜了),所以特地写一篇博客记录 Tarjan 的各种算法 无向图的割点与桥 (各种定义跳过) 割边判定法则 无向边 (x,y) 是桥,当且仅当 ...

  8. MyBatis之ResultMap简介,关联对象

    MyBatis中在查询进行select映射的时候,返回类型可以用resultType,也可以用resultMap,resultType是直接表示返回类型的,而resultMap则是对外部ResultM ...

  9. 安装texlive2017(latex的编译软件)

    准备工作是先卸载老版本的texlive,这个只要找到原来安装时的安装目录,然后直接把整个文件夹删掉即可.然后找到最近的Ctan的镜像,下载到对应版本的texlive,例如Mac系统,最好用的就是tex ...

  10. WEB端线上偶现问题如何复现?

    1.抓取出现问题的日志,还原操作过程,分析 每个过程中数据是否正常?是否有重复请求 2.询问当时操作员执行了哪些操作,尽可能多的了解事发经过 3.通过查看日志,数据库等信息,找到发生问题的节点, 比如 ...