【翻译自mos文章】改变数据库用户sysman(该用户是DB Control Repository 的schema)password的方法
改变数据库用户sysman(该用户是DB Control Repository 的schema)password的方法
參考原文:
How To Change the Password of the Database User Sysman (DB Control Repository Schema) (Doc ID 259379.1)
适用于:
Enterprise Manager for Oracle Database - Version 10.1.0.2 to 11.2.0.3 [Release 10.1 to 11.2]
Enterprise Manager for Oracle Database - Version 11.2.0.4 to 11.2.0.4 [Release 11.2]
Information in this document applies to any platform.
目的:
sysman的口令被加密存放在多个地方,因此。the Database Control (OMS and Agent)能够在不须要sysmanpassword的情况下能够訪问database。
所以,当改动sysman口令的时候,新口令必须提供给the Database Control OMS and Agent.
假设新口令没有更新给the Database Control OMS and Agent, oms将不能訪问数据库,而且在trace file中。你会注意到以下的错误:
2012-05-31 13:50:13,513 [PAFStartupThread] ERROR conn.ConnectionService verifyRepositoryEx.891 - Invalid Connection Pool. ERROR = ORA-01017: invalid username/password;
logon denied2012-05-31 13:50:20,717 [HTTPThreadGroup-4] ERROR conn.ConnectionService verifyRepositoryEx.891 - Invalid Connection Pool. ERROR = ORA-28000: the account is locked
2012-05-31 13:50:20,764 [HTTPThreadGroup-2] ERROR eml.OMSHandshake processFailure.806 - OMSHandshake failed.
(AGENT URL = https://uk-sno1-m018.uk-paper.group.wan:3938/emd/main)(ERROR = INTERNAL_ERROR)(CAUSE =java.sql.SQLException: ORA-01017: invalid username/password; logon denied
本文解释了在不断开Database 与 Database Control的情况下,改动数据库用户sysmanpassword的方法。
注意:Enterprise Manager 10g 已经进入扩展支持。oracle强烈建议升级你的环境到Enterprise Manager 11g or 12c。
Enterprise Manager 11g or 12c 如今是处于premier Support(翻译成:首先支持?)
范围:
全部使用Enterprise Manager DB Control 10g or 11g的数据库管理员。
细节:
注意:安装在 Windows 2008 / Vista上的 DB Control Release 10.2.0.3 及其更高版本号,emctl 命令可能会失败,错误是"Permission Denied".该错误的解决方法,请见以下的文章:
Document 1164293.1 - Executing Any EMCTL Command on Windows 2008 / Vista Returns "Permission denied" Error
第一种情况:Database Release prior 10.2.0.4
sysman 这个用户是 the standalone repository of the Enterprise Manager DB Control 的 schema
为了确保你是在正确的数据库中改动了sysman口令,请检查环境变量ORACLE_SID是否被设置,环境变量 ORACLE_HOME 是否被设置,PATH是否包含 正确的 $ORACLE_HOME/bin
请改动sysman口令时严格遵守例如以下的步骤。否则。你的DB Control 将会执行异常。
1.停止 DB Control
On Unix
$ emctl stop dbconsole
On Windows
Stop the Windows Service OracleDBConsole
Or
Open a Command Window and type
C> emctl stop dbconsole
2.确认DB Control 已经被停止:
On Unix
$ emctl status dbconsole
On Windows
Check the status of the Windows Service OracleDBConsole
Or
Open a DOS Command Window and type
C> emctl status dbconsole
3. 使用dba 权限登陆sqlplus。运行例如以下的语句:
SQL> alter user sysman identified by <password> ;
样例:
SQL> alter user sysman identified by rainbow ;
4.检查新password是否能登陆到db中
SQL> connect sysman/[@database_alias]
Example:
SQL> connect sysman/rainbow@DBRH
5.到$ORACLE_HOME/host_sid/sysman/config中
5.1 将emoms.properties 文件做一个备份emoms.properties.orig
5.2 编辑emoms.properties文件:
5.2.1 查找以以下内容开头的行:
oracle.sysman.eml.mntr.emdRepPwd=
以新password(额外注:明文不带;号)替换掉加密后的值。
样例:oracle.sysman.eml.mntr.emdRepPwd=rainbow
5.2.2 找以下的行:
oracle.sysman.eml.mntr.emdRepPwdEncrypted=TRUE
用FALSE替换TRUE
6.重新启动 DB Control
On Unix
$ emctl start dbconsole
On Windows
Start the Windows Service OracleDBConsole
Or
Open a DOS Command Window and type
C> emctl start dbconsole
7.检查password已经被加密:
查看$ORACLE_HOME/host_sid/sysman/config/emoms.properties文件
7.1 搜索以以下开头的行:
oracle.sysman.eml.mntr.emdRepPwd=
确认password已经被加密
7.2 搜索以以下开头的行:
oracle.sysman.eml.mntr.emdRepPwdEncrypted=
确认该值是 TRUE
另外一种情况: Database Release beginning 10.2.0.4
sysman 这个用户是 the standalone repository of the Enterprise Manager DB Control 的 schema
为了确保你是在正确的数据库中改动了sysman口令。请检查环境变量ORACLE_SID是否被设置,
对于 DB Control Release 11.2 以及更高版本号来说,你须要将环境变量ORACLE_UNQNAME设置为数据库參数DB_UNIQUE_NAME 的值
你必须检查环境变量 ORACLE_HOME 是否被设置,PATH是否包含 正确的 $ORACLE_HOME/bin
请改动sysman口令时严格遵守例如以下的步骤,否则。你的DB Control 将会执行异常。
1.1.Stop the DB Control
On Unix
$ emctl stop dbconsole
On Windows
Stop the Windows Service OracleDBConsole
Or
Open a Command Window and type
C> emctl stop dbconsole
2. 确认 DB Control 已经被停止
On Unix
$ emctl status dbconsole
On Windows
Check the status of the Windows Service OracleDBConsole
Or
Open a DOS Command Window and type
C> emctl status dbconsole
3. 使用dba 权限登陆sqlplus,运行例如以下的语句:
SQL> alter user sysman identified by <password> ;
4. 确认新password:
SQL> connect sysman/[@database_alias]
5. 在database directory $ORACLE_HOME/bin文件夹中,运行:
On Unix
$ emctl setpasswd dbconsole
Provide the new SYSMAN password
On Windows
C>: emctl setpasswd dbconsole
Provide the new SYSMAN password
6.重新启动DB Control
On Unix
$ emctl start dbconsole
On Windows
Start the Windows Service OracleDBConsole
Or
Open a DOS Command Window and type
C>: emctl start dbconsole
【翻译自mos文章】改变数据库用户sysman(该用户是DB Control Repository 的schema)password的方法的更多相关文章
- 【翻译自mos文章】ABMR:在asm 环境中測试Automatic Block Recover 特性的方法
ABMR:在asm 环境中測试Automatic Block Recover 特性的方法 參考原文: ABMR: How to test Automatic Block Recover Feature ...
- 【翻译自mos文章】11.2.0.4及更高版本号的asm实例中MEMORY_TARGET 和 MEMORY_MAX_TARGET的默认值和最小值
[翻译自mos文章]11.2.0.4及更高版本号的asm实例中MEMORY_TARGET 和 MEMORY_MAX_TARGET的默认值和最小值 来源于: Default and Minimum ME ...
- 【翻译自mos文章】job 不能自己主动执行--这是另外一个mos文章,本文章有13个解决方法
job 不能自己主动执行--这是另外一个mos文章 參考原文: Jobs Not Executing Automatically (Doc ID 313102.1) 适用于: Oracle Datab ...
- 【翻译自mos文章】使用asm来部署 超大数据库(10TB到PB 范围)--针对oracle 10G
使用asm来部署 超大数据库(10TB到PB 范围) 參考原文: Deployment of very large databases (10TB to PB range) with Automati ...
- 【翻译自mos文章】oracle db 中的用户账户被锁--查看oracle用户的尝试次数
參考原文: Users Accounts Getting Locked. (Doc ID 791037.1) 事实上这个文章是为oracle 别的软件产品写的,只是涉及到user 锁定问题.那还是跟d ...
- 【翻译自mos文章】在一次失败的 'Shutdown Immediate'之后,数据库job 不能执行。
在一次失败的 'Shutdown Immediate'之后.数据库job 不能执行. 參考原文: Database Jobs Do Not Run After a Failed 'Shutdown I ...
- 【翻译自mos文章】在12c数据库中,哪种audit trail 受到支持?
在12c数据库中,哪种audit trail 受到支持? 来源于:What Audit Trail Types Are Supported For A 12c Database? (文档 ID 198 ...
- 【翻译自mos文章】在Oracle单机数据库中定义database service
来源于: Defining a Database Service with a Stand Alone Database (文档 ID 1260134.1) APPLIES TO: Oracle Da ...
- 【翻译自mos文章】怎么找到OGG Director Server使用的数据库和username?
APPLIES TO: Management Pack for Oracle GoldenGate - Version: 1.0.0.0 - Release: 1.0 Information in t ...
随机推荐
- GNU所有软件下载,其中最有意思的是octave
http://ftp.gnu.org/gnu/ 最有意思的是octave:https://www.gnu.org/software/octave/http://ftp.gnu.org/gnu/octa ...
- Android仿微信图片上传,可以选择多张图片,缩放预览,拍照上传等
仿照微信,朋友圈分享图片功能 .可以进行图片的多张选择,拍照添加图片,以及进行图片的预览,预览时可以进行缩放,并且可以删除选中状态的图片 .很不错的源码,大家有需要可以下载看看 . 微信 微信 微信 ...
- linux之SQL语句简明教程---WHERE
我们并不一定每一次都要将表格内的资料都完全抓出.在许多时候,我们会需要选择性地抓资料.就我们的例子来说,我们可能只要抓出营业额超过 $1,000 的资料.要做到这一点,我们就需要用到 WHERE 这个 ...
- OpenStack开启sshd
修改配置sshd的文件 1. 修改sshd配置文件 /etc/ssh/sshd_config 2. 将#PasswordAuthentication no的注释去掉,并将no改为y ...
- C#软件winform程序安装包制作及卸载程序制作
使用vs2010 winform程序开发的软件的人比较多,程序的开发是为了在不同的人不同的机器使用,为了使不同的机器能使用该软件就需要在制作程序安装包,安装包里必须包含该软件运行所选的所有环境,下面就 ...
- LINQ 基本子句之一 (select/where/group/into)
特别喜欢同事看到我写了一句小排序的时候说,他当然喜欢Linq了,虽然我只是baidu之,不知其然也不知其所以然. 基本格式 var<变量> = from <项目> in < ...
- 一点用JS写控制权限的心得
<!DOCTYPE html><html lang="en"><head> <meta charset="UTF-8" ...
- Zepto.js touch模块深入分析 解决手机点击事件
源码: // Zepto.js // (c) 2010-2015 Thomas Fuchs // Zepto.js may be freely distributed under the MIT li ...
- 远程访问数据库查询数据量一大就Hang
最近刚为客户升级了一套Oracle Database,一切进展顺利,眼看就要顺利验收时,发现有部分客户端软件连接新版本数据库时会Hang,问题非常诡异. 系统环境如下 升级前的环境OS:Windows ...
- 一个利用Dataflow实现的Actor
最近进行并发数据处理,学习到了 Actor模型,其中最简单的实现方式是一位大牛利用Dataflow实现的. 大牛的方案:http://www.jayway.com/2013/11/15/an-acto ...