mysql的日志类型:

  错误日志: log-error
  查询日志: log
  慢查询日志: log-slow-queries
  更新日志: log-update
  二进制日志: log-bin

开启错误日志

log-error=/usr/local/mysql/log/log-error.log

开始查询日志

log=/usr/local/mysql/log/log-query.log

由于mysql版本升级,上面的参数设置会报错,要改成下面的参数设置,才能开启日志

general_log=ON
general_log_file=/usr/local/mysql/log/mysql_query.log

开启慢查询日志

log-slow-queries=/usr/local/mysql/log/log-slow-query.log

由于mysql版本升级,上面的参数设置会报错,要改成下面的参数设置,才能开启日志

slow-query-log=1 #开启为1,关闭为0
long_query_time = 2
slow-query-log-file=d:/wamp/logs/mysql_slow_query.log

开启更新日志

log-update=/usr/local/mysql/log/log-update.log

开启二进制日志

log-bin=/usr/local/mysql/log/log-bin.log

实例测试:开启查询日志、错误日志

  1、编辑/etc/my.cnf,即编辑mysql的配置文件

vi /etc/my.cnf

  2、添加开启查询日志、错误日志的代码段

    aaarticlea/png;base64,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" alt="" />

  3、重启mysql数据库

4、输入命令,实时查看log-query.log文件

tail -f /usr/local/mysql/log/log-query.log

  5、打开另一个终端,进入mysql里进行查询操作

     mysql -uroot -p123456

     use test

     select * from one;

 6、执行步骤5时,log-query.log的内容就会变动

问题:在/usr/local/mysql/log/文件夹中,有log-error.log文件,但是没有log-query.log文件。

原因:在log-error.log文件里,找到错误提示。本人理解为,没权限创建文件。但是,怎么又有权限创建log-error.log文件,真是纠结。

解决:自己创建一个log-query.log文件,并设置权限为777(有点暴力了)

mysql日志的查看与开启的更多相关文章

  1. 转:mysql日志(Windows下开启Mysql慢查询、通用日志)

    一.Windows下开启Mysql慢查询详解 //show variables like '%quer%';查询是否开启了慢查询!! 第一步:修改my.ini(mysql配置文件)  在my.ini中 ...

  2. mysql日志信息查看与设置mysql-bin

    查看 sql查询记录  日志是否开启 SHOW GLOBAL VARIABLES LIKE '%general_log%' 二进制日志 是否开启 SHOW GLOBAL VARIABLES LIKE ...

  3. mac 开启mysql日志

    step1: 进入终端进入mysql: step2 : 开启mysql日志 step3 : 查看mysql的日志文件所在位置 step4 : 在终端中用tail -f 命令打开该日志文件:

  4. Linux Centos下查看cpu、磁盘、内存使用情况,关闭MySQL日志

    Linux Centos下查看cpu.磁盘.内存使用情况,关闭MySQL日志 lsblk 查看分区和磁盘df -h 查看空间使用情况fdisk -l 分区工具查看分区信息cfdisk /dev/sda ...

  5. mysql日志开启和查看

    mysql日志开启和查看. 找到mysql根目录下的my.ini文件,打开在下面插入 log-bin=mysql-bin binlog_format=mixed 然后重启mysql. 在dos端登录m ...

  6. Mysql: mysqlbinlog命令查看日志文件

    想查看mysql的binlog文件,但是裸的binlog文件是无法直视的,mysqlbinlog这个工具是用来查看binlog文件内容的(使用方式man mysqlbinlog查看),但是使用mysq ...

  7. 转载Linux下开启MySQL日志

    转载https://blog.csdn.net/weixin_38187469/article/details/79273962 开启mysql日志   1.查看日志是否启用 mysql> sh ...

  8. 开启mysql日志及若干问题

    今天学习了mysql日志功能,以前也有所了解,只不过没有深入的学习,所以趁着“余热”,把我从网上找到的资料与实践 结合起来,总结一下其基本用法.学习从来都不是无趣的,就看你怎么看待学习. 1.查看查询 ...

  9. MYSQL启用日志,查看日志,利用mysqlbinlog工具恢复MySQL数据库【转载】

    转自 MYSQL启用日志,查看日志,利用mysqlbinlog工具恢复MySQL数据库 - _安静 - 博客园http://www.cnblogs.com/xionghui/archive/2012/ ...

随机推荐

  1. shell脚本结构示例1

    2013年以来自己因为偷懒,少写了很多东西,今年计划把以前积累的总结出来. 先从shell开始写起吧. 干了快3年游戏运维,期间经常会写一些shell本,不少脚本其实有很多可以复用的部分. 按照自己的 ...

  2. ZooKeeper 分布式锁实现

    1 场景描述 在分布式应用, 往往存在多个进程提供同一服务. 这些进程有可能在相同的机器上, 也有可能分布在不同的机器上. 如果这些进程共享了一些资源, 可能就需要分布式锁来锁定对这些资源的访问. 2 ...

  3. 将vs2012的项目转化成VS2010

    vs2012生成的项目,如何在只装有VS2010的电脑上打开, 步骤: 1.打开一个记事本,将你的Vs2012生成的项目解决方案文件(.sln文件)文件拖到记事本中 2.修改前两行  Microsof ...

  4. linux mysql 安装(rpm)

    linux上安装mysql, 就需要两个文件, xx.client.xx.rpm和 xx.server.xx.rpm 如 MySQL-client-community-5.1.72-1.rhel5.i ...

  5. iOS 制作发布证书,发布到App Store

    ---恢复内容开始--- 1.登陆 iOS Dev Center 选择进入iOS Provisioning Portal. 2.在 iOS Provisioning Portal中,点击App IDs ...

  6. RIME输入法

    RIME输入法 1.可以输入汉语拼音. (1) RIME内置的「地球拼音」可以在选择完字之后按下「Shift+Enter」键,直接输入汉语拼音,并且是带声调的. (2) 自己配置汉语拼音方案. 2.五 ...

  7. ZJK的黑OJ(树的最大独立集)(树形DP)

    ZJK的黑OJ zjk开了一家"善良OJ".这其实是家黑OJ.每AC一道题,网站便会自动在电脑上安装一种木马.zjk通过窃取信息获取收益(如网游帐号.OI资料.和KK的照片等等). ...

  8. OpenJudge 2787 算24

    1.链接地址: http://poj.org/problem?id=1631 http://bailian.openjudge.cn/practice/2787/ 2.题目: 总时间限制: 3000m ...

  9. samba和squid 安装

    一. samba配置1. 什么是sambaSamba服务类似于windows上的共享功能,可以实现在Linux上共享文件,windows上访问,当然在Linux上也可以访问到.是一种在局域网上共享文件 ...

  10. compass sprite

    1.compass init 初始化一个compass项目,并创建一个images文件夹用来存放合成的sprite图 2.将切好的小图放到images文件夹中 3.在sass文件夹中新建一个test. ...