转:对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问
控制台启动server时报"对于服务器server-1与计算机machin
<!--StartFragment -->
对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问。
所有所选服务器当前都处于与此操作不兼容的状态, 或未与运行的节点管理器关联, 或没有授权您执行请求的操作。不会执行任何操作
次错误基本都遇到过。在网上搜了半天,最后才解决,基本如下:
对于服务器server-1与计算机machine-2相关联的节点管理器无法访问。
所有所选服务器当前都处于与此操作不兼容的状态, 或未与运行的节点管理器关联, 或没有授权您执行请求的操作。不会执行任何操作。
原因:nodemanager没有启起来
一、对于managedServer于adminServer在同一服务器上的情况:
1、在控制台可查看该机器的节点管理器端口,比如为5556
2、用netstat -nap | grep 5556命令查看端口为5556的进程是否存在便知nodemanager是否已启动,这时肯定是不存在的
3、但是用ps -ef |grep java命令查看进程,可看到NodeManager进程
4、用kill -9 NodeManager进程号
5、vi /etc/hosts查看ip地址配置是否正确
6、vi /etc/sysconfig/network查看机器名配置是否正确
7、vi $WL_HOME/common/nodemanager/nodemanager.properties查看以下配置是否正确,这里的端口5556就与上文提到的端口一致,如果端口不对可能是因为在前一次nodemanager起来之后,在控制台修改了端口,而在nodemanager.properties文件中保存的还是原端口,所以当再次启动nodemanager时,启动的端口不是修改后的而是原来的。
ListenPort=5556
SecureListener=false
StartScriptEnabled=true
二、如果AdminServer在服务器A上,ManagedServer在服务器B上的情况:
这时候不能启动nodemanager还可能是因为服务器B无法与服务器A通讯,这时候会报socket相关错误。此时,
1、在B服务器上修改$WL_HOME/common/nodemanager/nodemanager.properties文件:
SecureListener=false
StartScriptEnabled=true
2、在B上$WL_HOME/common/bin/目录下执行wlst.sh脚本
./wlst.sh即可
3、执行完2后会来到wls:/offline>下,在此输入connect()回车
4、此时会依次要求输入AdminServer的用户名、密码及url如下
Please enter your username [weblogic] :weblogic
Please enter your password [weblogic] :
Please enter your server URL [t3://localhost:7001] :t3://adminServerIP:port
以上三项指服务器A上登录控制台时的用户名、密码及IP地址和端口
5、如果第4步执行成功,则显示
Successfully connected to Admin Server 'AdminServer' that belongs to domain 'my_domain'.
会跳到wls:/my_domain/serverConfig>
my_damain指服务器A上的domain
如果第4步执行不成功,会返回第3步重新输入connect()
此时也可输入dumpStack()回车,查看具体错误
6、第5步执行成功后,在wls:/my_domain/serverConfig>下依次执行
nmEnroll('/home/weblogic/Oracle/Middleware/wlserver_10.3/common/nodemanager')
nmEnroll('/home/weblogic/Oracle/Middleware/user_projects/domains/server_b_domain')
这里的weblogic目录指服务器B上的weblogic目录,视自己的目录修改语句。
7、注册成功后,按ctrl+c返回weblogic目录,再到$WL_HOME/servers/bin目录下
nohup ./startNodeManager.sh &启动nodemanager
如果启动时报以下错误
严重: Fatal error in node manager server
java.net.BindException: Address already in use
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
at java.net.ServerSocket.bind(ServerSocket.java:319)
at java.net.ServerSocket.<init>(ServerSocket.java:185)
at weblogic.nodemanager.server.Listener.init(Listener.java:54)
at weblogic.nodemanager.server.NMServer.start(NMServer.java:205)
at weblogic.nodemanager.server.NMServer.main(NMServer.java:355)
at weblogic.NodeManager.main(NodeManager.java:31)
说明前面以执行过该语句,此时需要杀掉nodemanager的进程号再次执行启动语句。
补充:节点管理器类型可选择"普通"。
转:对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问的更多相关文章
- 对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问
控制台启动server时报"对于服务器server-1与计算机machin<!--StartFragment -->对于服务器AdminServer, 与计算机Machine-0 ...
- 在控制台启动服务器时出现:对于服务器soa1_wls, 与计算机oim1相关联的节点管理器无法访问。
问题:在控制台启动服务器时出现:对于服务器soa1_wls, 与计算机oim1相关联的节点管理器无法访问.原因:nodemanager没有启起来解决方法: 一.对于managedServer于admi ...
- 使用 WLST 和节点管理器来管理服务器
使用节点管理器启动计算机上的服务器 WLST 可以连接至在任何计算机上运行的节点管理器,并能够在此计算机上启动一个或多个 WebLogic Server 实例.要通过此技术使用 WLST 和节点管理器 ...
- Spring3.0配置多个事务管理器(即操作多个数据源)的方法
大多数项目只需要一个事务管理器.然而,有些项目为了提高效率.或者有多个完全不同又不相干的数据源,最好用多个事务管理器.机智的Spring的Transactional管理已经考虑到了这一点,首先分别定义 ...
- Android 上传图片到服务器二--------调用相机7.0以上权限问题
[目录] (一)上传图片到服务器一 ---------------------------------Android代码 (二)上传图片到服务器二--------------------------- ...
- C# 发邮件 服务器响应为: 5.7.0 Must issue a STARTTLS command first
The SMTP server requires a secure connection or the client was not authenticated. The server respons ...
- redhat enterprixe 5.0 DNS 服务配置与管理
一.了解DNS相关概念 DNS是一个分布式数据库,在本地负责控制整个分布式数据库的部分段,每一段中的数据通过客户机/服务器模式在整个网络上存取.通过采用复制技术和缓存技术使得整个数据库稳定可靠的同时, ...
- Tomcat6.0 管理器配置
最近忙着毕业答辩,填写材料,好多事情都给耽搁了!一个月都没有继续翻译tomcat,这回有点时间赶紧补上. 这部分,其实对开发者或者tomcat管理者来说,只要会登录页面管理器或者使用写简单的http就 ...
- 打开FTP服务器上的文件夹时发生错误,请检查是否有权限访问该文件夹
打开FTP服务器上的文件夹时发生错误,请检查是否有权限访问 在win98,winme,win2000,win2003下都能正常上传文件夹,但在winxp+sp2下同样的文件夹就可能出现问题 1. 打开 ...
随机推荐
- c/c++常用网址
个人主页Dennis Ritchie's home pagehttp://cm.bell-labs.com/cm/cs/who/dmr/index.html Brian Kernighan's hom ...
- 百度前端技术学院2015JavaScript基础部分-BOM
5.1 任务描述 实现以下函数 // 判断是否为IE浏览器,返回-1或者版本号 function isIE() { // your implement } // 设置cookie function s ...
- 如何在MainWindowViewModel中引用MainWindow.xaml中的Resource?
问题描述:在MainWindow.xaml的Window.Resource中定义了一个资源,如下: <xctk:Wizard x:Key="_wizard" FinishBu ...
- 玩转mysql-5.7.9-winx64.zip解压版
解压zip文件,放到D盘 追加\bin到Path环境变量 修改my-default.ini,# basedir =D:\mysql_5.7.9_winx64# datadir =D:\mysql_5. ...
- 排序系列 之 简单选择排序及其改进算法 —— Java实现
简单选择排序算法: 基本思想: 在待排序数据中,选出最小的一个数与第一个位置的数交换:然后在剩下的数中选出最小的数与第二个数交换:依次类推,直至循环到只剩下两个数进行比较为止. 实例: 0.初始状态 ...
- 静态变量static和extern外引用
静态变量--加static关键字的变量,特点: (1)在全局数据区中分配内存,每次对其值得修改都会保留结果,直至程序结束. (2)若静态变量没显示初始化,那会被自动初始化为0,并且只能初始化一遍. 1 ...
- hash表C语言实现
算法参考<算法导论>第11章散列表.采用链地址法解决冲突. #include <stdio.h> #include <stdlib.h> #include < ...
- C#面向对象概念之继承
//经常讲到继承.重载,但还是有人概念比较模糊,因此想写个例子加深理解 interface ILog { void WriteLine(string message); } class LogBase ...
- MyEclipse中直接打开class文件的方法
安装步骤: 1>下载jad.exe(这是一个class文件的反编译工具,但是是命令行运行编译,使用起来不是很方便:), 将其拷贝到%JAVA_HOME%/bin目录下(其他目录也可). 2> ...
- Linux的任务计划--cron入门
Linux操作系统定时任务系统 Cron 入门 cron是一个linux下的定时执行工具,可以在无需人工干预的情况下运行作业.由于Cron 是Linux的内置服务,但它不自动起来,可以用以下的方法启动 ...