已经用cm  安装好了cdh,需要在上面添加HBase,并且做一个HBase故障转移功能,现在需要配置2个HMaster 在不同的机器上。

启动出现异常信息:

2015-12-23 14:44:38,893 INFO org.apache.zookeeper.ZooKeeper: Session: 0x351cc5eec210013 closed
2015-12-23 14:44:38,893 INFO org.apache.zookeeper.ClientCnxn: EventThread shut down
2015-12-23 14:44:38,895 INFO org.apache.hadoop.hbase.regionserver.HRegionServer: stopping server node8,60000,1450853073564; all regions closed.
2015-12-23 14:44:38,916 INFO org.apache.hadoop.hbase.ipc.RpcServer: Stopping server on 60000
2015-12-23 14:44:38,926 INFO org.apache.hadoop.hbase.zookeeper.RecoverableZooKeeper: Node /hbase/rs/node8,60000,1450853073564 already deleted, retry=false
2015-12-23 14:44:38,937 INFO org.apache.zookeeper.ZooKeeper: Session: 0x251cc5f0a63000c closed
2015-12-23 14:44:38,937 INFO org.apache.zookeeper.ClientCnxn: EventThread shut down
2015-12-23 14:44:38,937 INFO org.apache.hadoop.hbase.regionserver.HRegionServer: stopping server node8,60000,1450853073564; zookeeper connection closed.
2015-12-23 14:44:38,937 INFO org.apache.hadoop.hbase.regionserver.HRegionServer: master/node8/172.19.0.54:60000 exiting

节点启动信息:

错误原因:

在日志找到错误日志信息:

 by: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.security.AccessControlException): Permission denied: user=hbase, access=WRITE, inode="/":hdfs:supergroup:drwxr-xr-x

错误新日志:

org.apache.hadoop.hdfs.BlockMissingException: Could not obtain block: BP-738627331-172.19.0.54-1450685235299:blk_1073741872_1048 file=/hbase/hbase.version
at org.apache.hadoop.hdfs.DFSInputStream.chooseDataNode(DFSInputStream.java:938)
at org.apache.hadoop.hdfs.DFSInputStream.blockSeekTo(DFSInputStream.java:607)
at org.apache.hadoop.hdfs.DFSInputStream.readWithStrategy(DFSInputStream.java:847)
at org.apache.hadoop.hdfs.DFSInputStream.read(DFSInputStream.java:897)
at java.io.DataInputStream.read(DataInputStream.java:149)
at org.apache.hadoop.io.IOUtils.readFully(IOUtils.java:199)
at org.apache.hadoop.hbase.util.FSUtils.getVersion(FSUtils.java:498)
at org.apache.hadoop.hbase.util.FSUtils.checkVersion(FSUtils.java:582)
at org.apache.hadoop.hbase.master.MasterFileSystem.checkRootDir(MasterFileSystem.java:455)
at org.apache.hadoop.hbase.master.MasterFileSystem.createInitialFileSystemLayout(MasterFileSystem.java:146)
at org.apache.hadoop.hbase.master.MasterFileSystem.<init>(MasterFileSystem.java:126)
at org.apache.hadoop.hbase.master.HMaster.finishActiveMasterInitialization(HMaster.java:611)
at org.apache.hadoop.hbase.master.HMaster.access$500(HMaster.java:169)
at org.apache.hadoop.hbase.master.HMaster$1.run(HMaster.java:1484)
at java.lang.Thread.run(Thread.java:745)

以上2个错误都用同一个办法解决

解决办法:

hadoop fs -mkdir /hbase
hadoop fs -chmod /hbase
hadoop fs -chown hbase:hbase /hbase

org.apache.hadoop.hbase.TableExistsException: hbase:namespace

O org.apache.hadoop.hbase.master.MasterFileSystem: Log folder hdfs://nameservice1/hbase/WALs/node1,60020,1451382531829 belongs to an existing region server
2015-12-29 17:49:16,243 INFO org.apache.hadoop.hbase.master.MasterFileSystem: Log folder hdfs://nameservice1/hbase/WALs/node3,60020,1451382519808 belongs to an existing region server
2015-12-29 17:49:16,249 INFO org.apache.hadoop.hbase.master.MasterFileSystem: Log folder hdfs://nameservice1/hbase/WALs/node4,60020,1451382535204 belongs to an existing region server
2015-12-29 17:49:16,350 INFO org.apache.hadoop.hbase.master.RegionStates: Transition {1588230740 state=OFFLINE, ts=1451382556279, server=null} to {1588230740 state=OPEN, ts=1451382556350, server=node1,60020,1451382531829}
2015-12-29 17:49:16,351 INFO org.apache.hadoop.hbase.master.ServerManager: AssignmentManager hasn't finished failover cleanup; waiting
2015-12-29 17:49:16,352 INFO org.apache.hadoop.hbase.master.HMaster: hbase:meta assigned=0, rit=false, location=node1,60020,1451382531829
2015-12-29 17:49:16,432 INFO org.apache.hadoop.hbase.MetaMigrationConvertingToPB: hbase:meta doesn't have any entries to update.
2015-12-29 17:49:16,432 INFO org.apache.hadoop.hbase.MetaMigrationConvertingToPB: META already up-to date with PB serialization
2015-12-29 17:49:16,590 INFO org.apache.hadoop.hbase.master.AssignmentManager: Clean cluster startup. Assigning user regions
2015-12-29 17:49:16,674 INFO org.apache.hadoop.hbase.master.AssignmentManager: Joined the cluster in 242ms, failover=false
2015-12-29 17:49:16,708 INFO org.apache.hadoop.hbase.master.TableNamespaceManager: Namespace table not found. Creating...
2015-12-29 17:49:16,797 FATAL org.apache.hadoop.hbase.master.HMaster: Failed to become active master
org.apache.hadoop.hbase.TableExistsException: hbase:namespace
at org.apache.hadoop.hbase.master.handler.CreateTableHandler.checkAndSetEnablingTable(CreateTableHandler.java:152)
at org.apache.hadoop.hbase.master.handler.CreateTableHandler.prepare(CreateTableHandler.java:125)
at org.apache.hadoop.hbase.master.TableNamespaceManager.createNamespaceTable(TableNamespaceManager.java:233)
at org.apache.hadoop.hbase.master.TableNamespaceManager.start(TableNamespaceManager.java:86)
at org.apache.hadoop.hbase.master.HMaster.initNamespace(HMaster.java:902)
at org.apache.hadoop.hbase.master.HMaster.finishActiveMasterInitialization(HMaster.java:739)
at org.apache.hadoop.hbase.master.HMaster.access$500(HMaster.java:169)
at org.apache.hadoop.hbase.master.HMaster$1.run(HMaster.java:1484)
at java.lang.Thread.run(Thread.java:745)
2015-12-29 17:49:16,810 FATAL org.apache.hadoop.hbase.master.HMaster: Master server abort: loaded coprocessors are: []
2015-12-29 17:49:16,810 FATAL org.apache.hadoop.hbase.master.HMaster: Unhandled exception. Starting shutdown.

解决办法:

1.切换到zookeeper的bin目录;

2.执行$sh zkCli.sh

输入 ls /

4.输入rmr /hbase

5、重启zk,重启 hbase即可

HBase启动错误提示别的机器60000已经存在的更多相关文章

  1. wampserver 的Apache启动错误提示:The requested URL / was not found on this server.

    打开localhost显示以下错误 原因:之前我配置了虚拟主机,所以服务器是从虚拟环境访问的,localhost也就访问不到 解决方法:打开httpd.conf配置文件,将Include conf/e ...

  2. hbase启动报错

    前一段时间vmware上的ubuntu的hbase用不了了,而hadoop能正常的操作,非常的奇怪. 错误信息好像是connect fail, RPC什么的,看来跟网路有关. 想起以前曾经解决过hba ...

  3. 解决关于 ionic3 启动白屏 控制台错误提示:Uncaught SyntaxError Use of const in strict mode.

    今天将项目从ionic2 升级为ionic3 ,ionic serve 运行在网页上无任何错误. 但是将项目打包成为android apk 却一直卡在启动页面 白屏,进不去的情况.后来在android ...

  4. window nginx 启动无提示错误,却没有listen 80port

    一直使用虚拟机来使用web+hostonly方式; 今天为了測试一个php平台的window系统兼容性, 在官方下载了window-nginx 1.9.1版本号; 解压到文件夹, 执行nginx.ex ...

  5. Hbase启动hbase shell运行命令报Class path contains multiple SLF4J bindings.错误

    1:Hbase启动hbase shell运行命令报Class path contains multiple SLF4J bindings.错误,是因为jar包冲突了,所以对于和hadoop的jar包冲 ...

  6. VMware ESXi 启动时提示引导错误:不是VMware引导槽。找不到管理程序(bank6 not a vmware boot bank no hypervisor found)

    VMware ESXi 启动时提示引导错误: bank6 not a vmware boot bank no hypervisor found 大概中文意思是:不是VMware引导槽.找不到管理程序. ...

  7. Hbase启动的时候出现:[RpcServer.handler=28,port=60000] ipc.RpcServer: RpcServer.handler=28,port=60000: exiting,master.HMasterCommandLine: Master exiting

    hadoop 版本:CDH5.02 Hbase 版本:hbase-0.96.1.1-cdh5.0.2 配置文件:hbase-site.xml <configuration> <pro ...

  8. ENSP 安装后,启动路由器提示错误41

    ENSP 安装后,启动路由器提示错误41 环境: 安装的软件清单: VirtualBox-5.2.28-130011-Win.exe WinPcap_4_1_3.exe Wireshark-x64-3 ...

  9. selenium启动Chrome浏览器和禁止证书错误提示弹出

    要把ChromeDriver放到代码中的文件夹中c://*******Application public static WebDriver WebDriverRun(WebDriver driver ...

随机推荐

  1. Hexo next 添加复制粘贴代码的功能

    文章目录 广告: 自己的方式 感谢 广告: 本人博客地址:https://mmmmmm.me 源码:https://github.com/dataiyangu/dataiyangu.github.io ...

  2. C++——右值引用

    1.绑定到一个将要销毁的右值的引用——移动 2.左值表达式——对象的身份:右值表达式——对象的值 ; int& r=i; int&& rr=i;//×,左值不能绑定到右值引用 ...

  3. java连SQLServer失败 java.lang.ClassNotFoundException:以及 javax.xml.bind.JAXBException

    总结:jdk1.8及以下连sqlserver只需驱动,1.8以上除了驱动还需JAXB API. 1       java连SQLServer必须要先下驱动.否则出现: java.lang.ClassN ...

  4. DB2命令行查看执行计划

    查看对应SQL的执行计划 分析程序包   db2expln -d 数据库名 -i -g -c 模式名-p程序包 -s 0 -t   db2expln -d 数据库名 -i -g -c 模式名-p程序包 ...

  5. NOI 2018 Day1 T1 归程

    题面见洛谷 难点:  走过有积水的地方之后就需计算路径长了 关键算法:   kruskal重构树 ①原来的 kruskalkruskalkruskal 算法就是用并查集实现的, 但当我们使用 krus ...

  6. 理解EntityFramework两个核心类型的职责 DbSet和D'bContext

    DbSet与DbContext是多对一的关系DbSet是实体对象的集合,提供了实现CRUD的相应方法DbContext封装与数据库和数据模型相关的功能,依据数据实体状态创建SQL命令,将数据更改保存到 ...

  7. 代理-jdk动态代理

    1.基于接口的实现,要jdk动态代理的类必须要实现一个接口: 2.中介类:实现了InvocationHandler,并重写这个接口的 方法(public Object invoke(Object pr ...

  8. 2018-2-13-win10-uwp-活动磁贴

    title author date CreateTime categories win10 uwp 活动磁贴 lindexi 2018-2-13 17:23:3 +0800 2018-2-13 17: ...

  9. SVN版本管理与大型代码上线方案(一)

    SVN版本管理与大型代码上线方案(一) 链接:https://pan.baidu.com/s/1A3Iq3gGkGS27L_Gt37_I0g 提取码:ncy2 复制这段内容后打开百度网盘手机App,操 ...

  10. AtCoder Grand Contest 001F Wide Swap

    解法参考这位大佬的:https://www.cnblogs.com/BearChild/p/7895719.html 因为原来的数组不好做于是我们想反过来数组,根据交换条件:值相邻且位置差大于等于k, ...