关于 /var/tmp/.oracle 的作用測试

~---查看 /var/tmp 的权限

[root@lixora var]# ll

total 164

。。。

drwxrwxrwt  3 root root 4096 Oct 31 13:16 tmp

[root@lixora .oracle]# ll

total 0

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:11 s#12569.1

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:11 s#12569.2

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:11 sEXTPROC0

-----改动/var/tmp 的权限

[root@lixora var]# chmod 444 tmp

[root@lixora var]# ll

。。。

dr--r--r--  3 root root 4096 Oct 31 13:16 tmp

。。。

-----尝试启动监听

[oracle10g@lixora ~]$ lsnrctl start

LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 31-OCT-2014 14:13:31

Copyright (c) 1991, 2005, Oracle.  All rights reserved.

Starting /u02/app/oracle/product/10.2.0/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 10.2.0.1.0 - Production

System parameter file is /u02/app/oracle/product/10.2.0/db_1/network/admin/listener.ora

Log messages written to /u02/app/oracle/product/10.2.0/db_1/network/log/listener.log

Error listening on: (ADDRESS=(PROTOCOL=ipc)(PARTIAL=yes)(QUEUESIZE=1))

No longer listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=lixora)(PORT=1521)))

TNS-12557: TNS:protocol adapter not loadable

 TNS-12560: TNS:protocol adapter error

  TNS-00527: Protocol Adapter not loadable

Listener failed to start. See the error message(s) above...

----再次改动 /var/tmp 的权限

[root@lixora var]# chmod 777 tmp

[root@lixora var]# ll

。。。

drwxrwxrwx 
3 root root 4096 Oct 31 13:16 tmp

。。。

再次去启动监听,能够正常启动

关于错误

ORA-12557: TNS:protocol adapter not loadable
Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.

1. Make sure the %ORACLE_HOME%/bin directory is in your PATH.

2. Make sure the protocol is typed/specified correctly in your tnsnames.ora file or whatever source you're using to resolve servicenames.

3. TCP is the default protocol and is installed by default. Ifyou're using something different (like SPX) make sure you installed the protocol adapter.

4. Make sure TOAD is using the correct oracle home if you have multiple homes installed

貌似也没有涉及到相关的错误描写叙述啊!可是究竟 /var/tmp/.oracle 下的文件是啥呢? 依据文件的描写叙述:

[root@lixora .oracle]# ll

total 0

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:08 s#12538.1

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:08 s#12538.2

srwxrwxrwx 1 oracle10g oinstall 0 Oct 31 14:08 sEXTPROC0

[root@lixora .oracle]# ps -ef|grep 12538

54322    12538     1  0 14:08 ?        00:00:00 /u02/app/oracle/product/10.2.0/db_1/bin/tnslsnr LISTENER -inherit

这些文件均是 socket 文件, 且s#12368.1 中的12568 为进程号,经查证是 监听的进程号

那么这些scoket 是用来干嘛的呢?

ODM find:

The hidden directory  '/var/tmp/.oracle' (or /tmp/.oracle on some platforms) or its content was removed while instances & the CRS stack were up and running. Typically this directory contains a number of "special" socket files that are
used by local clients to connect via the IPC protocol (sqlnet) to various Oracle processes including the TNS listener, the CSS, CRS & EVM daemons or even  database or ASM instances. These files
are created when the "listening" process starts.

就是说:这些socket 文被用作 本地client使用进程间通信协议(ipc)和不同的oracle的进程通信,而这些进程包含:tns 监听,css ,crs,evm 守护进程;甚至数据库和asm 实例。这些socket 由‘主动监听’的进程创建。在这里oracle tns listener 创建这些socket 文件主要使用用作pmon 和 tnslsnr  通信从报错信息里就能够看出问题:

Error listening on: (ADDRESS=(PROTOCOL=ipc)(PARTIAL=yes)(QUEUESIZE=1))

不知道以上分析是否确切,不当之处请拍砖:-)

/var/tmp/.oracle 和 oracle listener (监听)的一点理解的更多相关文章

  1. ORACLE之手动注册监听listener。alter system set local_listener="XXX"

    记录下刚刚做的一个为一个数据库(t02)配置多个监听(listener)的实验,过程有点小曲折. (1)新增两个测试的监听,listener.ora的配置内容(可纯手动编辑该文件或使用netca)如下 ...

  2. 关于Oracle报“ORA-12514 TNS 监听程序当前无法识别连接描述符中请求服务”错误

    关于Oracle报“ORA-12514 TNS 监听程序当前无法识别连接描述符中请求服务”错误原因:listener.ora中没有指定监听服务器名. 如下是解决思路: 尝试1.通过重启服务的方式启动数 ...

  3. Oracle启动两个监听

    接上篇:Oracle服务器修改IP后 Oracle服务器更换IP后,办公网络里面可以正常访问了,外地的同事,连了vpn 也可以访问,以为可以收工回家,突然又有同事过来说,机房的服务器ping不通新的i ...

  4. 新建Oracle数据库时,提示使用database control配置数据库时,要求在当前oracle主目录中配置监听程序

    新建一个oracle数据库时,当提示使用database control配置数据库时,要求在当前oracle主目录中配置监听程序等字样的时候,问题是那个监听的服务没有启动,解决方法如下: 打开cmd命 ...

  5. 解决(Oracle)ORA-12528: TNS: 监听程序: 所有适用例程都无法建立新连接 问题

    解决(Oracle)ORA-12528: TNS: 监听程序: 所有适用例程都无法建立新连接 问题通过在CMD下用lsnrctl status 查看出的问题:发现BLOCKEDORACLE启动步骤:s ...

  6. java多个listener监听

    java 多个listener 监听方法 在class 名称上一行添加@Listeners 括号中用逗号隔开 @Listeners({com.example.MyListener.class,com. ...

  7. Listener 监听Session内的对象

    Listener用于监控Session内的对象,分别是HttpSessionBindingListener与HttpSessionActivationListener.它们的触发时机分别为: Http ...

  8. ORACLE清理、截断监听日志文件(listener.log)

    在ORACLE数据库中,如果不对监听日志文件(listener.log)进行截断,那么监听日志文件(listener.log)会变得越来越大,想必不少人听说过关于"LISTENER.LOG日 ...

  9. 怎样绕过oracle listener 监听的password设置

     怎样绕过oracle 监听的password设置: 1.找到监听进程pid ,并将它kill 掉 ps -ef|grep tns [oracle@lixora admin]$ ps -ef|gr ...

  10. Oracle 11gR2 RAC修改监听默认端口

    一.修改SCAN listener port 1.1 修改SCAN listener port 1.2 重启SCAN listener生效新端口 1.3 确认更改 二.修改Listener Ports ...

随机推荐

  1. Selector API用法

    java.nio.channels 类 Selector java.lang.Object java.nio.channels.Selector 直接已知子类: AbstractSelector pu ...

  2. Android 控件EditText的setOnEditorActionListener方法的理解

    需要注意的是 setOnEditorActionListener这个方法,并不是在我们点击EditText的时候触发,也不是在我们对EditText进行编辑时触发,而是在我们编辑完之后点击软键盘上的回 ...

  3. sequence配置

    在实现分库分表的情况下,数据库自增主键已经无法保证在集群中是全局唯一的主键了,因此mycat提供了全局的sequence,并且提供了本地配置.数据库配置等多种实现方式. 本地文件方式 采用该方式,my ...

  4. php date mktime 获取时间上的各种值

    echo date("Ymd",strtotime("now")), "\n"; echo date("Ymd",str ...

  5. thinkphp3.1 缓存配置设置读取

    以下黄字是我用的代码: //设置缓存名为zgg,内容为zongguagua,有效时间60秒 cache('zgg',"zongguagua",60); //读取缓存 if(cach ...

  6. CentOS7.1 KVM虚拟化之虚拟机快照(5)

    这里用之前克隆的虚拟机vm1-clone进行快照操作 注: 1.快照实际上做的是虚拟机的XML配置文件,默认快照XML文件在/var/lib/libvirt/qemu/snapshot/虚拟机名/下 ...

  7. Struts2与Spring的整合

    今天倒腾了半天,终于是把这个两个框架整合到一起了.还是要写一下总结,同时给大家一些帮助. 开发环境:myeclipse 9.0(不好用!)tomcat6.0 1.准备工作 需要导入的包:struts2 ...

  8. 后台返回的HTML整个页面代码打开方法

    后台返回的html代码片段,需要插入html标签中,而返回的整个html文档,则需要重写整个页面. 解决方法: 需要一个中转页面,用document.write()方法重写整个页面: // POST任 ...

  9. [Angular] Create a simple *ngFor

    In this post, we are going to create our own structure directive *ngFor. What it should looks like i ...

  10. [NPM] Add comments to your npm scripts

    The need for comments in your package.json file becomes desirable the more and more npm scripts you ...