Mysql的多机配置(主从、主主等)
前言:
最近这几天给弄了2台机器,部署centlos7.5,除了公司的一些模块外,给2台机器做了下主主备份。
其实网上资料一大堆,但是感觉按照别人的思路不如自己的舒服,虽然这玩意思路差不多,但是还是在此坐下总结吧。
首先普及下主从备份原理,面试出现几率比较大
主服务器创建同步用户,用户向主服务器发起建立数据库aa的请求(create database aa),主服务器通过应用线程把请求转发给i/o守护线程,主服务器i/o守护线程生成数据库同时生成二进制日志bin.000001和bin.000001.index,然后主服务器主动推送二进制日志到从服务器,并唤醒从服务器的i/o守护线程和sql守护线程,从服务器i/o守护线程将日志转存为relay-bin.000001和relay-bin.000001.index,sql守护线程将日志翻译成真正的数据,完成工作后,从服务器的i/o守护线程和sql守护线程进入休眠状态,等待新的操作唤醒!

主从步骤
环境:centos7.5 mysql5.7
步骤:1、首先安装好环境(上一篇中有操作步骤)
2、修改配置文件/etc/my.cnf(主、从都需要修改) ,[mysqld]中添加log_bin=mysql-bin server-id=1(主从不要相同,数字即可)
3、systemctl restart mysqld.server 重启使配置文件生效
4、进入主服务器数据库
grant all on *.* to 'slave'@'从服务器ip地址' identified by '给slave创建密码'; #创建的从服务器用户授予允许访问所有数据库的权限
5、查看主服务器二进制文件名及大小
show master status;

6、从服务器设置
change master to master_host='192.168.10.10',master_user='slave',master_password='123',master_log_file='mysql-bin.000001',master_log_pos=106;

成功后会再/var/lib/mysql下生成一个master-info的文件

7、查看从服务器同步状态
show slave status\G; 开启状态

start slave; 如果同步状态如上满一样是no表明没有开启,使用此命令开启即可

8、验证
主服务器创建库、表、添加数据

从服务器查看

Mysql的多机配置(主从、主主等)的更多相关文章
- MySQL 8.0.15 配置 MGR单主多从
转载自:http://www.cnblogs.com/zhangzihong/p/10443526.html 一.简介 MySQL Group Replication(简称MGR)字面意思是mysql ...
- MySQL 5.6数据库配置主从同步
win7环境下mysql主从搭建 我下载的是压缩包,免安装的那种 1.简单安装 解压后把my-default.ini复制一份改为my.ini默认mysql会找这个文件,首先从system32下找,然后 ...
- [原创]mysql 5.6安装配置,主从分离,读写分离简单教程
文章中参考使用了多个博客的资料,汇总而成!其流程准确性被人亦本人实践! https://blog.csdn.net/qq_35206261/article/details/81321201 https ...
- MySQL数据库主从(主主)配置
一.系统环境: centos7.4 (centos 1708) mysql 5.7 master主机的IP地址为192.168.159.50 slave主机的IP地址为192.168.159.51 M ...
- MySQL 主主同步配置和主从配置步骤
★预备知识 : 1.双机热备 对于双机热备这一概念,我搜索了很多资料,最后,还是按照大多数资料所讲分成广义与狭义两种意义来说. 从广义上讲,就是对于重要的服务,使用两台服务器,互相备份,共同执行同一服 ...
- mysql的主从配置以及主主配置
基础环境 系统:linuxmysql版本:5.5主服务器IP:192.168.1.101从服务器IP:192.168.1.102 1.主服务器(master)要打开二进制日志2.从服务器(slave) ...
- mysql主从配置主主配置
一. 概述 MySQL从3.23.15版本以后提供数据库复制(replication)功能,利用该功能可以实现两个数据库同步.主从模式.互相备份模式的功能.本文档主要阐述了如何在linux系 ...
- MySQL配置主主及主从备份
原文:https://www.cnblogs.com/ahaii/p/6307648.html MySQL主从备份配置实例 场景: 1.主服务器192.168.0.225.从服务器192.168.0. ...
- CentOS 6.5 下MySql主从、主主配置
参考网站: http://blog.csdn.net/faye0412/article/details/6280761 http://blog.csdn.net/kk185800961/article ...
随机推荐
- RabbitMQ入门学习系列(二),单生产者消费者
友情提示 我对我的文章负责,发现好多网上的文章 没有实践,都发出来的,让人走很多弯路,如果你在我的文章中遇到无法实现,或者无法走通的问题.可以直接在公众号<爱码农爱生活 >留言.必定会再次 ...
- Django连接MySQL(二)
1.首先我们需要创建好项目 2.安装MySQL数据库 3.setting中修改database设置 DATABASES = { 'default': { 'ENGINE': 'django.db.ba ...
- Bayesian Statistics for Genetics | 贝叶斯与遗传学
Common sense reduced to computation - Pierre-Simon, marquis de Laplace (1749–1827) Inventor of Bayes ...
- Cent0S 6.7直接在/etc/resolv.conf文件下修改DNS地址重启不生效问题【转】
CentOS 6.7/Linux下设置IP地址 1:临时修改: 1.1:修改IP地址 # ifconfig eth0 192.168.2.104 1.2:修改网关地址 # route add defa ...
- face-morpher过程函数分析
01 dlib.get_frontal_face_detector #功能:人脸检测画框#参数:无#返回值:默认的人脸检测器 02 points1.astype 转换数组的数据类型 03 np.mea ...
- vue报错:There are multiple modules with names that only differ in casing.
今天写项目时,遇到报错信息如下: 经过多次排除及参考网上文章,最后找到问题所在 排查原因:1 .在引用组件时,路径大小写不对也会造成此报错,看例子:错误写法: 正确写法: 2.在组件使用vuex时,引 ...
- jqGrid怎样冻结指定的列
第一步设置colModel 列内的 frozen: true: 第二步设置表格初始时宽度 shrinkToFit: false, 第三步设置 $gridTable.jqGrid('setFroze ...
- Chaos Engineering 混沌工程 Chaos Monkey vs Chaos xxx vs Chaos Blade
Chaos Engineering的历史.原则以及实践https://www.infoq.cn/article/chaos-engineering-the-history-principles-and ...
- shell编程系列15--文本处理三剑客之awk格式化输出printf
shell编程系列15--文本处理三剑客之awk格式化输出printf printf的格式说明符 格式符 含义 %s 打印字符串 %d 打印十进制数 %f 打印一个浮点数 %x 打印十六进制数 %o ...
- shell脚本中执行mysql sql脚本文件并传递参数
1 shell 文件内容替换 sed是一个很好的文件处理工具,本身是一个管道命令,主要是以行为单位进行处理,可以将数据行进行替换.删除.新增.选取等特定工作,下面先了解一下sed的用法. 调用sed命 ...