一同事将测试服务器从SQL Server 2008 R2 SP2升级到了SQL Server 2008 R2 SP3后发现Report Service的报表编辑时启动不了Report Builder,错误信息如下所示:

PLATFORM VERSION INFO

    Windows             : 6.1.7601.65536 (Win32NT)

    Common Language Runtime     : 4.0.30319.18408

    System.Deployment.dll         : 4.0.30319.18408 built by: FX451RTMGREL

    clr.dll             : 4.0.30319.18408 built by: FX451RTMGREL

    dfdll.dll             : 4.0.30319.18408 built by: FX451RTMGREL

    dfshim.dll             : 4.0.41209.0 (Main.041209-0000)

 

SOURCES

    Deployment url            : http://localhost/ReportServer/ReportBuilder/ReportBuilder_3_0_0_0.application?ReportPath=/GLS/FlowCotton

                        Server        : Microsoft-HTTPAPI/2.0

                        X-AspNet-Version: 2.0.50727

    Application url            : http://localhost/ReportServer/ReportBuilder/RptBuilder_3/MSReportBuilder.exe.manifest

                        Server        : Microsoft-HTTPAPI/2.0

                        X-AspNet-Version: 2.0.50727

 

IDENTITIES

    Deployment Identity        : ReportBuilder_3_0_0_0.application, Version=10.50.6000.34, Culture=neutral, PublicKeyToken=c3bce3770c238a49, processorArchitecture=x86

    Application Identity        : MSReportBuilder.exe, Version=10.50.6000.34, Culture=neutral, PublicKeyToken=c3bce3770c238a49, processorArchitecture=x86, type=win32

 

APPLICATION SUMMARY

    * Online only application.

    * Trust url parameter is set.

ERROR SUMMARY

    Below is a summary of the errors, details of these errors are listed later in the log.

    * Activation of http://localhost/ReportServer/ReportBuilder/ReportBuilder_3_0_0_0.application?ReportPath=/GLS/FlowCotton resulted in exception. Following failure messages were detected:

        + File, Microsoft.ReportingServices.ComponentLibrary.Controls.dll, has a different computed hash than specified in manifest.

 

COMPONENT STORE TRANSACTION FAILURE SUMMARY

    No transaction error was detected.

 

WARNINGS

    There were no warnings during this operation.

 

OPERATION PROGRESS STATUS

    * [12/30/2015 3:22:38 PM] : Activation of http://localhost/ReportServer/ReportBuilder/ReportBuilder_3_0_0_0.application?ReportPath=/GLS/FlowCotton has started.

    * [12/30/2015 3:22:40 PM] : Processing of deployment manifest has successfully completed.

    * [12/30/2015 3:22:40 PM] : Installation of the application has started.

    * [12/30/2015 3:22:44 PM] : Processing of application manifest has successfully completed.

    * [12/30/2015 3:22:48 PM] : Found compatible runtime version 2.0.50727.

    * [12/30/2015 3:22:48 PM] : Detecting dependent assembly Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil using Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil.

    * [12/30/2015 3:22:48 PM] : Detecting dependent assembly System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.

    * [12/30/2015 3:22:48 PM] : Request of trust and detection of platform is complete.

 

ERROR DETAILS

    Following errors were detected during this operation.

    * [12/30/2015 3:23:08 PM] System.Deployment.Application.InvalidDeploymentException (HashValidation)

        - File, Microsoft.ReportingServices.ComponentLibrary.Controls.dll, has a different computed hash than specified in manifest.

        - Source: System.Deployment

        - Stack trace:

            at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, Hash hash)

            at System.Deployment.Application.ComponentVerifier.VerifyFileHash(String filePath, HashCollection hashCollection)

            at System.Deployment.Application.ComponentVerifier.VerifyComponents()

            at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)

            at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)

            at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)

            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

 

COMPONENT STORE TRANSACTION DETAILS

    No transaction information is available.

搜索了一下资料,居然发现官方有资料介绍了这个问题:Report Builder of SQL Server 2008 R2 Service Pack 3 does not launch.

We have discovered a problem with Report Builder that ships with SQL Server 2008 R2 Service Pack 3.

If you installed SQL Server 2008 R2, have upgraded it to Service Pack 2 and then applied Service Pack 3, then Report Builder will fail to launch. It will raise the following error.

ERROR SUMMARY

Below is a summary of the errors,
details of these errors are listed later in the log.

* Activation of http://.../ReportServer/ReportBuilder/ReportBuilder_3_0_0_0.application resulted in exception. Following failure messages were detected:

+ File,
Microsoft.ReportingServices.ComponentLibrary.Controls.dll, has a different computed hash than specified in manifest.

We are not planning to release a fix for this issue. Instead we recommend you implement one of the following workarounds.

- Client side workaround:

- Install and run Report Builder 3.0 of SQL Server 2008 R2 RTM from the following location:http://www.microsoft.com/en-pk/download/details.aspx?id=6116

- Or install and run Report Builder of SQL Server 2014 from the following location: http://www.microsoft.com/en-us/download/details.aspx?id=42301

- Server side workaround:

- Uninstall Service Pack 3 then uninstall Service Pack 2 and then reinstall Service Pack 3.

We acknowledge the inconvenience. Apologies for this.

Also, we are in the process of:

- Updating the SQL Server Release Services Blog post announcing the release of SQL Server 2008 R2 Service Pack 3 to add a note to proactively inform customers.

- Updating the download page of SQL Server 2008 R2 Service Pack 3 to add a note to proactively inform customers.

- Creating and publishing quickly a dedicated KB article about this issue.

- Responding to the two MSConnect items that we are aware of about this issue: 1001935 and 1001699.

Regards.

Jean-Yves Devant

Senior Program Manager - SQL Server.

官方解释不打算修复这个问题(真是坑爹),它建议执行下面两个解决办法:

   

1: 客户端

从链接http://www.microsoft.com/en-pk/download/details.aspx?id=6116下载安装SQL SERVER 2008 R2 RTM的Report Builder 3.0

或者从连接http://www.microsoft.com/en-us/download/details.aspx?id=42301限制安装SQL SERVER 2014的Report Builder。

2:服务器端

卸载SP3,然后卸载 SP2,然后从新应用SP3来解决问题。

SQL Server 2008 R2 升级到 Service Pack 3后Report Builder启动不了的更多相关文章

  1. SQL Server 2008 R2升级到SQL Server 2012 SP1

    1.建议对生产环境对的数据库升级之前做好备份,以防不测. 2.从SQL Server 2008 R2 升级到SQL Server 2012 SP1,需要先安装SQL Server 2008 R2 的S ...

  2. sql server 2008 R2 升级与安装遇到的问题

    因工作需要,遂把以前的2008升级到r2,升级失败,具体原因忘了,卸载2008,清了注册表删了文件,结果安装的时候失败了,如下图: 下一步-有错误日志和错误的序列号,错误日志在C:\Program F ...

  3. SQL Server 2008 R2 Build List

    By Steve Jones, 2014/09/30 (first published: 2010/05/25) This is a list of the builds for SQL Server ...

  4. SQL Server 2000向SQL Server 2008 R2推送数据

    [文章摘要]最近做的一个项目要获取存在于其他服务器的一些数据,为了安全起见,采用由其他“服务器”向我们服务器推送的方式实现.我们服务器使用的是SQL Server 2008 R2,其他“服务器”使用的 ...

  5. SQL Server 2008 R2 Service Pack 3 已经发布

    微软SQL Server Product Team在9月26号官方博客宣布,Microsoft SQL Server 2008 R2 Service Pack 3 (SP3)正式发布了 .具体信息可以 ...

  6. 安装SQL server 2008 R2和QL server 2008,与SQL server 2008升级SQL server 2008 R2

    安装SQL server 2008 R2和由SQL server 2008升级SQL server 2008 R2 前提条件: 由SQL server2008 升级SQL server2008 R2 ...

  7. Windows Server 2008 R2+SQL Server 2014 R2升级到Windows Server 2016+SQL Server 2016

    环境: 操作系统:Windows Server 2008 R2 数据库:SQL Server 2014 因SQL Server 2016可以无域创建AlwaysOn集群,集群只剩下单节点也不会挂掉,故 ...

  8. [转]Microsoft SQL SERVER 2008 R2 REPORT SERVICE 匿名登录

    本文转自:https://www.cnblogs.com/Zouzhe/p/5736070.html SQL SERVER 2008 R2 是微软目前最新的数据库版本,在之前的SQL SERVER 2 ...

  9. Microsoft SQL SERVER 2008 R2 REPORT SERVICE 匿名登录

    SQL SERVER 2008 R2 是微软目前最新的数据库版本,在之前的SQL SERVER 2005中,我们可以通过修改IIS对应的SSRS站点及SSRS的配置文件,将SSRS配置成匿名登录的方式 ...

随机推荐

  1. 1Z0-053 争议题目解析686

    1Z0-053 争议题目解析686 考试科目:1Z0-053 题库版本:V13.02 题库中原题为: 686.You execute the following FLASHBACK TABLE com ...

  2. ACM-南京理工大学第八届程序设计竞赛-网络赛(2016.04.17)

    A.偷吃糖果Time Limit: 1000Ms Memory Limit: 65536KB Description小鱼喜欢吃糖果.他有两盒糖果,两盒糖果分别仅由小写字母组成的字符串s和字符串t构成. ...

  3. WebLogic12.1.1中跨域问题的探讨以及几种常见中间件中跨域问题的解决方法

    文章版权由作者李晓晖和博客园共有,若转载请于明显处标明出处:http://www.cnblogs.com/naaoveGIS/. 1.问题描述 扬州现场中最开始安装了中间件WebLogic12.1.1 ...

  4. 【JUC】JUC线程池框架综述

    一.前言 在分析完了JUC的锁和集合框架后,下面进入JUC线程池框架的分析,下面给出JUC线程池的总体框架,之后再逐一进行分析. 二.JUC线程池框架图 说明:从上图可知,JUC线程池框架中的其他接口 ...

  5. SQL Server 执行计划利用统计信息对数据行的预估原理以及SQL Server 2014中预估策略的改变

    前提  本文仅讨论SQL Server查询时, 对于非复合统计信息,也即每个字段的统计信息只包含当前列的数据分布的情况下, 在用多个字段进行组合查询的时候,如何根据统计信息去预估行数的. 利用不同字段 ...

  6. Oracle索引梳理系列(四)- Oracle索引种类之位图索引

    版权声明:本文发布于http://www.cnblogs.com/yumiko/,版权由Yumiko_sunny所有,欢迎转载.转载时,请在文章明显位置注明原文链接.若在未经作者同意的情况下,将本文内 ...

  7. iOS9的几个新关键字(nonnull、nullable、null_resettable、__null_unspecified)

    1.nonnull:字面意思就能知道:不能为空(用来修饰属性,或者方法的参数,方法的返回值) 代码: //三种使用方式都可以 @property (nonatomic, copy, nonnull) ...

  8. python处理空格脚本

    博客园上传代码时拷贝vs里面的代码不能直接粘贴,否则空格会不符合要求 去掉空格代码 # -*- coding: utf-8 -*- '''打开delSpace.txt文本并删除每行开头的八个空格''' ...

  9. .Net调用R语言

    ///加载自己写的R语言算法库 public List<double> GetZTFB(double[] data) { List<double> par = new List ...

  10. 如何实现一个php框架系列文章【1】如何组织文件

    1. 组织文件布局应该考虑什么问题 前后端分离 各业务模块分离但方便互相调用 上传文件安全性 方便接入第三方类库 如图所示 框架入口文件 uct/index.php 框架目录         uct/ ...