Docker 部署 Kibana
Docker 部署 Kibana
本篇主要介绍 使用 Docker 部署 kibana 用于操作 Elasticsearch 使用.

1. 前置准备
1.1 Elasticsearch 准备
可以先准备一个 Elasticsearch 服务 后续用于使用Kibana 去连接它操作,本篇就不展开了
1.2 查看Elasticsearch 和 Kibana 的 版本关系
https://www.elastic.co/cn/support/matrix#matrix_compatibility
根据自己的Elastsearch 版本 可以查询一下适合的 Kibana 的版本

2.Docker 拉取特定版本 Kibana
我的Elastcsearch 版本 8.x 所以 根据版本关系表 我选择了 Kibana 8.x 版本
docker pull kibana:8.0.1

3.配置 kibana.yml
需要先得到 kibana.yml文件 , 可以通过docker cp
3.1 临时启动kibana
# 临时启动
docker run --name kibana -d -p 5601:5601 kibana:8.0.1
# 宿主机 创建一个 用于存储kibana config文件夹
mkdir -p kibana
# docker cp 拷贝 kibana/config 到 宿主机对于的配置文件夹
docker cp kibana:/usr/share/kibana/config /Users/johnny/Desktop/kibana
cp 后 宿主机下对于的路径 就有如下文件了

3.2 配置 Elasticsearch 地址
vim kibana.yml 文件 把 对于的 elasticsearch 地址修改成自己的

3.3 访问 5601 地址

3.4 中文配置
# 添加
i18n.locale: "zh-CN"


4. 通过 Kibana 创建 Elasticsearch 索引
Kibana 提供了开发工具一栏 可以在里面发送 请求操作 Elasticsearch

PUT test_index
{
"settings": {
"number_of_shards": 2, //分片数量
"number_of_replicas": 0 //副本数量
}
}
可以看到 acknowleaged: true 表示成功了

通过 Es-Head 也能看到创建的索引

总结
本篇主要介绍了 Docker 部署 Kibana , 使用Kibana 去操作 Elastcsearch 或者 后续查看 Elasticsearch的日志等 都是很方便的
欢迎大家访问 个人博客 Johnny小屋
欢迎关注个人公众号

Docker 部署 Kibana的更多相关文章
- 【原创】运维基础之Docker(2)通过docker部署zookeeper nginx tomcat redis kibana/elasticsearch/logstash mysql kafka mesos/marathon
通过docker可以从头开始构建集群,也可以将现有集群(配置以及数据)平滑的迁移到docker部署: 1 docker部署zookeeper # usermod -G docker zookeeper ...
- Docker部署ELK 7.0.1集群之Kibana安装介绍
1.下载镜像 [root@vanje-dev01 ~]# docker pull kibana: 2.安装部署 2.1 创建宿主机映射目录 [root@vanje-dev01 ~]# mkdir /e ...
- Docker日志管理--docker部署安装ELK (十一)--技术流ken
Docker logs 对于一个运行的容器,Docker 会将日志发送到 容器的 标准输出设备(STDOUT)和标准错误设备(STDERR),STDOUT 和 STDERR 实际上就是容器的控制台终端 ...
- 【Docker江湖】之docker部署与理解
转载请注明出处:http://blog.csdn.net/gamer_gyt 博主微博:http://weibo.com/234654758 Github:https://github.com/thi ...
- Docker 部署 elk + filebeat
Docker 部署 elk + filebeat kibana 开源的分析与可视化平台logstash 日志收集工具 logstash-forwarder(原名lubmberjack)elastics ...
- Docker部署ELK 日志归集
ELK ELK是Elasticsearch.Logstash.Kibana的缩写,使用ELK的原因是因为公司使用Spring cloud部署了多个微服务,不同的微服务有不同的日志文件,当生产上出现问题 ...
- 使用 docker 部署常用的开发环境
使用 docker 部署常用的开发环境 Intro 使用 docker,很多环境可以借助 docker 去部署,没必要所有的环境都在本地安装,十分方便. 前段时间电脑之前返厂修了,回来之后所有的软件都 ...
- Docker 部署ELK之Sentinl日志报警
前篇文章简单介绍了Docker 部署ELK,以及使用filebeat收集java日志.这篇我们介绍下日志报警配置,这里我们使用Sentinl插件. 1.修改kibana参数 进入elk容器,修改对应参 ...
- ELK 日志系统入门及通过 Docker 部署
1. ELK 系统是什么 ELK 是一套日志中心解决方案,其三个字母分别表示: Elasticsearch:负责日志存储及检索 Logstash:负责日志收集.过滤及格式化 Kibana:数据看板,负 ...
随机推荐
- 迭代器和增强for循环
iterator 迭代:即Collection集合元素的通过获取方法,在获取元素之前先要判断集合中有没有元素,如果有就把这个元素取出来,然后在判断,如果还有就再去除卡u,一直把集合中的所有元素全部拿出 ...
- 妙用 CSS 构建花式透视背景效果
本文将介绍一种巧用 background 配合 backdrop- filter 来构建有趣的透视背景效果的方式. 本技巧源自于一名群友的提问,如何构建如 ElementUI 文档的一种顶栏背景特效, ...
- Luogu1919 【模板】A*B Problem升级版(FFT)
简单的\(A*B\) \(Problem\),卡精度卡到想女装 #include <iostream> #include <cstdio> #include <cstri ...
- 记一次 ClickHouse 性能测试
前言 在工作场景中,我们会采集工厂设备数据用于智能控制,数据的存储用了 InfluxDB,随着数据规模越来越大,InfluxDB 的性能越来越差,故考虑引入 ClickHouse 分担 InfluxD ...
- Oracle-查询之函数
DQL语句:查询语句用于查询表中数据DQL必须包含的两个部分:select 子句 和from 子句select子句:指定要查询的内容,可以指定表中的具体字段,*号,函数,或者表达式from子句:指定数 ...
- MySQL启动报:[ERROR] The server quit without updating PID file
修改配置后MySQL启动不了,报错: [root@localhost mysql]# service mysql restart Starting MySQL...[ERROR] The server ...
- JavaScript 基础知识(二):闭包
首先来思考一下下面的案例: function unclosure() { let count = 0 return count++ } for (let index = 0; index < 1 ...
- java方法---定义,调用
定义,调用 1.方法的定义 方法就是一段用来完成特定功能的代码片段,类似于其它语言的函数. 方法用于定义该类或该类的实例的行为特征和功能实现.方法是类和对象行为特征的抽象. 方法很类似于面向过程中的函 ...
- CVE-2021-3156 sudo提权复现
直接查看https://www.bilibili.com/video/BV1Gp4y1s7dd/,已发至B站
- 面试现场!月薪3w+的这些数据挖掘SQL面试题你都掌握了吗? ⛵
作者:韩信子@ShowMeAI 数据分析实战系列:https://www.showmeai.tech/tutorials/40 AI 面试题库系列:https://www.showmeai.tech/ ...