1、  检查是否存在旧的mysql,执行:

rpm -qa|grep -i mysql

PS:若存在旧mysql,删除查询到的旧mysql,执行:

rpm -e --nodeps  XXXX               #XXXX为查询到的mysql名称

2、  检测是否存在MariaDB数据库(影响mysql安装),执行:

rpm -qa|grep mariadb

PS:若存在旧MariaDB,删除查询到的旧MariaDB,执行:

rpm -e --nodeps  XXXX               #XXXX为查询到的MariaDB名称

例如:rpm -e --nodeps mariadb-libs-5.5.35-3.el7.x86_64

3、  关闭SELINUX,影响mysql启动

vi /etc/selinux/config             #编辑防火墙配置文件

SELINUX=enforcing修改为disabled

#SELINUXTYPE=targeted       #注释掉

:wq                                           #保存,关闭

reboot                               #重启机器才能生效

4、  上传mysql安装包到/data目录,安装mysql,执行:

上传MySQL-client-5.6.32-1.el7.x86_64.rpm、

MySQL-server-5.6.32-1.el7.x86_64.rpm、MySQL-devel-5.6.32-1.el7.x86_64.rpm、MySQL-shared-5.6.32-1.el7.x86_64.rpm到/data目录,执行:

rpm -ivh MySQL-client-5.6.32-1.el7.x86_64.rpm

rpm -ivh MySQL-devel-5.6.32-1.el7.x86_64.rpm

rpm -ivh MySQL-server-5.6.32-1.el7.x86_64.rpm

rpm -ivh MySQL-shared-5.6.32-1.el7.x86_64.rpm

ps:安装的mysql版本5.6.32,查看版本mysql --version

删除安装包:rm -f MySQL-*.rpm

5、  启动mysql服务,指令:

service mysql start

假如报如下错误:

Starting MySQL. ERROR! The server quit without updating PID file (/var/lib/mysql/localhost.localdomain.pid).

解决方法,依次执行:

cd /var/lib/mysql/            #提示的安装目录

mysql_install_db                     #初始化数据库

【如果报以下错:

FATAL ERROR: please install the following Perl modules before executing /usr/bin/mysql_install_db:

Data::Dumper

则:

yum-y install autoconf   //此包安装时会安装Data:Dumper模块

再次执行mysql_install_db

】

chown -R mysql.mysql ./ #修改目录文件权限

service mysql start           #启动mysql

6、  修改mysql存储路径,依次执行如下操作:

A、停止mysql,指令:service mysql stop

B、复制mysql安装文件,指令:cp -arf /var/lib/mysql /data/

C、修改mysql目录权限,指令:chown -R mysql:mysql /data/mysql/

D、vi /etc/my.cnf新建配置文件,配置如下内容:

[client]
port =
default-character-set=utf8 [mysqld]
datadir=/data/mysql
socket=/data/mysql/mysql.sock
character_set_server=utf8
init_connect='SET NAMES utf8' [mysql]
no-auto-rehash
default-character-set=utf8

保存,退出。

E、修改mysql启动脚本,执行:

sed -i "s#datadir=/var/lib/mysql#datadir=/data/mysql#g" /etc/rc.d/init.d/mysql

手动修改脚本方法如下:(参考)

编辑vi /etc/rc.d/init.d/mysql

脚本文件,找到第70行

修改datadir值为/data/mysql,保存,退出。

F、建立软连接,指令:ln -s /data/mysql/mysql.sock /var/lib/mysql/mysql.sock

确认sock文件是否存在。

【如果找不到sock文件,

cd /data/mysql/        #提示的安装目录

mysql_install_db                     #初始化数据库

chown -R mysql.mysql ./ #修改目录文件权限

】

G、启动mysql,指令:service mysql start #到这一步,一般启动失败,多为目录权限问题,再次授权即可解决。

7、  修改mysql里root用户的密码,依次执行:(需安装mysql客户端)

mysql -u root                          #登录mysql数据库

如果报错,则cat /root/.mysql_secret获取密码,再执行mysql -uroot -p输入获取

的密码,进入后先修改root密码才能进行其他操作

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('db@123');

mysql> use mysql;                  #切换到mysql数据库

mysql> UPDATE user SET Password = PASSWORD('db@123') WHERE user = 'root';                                    #更新user表中root用户的密码为db@123

mysql> grant all privileges on *.* to root@"%" identified by 'db@123'; #授权

mysql> FLUSH PRIVILEGES;    #刷新mysql的系统权限相关表

mysql> exit

验证是否修改成功:mysql -uroot -pdb@123

验证字符集是否正确:show variables like 'character_set%';

centos7 安装mysql5.6.32的更多相关文章

  1. Centos7 安装 MySQL5.7

    Centos7 安装 MySQL5.7 一.环境介绍 1.安装包版本介绍 MySQL 有三种安装方式:RPM安装.二进制包安装.源码包安装.我们这篇文章以二进制方式安装MySQL 软件名称 版本 系统 ...

  2. centos7安装mysql5.7.19及配置远程连接

    centos7安装mysql5.7.19及配置远程连接------https://blog.csdn.net/Lh19931122/article/details/77996213

  3. Centos7安装Mysql5.7方法总结 - 实操手册

    Centos7.x版本下针对Mysql的安装和使用多少跟之前的Centos6之前版本有所不同的,废话就不多赘述了,下面介绍下在centos7.x环境里安装mysql5.7的几种方法:一.yum方式安装 ...

  4. 源码安装mysql-5.6.32.tar.gz

    http://mirrors.sohu.com/mysql/MySQL-5.6/mysql-5.6.32.tar.gz 安装依赖包: #yum install wget bison gcc gcc-c ...

  5. CentOS6.5一键安装MySQL5.5.32(源码编译)

    ###################################################mysql_install.sh                                 ...

  6. Linux学习第三步(Centos7安装mysql5.7数据库)

    版本:mysql-5.7.16-1.el7.x86_64.rpm-bundle.tar 前言:在linux下安装mysql不如windows下面那么简单,但是也不是很难.本文向大家讲解了如何在Cent ...

  7. Centos7安装mysql-5.7.19

    Centos7安装Mysql 一 mysql下载 地址: https://dev.mysql.com/downloads/mysql/#downloads 二 在centos7上创建安装文件存放.解压 ...

  8. centos7安装mysql5.7修改设置密码策略

    centos7操作系统在安装mysql5.7社区版之后会有默认密码,通过grep命令在mysqld.log文件中即可找到,如下所示: 标识位置即在初始化安装时mysql的默认密码,然后通过mysql ...

  9. centos7安装MySQL5.7无法设置密码问题

    前言 在使用centos7系统yum方式安装MySQL5.7后 不知道默认密码是多少  知道后没办法修改? 一.找到MySQL密码 service mysqld start vim /var/log/ ...

随机推荐

  1. oracle之 调整 I/O 相关的等待

    I/O相关竞争等待简介 当Oracle数据库出现I/O相关的竞争等待的时候,一般来说都会引起Oracle数据库的性能低下,发现数据库存在I/O相关的竞争等待一般可以通过以下的三种方法来查看Oracle ...

  2. 『备忘录』elasticsearch 去重分页查询

    一开始数据结构设计的很复杂,又是父子关系又是嵌套关系,结果发现不能通过简单的查询得到想要的结果:比如一个商店只出现一件符合条件的商品,弄得查询语句就变成这样了 curl -XPOST http://l ...

  3. Micro-PaaS(Docker+K8S)

    1.概述 Docker是一种Linux容器工具集,它是为构建(Build).交付(Ship)和运行(Run)分布式应用而设计的. Kubernates:是开源的容器集群管理系统.它构建在Docker技 ...

  4. 【经验】实现STL算法时遇到的模板编译错误问题

    在实现set_union算法时调用了自己写的copy算法,出现了以下问题. Error 1 error C2665: 'xyz_stl::__copy' : none of the 2 overloa ...

  5. Cousera 无法播放视频 解决办法 widows 和 linux

    查资料得知,Cousera无法播放课程视频原因在于DNS污染. 尽管通过FQ软件把视频看完了,在最后一课找到了这个解决办法,现在拿出来分享给大家: Windows: 请参照以下链接: http://j ...

  6. 初学FPGA一些建议

    数字电路: 这是大学里的基本课程 ,涵盖了一般数字电路的组合电路.时序电路.寄存器传输.储存器以及可编程逻辑电路(FPGA 就是其中一种),还有比较好的添加了计算机的指令集结构.处理器设计等计算机方面 ...

  7. 数据报表类(BI)项目测试应该如何去啃?

    测试工作是一项十分枯燥的工作,与之相对的测试人员必须有足够的耐心.绝对的细心等素质才能完美的完成这项工作. 从最初的瀑布模式,到如今风靡的敏捷,Devops等:从最初的最后一道关卡到渗透至各个流程,再 ...

  8. nginx 反向代理与负载均衡应用实践

    集群介绍 集群就是指一组(若干个)相互独立的计算机,利用高速通信网络组成的一个较大的计算机服务系统,每个集群节点(即集群中的每台计算机)都是运行各自服务的独立服务器.这些服务器之间可以彼此通信,协同向 ...

  9. 20181110_wait和async

    一. Awit和async的由来: await/async本身是一个语法糖,编译器提供的一个简化编程的功能; 在C#升级和.net Framework升级的时候, 产生的, 所以说并不是CLR的产物 ...

  10. 第四章 istio快速入门(快速安装)

    4.1 环境介绍 K8s 1.9 以上版本. 4.2 快速部署Istio 下载:  https://github.com/istio/istio/releases/,  下载 1.1.0-snapsh ...