1. 服务端指定模块没有对应目录

报错详情:

@ERROR: chdir failed

rsync error: error startingclient-server protocol (code 5) at main.c(1503) [sender=3.0.6]

错误原因

服务端指定模块没有对应目录

解决方法

[root@nfs01 ~]# mkdir –p /backup                            在服务端创建指定模块对应目录

2. 服务端目录属主和数组不正确

报错详情:

sending incremental file list

./

rsync: failed to set times on"." (in backup): Operation not permitted (1)

nfs01_172.16.1.31/

rsync: recv_generator: mkdir"nfs01_172.16.1.31" (in backup) failed: Permission denied (13)

*** Skipping any contents fromthis failed directory ***

sent 106 bytes  received 15 bytes  80.67 bytes/sec

total size is 655  speedup is 5.41

rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1039) [sender=3.0.6]

错误原因

1>    服务端配置文件中指定的用户和模块指定的目录的属主属组不同

2>    服务端模块指定的目录属组属组没有权限

解决方法

将模块指定目录的属主属组修改为 配置文件中指定的 uid gid

[root@nfs01 ~]# chown rsync.rsync /backup           配置文件中指定的用户和组

3. 服务端Rsync对目录操作权限不足

报错详情:

sending incremental file list

rsync: ERROR: cannot statdestination "." (in backup): Permission denied (13)

rsync error: errors selectinginput/output files, dirs (code 3) at main.c(554) [receiver=3.0.6]

rsync: read error: Connectionreset by peer (104)

rsync error: error in rsyncprotocol data stream (code 12) at io.c(759) [sender=3.0.6]

错误原因

服务端rsync对目录操作权限不足

解决方法

修改对应目录权限为755

[root@backup ~]# chmod 755 /backup/

4. 认证错误

报错详情

@ERROR: auth failed on module backup

rsync error: error startingclient-server protocol (code 5) at main.c(1503) [sender=3.0.6]

错误原因

1>    客户端密码文件的权限不是600

2>    服务端密码文件不是600

3>    服务端密码文件不存在(名字写错了/没有创建/配置文件参数写错了)

4>    服务端密码文件里保存的用户名和密码不正确

解决方法:

chmod 600 /etc/rsync.password  # 客户端和服务端都改

5. 服务端不存在模块

报错详情

@ERROR: Unknown module ‘backup‘
rsync error: error starting client-server protocol (code 5) at main.c(1522)[receiver=3.0.3]

错误原因

1>    推送/拉取命令写错了

2>    服务端模块名字写错了

6. 磁盘空间不足

报错详情

rsync: write failed on"/home/backup2010/wensong": No space left on device (28)
rsync error: error in file IO (code 11) at receiver.c(302) [receiver=3.0.7]
rsync: connection unexpectedly closed (2721 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(601)[generator=3.0.7]

错误原因

服务端磁盘空间被占满

7. 服务端防火墙没有关闭或设置规则

报错详情

rsync: failed to connect to172.16.1.41: No route to host (113)

rsync error: error in socket IO(code 10) at clientserver.c(124) [sender=3.0.6]

解决方法

关服务端selinux 和 iptabs 防火墙

【集群实战】Rsync常见错误总结的更多相关文章

  1. Mongodb 集群搭建以及常见错误

    Mongodb 集群搭建以及常见错误 1 关于Replica Sets +Sharding(主从复制加分片)搭建,不这详细去说,网上有很多,大部分的例子就三台服务器之间做主从复制,分2个shard,架 ...

  2. Mongodb 集群搭建以及常见错误(不分块,分片,以及加验证)

    1 关于Replica Sets +Sharding(主从复制加分片)搭建,不这详细去说,网上有很多,大部分的例子就三台服务器之间做主从复制,分2个shard,架构图如下 mongodb节点 分别为 ...

  3. Haproxy+keepalived高可用集群实战

    1.1  Haproxy+keepalived高可用集群实战 随着互联网火热的发展,开源负载均衡器的大量的应用,企业主流软件负载均衡如LVS.Haproxy.Nginx等,各方面性能不亚于硬件负载均衡 ...

  4. redis3.0 集群实战1 -- 安装和配置

    本文主要是在centos7上安装和配置redis集群实战 参考: http://hot66hot.iteye.com/blog/2050676 集群教程: http://redisdoc.com/to ...

  5. 《跟老男孩学Linux运维:Web集群实战》读书笔记

    Linux 介绍 Linux 安装 Linux 调优 Web 基础 Nginx 应用 LNMP 应用 PHP 缓存加速 Nginx 调优 MySQL 应用 NFS 网络文件共享 Nginx 反向代理与 ...

  6. centos linux 系统日常管理4 scp,rsync,md5sum,sha1sum,strace ,find Rsync 常见错误及解决方法 第十七节课

    centos linux 系统日常管理4  scp,rsync,md5sum,sha1sum,strace ,find Rsync 常见错误及解决方法  第十七节课 rsync可以增量同步,scp不行 ...

  7. MySQL/MariaDB数据库的Galera高可用性集群实战

      MySQL/MariaDB数据库的Galera高可用性集群实战 作者:尹正杰  版权声明:原创作品,谢绝转载!否则将追究法律责任. 一.Galera Cluster概述 1>.什么是Gale ...

  8. 基于Ambari Server部署HDP集群实战案例

    基于Ambari Server部署HDP集群实战案例 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 一.部署Ambari Server端 博主推荐阅读: https://www.c ...

  9. Oracle归档日志所在目录时间不对&&Oracle集群日志时间显示错误

    Oracle归档日志所在目录时间不对&&Oracle集群日志时间显示错误 前言 这个问题在18年的时候遇到了,基本不注意并且集群或者数据库运行正常是很难注意到的. 忘记当时怎么发现的了 ...

  10. 【集群实战】Rsync数据同步工具

    1. Rsync介绍 1.1 什么是Rsync? Rsync是一款开源的,快速的,多功能的,可实现全量及增量的本地或远程数据同步备份的优秀工具.Rsync软件适用于unix/linux/windows ...

随机推荐

  1. 百度在PWA中阐述的弹性布局-[CSS]

    原文链接 响应式布局 自从进入移动互联网时代,响应式布局这个词经常出现在 Web 设计和开发领域,它让 Web 页面在不同尺寸的设备上都具有良好的浏览体验. 开始之前 在讲解响应式布局之前,需要先了解 ...

  2. C#通用类库整理--日志记录

    日志的记录是将程序过程中的一些行为数据记录下来,方便开发.运维迅速的找到问题的所在,节省时间.使用时在 站点的web.config 中的<appSettings></appSetti ...

  3. ansible七种武器和json

                                                               ansible七种武器和json • 第一种武器 – ansible 命令,用于执 ...

  4. 路由与交换,cisco路由器配置,基础知识点(二)

    1.进退用户/特权/全局模式 (1)从用户模式进入特权模式 enable (2)从特权模式进入全局配置模式 configure terminal (3)从其他模式回到特权模式 end (4)从特权模式 ...

  5. 七、环回接口ip地址(逻辑接口)

    loopback接口,在网络设备(一般是路由器)上是一种特殊的接口,它不是物理接口,而是一种看不见摸不着的逻辑接口(也称虚拟接口),但是对于网络设备来说却是至关重要的. 在网络设备上可以通过配置命令来 ...

  6. vue(element)中使用codemirror实现代码高亮,代码补全,版本差异对比

    vue(element)中使用codemirror实现代码高亮,代码补全,版本差异对比 使用的是vue语言,用element的组件,要做一个在线编辑代码,要求输入代码内容,可以进行高亮展示,可以切换各 ...

  7. Shell 变量引用实例

    初学 Shell 编程时,对变量各种引用使用不太熟悉,走了很多弯路,本文记录变量引用的一些用法,希望对大家有所帮助. 引用 引用指将字符串用引用符号引起来,以防止特殊字符被 shell 脚本解释为其他 ...

  8. Spring Cloud 系列之 Gateway 服务网关(二)

    本篇文章为系列文章,未读第一集的同学请猛戳这里:Spring Cloud 系列之 Gateway 服务网关(一) 本篇文章讲解 Gateway 网关的多种路由规则.动态路由规则(配合服务发现的路由规则 ...

  9. Vmware下安装Linux

    Linux系统 开源的操作系统.主要是应用在软件的服务器,性能比windows要好. Linux系统(ubuntu,centos,redhat,aix....) Linux主要是通过命令去操作计算机, ...

  10. PrestoSPI安全扩展

    由于Presto官方文档和谷歌搜索都没有相关的内容,git项目中也没有支持sentry的安全插件扩展,因此只能从源码中寻找答案,在梳理完SPI包的安全相关源码结构后,已实现了一个自定义的安全插件,经验 ...