如果是在oracle 10gRAC, 私网网卡冗余保护只能使用操作系统网卡绑定方式,但是到了oracle 11g,如果担心一个私网网卡故障导致rac节点驱逐,可以使用2个私网网卡,Oracle将自动使用HAIP服务冗余私网网卡。

HAIP之后,无需使用网卡绑定就可以实现私网网卡的冗余。

如下测试环境rac 2节点,linux redhat6.9

1.配置

#/etc/hosts
10.0.0.11 wsgwa1
10.0.0.12 wsgwa2
192.168.53.11 wsgwa1-priv1
192.168.54.11 wsgwa1-priv2
192.168.53.12 wsgwa2-priv1
192.168.54.12 wsgwa2-priv2
10.0.0.13 wsgwa1-vip
10.0.0.14 wsgwa2-vip
10.0.0.15 wsgwa-scan # cd /etc/sysconfig/network-scripts/
[root@wsgwa2 network-scripts]# cat ifcfg-eth1
DEVICE=eth1
IPADDR=192.168.53.12
BOOTPROTO=static
ONBOOT=yes
[root@wsgwa2 network-scripts]# cat ifcfg-eth2
DEVICE=eth2
IPADDR=192.168.54.12
BOOTPROTO=static
ONBOOT=yes
HWADDR=:0C::3F:A5:

2.测试,down一个私网网卡,如果rac只有一块私网网卡, 假设rac 2节点,将导致节点2被驱逐。

[grid@wsgwa2 ~]$ crsctl stat res -t -init
--------------------------------------------------------------------------------
NAME TARGET STATE SERVER STATE_DETAILS
--------------------------------------------------------------------------------
Cluster Resources
--------------------------------------------------------------------------------
ora.cluster_interconnect.haip
ONLINE ONLINE wsgwa2
[grid@wsgwa2 ~]$ ifconfig -a
eth1 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.53.12 Bcast:192.168.53.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe3f:a584/ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (53.5 MiB) TX bytes: (90.0 MiB) eth1: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.109.141 Bcast:169.254.127.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric:
eth2 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.54.12 Bcast:192.168.54.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe3f:a598/ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (68.8 MiB) TX bytes: (97.5 MiB) eth2: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.174.33 Bcast:169.254.255.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric: [grid@wsgwa2 ~]$ oifcfg iflist
eth1 192.168.53.0
eth1 169.254.0.0
eth2 192.168.54.0
eth2 169.254.128.0
bond0 10.0.0.0 [grid@wsgwa2 ~]$ oifcfg getif
eth2 192.168.54.0 global cluster_interconnect
eth1 192.168.53.0 global cluster_interconnect
bond0 10.0.0.0 global public SQL> select * from gv$cluster_interconnects;
INST_ID NAME IP_ADDRESS IS_ SOURCE
---------- --------------- ---------------- --- -------------------------------
eth1: 169.254.109.141 NO
eth2: 169.254.174.33 NO
eth1: 169.254.22.31 NO
eth2: 169.254.202.196 NO [root@wsgwa2 ~]# ifconfig eth1 down grid_alert
Sun May ::
SKGXP: ospid : network interface with IP address 169.254.109.141 no longer running (check cable)
SKGXP: ospid : network interface with IP address 169.254.109.141 is DOWN Sun May ::
SKGXP: ospid : network interface with IP address 169.254.109.141 is now running
SKGXP: ospid : network interface with IP address 169.254.109.141 is now UP
#ifconfig -a ip 169.254..141移动到存活的eth2网卡上
eth1 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.53.12 Bcast:192.168.53.255 Mask:255.255.255.0
BROADCAST MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (55.8 MiB) TX bytes: (94.0 MiB) eth2 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.54.12 Bcast:192.168.54.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe3f:a598/ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (72.9 MiB) TX bytes: (102.7 MiB) eth2: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.174.33 Bcast:169.254.255.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric: eth2: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.109.141 Bcast:169.254.127.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric: 启动恢复
[root@wsgwa2 ~]# ifconfig eth1 up
eth1 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.53.12 Bcast:192.168.53.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe3f:a584/ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (56.0 MiB) TX bytes: (94.1 MiB) eth1: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.109.141 Bcast:169.254.127.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric: eth2 Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:192.168.54.12 Bcast:192.168.54.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe3f:a598/ Scope:Link
UP BROADCAST RUNNING MULTICAST MTU: Metric:
RX packets: errors: dropped: overruns: frame:
TX packets: errors: dropped: overruns: carrier:
collisions: txqueuelen:
RX bytes: (75.6 MiB) TX bytes: (106.6 MiB) eth2: Link encap:Ethernet HWaddr :0C::3F:A5:
inet addr:169.254.174.33 Bcast:169.254.255.255 Mask:255.255.128.0
UP BROADCAST RUNNING MULTICAST MTU: Metric:

RAC配置2个私网网卡使用HAIP服务的更多相关文章

  1. Ubuntu16.04双网卡配置,内网外网同时访问

    Ubuntu16.04双网卡配置,内网外网同时访问 配置:vim/etc/network/interface auto lo iface lo inet loopback auto eno1 ifac ...

  2. 配置redis外网可访问

    redis采用的安全策略,默认会只准许本地访问 通过简单配置,完成允许外网访问 [root@cache01 conf]# egrep "(^bind|#bind|# bind)" ...

  3. 配置 redis 外网访问

    redis采用的安全策略,默认会只准许本地访问 1 2 3 4 5 6 7 8 9 10 通过简单配置,完成允许外网访问 [root@cache01 conf]# egrep "(^bind ...

  4. Hyper-V 配置虚拟机内网及外网环境

    一.为Hyper-V虚拟机准备内外网环境 1.内网环境——虚拟机与虚拟机及主机可以互通

  5. 【转】CentOS5.6下配置rsync内网同步数据到外网

    [转]CentOS5.6下配置rsync内网同步数据到外网 本文转自:http://www.linuxidc.com/Linux/2012-06/64070.htm 一.需求 卫士那边有一个需求,就是 ...

  6. RAC配置、安装

    RAC  配置及安装 2012年12月30日 星期日 21:49 ******************************************************************* ...

  7. Linux防火墙配置—访问外网WEB

    一.实验目标 1.本次实验在"Linux基础网络搭建实验"的基础上,在外网虚拟机上搭建WEB服务,并分别配置外网和网关的防火墙规则,使内网能够访问WEB服务 2.Linux基础网络 ...

  8. Oracle rac配置Weblogic数据源(实例名及URL的选择)

    这几天,应用程序后台一直报无法取得连数据库接池.但之前从来没有这个问题,迁移到Weblogic后才发生. 之后据了解,我们服务器上的Oracle 10G 是 RAC 的,即有两个节点. 两个节点 IP ...

  9. Oracle rac 配置Weblogic数据源时 实例名及URL的选择

    Oracle 10G 是 RAC 的,即有两个节点.两个节点 IP及实例名分别为:10.1.43.11 stnic110.1.43.21 stnic2配置数据源时 一直使用的是第一个 URL 及 实例 ...

随机推荐

  1. 【Linux常见命令】uname命令

    uname命令用于显示系统信息. uname可显示电脑以及操作系统的相关信息. 语法 uname [-amnrsv][--help][--version] 参数说明: -a或--all 显示全部的信息 ...

  2. POJ - 2387 Til the Cows Come Home (最短路入门)

    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before ...

  3. 线程池(Java中有哪些方法获取多线程)

    线程池(Java中有哪些方法获取多线程) 前言 获取多线程的方法,我们都知道有三种,还有一种是实现Callable接口 实现Runnable接口 实现Callable接口 实例化Thread类 使用线 ...

  4. Tarjan缩点割点(模板)

    描述:https://www.luogu.com.cn/problem/P3387 给定一个 nn 个点 mm 条边有向图,每个点有一个权值,求一条路径,使路径经过的点权值之和最大.你只需要求出这个权 ...

  5. 王颖奇 20171010129《面向对象程序设计(java)》第十一周学习总结

    实验十一   集合 实验时间 2018-11-8 1.实验目的与要求 (1) 掌握Vetor.Stack.Hashtable三个类的用途及常用API: (2) 了解java集合框架体系组成: (3)  ...

  6. LeetCode--To Lower Case && Remove Outermost Parentheses (Easy)

    709. To Lower Case(Easy)# Implement function ToLowerCase() that has a string parameter str, and retu ...

  7. Vue 做的项目在IE下面打开一片空白解决方法

    ie浏览器打开报这个错并且页面空白: 原因:这是因为浏览器对于部分ES6语法识别不出来导致,所以我们要安装一个插件,把ES6语法转换成IE浏览器可以识别的语法. 解决方法: 需要安装 "ba ...

  8. [hdu5247]rmq+预处理

    题意:有一个无序数组,求有多少个长度为k的区间满足把区间内的数排序后是连续的. 思路:长度为k的区间排序后是 连续的数等价于maxval-minval等于k-1并且不同的数有k个(或者说没有相同的数) ...

  9. python 基础知识5-集合

    1.集合set概念: 集合是无序的,不重复的数据集合,它里面的元素是可哈希的(不可变类型),但是集合本身是不可哈希(所以集合做不了字典的键)的.以下是集合最重要的两点: 1.去重,把一个列表变成集合, ...

  10. 使用JDBC操作MySQL

    使用JDBC操作MySQL 步骤 加载驱动 连接数据库 操作数据库(增删改查) 关闭结果集,操作,数据库 准备工作 java连接MySQL的jar包 加载数据库驱动 public class Load ...