关闭或开启memory_target
对于Oracle数据库内存参数配置大小,一般满足如下规则
sga_target + pga_aggregate_target < memory_target <=memory_max_target sga_max_size < memory_target PGA_AGGREGATE_TARGET= memory_target - sga_target
本篇文档,配置ASMM,ASM进行转换,进行配置。
1.关闭ASM(关闭)memory_target
SQL> show parameter memory
NAME VALUE
------------------------------
memory_max_target 800M
memory_target 720M
SQL> show parameter pga
NAME TYPE VALUE
------------------------------------ ---------------------- ------------------------------
pga_aggregate_target big integer 175M
SQL> show parameter sga
NAME TYPE VALUE
------------------------------------ ---------------------- ------------------------------
pre_page_sga boolean FALSE
sga_max_size big integer 800M
sga_target big integer 528M
******************关闭memory_target 两种方法
方法一。参数修改方式
SQL> alter system reset memory_max_target;
SQL> alter system set memory_target=0;
方法二(错误修改方式)
SQL> alter system set memory_max_target=0 scope=spfile;
SQL> alter system set memory_target=0;
SQL> shutdown immediate; SQL> alter system set memory_target=0 scope=spfile; 要么数据库实例无法启动,要么并没有关闭memory管理方式
方法三。编辑参数文件方式
SQL> create pfile='/tmp/pfile.ora' from spfile;
vi /tmp/pfile.ora
修改前
*.memory_max_target=0
*.memory_target=0
修改后
#*.memory_max_target=0
#*.memory_target=0
SQL> create spfile from pfile='/tmp/pfile.ora';
SQL> startup
2.启用ASM管理
参数说明
Memory_max_target 代表Oracle数据库总内存最大值 memory_target 代表总内存最小值 参数限制:memory_max_target(初始化参数:需要重启生效) Linux环境下:memory_max_target=>受到操作系统shared memory的影响: memory_max_target < /etc/fstab 报错描述: ORA-: MEMORY_TARGET not supported on this system 参数查看: [root@hukou ~]# df -h |grep tmpfs
tmpfs .7G .7G % /dev/shm 操作系统shared memory大小增加:默认为系统整体内存的一半大小:修改后,size指定值 解决方案:增加:vi /etc/fstab tmpfs /dev/shm tmpfs defaults,size=3200m [root@hukou ~]# mount -o remount /dev/shm
[root@hukou ~]# df -h |grep shm
tmpfs .2G .2G % /dev/shm 参数限制:memory_target(在线即可修改) 报错信息: 内存的最小值:需要小于或者等于内存的最大值 ORA-: Specified value of MEMORY_TARGET greater than MEMORY_MAX_TARGET memory_target <= memory_max_target 报错信息:内存的最小值小于512M ORA-: Specified value of MEMORY_TARGET is too small, needs to be at least512M memory_target > sga_target +pga_aggregate_target sga_target big integer 400M pga_aggregate_target big integer 100M 参数限制:sga_max_size(初始化参数:需要重启生效) 参数说明: SGA区域内存最大值 报错信息:sga_max_size的值大于memory_target ORA-: SGA_MAX_SIZE cannot be set to more than MEMORY_TARGET . sga_max_size < memory_target 参数限制:sga_target(在线修改即可) 参数说明:SGA区域内存最小值 报错信息:SGA_TARGET 的值大于sga_max_size ORA-: Specified value of sga_target greater than sga_max_size SQL> show parameter pga
NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
pga_aggregate_target big integer 100M 参数限制:pga_aggregate_target (在线修改即可)
使用ASM管理,启用memory参数
当前内存参数
SQL> show parameter sga NAME TYPE VALUE
------------------------------------ ---------------------- ------------------------------
lock_sga boolean FALSE
pre_page_sga boolean FALSE
sga_max_size big integer 528M
sga_target big integer 528M
SQL> show parameter pga NAME TYPE VALUE
------------------------------------ ---------------------- ------------------------------
pga_aggregate_target big integer 192M 按照规则,如果不修改sga/pga内存大小,那么memory_target >620M,memory_max_target >620M,
memory_max_target小于操作系统内存参数最大值3.9G
enmo:/home/oracle df -h |grep tmpfs
tmpfs 3.9G 0 3.9G 0% /dev/shm
本次参数配置: memory_target =620M,memory_max_target=2200m;
方法一:
SQL> alter system set memory_target=620m scope=spfile;
SQL> alter system set memory_max_target=2200m scope=spfile;
SQL> shutdown immediate;
---本次小学生算数错误,因此启动报错
ORA-00838: Specified value of MEMORY_TARGET is too small, needs to be at least 720M
---由于本次数据库已关闭,因此无法通过sqlplus alter system 修改参数,可以通过手工编辑参数文件。 开车没开好
方法二:
SQL> create pfile='/tmp/pfile.ora' from spfile;
vi /tmp/pfile.ora
修改前
*.memory_max_target=2306867200
*.memory_target=650117120
修改后
*.memory_max_target=2306867200
*.memory_target=720m
SQL> create spfile from pfile='/tmp/pfile.ora';
SQL> startup
SQL> show parameter memory
NAME TYPE VALUE
------------------------------------ ---------------------- ------------------------------
hi_shared_memory_address integer 0
memory_max_target big integer 2208M
memory_target big integer 720M
关闭或开启memory_target的更多相关文章
- SELinux的关闭与开启
SELinux是美国国家安全局对于强制访问控制的实现,是NSA在Linux社区的帮助下开发的一种访问控制体系,所以SELinux可以看做是安全强化的Linux子系统,和防火墙有相似点,作用之一是保证计 ...
- 关闭IIS开启自启
关闭IIS开启自启 win+R输入services.msc 找到服务名称为World Wide Web Publishing Service 双击停止,右键禁用
- [Linux]防火墙关闭与开启
防火墙关闭与开启 系统环境:ubuntu16.04 工具:xshell 测试远程主机的端口是否开启 telnet 192.168.xx.xx 80 防火墙关闭/开启/重启 # 防火墙关闭 sudo u ...
- 关闭或者开启apache的目录浏览
为了安全或者方便需要关闭或者开启apache的目录浏览 关闭目录浏览 修改http.conf 文件 Options Indexes FollowSymLinks 改为 ...
- Linux系统目录结构,Shell脚本;关闭和开启防火墙
Linux系统目录结构 目录 描述 备注 /bin a.存放着最经常使用的命令 b.可执行文件,用户命令 c.构建最小系统所需要的命令 /boot a.内核与启动文件 b.系统启动相关文件 c.启动L ...
- Linux下关闭和开启IPv6的方法
确认IPV6是否开启 在Linux下确认IPv6是否已经被启用,可以从三个方面确定. 1.使用ifconfig查看自己的IP地址是否含有IPv6地址. eth0 Link encap:Ethernet ...
- SELinux关闭和开启
检测Selinux状态 ./usr/sbin/sestatus -v ##如果SELinux status参数为enabled即为开启状态 SELinux status: enabled .geten ...
- Fedora 防火墙关闭与开启
重启后生效 开启: chkconfig iptables on 关闭: chkconfig iptables off 或者 /sbin/chkconfig --level 2345 iptable ...
- 如何查看,关闭和开启selinux
以下介绍一下SELinux相关的工具/usr/bin/setenforce 修改SELinux的实时运行模式setenforce 1 设置SELinux 成为enforcing模式setenforce ...
随机推荐
- [CodeForces - 447D] D - DZY Loves Modification
D - DZY Loves Modification As we know, DZY loves playing games. One day DZY decided to play with a n ...
- 六、持久层框架(Hibernate)
一.乐观锁 Hibernate使用乐观锁来处理脏数据问题. 比如有这样一个制造脏数据的场景: 1.通过session1得到id=1的对象product1 2.在product1原来的价格基础上增加10 ...
- oracle having字句
现在要求查询出职位的平均每个职位的名称,工资,但是要求显示的职位的平均工资高于2000. 即:按照职位先进行分组,同时统计出每个职位的平均工资 随后要求直显示哪些平均工资高 ...
- 【转】vue项目重构技术要点和总结
vue数据更新, 视图未更新 这个问题我们经常会遇到,一般是vue数据赋值的时候,vue数据变化了,但是视图没有更新.这个不算是项目重构的技术要点,也和大家分享一下vue2.0通常的解决方案吧! 解决 ...
- python3 get/post/使用代理/自定义header/自定义Cookie
说明:urllib发送http请求并不是很人性化,更推荐使用在urllib基础上封装的.python2和python3都兼容的requests模块,移步查看. 一.get请求 get请求就是在构造Re ...
- ntpd修改版本号教程
1.查看当前ntpd版本号 执行:ntpd -v 2.查看当前ntpd位置 执行:which ntpd 3.备份ntpd 执行:cp /usr/sbin/ntpd /usr/sbin/ntpd.bak ...
- iptables报错:Couldn't load target `accept':/lib64/iptables/libipt_accept.so: cannot open shared object file: No such file or directory
语句:iptables -A INPUT -s 134.192.204.235 -p TCP --dport 11211 -j accept 报错:Couldn't load target `acce ...
- python 数字格式化
第二种办法比较常用: %02d print '%02d' % 11
- IOS中position:fixed弹出框中的input出现光标错位的问题
解决方案是 在弹框出现的时候给body添加fixed <style type="text/css"> body{ position: fixed; width: 100 ...
- laravel composer 安装指定版本以及基本的配置
1 安装指定的 laravel版本 以下的案例是安装5.2版本 composer create-project laravel/laravel=5.2.* --prefer-dist 2 配置 优化相 ...