CentOS 6.3 安装以及配置Apache php mysql
准备篇:
1、配置防火墙,开启80端口、3306端口
vi /etc/sysconfig/iptables
-A
INPUT -m state –state NEW -m tcp -p tcp –dport 80 -j ACCEPT
#允许80端口通过防火墙
-A INPUT -m state –state NEW -m tcp -p tcp –dport 3306 -j
ACCEPT
#允许3306端口通过防火墙
备注:很多网友把这两条规则添加到防火墙配置的最后一行,导致防火墙启动失败,
正确的应该是添加到默认的22端口这条规则的下面
如下所示:
########################################################
#
Firewall configuration written by system-config-firewall
# Manual
customization of this file is not recommended.
*filter
:INPUT
ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A
INPUT -m state –state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j
ACCEPT -A INPUT -i lo -j ACCEPT
-A INPUT -m state –state NEW -m tcp -p
tcp –dport 22 -j ACCEPT
-A INPUT -m state –state NEW -m tcp -p tcp –dport
80 -j ACCEPT
-A INPUT -m state –state NEW -m tcp -p tcp –dport 3306 -j
ACCEPT
-A INPUT -j REJECT –reject-with icmp-host-prohibited
-A
FORWARD -j REJECT –reject-with icmp-host-prohibited COMMIT
########################################################
/etc/init.d/iptables
restart #重启防火墙使配置生效
2、关闭SELINUX (不建议关闭)
vi /etc/selinux/config
#SELINUX=enforcing #注释掉
#SELINUXTYPE=targeted #注释掉
SELINUX=disabled #增加
:wq! #保存退出
shutdown
-r now #重启系统
安装篇:
一、安装Apache
yum install
httpd
#根据提示,输入Y安装即可成功安装
/etc/init.d/httpd start
#启动Apache
备注:Apache启动之后会提示错误: 正在启动httpd:httpd: Could not reliably
determine the server’s fully qualif domain name, using ::1 for
ServerName
解决办法:
vi /etc/httpd/conf/httpd.conf #编辑
找到
#ServerName www.example.com:80
修改为ServerName www.1000seo.com:80
#这里设置为你自己的域名,
如果没有域名,可以设置为localhost
:wq! #保存退出
chkconfig
httpd on #设为开机启动
/etc/init.d/httpd restart
#重启Apache
二、安装MySQL
1、安装MySQL
yum install mysql
mysql-server #询问是否要安装,输入Y即可自动安装,直到安装完成
/etc/init.d/mysqld start
#启动MySQL
chkconfig mysqld on #设为开机启动
cp
/usr/share/mysql/my-medium.c n f /etc/my.c n f #拷贝配置文件(注意:如果/etc目录下面默认有一个my.c
nf,直接覆盖即可)
2、为root账户设置密码
mysql_secure_installation
回车,根据提示输入Y
输入2次密码,回车 根据提示一路输入Y 最后出现:Thanks for using MySQL!
MySql密码设置完成,重新启动MySQL:
/etc/init.d/mysqld restart
#重启
/etc/init.d/mysqld stop #停止
/etc/init.d/mysqld start
#启动
三、安装PHP5
1、安装PHP5
yum install php
#根据提示输入Y直到安装完成
2、安装PHP组件,使PHP5 支持MySQL
yum install php-mysql
php-gd libjpeg* php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc
php-mbstring php-mcrypt php-bcmath php-mhash libmcrypt
#这里选择以上安装包进行安装,根据提示输入Y回车
/etc/init.d/mysqld restart
#重启MySql
/etc/init.d/httpd restart
#重启Apche
配置篇
一、Apache配置
vi /etc/httpd/conf/httpd.conf
#编辑文件 ServerTokens OS #在44行
修改为:ServerTokens Prod
(在出现错误页的时候不显示服务器操作系统的名称)
ServerSignature
On #在536行
修改为:ServerSignature Off (在错误页中不显示Apache的版本)
Options
Indexes FollowSymLinks #在331行
修改为:Options Includes ExecCGI
FollowSymLinks(允许服务器执行CGI及SSI,禁止列出目录)
#AddHandler cgi-script
.cgi #在796行
修改为:AddHandler cgi-script .cgi .pl
(允许扩展名为.pl的CGI脚本运行)
AllowOverride None #在338行
修改为:AllowOverride
All (允许.htaccess)
AddDefaultCharset
UTF-8 #在759行
修改为:AddDefaultCharset GB2312 (添加GB2312为默认编码)
Options
Indexes MultiViews FollowSymLinks #在554行
修改为Options MultiViews
FollowSymLinks(不在浏览器上显示树状目录结构)
DirectoryIndex index.html index.html.var
#在402行 修改为:
DirectoryIndex index.html index.htm Default.html Default.htm
index.php Default.php index.html.var (设置默认首页文件,增加index.php)
KeepAlive
Off #在76行
修改为:KeepAlive On (允许程序性联机)
MaxKeepAliveRequests 100
#在83行
修改为:MaxKeepAliveRequests 1000 (增加同时连接数)
:wq!
#保存退出
/etc/init.d/httpd restart #重启
rm -f
/etc/httpd/conf.d/welcome.conf /var/www/error/noindex.html
#删除默认测试页
二、php配置
vi /etc/php.ini
#编辑 date.timezone =
PRC #在946行
把前面的分号去掉,改为date.timezone = PRC
disable_functions =
passthru,exec,system,chroot,scandir,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server,escapeshellcmd,dll,popen,disk_free_space,checkdnsrr,checkdnsrr,getservbyname,getservbyport,disk_total_space,posix_ctermid,posix_get_last_error,posix_getcwd,
posix_getegid,posix_geteuid,posix_getgid,
posix_getgrgid,posix_getgrnam,posix_getgroups,posix_getlogin,posix_getpgid,posix_getpgrp,posix_getpid,
posix_getppid,posix_getpwnam,posix_getpwuid, posix_getrlimit,
posix_getsid,posix_getuid,posix_isatty,
posix_kill,posix_mkfifo,posix_setegid,posix_seteuid,posix_setgid,
posix_setpgid,posix_setsid,posix_setuid,posix_strerror,posix_times,posix_ttyname,posix_uname
#在386行
列出PHP可以禁用的函数,如果某些程序需要用到这个函数,可以删除,取消禁用。
expose_php = Off
#在432行
禁止显示php版本的信息
magic_quotes_gpc = On
#在745行
打开magic_quotes_gpc来防止SQL注入
short_open_tag = ON
#在229行
支持php短标签
open_basedir = .:/tmp/
#在380行
设置表示允许访问当前目录(即PHP脚本文件所在之目录)和/tmp/目录,可以防止php木马跨站,如果改了之后安装程序有问题,可以注销此行,或者直接写上程序的目录/data/www.bamaol.com/:/tmp/
:wq!
#保存退出
/etc/init.d/mysqld restart #重启MySql
/etc/init.d/httpd
restart #重启Apche
测试篇
cd /var/www/html
vi index.php
#编辑输入下面内容
<?php phpinfo(); ?>
:wq! #保存退出
原文出处:http://www.bamaol.com/Psy/Showposts-010000108-4764.html
CentOS 6.3 安装以及配置Apache php mysql的更多相关文章
- CentOS linux下安装和配置Apache+SVN(用浏览器http方式访问SVN目录)
在CentOS linux下安装SVN,我们可以进行以下步骤: 第一步:安装CentOS Linux操作系统,并在CentOS安装进行的同时,自定义安装这一步,一定要勾选Subversion(在“开发 ...
- win64安装及配置apache+php+mysql
Windows是64位Win7,所以Apache.PHP和Mysql都选用的64位版本(最好是统一64位). Apache:httpd-2.4.7-win64.zip PHP:PHP-5.4.6-Wi ...
- CentOS 安装以及配置Apache php mysql
准备篇: 1.配置防火墙,开启80端口.3306端口 vi /etc/sysconfig/iptables -A INPUT -m state –state NEW -m tcp -p tcp –dp ...
- Ubuntu/Centos 系统上安装与配置Apache
一.在线安装: Ubuntu:sudo apt-get install apache2 Centos: sudo yum install apache2 二.安装后的位置: 1.服务地址:/etc/i ...
- Centos7安装配置Apache+PHP+Mysql+phpmyadmin
转载自: Centos7安装配置Apache+PHP+Mysql+phpmyadmin 一.安装Apache yum install httpd 安装成功后,Apache操作命令: systemctl ...
- CentOS 下 redis 安装与配置
CentOS 下 redis 安装与配置 1.到官网上找到合适版本下载解压安装 [root@java src]# wget -c http://redis.googlecode.com/files ...
- 环境搭建系列-系统安装之centos 6.5安装与配置
按照国际惯例,系列目录先奉上: 系列一:系统安装之centos 6.5安装与配置 系列二:准备工作之Java环境安装 系列三:数据为先之MySQL读写集群搭建 系列四:谈分布式之RabbitMQ集群搭 ...
- 如何安装、配置Apache
Apache的安装流程网上版本很多,但很多版本有错误,或者缺漏,如果初学者按照那样安装的话会遇到各种各样的问题.我整理了自己安装.配置Apache的过程,亲测有效,分享给大家. 基本过程如下: Dow ...
- 在CentOS 7中安装与配置Tomcat-8方法
安装前提 在CentOS 7中安装与配置JDK8 安装tomcat apache-tomcat-8.0.14.tar.gz文件上传到/usr/local中执行以下操作: [root@localhos ...
随机推荐
- 用Ossim管理IT资产(视频)
用Ossim管理IT资产 在Ossim中集成了Ocs Server,OCS用于帮助网络或系统管理员来跟踪网络中计算机配置与软件安装情况的应用程序.收集到硬件和系统信息,OCS Inventory 也可 ...
- 創建HTTP 服務器
var http = require('http'); var fs = require('fs'); var server = http.createServer(function(req, res ...
- firefox chrome强制指定网址使用https
chrome强制网站使用httpschrome://net-internals/firefox强制指定网站使用https使用noScript插件
- Oracle笔记 三、function 、select
Scott表下有这么几个常用的表,而且还带有数据.分别是emp.dept.salgrade: 1.查看表结构用desc desc emp; 2.空表dual,最常用的空表,如: select 2 * ...
- CentOS系统安装中文man手册
http://jingyan.baidu.com/article/f25ef25466bffc482c1b82b6.html
- 使用JDBC向数据库中插入一条数据(第一次修改版)
增加了一个Tools类,放了一些常用的工具 package com.JDBC.java; import java.io.IOException; import java.io.InputStream; ...
- C puzzles详解【6-8题】
第六题 #include<stdio.h> int main() { ; switch(a) { ': printf("ONE\n"); break; ': print ...
- ping通网关 ping不能外网 DNS无法解析
###ping通网关 ping不能外网 DNS无法解析 客户上不了网 DNS解析不了 首先登陆机器 先查看IP 然后看dns是否正常 然后测试ping网关 ping外网 nslookup ...
- Lenovo Setup(安装程序)
按住F1,进入“Lenovo Setup”. 一.Main(条目处的设置不可更改) UEFI BIOS Version H1ET69WW(1.12) UEFI BIOS Date(Year-Month ...
- NetCat使用手册
简介: 在网络工具中有“瑞士军刀”美誉的NetCat(以下简称nc),在我们用了N年了至今仍是爱不释手.因为它短小精悍(这个用在它身上很适合,现在有人已经将其修改成大约10K左右,而且功能不减少) ...