Hyper-V中的Linux无法配置网络地址的解决办法
一周碰到2次在Hyper-V 2012中安装了Linux,也安装了IC 3.4。但是却无法配置IP地址的问题。因此造成很多不便,因此找机会把这个原因和解决办法进行了尝试。
这过程中感谢同事的提示,让我很快找到解决办法。
在这里总结下Hyper-V下安装Linux的注意事项:
1.正确选择Linux版本,具体请参见官网的兼容性列表
2.安装完成后,务必安装Linux IC 3.4
mkdir /ic
mount /dev/cdrom /mnt/cdrom(如无法挂载,则首先执行mkdir /mnt/cdrom)
cp /mnt/cdrom/RHEL6.3 /ic (首先确认拷贝的ic版本)
切换到/ic/RHEL6.3的目录下
执行./install.sh
等待安装完成,并执行:reboot
注释:如果碰到权限问题,请使用chmod -R 777 /ic来获得权限
3.在Linux中使用ifconfig -a命令确认已经正确识别到网卡。除了lo网卡外需要认到eth0之类的网卡)
截止此时,Linux已经正常识别了虚拟网卡,如果仍无法配置ip地址,则需要执行手动创建配置文件的步骤:
Linux网卡配置文件分为2个
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
制定目录下如果没有这两个文件,则需要手动创建,创建步骤如下:
vi /etc/sysconfig/network(虽然没有这个文件,但是仍然可以编辑,编辑完成后切换到vi的命令行使用wq即可保存)
配置文件内容如下:
NETWORKING=yes
HOSTNAME=Linuxtest
GATEWAY=192.168.1.254 按实际地址填写)
创建完成network文件后,再创建/etc/sysconfig/network-scripts/ifcfg-eth0eth0请根据ifconfig -a显示的内容进行修改)
vi /etc/sysconfig/network-scripts/ifcfg-eth0
此配置文件的内容如下:
DEVICE=eth0根据实际情况填写)
BOOTPROTO=static获取ip方式,自动获取则修改为dhcp)
IPADDR=192.168.1.140
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
ONBOOT=yes开机自动激活)
创建完成后使用:service network restart重启网卡服务。
OK!enjoy!
Hyper-V中的Linux无法配置网络地址的解决办法的更多相关文章
- WPS for Linux 字体配置(字体缺失解决办法)
WPS for Linux 字体配置(字体缺失解决办法) 1. 背景 有些linux装完wps后提示"部分字体无法显示"或"some formula symbols mi ...
- Debian9.5 WPS for Linux字体配置(字体缺失解决办法)
启动WPS for Linux后,出现提示"系统缺失字体" . 出现提示的原因是因为WPS for Linux没有自带windows的字体,只要在Linux系统中加载字体即可. 具 ...
- IIS关于“ 配置错误 不能在此路径中使用此配置节”的解决办法
IIS关于“ 配置错误 不能在此路径中使用此配置节”的解决办法 原文链接:http://www.cnblogs.com/200325074/p/3679316.html 今天刚安装好IIS8.5, 我 ...
- linux中没有dos2UNIX或者UNIX2dos命令怎么解决办法
linux中没有dos2UNIX或者UNIX2dos命令怎么解决办法 http://blog.csdn.net/w616589292/article/details/38274475 dos2unix ...
- [转帖]Linux中buff/cache内存占用过高解决办法
Linux中buff/cache内存占用过高解决办法 https://www.cnblogs.com/rocky-AGE-24/p/7629500.html /proc/sys/vm/drop_cac ...
- 配置IIS提示打开目录浏览时的问题:未能从程序集“System.ServiceModel, Version=3.0.0.0”中加载类型“System.ServiceModel.Activation.HttpModule” 的解决办法
错误消息: 未能从程序集“System.ServiceModel, Version=3.0.0.0”中加载类型“System.ServiceModel.Activation.HttpModule” 的 ...
- linux中文显示乱码的解决办法
linux中文显示乱码的解决办法 linux中文显示乱码是一件让人很头疼的事情. linux中文显示乱码的解决办法:[root@kk]#vi /etc/sysconfig/i18n将文件中的内容修改为 ...
- Spring MVC普通类或工具类中调用service报空空指针的解决办法(调用service报java.lang.NullPointerException)
当我们在非Controller类中应用service的方法是会报空指针,如图: 这是因为Spring MVC普通类或工具类中调用service报空null的解决办法(调用service报java.la ...
- HTTP 错误 500.19 请求的页面的相关配置数据无效 解决办法
"HTTP 错误 500.19 请求的页面的相关配置数据无效" 解决办法 HTTP 错误 500.19 - Internal Server Error无法访问请求的页面,因为该 ...
随机推荐
- 2018.9.8pat秋季甲级考试
第一次参加pat考试,结果很惨,只做了中间两道题,还有一个测试点错误,所以最终只得了不到50分.题目是甲级练习题的1148-1151. 考试时有些紧张,第一题第二题开始测试样例都运行不正确,但是调试程 ...
- 广搜,深搜,单源最短路径,POJ(1130),ZOJ(1085)
题目链接: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=85 http://poj.org/problem?id=1130 这 ...
- JS显示上一周
<html> <head> <script> var currDT; var aryDay = new Array("日","一&qu ...
- C语言函数申明关键字inline
内联inline是给编译器的优化提示,如果一个函数被编译成inline的话,那么就会把函数里面的代码直接插入到调用这个函数的地方,而不是用调用函数的形式.如果函数体代码很短的话,这样会比较有效率,因为 ...
- Spring注解@Value数值取值转换字符串失败
配置文件(yml)中,配置项如下: cebconfig: INST_CODE: 08801001 SFT_NOTIFY_CEB_CHANNEL: 123456 期望INST_CODE: 0880100 ...
- ADO.NET之一:连接层
ADO.NET大部分由System.Data.dll核心程序集来表示. ADO.NET类库有三种完全不听的方式来实现数据访问:连接式.断开式和通过Entity框架.连接式就是会一直占用网络资源,断开式 ...
- Large-scale Scene Understanding (LSUN)
Large-scale Scene Understanding (LSUN) http://lsun.cs.princeton.edu/#organizers http://sunw.csail.mi ...
- Maven学习总结(10)
本文通过一个例子来介绍利用maven来构建一个多模块的jave项目.开发工具:intellij idea. 一.项目结构 multi-module-project是主工程,里面包含两个模块(Modul ...
- Codeforces#498F. Xor-Paths(折半搜索)
time limit per test 3 seconds memory limit per test 256 megabytes input standard input output standa ...
- 【期望dp 质因数分解】cf1139D. Steps to One
有一种组合方向的考虑有没有dalao肯高抬啊? 题目大意 有一个初始为空的数组$a$,按照以下的流程进行操作: 在$1\cdots m$中等概率选出一个数$x$并添加到$a$的末尾 如果$a$中所有元 ...