Failed to start LSB: start and stop MariaDB
Failed to start LSB: start and stop MariaDB
*/-->
Failed to start LSB: start and stop MariaDB
1 总结
Failed to start LSB: start and stop MariaDB 这仅是一个提示,提示我们数据库无法
正常启动。至于具体原因,在这个错误之前的信息里有的可能提示,有的并没有提示。这就需要我
们抽丝剥茧,一点一点去研究,分析。
在我遇到的这个问题里,有以下几点原因(文章随时可能更新):
- 参数配置不正确
参数配置不正确时,有时也会出现这个错误。Mariadb 中的一些参数,与原来的MySQL参数所属选项不一样。比如log-error原来属于[mysql_safe]
而新版本的Mariadb 中应属于[mysqld]. - 路径不存在
比如log-error相关路径没有创建。检查参数文件是否配置,如果有配置,配置路径是否都存在。 - 数据库跳过回滚大事备,导致的数据不一致。
执行大事务中断后,关键表被锁,回滚的耗时长到人神共愤,于是将数据库关闭,配置
innodb_force_recover参数,规避回滚事务而启动数据库,之后没有通过逻辑备份
重建数据库。
日后遇到其他原因,再补充。
2 错误信息
Jun 22 21:40:11 test1 systemd[1]: Starting LSB: start and stop MariaDB...
Jun 22 21:40:11 test1 mysqld[29013]: Starting MariaDB.190622 21:40:11 mysqld_safe Logging to '/var/log/mariadb/mariadb.log'.
Jun 22 21:40:11 test1 mysqld[29013]: 190622 21:40:11 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
Jun 22 21:40:12 test1 mysqld[29013]: /etc/rc.d/init.d/mysqld: line 264: kill: (29029) - No such process
Jun 22 21:40:12 test1 mysqld[29013]: ERROR!
Jun 22 21:40:12 test1 systemd[1]: mysqld.service: control process exited, code=exited status=1
Jun 22 21:40:12 test1 systemd[1]: Failed to start LSB: start and stop MariaDB.
Jun 22 21:40:12 test1 systemd[1]: Unit mysqld.service entered failed state.
Jun 22 21:40:12 test1 systemd[1]: mysqld.service failed.
从错误信息上来看,什么有用的信息都没有。
报错退出之前mysql 要做的操作是" Logging to '/var/log/mariadb/mariadb.log". 看看日志吧。
结果发现没有这个日志
3 解决
3.1 路径问题
查看相关参数
[root@test1 mysql]# grep log-err /etc/my.cnf
log-error=/var/log/mariadb/mariadb.log
[root@test1 mysql]# ls /var/log|grep mariadb
[root@test1 mysql]#通过以上两步操作,确认,相关路径确实是不存在的。
创建相关路径:
mkdir -p /var/log/mariadb
启动数据库
systemctl start mysqld
就这样成功了。
Failed to start LSB: start and stop MariaDB的更多相关文章
- 【centos7】 Failed to start LSB Bring up/down
今天碰到几个问题: 1. Failed to start LSB Bring up/down 归结一下 百度 的答案: 1). 90% 修改MAC 地址 2).10% 重启 networkmanage ...
- CentOS7 Failed to start LSB: Bring up/down解决方法
刚刚装好的虚拟机突然不能上网了,报错很诡异,具体报错如下: /etc/init.d/network restart Restarting network (via systemctl): Job f ...
- CentOS7 Failed to start LSB: Bring up/down networking.解决方法
https://www.cnblogs.com/bonjov1/p/4323836.html CentOS7 Failed to start LSB: Bring up/down networking ...
- Centos7:Failed to start LSB: Bring up/down networking
一开始配置的ifcfg-ens33 [root@cdh- ~]# cd /etc/sysconfig/network-scripts/ [root@cdh- network-scripts]# ls ...
- CentOS7 重启网卡Failed to start LSB: Bring up/down networking.解决方法
环境:MAC PD虚拟机安装centos7 修改完网卡配置,重启网络服务报错 使用提示命令查看:systemctl status network.service 发现报错为Failed to star ...
- Failed to start LSB: Bring up/down networking 问题
Failed to start LSB: Bring up/down networking 问题 1.执行 service network restart 出现以下错误 Restarting ne ...
- code=exited,status=1/failure;failed to start LSB:Bring up/down networking
环境: CentOS 7 vmware 12 操作: 复制可使用的vmware centOS 7系统至新环境 问题: 无法启动网络 查看“systemctl status network" ...
- 虚拟机Failed to start LSB: Bring up/down networking
1.执行 service network restart 出现以下错误 Restarting network (via systemctl): Job for network.service f ...
- Failed to start LSB: Bring up/down networking.
由于我的虚拟机是从别的机器拷贝过来的,导入新机器后,没有问题,第二天就网络连接不上了,就出现下面的错误 [root@centos ~]# /etc/init.d/network restart Res ...
随机推荐
- mysql 关于字符串搜索的函数
与like作用相似 FIND_IN_SET LOCATE POSITION
- 命令行工具--curl
目录 命令:curl 一.简介 二.使用案例 1.基本用法 2.保存访问的网页 3.测试网页返回值 4.指定proxy服务器以及其端口 5.cookie 6.模仿浏览器 7.伪造referer(盗链) ...
- zencart批量评论插件Easy Populate CSV add reviews使用教程
此插件在Easy Populate CSV 1.2.5.7b产品批量插件基础上开发,有1.3x与1.5x两个版本. zencart批量评论插件Easy Populate CSV add reviews ...
- zencart设置特价商品价格
登录后台-工具-安装SQL脚本(Install SQL Patches) 运行以下语句: , '0001-01-01'); 红色部分请替换成实际要设置的数据:1234表示产品ID,888表示特价.
- Springboot定时任务实现动态配置Cron参数(从外部数据库获取)
https://blog.csdn.net/qq_35992900/article/details/80429245 我们主要讲解它的动态配置使用方法. 在刚开始使用的时候,我们更改一个任务的执行时间 ...
- 集成学习的不二法门bagging、boosting和三大法宝<结合策略>平均法,投票法和学习法(stacking)
单个学习器要么容易欠拟合要么容易过拟合,为了获得泛化性能优良的学习器,可以训练多个个体学习器,通过一定的结合策略,最终形成一个强学习器.这种集成多个个体学习器的方法称为集成学习(ensemble le ...
- for update的作用和用法
一.for update定义 for update是一种行级锁,又叫排它锁,一旦用户对某个行施加了行级加锁,则该用户可以查询也可以更新被加锁的数据行,其它用户只能查询但不能更新被加锁的数据行.如果其它 ...
- [人物存档]【AI少女】【捏脸数据】1222今日份的推荐
AISChaF_20191030183624290.png
- RAID技术超详细讲解
RAID 技术是一种多磁盘技术,面对数据的各方面有着两面性的影响,整体来说优点大于缺点的,下面我将详细介绍一下 RAID ,简称磁盘阵列技术. 一.RAID 概述 1988 年美国加州大学伯克利分校的 ...
- 【Java Web】IDEA如何创建及配置Web项目(多图)
正文之前 在学习Java Web时,第一个遇到的问题就是如何创建或配置Web项目了,今天,就用IntelliJ IDEA 来进行Web项目配置: 创建Web项目 配置web项目 正文 创建Web项目 ...