apache-service的使用
apache service目录设置
设置Apache HTTP Server的文件根目录(DocumentRoot)
安装Apache 时,系统会给定一个缺省的文件根目录
如果你觉得这个网页存在这个缺省目录不方便,需要另外设个Apache 文件根目录
你可以修改Apache的配置文件httpd.conf里有关根目录的设置。
Apache HTTP Server的缺省文件根目录(DocumentRoot)是:
DocumentRoot "C:\Program Files\Apache Software Foundation\Apache2.2\htdocs"
修改Apache 文件根目录(DocumentRoot)的操作如下:
1> 为了避免修改失误,请先备份你的Apach配置文件httpd.conf,该配置文件的路径是
2> 打开http.conf文件找到DocumentRoot为开头的那一行,将
DocumentRoot "C:/Program Files/Apache Software Foundation/Apache2.2/htdocs"
改成新的 DocumentRoot 路径,比如你新的路径为 C:\htdocs,就改成
DocumentRoot "C:/htdocs"
3> 然后找到httpd.conf 文件中的如下内容:
# This should be changed to whatever you set DocumentRoot to.
<Directory "C:/Program Files/Apache Software Foundation/Apache2.2/htdocs">
将 Diectory 中的路径改成你新设的文件根目录,比如:
<Directory "C:/htdocs">
4>保存配置文件httpd.conf ,重启Apache Service
apache server 修改端口
找到Listener 80 (--->修改为自己的端口即可)
常见的错误
当修改Apache的配置后,重启启动往往会出现the requested operation has failed报错问题,初学Apache搭建,遇到了这种问题很是困扰。
原因一:Apache服务器端口冲突
解决方法一:打开cmd命令行,用”netstat -aon | findstr “80”“命令查看端口占用程序的PID,然后再用”tasklist | findstr “PID”“查看被哪个进程占用了。然后kill掉此进程。
解决方法二:更改Apache的端口号。在httpd.conf文件中,找到”Listen 80”属性,将80改为其他未被占用的端口。
原因二:更改Apache服务器默认存储的文件路径
Apache服务器的核心配置文件是httpd.conf,默认路径为“Apache安装路径\conf\”,打开该文件,定为到DocumentRoot。
该路径用于指定网络路径,存放主页配置的目录,如:DocumentRoot “D:/Webpage”,句末不能加“/”。
同时定位到Directory行,此处为服务器的虚拟路径,要与DocumentRoot配置相同,如:<”Directory “D:/Webpage”>
原因三:httpd.conf配置错误
如果apache的配置文件httpd.conf错误,可以使用命令行启动apache,并带上参数,apache会提示哪句有误,然后可以针对性的解决问题。
解决方法:打开cmd,到apache安装路径\bin下,执行“httpd.exe -w -n “Apache2.2” -k start”,其中Apache2.2位安装Apache服务器的目录名。
apache-service的使用的更多相关文章
- Apache service named reported the following error(OS 10055)由于系统缓冲区空间不足或队列已满解决办法?
apache启动失败报错: The Apache service named reported the following error:>>> AH00451: no listeni ...
- 安装新版xampp后apache无法启动提示:Apache Service detected with wrong path解决方案
我以前安装过xampp,因为学习thingPHP需要升级PHP5.0以上,所以我就卸掉了xampp,从新安装新版本的xampp其中PHP是最新版的,但是安装后启动xampp提示如下:Apache Se ...
- windows apache 配置多个服务 站点 Apache Service Monitor
把Apache安装为多个Window NT服务 ~~~ 可以在 services.msc中查看到1. 在DOS下跳到Apache安装目录里的bin目录(~~~或者用path命令 把apache的安装目 ...
- Apache, service httpd stop, Address already in use:
service httpd stopStopping httpd: [FAILED][root@testtest ...
- PHP环境配置-从Apache官网下载windows版apache服务器
由于个人有强迫倾向,下载软件都喜欢从官网下载,摸索了好久终于摸清楚怎么从Apache官网下载windows安装版的Apache服务器了,现在分享给大家. 进入apache服务器官网http://htt ...
- 将Apache手动安装成Windows的服务
将Apache手动安装成Windows的服务 可以选择在安装Apache时自动将其安装为一个服务.如果选择"for all users",那么Apache将会被安装为服务. 如果选 ...
- Apache不重新编译,利用apxs工具给Apache添加模块,如cgi模块
想实践下Apache是如何运行cgi程序的,却发现先前编译安装Apache的时候,没有安装Apache的cgi模块. 附:CentOS6.x编译安装LAMP(2):编译安装 Apache2.2.25 ...
- Loadrunner监控Apache
一.安装Apache yum -y install httpd 二.配置Apache 1.设置开机启动 chkconfig httpd on 2.开启Apache service httpd star ...
- debian 安装svn apache 小记. AuthzSVNAccessFile 不生效问题.
docker 使用docker镜像搭建svn+Apache环境 https://my.oschina.net/u/2006667/blog/637882 1,安装 apache ,svnapt-get ...
- linux centos service 参数详解
Service文件 开门见山,直接来看两个实际的服务配置文件吧. 第一个配置是 CoreOS 系统中 Docker 服务的 Unit 文件,路径是 /usr/lib/systemd/system/do ...
随机推荐
- cogs 330. [NOI2003] 文本编辑器
★★★ 输入文件:editor2003.in 输出文件:editor2003.out 简单对比 时间限制:2 s 内存限制:128 MB [问题描述] 很久很久以前,DOS3.x的程序 ...
- SPOJ Hacking(字典树 + 搜索)题解
思路1:字典树存每个串,然后dfs遍历是否存在.这里有个技巧,如果每次都重新初始化字典树为-1,那么会超时,所以我先初始化为-1,然后设一个Case,每个test时Case都++,那么只要开一个数组判 ...
- Luogu 2671 求和 NOIP2015T3
题目链接 题解 20pts $O(n^3)$枚举$x,y,z$,根据题目要求判断 40pts $O(n^2)$枚举$x,z$,需要满足$x,z$奇偶相同 20~40pts的代码我都没有写过...就不贴 ...
- Unity3D学习笔记(二十三):事件接口、虚拟摇杆、层级管理和背包系统
事件接口 IDragHandler(常用):鼠标按下拖动时执行(只要鼠标在拖动就一直执行) IDropHandler:对象拖动结束时,如果鼠标在物体的范围内,执行一次(依赖于IDragHandler存 ...
- hbase读写流程分析
前言 最近被大佬问到一个问题,hbase查询数据在最坏的场景下需要进行几次rpc,当时就懵了..下面主要对client端代码进行分析.阅读文章和看源码更配~ 读数据 流程总览 1. 从zookeepe ...
- ftp协议及vsftpd的基本应用
1.ftp协议及vsftpd的基本应用 vsftpd 是"very secure FTP daemon"的缩写,安全性是它的一个最大的特点.vsftpd 是一个 UNIX 类操作系 ...
- UVa 10618 跳舞机
https://vjudge.net/problem/UVA-10618 这道题目题意很复杂,代码也是参考了别人的,因为自己实在是写不出.d[i][a][b][s]表示分析到第i个箭头时,此时左脚处于 ...
- bzoj 4403 序列统计 卢卡斯定理
4403:序列统计 Time Limit: 3 Sec Memory Limit: 128 MB Description 给定三个正整数N.L和R,统计长度在1到N之间,元素大小都在L到R之间的单调 ...
- jenkins网页报错,Unable to create the home directory ‘/usr/share/tomcat7/.jenkins’. This is most likely a permission problem
cd /usr/share/tomcat7 sudo mkdir .jenkins sudo chown tomcat7:nogroup .jenkins 执行以上操作,重启解决
- python2 安装scrapy出现错误提示解决办法~
首先:set STATICBUILD=true && pip install lxml 安装环境: windows7操作系统,已经正确安装python,pip. 使用pip功能安装Sc ...