OS: Centos7.0
DB: Percona5.7

1. 通过yum安装

## 删除之前的mysql数据库, 我用的是centos7.再安装虚拟机的时候,预装了很多软件。所以mysql和mariadb的一些东西安装了。必须要删除掉
rpm -qa | grep mysql
rpm -qa | grep mariadb rpm -e mysql
rpm -e --nodeps mysql
yum remove mariadb-libs-5.5.41-2.el7_0.x86_64 ## 安装其他依赖包:perl 和libaio
yum -y install perl-Module-Install.noarch
yum -y install libaio libaio-devel ## 配置yum安装源
yum install https://www.percona.com/redir/downloads/percona-release/redhat/0.1-4/percona-release-0.1-4.noarch.rpm ## 最新的是0.1-4 ## 安装percona
yum install Percona-Server-server-57

2. 通过rpm安装

wget https://www.percona.com/downloads/Percona-Server-LATEST/Percona-Server-5.7.18-16/binary/redhat/7/x86_64/Percona-Server-5.7.18-16-rd7301f8-el7-x86_64-bundle.tar

tar xvf Percona-Server-5.7.18-16-rd7301f8-el7-x86_64-bundle.tar

rpm -ivh Percona-Server-shared-compat-57-5.7.18-16.1.el7.x86_64
rpm -ivh Percona-Server-shared-57-5.7.18-16.1.el7.x86_64
rpm -ivh Percona-Server-client-57-5.7.18-16.1.el7.x86_64
rpm -ivh Percona-Server-server-57-5.7.18-16.1.el7.x86_64

3. 配置

## 配置用户组
groupadd mysql
useradd -r -g mysql mysql mysqld --initialize --user=mysql --datadir=/user/local/webserver/mysql ## 如果没报错,恭喜你很幸运

vim /etc/percona-server.conf.d/mysqld.cnf

[mysqld]

datadir=/usr/local/webserver/mysql
socket=/usr/local/webserver/mysql/mysql.sock # initialize need
explicit_defaults_for_timestamp=true # Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0 log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid [mysql]
socket=/usr/local/webserver/mysql/mysql.sock

chown -R mysql:mysql /usr/local/webserver/mysql

service mysqld start ## 如果没报错,恭喜你很幸运。

4. 登录

cat /var/log/mysqld.log | grep "temporary password" ## 找到root的初始密码。

mysql -u root -p 

set password = password('root');

5. ERROR

  • mysqld --initialize 报错:TIMESTAMP with implicit DEFAULT value is deprecated

    从 5.6开始,timestamp 的默认行为已经是 deprecated

vim /etc/percona-server.conf.d/mysqld.cnf

explicit_defaults_for_timestamp=true ## 加上这段(显示指定默认值为timestamp类型的字段)
  • mysql --initialize 报错:initialize specified but the data directory has files in it. Aborting.

    datadir 已经存在了。删除即可

  • service mysqld start 报错:InnoDB: .\ibdata1 must be writable > InnoDB 在启动时需要配置LOG File的目录,如果没有制定目录,则会在MySQL Data目录下创建2个日志文件ib_logfile0 and ib_logfile1,在创建的时候需要确保MYSQL拥有对该目录的权限。

ps -ef | grep mysqld
kill 21222 ## kill掉mysqld的进程
rm /usr/local/webserver/mysql/ib_logfil*
service mysqld start
  • service mysqld start 报错:Could not create unix socket lock file /user/lib/mysql/mysql.sock.lock.
## 很简单的问题。加权限即可
chown -R mysql:mysql /user/lib/mysql/

6. 总结

安装mysql的数据库必要步骤有:

  1. 安装依赖包
  2. 安装mysql数据库
  3. 初始化服务(mysqld --initialize)
  4. 修改配置文件,配置datadir目录权限和用户
  5. 启动服务,链接数据库

参考资料

  1. MySQL 5.6 中TIMESTAMP with implicit DEFAULT value is deprecated错误
  2. MYSQL 服务无法启动,错误日志:InnoDB: .\ibdata1 must be writable
  3. 如何在 CentOS 7 上安装 Percona服务器
  4. percona5.7 源码安装

<wiz_tmp_tag id="wiz-table-range-border" contenteditable="false" style="display: none;">

 
 
 
 

Centos7安装Percona5.7的更多相关文章

  1. HP服务器 hp 360g5 centos7安装问题

    HP服务器  hp 360g5 centos7安装问题 一 :启动盘无法识别硬盘 1.进入安装光盘,用上下键选择安装centos--Install Centos7(注意不可按Enter键),如图: 2 ...

  2. CentOS7 安装Mono及Jexus

    CentOS7安装Mono及Juxes 1 安装Mono 1.1 安装yum-utils 因为安装要用到yum-config-manager,默认是没有安装的,所以要先安装yum-utils包.命令如 ...

  3. CentOS7安装mysql提示“No package mysql-server available.”

    针对centos7安装mysql,提示"No package mysql-server available."错误,解决方法如下: Centos 7 comes with Mari ...

  4. CentOS7安装Oracle 11gR2 安装

    概述 Oracle 在Linux和window上的安装不太一样,公司又是Linux系统上的Oracle,实在没辙,研究下Linux下Oracle的使用,oracle默认不支持CentOS系统安装,所以 ...

  5. Centos7安装完毕后重启提示Initial setup of CentOS Linux 7 (core)的解决方法

    问题: CentOS7安装完毕,重新开机启动后显示: Initial setup of CentOS Linux 7 (core) 1) [x] Creat user 2) [!] License i ...

  6. centos7安装eclipse

    centos7安装eclipse Eclipse是一个集成开发环境(IDE),包含一个基工作区和定制环境的可扩展插件系统.大部分使用 Java 编写,Eclipse 可以用来开发应用程序.通过各种插件 ...

  7. CentOS7安装mongoDB数据库

    CentOS7安装mongoDB数据库 时间:2015-03-03 16:45来源:blog.csdn.net 作者:进击的木偶 举报 点击:8795次 mongoDB是目前发展比较好的NOSQL数据 ...

  8. CentOS7安装Ambari

    环境: CentOS7安装两个节点:master.slave1.并配置ssh无密码登录. 步骤: 获取 Ambari 的公共库文件(public repository): wget http://pu ...

  9. [CentOs7]安装mysql(2)

    摘要 之前安装过一次mysql,最后配置,发现在本地无法连接,重启服务的时候一直卡在那里不动,感觉是安装的过程出问题,最后没办法还是卸载了,然后重新安装一下. [CentOs7]安装mysql Mys ...

随机推荐

  1. Arrays和Collections 对于sort的不同实现原理

    详见:http://blog.yemou.net/article/query/info/tytfjhfascvhzxcytp46 1.Arrays.sort() 该算法是一个经过调优的快速排序,此算法 ...

  2. spring配置datasource三种方式

    详见:http://blog.yemou.net/article/query/info/tytfjhfascvhzxcytp34 spring配置datasource三种方式 1.使用org.spri ...

  3. Redis 常用数据结构及其控制命令整合

    Redis 键值支持5种基本结构,分别是字符串,列表,哈希,集合,有序集合.每一种数据结构都有对应的取值和设值命令,辅助命令,除此之外,还有一些全局命令,用来管理Redis存储的所有 键. 全局命令 ...

  4. jvm系列 (五) ---类的加载机制

    类的加载机制 目录 jvm系列(一):jvm内存区域与溢出 jvm系列(二):垃圾收集器与内存分配策略 jvm系列(三):锁的优化 jvm系列 (四) ---强.软.弱.虚引用 我的博客目录 什么是类 ...

  5. makefile使用.lds链接脚本以及 $@ ,$^, $,< 解析

    先来分析一个简单的.lds链接脚本 例1,假如现在有head.c init.c nand.c main.c这4个文件: 1.1 首先创建链接脚本nand.lds: SECTIONS { firtst ...

  6. poj 1384完全背包

    题意:给出猪罐子的空质量和满质量,和n个硬币的价值和质量,求猪罐子刚好塞满的的最小价值. 思路:选择硬币,完全背包问题,塞满==初始化为无穷,求最小价值,min. 代码: #include<io ...

  7. [自制操作系统] 图形界面&VBE工具&MMIO显存&图形库/字库

    本文记录了在JOS(或在任意OS)上实现图形界面的方法与一些图形库的实现. 本文中支持的新特性: 支持基本图形显示 支持中英文显示(中英文点阵字库) 相关:VBE VESA MMIO 点阵字库 Git ...

  8. pip install python 如何快速安装模块

    之前python安装模块要在网络上下载,从python2.7.9之后,以及python3,python就自带pip 这个命令,能够快速的安装模块 1,  首先打开python的主文件夹 2.在主文件夹 ...

  9. python--用户登录验证

    目标要求: 1.最多输入3次用户名密码, 2.如果是被锁用户,则一次即退出程序, 3.如果输入正确的用户名密码,则提示登陆成功,程序结束, 4.3次输入不对,会将用户写入被锁用户列表,当然,该用户名需 ...

  10. 第二次项目冲刺(Beta阶段)5.23

    1.提供当天站立式会议照片一张 会议内容: ①检查前一天的任务情况,将遇到的瓶颈反馈,看看团队成员是否有好的建议. ②制定新一轮的任务计划. 2.每个人的工作 (1)工作安排 队员 今日进展 明日安排 ...