mysqlGTID主从同步出现1236错误问题
从主库xtrabackup备份,配置好gtid复制,从主库的从库复制。一直报错误
Last_IO_Error: Got fatal error 1236 from master when reading data from binary log: 'The slave is connecting using CHANGE MASTER TO MASTER_AUTO_POSITION = 1, but the master has purged binary logs containing GTIDs that the slave requires.'
看了从库,保留有最近7天的binlog日志,怎么还有找不到binlog,查了一下,原来是主库的gtid和从库的gtid不一样
主库gtid:
04cfe2d0-8709-11ea-993a-a4fa76fdf2a6:1-2316735354,
151ba254-8709-11ea-95a6-a4fa76fdf4b0:1,
2b02a6a4-18ba-11e9-bec1-e435c881d012:1-132,
5dc542a6-4627-11e9-a3e8-e435c881d116:1-28835327,
62cd3f43-53d4-11e9-9461-883fd358a4b0:1-61077414,
645f56c0-6e68-11e9-8951-18ded7a37b4a:1-232612455,
749003b7-909d-11e8-a759-9c37f402a633:1-143387296,
daf04b34-9b3e-11e9-a1fc-6c92bf487ed9:1-3546539260,
e7ae93d4-9b3e-11e9-ba88-6c92bf48c282:1,
f251b4f3-53cb-11ea-aeb1-a4fa76fdf372:1-982537851
从库gtid
04cfe2d0-8709-11ea-993a-a4fa76fdf2a6:1-2344893812,
151ba254-8709-11ea-95a6-a4fa76fdf4b0:1,
2b02a6a4-18ba-11e9-bec1-e435c881d012:1-132,
3fd2272b-fc07-11e9-b7d7-6c92bf488712:1-3546,
5dc542a6-4627-11e9-a3e8-e435c881d116:1-28835327,
62cd3f43-53d4-11e9-9461-883fd358a4b0:1-61077414,
645f56c0-6e68-11e9-8951-18ded7a37b4a:1-232612455,
749003b7-909d-11e8-a759-9c37f402a633:1-143387296,
daf04b34-9b3e-11e9-a1fc-6c92bf487ed9:1-3546539260,
e7ae93d4-9b3e-11e9-ba88-6c92bf48c282:1,
ec4524cc-bd00-11e9-a6f6-246e9649a940:1,
f251b4f3-53cb-11ea-aeb1-a4fa76fdf372:1-982537851,
f88526bb-bd00-11e9-89ff-6c92bf482749:1-60
如果再建一个级联从库,必须修改一下gtid值,因为gtid的唯一性:
04cfe2d0-8709-11ea-993a-a4fa76fdf2a6:1-2316735354, 这块是不变的。要从库同步,需要修改gtid
SET GLOBAL gtid_purged= 改成如下即可 :
04cfe2d0-8709-11ea-993a-a4fa76fdf2a6:1-2316735354,
151ba254-8709-11ea-95a6-a4fa76fdf4b0:1,
2b02a6a4-18ba-11e9-bec1-e435c881d012:1-132,
3fd2272b-fc07-11e9-b7d7-6c92bf488712:1-3546,
5dc542a6-4627-11e9-a3e8-e435c881d116:1-28835327,
62cd3f43-53d4-11e9-9461-883fd358a4b0:1-61077414,
645f56c0-6e68-11e9-8951-18ded7a37b4a:1-232612455,
749003b7-909d-11e8-a759-9c37f402a633:1-143387296,
daf04b34-9b3e-11e9-a1fc-6c92bf487ed9:1-3546539260,
e7ae93d4-9b3e-11e9-ba88-6c92bf48c282:1,
ec4524cc-bd00-11e9-a6f6-246e9649a940:1,
f251b4f3-53cb-11ea-aeb1-a4fa76fdf372:1-982537851,
f88526bb-bd00-11e9-89ff-6c92bf482749:1-60
mysqlGTID主从同步出现1236错误问题的更多相关文章
- 解决mysql开启GTID主从同步出现1236错误问题【转】
最近遇到mysql开启gtid做复制时,从库出现1236错误,导致同步无法进行,本文就这问题记录下处理步骤,有关gtid知识在这里不做介绍,mysql版本为5.7.16. 一.错误原因分析 错误信息如 ...
- 解决mysql开启GTID主从同步出现1236错误问题
解决mysql开启GTID主从同步出现1236错误问题 最近遇到mysql开启gtid做复制时,从库出现1236错误,导致同步无法进行,本文就这问题记录下处理步骤,有关gtid知识在这里不做介 ...
- 【转】主从同步出现一下错误:Slave_IO_Running: Connecting
主从同步出现一下错误: Slave_IO_Running: ConnectingSlave_SQL_Running: Yes 解决方法: 导致lave_IO_Running 为connecting 的 ...
- mysql主从同步原理及错误解决
mysql主从同步的原理: 1.在master上开启bin-log日志功能,记录更新.插入.删除的语句. 2.必须开启三个线程,主上开启io线程,从上开启io线程和sql线程. 3.从上io线程去连接 ...
- mysql 5.7 基于GTID 主从同步的1236故障处理(其它事务故障等同)
登录从库 stop slave; 查看执行事务 show slave status\G Retrieved_Gtid_Set: Executed_Gtid_Set: ee3bdb44-f6a1-11 ...
- mysql主从同步失败Last_IO_Error: Got fatal error 1236 from master解决方法
mysql教程主从同步失败Last_IO_Error: Got fatal error 1236 from master解决方法 遇到这样的错误如:“Last_IO_Error: Got fatal ...
- Got fatal error 1236 from master when reading data from binary log: 'Could not find first log file name in binary log index file'系列三:重置主从同步
1:停止slave服务器的主从同步 stop slave; 2:对Master数据库加锁 flush tables with read lock; 3:备份Master上的数据 mysqldump - ...
- Mysql5.7安装错误处理与主从同步及!
basedir=/iddbs/mysql-5.7.16 datadir=/iddbs/mysql5.7/data3306 一.自定义Mysql.5.7版本免编译安装: 1.Db-server1安装前期 ...
- 从库因为sql错误导致主从同步被中断的问题解决
从库因为sql错误导致主从同步被中断的问题解决:show slave status\G;看lasterror:看延迟多少秒,正常情况下是没有延迟的. 跳过错误的那条sql:SET GLOBAL SQL ...
- 主从同步遇到 Got fatal error 1236 from master when reading data from binary log: 'Could not find first log file name in binary log index file'时怎么解决
首先遇到这个是因为binlog位置索引处的问题,不要reset slave: reset slave会将主从同步的文件以及位置恢复到初始状态,一开始没有数据还好,有数据的话,相当于重新开始同步,可能会 ...
随机推荐
- MongoDB 部署分片集群
部署配置服务器:configsvr 先生成.conf文件 mkdir -p /data/mongodb/configsvr vim /data/mongodb/configsvr/configsvr. ...
- Oceanbase开源版 数据库恢复MySQL数据库的过程
# Oceanbase开源版 数据库恢复MySQL数据库的过程 背景 想进行一下Oceanbase数据库的兼容性验证. 想着用app create 数据库的方式周期比较长. 所以我想着换一套 备份恢复 ...
- [转帖]k8s集群部署工具kubeadm详解
https://zhuanlan.zhihu.com/p/670125857 kubeadm是快捷创建Kubernetes集群的最佳实践工具,我们只需用kubeadm init 和 kubeadm j ...
- [转帖]SkyWalking告警使用
SkyWalking告警 SkyWalking提供了强大的监控告警功能,在监控到应用出现问题的时候,会调用webhook或者gRPC hook或者Wechat DingDing等工具报告警告信息 而且 ...
- ESXi规避ESXiArgs勒索软件的简单方法
摘要 今天查看深信服科技的公众号 发现有一个ESXiArgs 的勒索软件. 感觉对公司存在一定的风险.但是感觉操作手册有点简单. 这里想着写全面一点. 作为操作手册使用. 并且深信服仅是解决了在运行, ...
- Promise的异常穿透和中断Promise的链式请求
1.Promise的异常穿透 1==>当你使用Promise的then,进行链式调用的时候,可以在最后指定失败的回调 2==>前面任何操作出现了异常,都会传递到最后失败的回调中进行处理: ...
- element-ui中Select 选择器列表内容居中
<el-select class="my-el-select" v-model="tenantCont" placeholder="请输入机构标 ...
- session未过期就丢失的原因以及处理方式
转 https://blog.csdn.net/flamelp/article/details/5316725?utm_medium=distribute.pc_relevant.none-task- ...
- go中bytes.Buffer使用小结
buffer 前言 例子 了解下bytes.buffer 如何创建bytes.buffer bytes.buffer的数据写入 写入string 写入[]byte 写入byte 写入rune 从文件写 ...
- 强化学习从基础到进阶-常见问题和面试必知必答[6]:演员-评论员算法(advantage actor-critic,A2C),异步A2C、与生成对抗网络的联系等详解
强化学习从基础到进阶-常见问题和面试必知必答[6]:演员-评论员算法(advantage actor-critic,A2C),异步A2C.与生成对抗网络的联系等详解 1.核心词汇 优势演员-评论员(a ...