最近遇到了鼠标双击启动不了数据库的问题,根据事件管理器和自己的最近的使用情况初步判断估计是自己在用360误伤了数据库(哭)

没有办法只好重新安装一下了,参考了网上的一些大神们的教程然后自己实战操作一下,感觉还是蛮快的,(个人感觉,仅供参考)

成功重装好了SQLServer,又可以开心地使用CRUD(Create,Retrieve,Update,Delete)!

下面操作均以2008版为例,其他版本亦可作为参考

注意:普通的卸载是无法做到完全删除干净SQL的,必须要动注册表!

1、找到控制面板,点击程序分类下的“卸载程序”

2.找到Microsoft SQL2008一系列的程序,右击选择卸载

3.点击删除按钮

.

4.然后会进入SQL安装程序支持规则对话窗口,如果出现了要你重启就重启,没有更好,不过一般要重启

如果验证通过就一直点下一步就可以了,直到弹出删除完成窗口,其实就是一个引导你删除的向导程序,不用管其他的只要点下一步就OK了

需要注意的是上面红框中所有带了SQL的都一定要右击删除,如果你还有其他的SQL组件也一定要删除,否则重装时一定会报错!

5.删除磁盘里的安装文件(一般数据库默认安装在C盘)

路径:“C:\Program Files”删除“Microsoft SQL Server”文件夹和“C:\Program Files(x86)”中的“Microsoft SQL Server”

一定要将两个都删掉不要有遗漏,当然为了保险起见你还可以把C盘搜索一遍把关于SQL2008的文件全都一个不漏的删除!

6.最关键也是最重要的一步,删除注册表

可以在开始菜单右键找到运行点击也可以在键盘上同时按住“Windows"+"R”可以快速进入运行,输入“regedit”,进入注册表编辑。

然后就是要找到:“HKEY_LOCAL_MACHINE ” 下的“ SYSTEM ”——“CurrentControlSet”——“Control”——“Session Manage” 中找到PendingFileRenameOperations值右键删除。

具体过程如下:

参照上面的过程分别删除下面注册表中的值

HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer

7.最后重启电脑然后安装你想要的SQL即可

7步快速解决SQLServer数据库(2008版)重装问题的更多相关文章

  1. 三步快速解决dll冲突问题

    最近在推广应用我们的分布式服务网关(Web Api):业务组大部分对外的业务逻辑以HSF服务或者自定义扩展插件的方式,注册并发布到分布式服务网关中,统一对外提供WebApi服务.临时介绍下我们的分布式 ...

  2. 【风哥干货】快速解决Oracle数据库故障必备的20个脚本与命令

    1.操作系统性能(通常故障出现时最先检查的内容)top.topas.vmstat.iostat.free.nmon 2.万能重启方法 如应急情况,需要重启数据库:tail -100f <对应路径 ...

  3. 解决sqlserver数据库显示单个用户

    今天突然发现数据库显示为单个用户并且,访问速度超慢,执行以下语句解决了 USE master; GO DECLARE @SQL VARCHAR(MAX); SET @SQL='' SELECT @SQ ...

  4. 解决sqlserver数据库表空间不自动释放问题

    在项目中遇到了sql server数据库经过频繁地删减数据后,查询变慢的问题. 我把数据导到另一个库中,发现查询就很快. 查了下原因,根本原因是删除数据并不释放表空间,日志文件太过巨大的原因. 网上查 ...

  5. 解决SQLSERVER数据库表被琐死!

    ) )     BEGIN   Exec (@spId)   FETCH NEXT FROM TmpCursor INTO @spId   END     CLOSE TmpCursor DEALLO ...

  6. Sqlserver数据库日志太大如何快速删除

    sqlserver使用在windows系统中,如果文件超上百GB了,我们还直接删除不了,这个问题我以前的apache日志就碰到过,至今还没删除呢,那么Sqlserver数据库日志太大如何快速删除呢,有 ...

  7. 阿里云数据库MySQL版快速上手!

    MySQL是全球最受欢迎的开源数据库,其在各Web应用中均有广泛部署.阿里云数据库MySQL版基于Alibaba的MySQL源码分支,经过双11高并发.大数据量的考验,拥有优良的性能和吞吐量.除此之外 ...

  8. 替换系统数据库解决SQLSERVER服务启动不了的问题

    替换系统数据库解决SQLSERVER服务启动不了的问题 当遇到SQLSERVER服务启动不起来的时候,我们试过把系统的四个数据库master ,model ,tempdb,msdb 替换掉,Windo ...

  9. SqlServer数据库(可疑)解决办法4种

     亲自试过,可行!!!!! SqlServer数据库(可疑)解决办法4种   重启服务--------------------------------------------------日志文件丢了, ...

随机推荐

  1. 电子产品使用感受之——我的Mac只有256GB,我的照片库该怎么办?

    说实话我使用过的Mac中最大的默认存储可能就是2011年开始使用的MacBook Pro了,机器型号大概是MC700,这台机器当年自带320GB 5400转机械硬盘,直到2016年因为使用率太高,机械 ...

  2. ping vs telnet, what is the difference between them and when to use which?

    Ping is an ICMP protocol. Basically any system with TCP/IP could respond to ICMP calls if they were ...

  3. 推送测试,生产环境无法打印log获取deviceToken,可以通过弹窗获取deviceToken

    z- (void)application:(UIApplication *)application didRegisterForRemoteNotificationsWithDeviceToken:( ...

  4. 截取字段split

    172.0.0.1String[] splitAddress=qip.split("\\.");//--172001 String ip=splitAddress[0]+" ...

  5. IDEA中创建maven项目后解决main文件夹下目录不全的问题

    IDEA创建maven-archetype-webapp项目的时候,创建完成后发现在main文件夹下没有java,resource等源文件夹. 解决方法: 1.选择File->Project S ...

  6. Linux 的umask详解

    1.由权限得到umask的值 umask是一个系统变量,是一个由3个八进制数字组成的值,具体含义见表:每个数字都是八进制值1.2.4的OR操作结果. 作用:当文件被创建时,为文件的访问权限设定一个掩码 ...

  7. 添加新网络模型后运行报错:未定义的参数:ps_roipooling param

    现象描述:在新增了具有自定义的data层或者loss层的网路之后,工程运行会报错: 疑惑:并没有这样的参数新增,并且前向的deploy文件已经将自定义的loss以及data等都去掉了: 可能的原因:虽 ...

  8. matlab2014a 转化c语言

    一.原因错误 第一种,命令窗口测试代码mbulid -setup  出错 , 就是电脑没有安装sdk7.1  网上有很多安装教程(注意要有vc++2010要卸载,具体看网上教程,安装好了要更性vc++ ...

  9. Redis集群方案怎么做?

    转载自:https://www.jianshu.com/p/1ecbd1a88924 Redis集群方案 Redis数据量日益增大,而且使用的公司越来越多,不仅用于做缓存,同时趋向于存储这块,这样必促 ...

  10. iOS 上架注意

    一.推送证书 配置推送证书的流程说明:https://docs.aws.amazon.com/zh_cn/pinpoint/latest/developerguide/apns-setup.html ...