Elasticsearch6.x和Kibana6.x的安装
Elasticsearch6.x的安装(centos6.x下)
Elasticsearch6.x目前需要至少jdk8的支持,关于如何安装jdk不在讲述。Oracle的推荐安装文档可以在Oracle的网站上找到,下载解压后只需要配置下环境变量即可
在/etc/profile里面配置
export JAVA_HOME=/usr/local/src/jdk1..0_171
export JRE_HOME=/usr/local/src/jdk1..0_171/jre
export CLASSPATH=.:$JAVA_HOME/lib:$JRE_HOME/lib
export PATH=$JAVA_HOME/bin:$PATH
安装了Java之后,下载并运行 Elasticsearch 。这些二进制文件可以在www.elastic.co/downloads下载,与过去所有的所有版本一起提供。对于每个版本,您可以选择一个zip、tar、DEB或RPM包。
下载:
curl -L -O https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.0.1.tar.gz
然后解压缩如下
tar -zxvf elasticsearch-6.0.1.tar.gz
修改目录权限,Elasticsearch6.x不准许以root用户启动,只能以普通用户启动,这里创建一个普通用户
useradd elasticsearch
chown elasticsearch:elasticsearch elasticsearch-6.0.1 -R
切换到普通用户
su - elasticsearch
然后进入bin目录进行启动
cd elasticsearch-6.0./bin
启动我们的节点和单个集群
./elasticsearch
另外我们可以修改集群或节点名称。这可以在启动 Elasticsearch 时从命令行完成,如下所示:
./elasticsearch -Ecluster.name = my_cluster_name -Enode.name = my_node_name
想要本机监听本机ip的话,需要修改elasticsearch.yml,添加如下
network.host: 192.168.73.133
以上修改完,启动后没有报错的话,可以在浏览器访问了ip:9200,显示如下,表示成功。
{
"name" : "91NMjsU",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "sbyxgvkLTle-La47kVfzPQ",
"version" : {
"number" : "6.0.1",
"build_hash" : "601be4a",
"build_date" : "2017-12-04T09:29:09.525Z",
"build_snapshot" : false,
"lucene_version" : "7.0.1",
"minimum_wire_compatibility_version" : "5.6.0",
"minimum_index_compatibility_version" : "5.0.0"
},
"tagline" : "You Know, for Search"
}
在es安装过程中常见错误以下几种;
1 不能以root用户启动,需要建立普通用户并且给文件夹授权
2启动出现的错误
ERROR: bootstrap checks failed
max file descriptors [] for elasticsearch process likely too low, increase to at least []
max number of threads [] for user [elsearch] likely too low, increase to at least []
max virtual memory areas vm.max_map_count [] likely too low, increase to at least []
[--14T10::,][INFO ][o.e.n.Node ] [mysteel-node1] stopping ...
[--14T10::,][INFO ][o.e.n.Node ] [mysteel-node1] stopped
切换到root用户
vi /etc/security/limits.conf
添加如下内容:
* soft nofile 65536 * hard nofile 131072 * soft nproc 2048 * hard nproc 4096
vi /etc/security/limits.d/90-nproc.conf
修改如下内容: * soft nproc 1024 #修改为 * soft nproc 2048
3另外一种
ERROR: bootstrap checks failed
system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
原因:
这是在因为Centos6不支持SecComp,而ES5.2.0默认bootstrap.system_call_filter为true进行检测,所以导致检测失败,失败后直接导致ES不能启动。
解决:
在elasticsearch.yml中配置bootstrap.system_call_filter为false,注意要在Memory下面:
bootstrap.memory_lock: false
bootstrap.system_call_filter: false
4最后一种
ERROR: bootstrap checks failed
max virtual memory areas vm.max_map_count [] is too low, increase to at least []
解决办法:
修改/etc/sysctl.conf 文件,添加 “vm.max_map_count”设置
vm.max_map_count=262144
并执行:sysctl -p
Elasticsearch6.x和Kibana6.x的安装的更多相关文章
- elasticsearch-6.2.4 + kibana-6.2.4-windows-x86_64安装配置
1.es和kibana的版本都是6.2.4 elasticsearch-6.2.4 + kibana-6.2.4-windows-x86_64 2.先安装es,下载下来解压, config目录下修改 ...
- ELK(Elasticsearch6.0以上版本head插件安装)
参考:https://www.cnblogs.com/Onlywjy/p/Elasticsearch.html Elasticsearch6.0不能使用命令直接安装head插件 修改配置文件/etc/ ...
- Mac环境下 elasticsearch-6.0.1 和 elasticsearch-head 完整安装过程
安装步骤: 安装java jdk 安装elasticsearch-6.0.1 及中文分词 anslysis-ik-6.0.1 安装elasticsearch-head 下载jdk https://w ...
- Elasticsearch6.5.2 X-pack破解及安装教程
先正常安装 elasticSearch, kibana. 1. 如果是6.5.2版本,可以直接下载jar文件:https://download.csdn.net/download/bigben0123 ...
- CentOS7.5 搭建ElasticSearch6.4.2 + Kibana6.4.2 环境
本文目录: 1.创建用户 2.授权sudo 3.下载ElasticSearch.Kibana 3.1 创建目录 3.2 下载文件 4.配置Elasticsearch 5.配置Kibana 参考资料: ...
- ElasticSearch(二):windows下ElasticSearch6.3.2插件Head的安装
前言 上一篇我们记录了如何安装ElasticSearch,这一篇我们来记录下如何安装Head插件 正文 方法总计有三种,但是安装ElasticSearch6.x的时候,只有一种完成了. 第一种:直接使 ...
- Kibana6.3.1安装
Kibana安装 Kibana官方下载地址: https://www.elastic.co/cn/downloads/kibana 也可以直接使用以下命令下载(文章下载目录一概为/home/tools ...
- 在 CentOS7 安装 ELK
ELK是一个成熟的日志系统,主要功能有收集.分析.检索,详细见 elastic官网. 本文主要介绍如何在CentOS7下安装最新版本的ELK,当然现在docker已经有完全配置成功的elk容器,安装配 ...
- elasticSearch安装 Kibana安装 Sense安装
安装最新版本,安装6.*版本 先提示一个重要的事情,kibana新版本不需要安装Sense, 官方的是老版的Kibana才需要,我们现在用devTool http://localhost:5601/a ...
随机推荐
- Android 网络框架 Retrofit2
概述 Retrofit是一个OkHttp网络请求框架的封装库,Retrofit通过注解配置网络参数,可以按照我们的规则去构造实际的HTTP请求,能够灵活设置URL.头部.请求体.返回值等,是目前最优雅 ...
- C# Debug和release判断用法
C# Debug和release判断用法 #if (!DEBUG) Response.Write("DEBUG下运行");#else Response.Write("re ...
- 2017 百度杯丶二月场第一周WP
1.祸起北荒 题目: 亿万年前 天子之子华夜,被父神之神末渊上神告知六荒十海之北荒西二旗即将发生一场"百度杯"的诸神之战 他作为天族的太子必须参与到此次诸神之战定六荒十海 华夜临危 ...
- hmac_检验客户端是否合法
老师博客:http://www.cnblogs.com/Eva-J/articles/8244551.html#_label6 server端 import socket import os impo ...
- 【转】Android 增,删,改,查 通讯录中的联系人
一.权限 操作通讯录必须在AndroidManifest.xml中先添加2个权限, <uses-permission android:name="android.permission. ...
- Linux:Day13(下) GRUB
GRUB(Boot Loader): grub:GRand Unified Bootloader grub 0.x:grub legacy grub 1.x:grub2 grub legacy: st ...
- [LeetCode] 12,13 整数和罗马数互转
12. 整数转罗马数字 题目链接:https://leetcode-cn.com/problems/integer-to-roman/ 题目描述: 罗马数字包含以下七种字符: I, V, X, L,C ...
- MongoDB 用MongoTemplate查询指定时间范围的数据
mongoDB大于小于符号对应: > 大于 $gt< 小于 $lt>= 大于等于 $gte<= 小于等于 $lte 要查询同一个时间多个约束可能出现的error: org.sp ...
- centos7 python环境安装
https://blog.csdn.net/LeonTom/article/details/81289326
- java 面试题整理(不定期更新)
一.Java基础 1.Java面向对象的三个特征与含义 三大特征是:封装.继承和多态. 封装是指将某事物的属性和行为包装到对象中,这个对象只对外公布需要公开的属性和行为,而这个公布也是可以有选择性的公 ...