Zabbix通过C/S模式采集数据,通过B/S模式在web端展示和配置。
被监控端:主机通过安装agent方式采集数据,网络设备通过SNMP方式采集数据
Server端:通过收集SNMP和agent发送的数据,写入MySQL数据库,再通过php+apache在web前端展示。
Zabbix运行条件:
Server:
Zabbix Server需运行在LAMP或LNMP环境下,对硬件要求低
Agent:
目前已有的agent基本支持市面常见的Linux、HPUX、Solaris、Sun、windows等
1.安装系统:CentOS 6.5 部署LAMP架构
2.源码包:官网下载zabbix-2.4.3.tar.gz
1.服务端环境准备
配置好yum源,确认已安装httpd,mysql-server,php
安装所需的依赖环境
# yum install mysql-devel gcc net-snmp-devel curl-devel perl-DBI php-gd php-mysql php-bcmath php-mbstring php-xml -y
增加zabbix用户和组
# groupadd zabbix
# useradd -g zabbix -m zabbix
下载zabbix-2.4.3.tar.gz解压
# tar zxvf zabbix-2.4.3.tar.gz
2.数据库准备
启动mysqld服务并进入mysql,创建zabbix库和用户
mysql> create database zabbix default charset utf8;
Query OK, 1 row affected (0.00 sec)
mysql> grant all on zabbix.* to zabbix@'localhost'
-> identified by '123';
mysql> grant all on zabbix.* to zabbix@'127.0.0.1'
-> identified by '123';
导入zabbix基础数据到数据库,注意按顺序导入
# cd /root/zabbix-2.4.3/database/mysql/
# mysql -u zabbix -p123 zabbix < schema.sql
# mysql -u zabbix -p123 zabbix < images.sql
# mysql -u zabbix -p123 zabbix < data.sql
1.编译安装zabbix
进入zabbix-2.4.3
# ./configure --prefix=/usr/local/zabbix --enable-server --with-mysql --with-net-snmp --with-jabber --with-libcurl --with-openipmi --enable-agent
报错checking for IKSEMEL... No
configure: error: Jabber library not found
需要安装iksemel和iksemel-devel
下载安装iksemel-1.4-2.el6.x86_64.rpm和iksemel-devel-1.4-2.el6.x86_64.rpm
# rpm -ivh iksemel-1.4-2.el6.x86_64.rpm
# rpm -ivh iksemel-devel-1.4-2.el6.x86_64.rpm
报错 error: Failed dependencies:
gnutls-devel is needed by iksemel-devel-1.4-2.el6.x86_64
# yum install gnutls-devel
# rpm -ivh iksemel-devel-1.4-2.el6.x86_64.rpm
2.再次编译安装zabbix
# ./configure --prefix=/usr/local/zabbix --enable-server --with-mysql --with-net-snmp --with-jabber --with-libcurl --with-openipmi --enable-agent
报错checking for OPENIPMI support... no
configure: error: Invalid OPENIPMI directory - unable to find ipmiif.h
需要安装OpenIPMI和OpenIPMI-devel
Yum安装OpenIPMI并下载OpenIPMI-devel-2.0.16-14.el6.x86_64.rpm
# yum install OpenIPMI
# rpm -ivh OpenIPMI-devel-2.0.16-14.el6.x86_64.rpm
报错 error: Failed dependencies:
pkgconfig(ncurses) is needed by OpenIPMI-devel-2.0.16-14.el6.x86_64
# yum install ncurses-devel
# rpm -ivh OpenIPMI-devel-2.0.16-14.el6.x86_64.rpm
3.继续编译安装zabbix
# ./configure --prefix=/usr/local/zabbix --enable-server --with-mysql --with-net-snmp --with-jabber --with-libcurl --with-openipmi --enable-agent
***********************************************************
* Now run 'make install' *
* *
* Thank you for using Zabbix! *
* <http://www.zabbix.com> *
***********************************************************
依赖环境ok
# make && make install
拷贝zabbix web 文件到html目录下并改名
# cp -rf /root/zabbix-2.4.3/frontends/php /var/www/html/
# cd /var/www/html/ && mv php zabbix
# chown zabbix:zabbix /var/www/html/zabbix/
配置php相关参数
# vim /etc/php.ini
max_execution_time = 300
date.timezone = Asia/Shanghai
max_input_time = 600
启动apache
# service httpd start
配置zabbix server端
# vim /usr/local/zabbix/etc/zabbix_server.conf
DBHost=localhost ---数据库本机
DBName=zabbix ---数据库库名
DBUser=zabbix ---数据库账号
DBPassword=123 ---数据库密码
DBSocket=/var/lib/mysql/mysql.sock ---指定sock路径
ListenPort=10051 ---服务端监听端口
ListenIP=0.0.0.0 ---监听IP范围
启动服务
# cp /root/zabbix-2.4.3/misc/init.d/fedora/core/zabbix_server /etc/init.d/
# vim /etc/init.d/zabbix_server
BASEDIR=/usr/local/zabbix
# service zabbix_server start
查看启动端口
# lsof -i:10051
添加开机启动
# chkconfig --add zabbix_server
# chkconfig --level zabbix_server on
配置zabbix agent端
# vim /usr/local/zabbix/etc/zabbix_agentd.conf
Server=127.0.0.1 ---填写server端IP,server链接agent获取数据
ServerActive=127.0.0.1 ---填写server端IP,agent主动提交数据
Hostname=Zabbix server ---给agent设定一个名字,默认为Zabbix server
启动服务
#cp /root/zabbix-2.4.3/misc/init.d/fedora/core/zabbix_agentd /etc/init.d/
# vim /etc/init.d/zabbix_agentd
BASEDIR=/usr/local/zabbix
# service zabbix_agentd start
添加开机启动
# chkconfig --add zabbix_agentd
# chkconfig --level zabbix_agentd on
输入本机IP/zabbix地址进入web界面,点击next>>
http://192.168.1.238/zabbix
确认信息,点击next>>
点击下载配置文件,然后拷贝到提示目录下,点击retry,点击finish
登陆界面输入账号admin,密码zabbix进入
将zabbix-2.4.3.tar.gz拷贝到需要安装agent端的主机解压
# tar zxvf zabbix-2.4.3.tar.gz
编制安装agent端
# ./configure --prefix=/usr/local/zabbix --enable-agent
# make && make install
配置zabbix agent端
# vim /usr/local/zabbix/etc/zabbix_agentd.conf
Server=192.168.1.238 ---server端IP
ListenPort=10050 ---agent端端口
ServerActive=192.168.1.238 ---server端IP
Hostname=test237 ---定义agent端主机名字
启动服务
#cp /root/zabbix-2.4.3/misc/init.d/fedora/core/zabbix_agentd /etc/init.d/
# vim /etc/init.d/zabbix_agentd
BASEDIR=/usr/local/zabbix
# service zabbix_agentd start
查看启动端口添加开机启动
# lsof -i:10050
# chkconfig --add zabbix_agentd
# chkconfig --level zabbix_agentd on
zabbix server添加监控agent,点击configuration---host---create host
host name填写之前agent端配置文件设定的名字test237,groups选择
linux servers,IP地址填写agent端的IP 192.168.1.237,然后点击update
在templates项目选择添加template os linux模块,然后点击update
完成test237主机的监控,后续根据需求添加监控模块或自定义扩展
- zabbix源码安装实例
环境 系统 Centos7 zabbix版本 Zabbix 3.4.15 (revision 86739) zabbix源码安装 .tar.gz cd zab ...
- zabbix源码安装后,设置为服务启动和关闭
zabbix源码安装,使用service启动与关闭服务 1. zabbix客户端的系统服务脚本 1.1 拷贝启动脚本 zabbix的源码提供了系统服务脚本,在/usr/local/src/zabbix ...
- Zabbix源码安装部署
zabbix源码部署安装 参考文档:https://www.zabbix.com/documentation/4.0/manual/installation/install https://www ...
- zabbix源码安装 令人窒息的操作
一.简介 zabbix-server主要分为2部分: zabbix程序 程序根据客户端的监控项,从客户端获取数据并写入到数据库,再根据触发器/动作等配置进行操作. 展示页面 使用php编写,php脚本 ...
- zabbix 源码安装
操作系统:CentOS IP地址:192.168.21.127 Web环境:Nginx+MySQL+PHP zabbix版本:Zabbix 2.2 LTS 备注:Linux下安装zabbix需要有LA ...
- Zabbix源码安装,使用service命令管理zabbix进程
1. 前期环境: Zabbix源代码解压包:/root/zabbix-3.0.27 Zabbix安装路径:/usr/local/zabbix-3.0.27 2. 复制启动脚本到 ...
- 源码安装zabbix
源码安装zabbix 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 欢迎加入:高级运维工程师之路 598432640 前言:参考网上多篇源码安装的连接,自己把安装过程丢在这 ...
- Zabbix源码包安装
Zabbix源码包安装 Cenos5.3 Basic server 安装顺序 Libxml2 Libmcrypt Zlib Libpng Jpeg:需要创建目录jpeg /bin /lib / ...
- [原创] zabbix学习之旅一:源码安装
zabbix是一个基于WEB界面的提供分布式系统监视以及网络监视功能的企业级的开源解决方案.zabbix能监视各种网络参数,保证服务器系统的安全运营:并提供灵活的通知机制以让系统管理员快速定位/解决存 ...
随机推荐
- UVA 10127题目描述
Given any integer 0 ≤ n ≤ 10000 not divisibleby 2 or 5, some multiple of n is a number whichin decim ...
- 7z usecaes
1. Archive without compressing 7z a -t7z -mx=0 OutputFilename InputFilename Descryption: a: command, ...
- K线指标线计算方法
指标线计算方法 l dataDR = Kdata(原始数据)/dr(除权) //除权数据等于原始数据除以DR(除权) 其中,日K数据 需要本地进行除权处理.周K和月K的旧数据部分由服务器进行处理 ...
- Java 多线程Thread和Runnable
Thread: class MyThread extends Thread { private int ticketsCont=5; //一共有5张火车票 private String name; / ...
- python_条件、循环语句
1. python中语句块如何定义: 在Python中,冒号(:)用来标识语句块的开始,块中的每一个语句都是缩进的.当回退到和已经闭合的块一样的缩进量时,就表示当前块已经结束. 默认推荐缩进 ...
- LuaExpat笔记
xml xml是一种格式化数据交换语言, 适用于在网络上不同应用会话. http://www.xml.com/pub/a/98/10/guide0.html exPat 一种C语言实现的 xml 文档 ...
- jdk安装与环境变量配置(一劳永逸)
换了一个项目组做新的项目,新的机器,又得重新打环境,懒得去百度下,这里做个备份,下回直接看就行,如下 进行java开发,首先要安装jdk,安装了jdk后还要进行环境变量配置: 1.下载jdk(http ...
- 【java开发系列】—— JDK安装
前言 作为一个java开发者,安装JDK是不可避免的,但是配置路径却总是记不住,百度也有很多参考例子.这里仅仅当做以后参考的笔记记录. 说到JDK,就不得不提JRE.他们到底是什么呢? 通常我们进行j ...
- Winform 基本属性
WinForm--- 客户端应用程序 - 是需要安装在用户电脑上才可以使用的程序特点:不需要联网也可以打开使用部分功能但是现在的情况是许多功能依然需要互联网的支持 代码部分在用户电脑上执行 WinFo ...
- 转:python webdriver API 之定位一组对象
webdriver 可以很方便的使用 find_element 方法来定位某个特定的对象,不过有时候我们却需要定位一组对象,WebElement 接口同样提供了定位一组元素的方法 find_eleme ...