MySQL5.7安装及遇到的问题
Mysql安装教程:
将在官网下载的安装包解压(如:如D:\mysql-5.7.19-x64)
1.(修复问题Q1时必做,全新安装时不要删除)在mysql的安装路径(如D:\mysql-5.7.19-x64)下找到 data 文件夹,清空该文件夹,没有则新建 data 文件夹。
2.在mysql的安装路径(如D:\mysql-5.7.19-x64)下新建一个my.ini文件,复制以下内容到文件中,保存文件。
[mysql] # 设置mysql客户端默认字符集 default-character-set=utf8 [mysqld] #设置端口号 3306 port = 3306 # 设置mysql的安装目录,注意此处要对应自己的MySQL安装路径 # 设置mysql数据库的数据的存放目录 basedir=D:\mysql-5.7.19-x64 datadir=D:\mysql-5.7.19-x64\data # 允许最大连接数 max_connections=200 # 服务端使用的字符集默认为8比特编码的latin1字符集 character-set-server=utf8 # 创建新表时将使用的默认存储引擎 default-storage-engine=INNODB
3.在D:\mysql-5.7.19-x64\bin文件夹下按shift+鼠标右键,选择“在此处打开命令窗口”

4.在命令窗口中执行命令:mysqld --initialize-insecure --user=mysql(注意:复制时不要复制命令前后的标点符号),然后直接在命令行窗口中鼠标右键选择粘贴,回车即可。
5.此时生成了一个mysql 的账户,用户名为root,密码为空。若要修改密码可以在mysql的图形管理工具里操作。
6.接下来安装mysql服务:在命令行中执行命令:mysqld -install(注意:复制时不要复制命令前后的标点符号)。
7.启动mysql服务:在命令行中执行命令:net start mysql
8.此时在服务中找到mysql服务,能正常运行则代表问题已经解决。
Q1:MySQL无法启动服务,启动服务时提示:“本地计算机 上的 MySQL 服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。”
问题原因:MySQL数据库的.ini配置文件加载错误
解决办法:重新执行一次安装过程即可(注意配置文件my.ini是否正确)
Q2:发生系统错误 1067。进程意外终止。
问题原因:原因不尽相同,我的问题是新安装mysql 时删掉了data文件夹中的内容,导致mysql 找不到系统的初始数据
解决办法:重新将官网zip包中data文件夹里的内容解压到对应的安装目录文件夹即可
附:
删除mysql服务的命令(mysql安装时服务名为mysql):sc delete mysql
【windows事件查看】
我的电脑--此电脑--右键管理--计算机管理--系统工具--事件查看器--Windows日志--应用程序--找错误标志,如下图
根据系统提示的错误信息,使用不同的解决方案

MySQL5.7安装及遇到的问题的更多相关文章
- MySQL5.6安装步骤
MySQL5.6安装步骤(windows7/8_64位) 1. 下载MySQL Community Server 5.6.11 2. 解压MySQL压缩包 将以下载的MySQL压缩包解压到自定义目录下 ...
- linux mysql5.5安装与配置(转帖,在网上收集,自用)
MySQL是一个关系型数据库管理系统 ,由瑞典MySQL AB公司开发,目前属于Oracle 公司.MySQL分为社区版和商业版,由于其体积小.速度快.总体拥有成本低,尤其是开放源码 这一特点,一般中 ...
- mysql5.6安装
mysql5.6安装 #卸载原有的mysqlyum remove mysql*ls /etc/my.cnf*mv /etc/my.cnf* /tmp/ #安装依赖包yum install make c ...
- win8.1(64位) apache2.4.3+php5.6.3+mysql5.6安装
win8.1(64位) apache2.4.3+php5.6.3+mysql5.6安装 http://blog.csdn.net/jiangzeyun/article/details/41676639
- Windows+Atlassian-Jira-6.0.4+MySql5.0安装破解汉化
Windows+Atlassian-Jira-6.0.4+MySql5.0安装破解汉化 一:整理的安装程序 例如以下图: 文件太大.上传不到csdn上.有须要的联系. 新增的百度云盘下载:链接: ...
- MySQL5.7 安装过程中出现 attempting to start service 过不去
MySQL5.7 安装过程中出现 attempting to start service 过不去. 1,机制打开服务,把MySql服务名启动(我的是MySqlAliyun) 启动失败:提示1067错误 ...
- mysql5.7安装和修改密码
mysql5.7安装 第一 下载 https://downloads.mysql.com/archives/community/ 首先下载mysql5.7.18zip安装包 根据电脑配置选择32/64 ...
- Linux(Deepin 15.9) - MySQL5.7 安装
Linux(Deepin 15.9) - MySQL5.7 安装 sudo apt install mysql-server/panda sudo apt install mysql-client/p ...
- MySql5.5安装详细说明
双击MySql5.5安装文件开始: next 打勾,Next 选Custom,原因如下面所述: Typical(典型安装) Installs the most common program fea ...
- 呕心沥血之作,最多坑mysql5.7安装教程
前言: 业务需要,需要数据库接binlog发数据变更消息,但是项目用到的数据库是mysql5.6,不支持,于是就有了接下来的一切一切,新的测试服务器上安装mysql5.7 安装步骤: 1.官网下载my ...
随机推荐
- 解决Win10系统下 C# DateTime 出现星期几的问题 解决ASP.NET MVC 接受Request Playload参数问题
解决Win10系统下 C# DateTime 出现星期几的问题 昨天晚上写代码的时候偶然发现 DateTime 里出现了星期几,当时一阵凌乱,去网上百度没有详细解决办法,很多人说可以用用 ToStri ...
- 重置linux mysql root密码
2.修改MySQL的登录设置: # vi /etc/my.cnf 在[mysqld]的段中加上一句:skip-grant-tables 例如: [mysqld] datadir=/var/lib/my ...
- BootStrap modal() 如何根据返回的HTML宽度自动调整宽度?
首先声明,如果真的这么做了也就失去了 bootstrap 多分辨率适配的好处.bootstrap 的 modal 窗口能够自动在不同分辨率下用不同的宽度,这就是它的特色呢. 以默认大小的 modal ...
- memcache stats命令详解
参数不算多,我们来启动一个Memcache的服务器端: /usr/local/bin/memcached -d-m 10 -u root-l 192.168.0.200-p 12000-c 256- ...
- SiteWhere物联网云平台架构
SystemArchitecture系统架构 Thisdocument describes the components that make up SiteWhere and how theyrela ...
- [PIC32--IDE]Microchip PIC32开发环境的搭建
问题描写叙述 PIC32是Microchip推出的32 bit MCU,其内核是MIPS架构的,MIPS也是属于RISC指令集的,好像ARM的指令集还在RISC指令集中做了一些扩充,而MIPS应当是更 ...
- Javascript网页截屏的方法
最近我在研究开发一个火狐插件,具体的功能是将网页内容截屏并分享到微博上.目前基本功能已经实现,大家可以在 @程序师视野 里看到用这个截图插件分享的微博的效果. 之前我曾写过如何将canvas图形转换成 ...
- html 基本标签 ---特殊格式
<address> </address> 地址 <blockquote> </blockquote> 缩进 <q> </q> 小 ...
- Unix系统编程()close系统调用
close系统调用关闭一个打开的文件描述符,并将其释放回调用进程,供该进程继续使用.当一进程终止时,将自动关闭其已打开的所有文件描述符. int close(int fd); 显式关闭不再需要的文件描 ...
- MapReduce机制
1. MapReduce是一种分布式计算模型,由Google提出,主要用于搜索领域,解决海量数据的计算问题.2. MR由两个阶段组成:Map和Reduce,用户只需要实现map()和reduce()两 ...