1. https://serverfault.com/questions/490656/mysql-not-starting-error-usr-sbin-mysqld-unknown-option-query-cache-si

I have a big problem.

i try to start mysql in ubuntu, butI have this error:

130323  0:13:55 [Note] Plugin 'FEDERATED' is disabled.
130323 0:13:55 InnoDB: The InnoDB memory heap is disabled
130323 0:13:55 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130323 0:13:55 InnoDB: Compressed tables use zlib 1.2.3.4
130323 0:13:55 InnoDB: Initializing buffer pool, size = 8.0G
130323 0:13:55 InnoDB: Completed initialization of buffer pool
130323 0:13:55 InnoDB: highest supported file format is Barracuda.
130323 0:13:55 InnoDB: Waiting for the background threads to start
130323 0:13:56 InnoDB: 1.1.8 started; log sequence number 1195255849922
130323 0:13:56 [ERROR] /usr/sbin/mysqld: unknown option '--query_cache_size-128M'
130323 0:13:56 [ERROR] Aborting 130323 0:13:56 InnoDB: Starting shutdown...
130323 0:13:57 InnoDB: Shutdown completed; log sequence number 1195255849922
130323 0:13:57 [Note] /usr/sbin/mysqld: Shutdown complete

This has no sense, because I dont use that in the my.cnf:

    #
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html # This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock # Here is entries for some specific programs
# The following values assume you have at least 32M ram # This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0 [mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
#datadir = /var/lib/mysql
datadir = /home/mysql
tmpdir = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking #innodb_force_recovery = 3
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 500M
max_allowed_packet = 128M
thread_stack = 192K
thread_cache_size = 8 default-storage-engine = INNODB # This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover = BACKUP
max_connections = 75
sort_buffer_size = 4M
join_buffer_size = 4M
table_cache = 128K
#thread_concurrency = 10
#
# * Query Cache Configuration
#
query_cache_limit = 1M
query_cache_size = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
general_log_file = /var/log/mysql/mysql.log
log-error=/var/log/mysql.err
#general_log = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
# other settings you may need to change.
#server-id = 1
#log_bin = /var/log/mysql/mysql-bin.log
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem innodb_additional_mem_pool_size = 50M
innodb_thread_concurrency = 8
innodb_flush_method = O_DSYNC
innodb_flush_log_at_trx_commit = 2
innodb_buffer_pool_size = 8G
innodb_log_files_in_group = 2
innodb_log_file_size = 32M
innodb_log_buffer_size = 16M
innodb_file_per_table = 1
innodb_table_locks = 0 [mysqldump]
quick
quote-names
max_allowed_packet = 16M [mysql]
#no-auto-rehash # faster start of mysql but no tab completition [isamchk]
key_buffer = 16M #
# * IMPORTANT: Additional settings that can override those from this file!
# The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/

Any ideas? :(

asked Mar 22 '13 at 23:17
poormysql

21112
  • 1
    Fix the typo. Then it should work. – Michael Hampton♦ Mar 22 '13 at 23:22
  •  
    the typo is the minus sign where equals should be: query_cache_size-128M -> query_cache_size=128M – user16081-JoeT Mar 23 '13 at 0:13 

###########2.

问题描述】

使用

service mysqld start

启动MySQL服务失败,提示

Starting MySQL. ERROR! The server quit without updating PID file

【解决方案】

在my.cnf配置文件中的 [mysqld_safe] 下添加

log-error = /apps/logs/mysql/error.log      # 表示mysql服务启动日志文件的位置,路径可以根据自己的系统更改

之后再次启动mysql服务,查看error.log文件,注意error标签的提示内容,修改相应的错误

####3:

常用命令:

创建完成并启动服务器,此时密码为空

/bin/mysql -u root -p 即可进入

show databases

2. 授权法。

例如,你想myuser使用mypassword从任何主机连接到mysql服务器的话。

Sql代码

1. GRANT ALL PRIVILEGES ON *.* TO 'myuser'@'%' IDENTIFIED BY 'mypassword' WITH

GRANT OPTION;

2.FLUSH PRIVILEGES;

如果你想允许用户myuser从ip为192.168.1.6的主机连接到mysql服务器,并使用mypassword作为密码

mysql 无法启动 unkown command的更多相关文章

  1. linux 下mysql的启动 、调试、排错

    Linux 下 MySQL 启动与关闭 说明 一.启动 1.1  MySQL 进程 可以用ps 命令查看进程: [root@rac2 ~]# ps -ef|grep mysql root     21 ...

  2. 关于在安装MySQL时报错"本地计算机上的mysql服务启动后停止,某些服务在未由其他服务或程序使用时将自动停止"的解决方法

    首先将你下载的MySQL安装或者解压(对应安装版和解压版),下载地址http://dev.mysql.com/downloads/mysql/ 然后复制你安装目录中的my-default.ini,更改 ...

  3. CentOS 7下MySQL服务启动失败的解决思路

    今天,启动MySQL服务器失败,如下所示: [root@spark01 ~]# /etc/init.d/mysqld start Starting mysqld (via systemctl): Jo ...

  4. Mysql服务启动的时候 如何加载配置文件

    Mysql服务启动的时候 如何引导配置文件 (启动加载顺序)

  5. MySQL 安装和启动服务,“本地计算机 上的 MySQL 服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。”

    MySQL 安装和启动服务,以及遇到的问题 MySQL版本: mysql-5.7.13-winx64.zip (免安装,解压放到程序文件夹即可,比如 C:\Program Files\mysql-5. ...

  6. 一台MySQL服务器启动多个端口

    一台MySQL服务器启动多个端口 在测试Mysql多主一从服务器,即一个从服务器多端口同步不同主库.本文记录了开启不同端口的操作. 详细步骤: 1.首先要先把my.cnf配置文件复制一份,开几个端口要 ...

  7. MySQL 安装 启动 基本语法概述

    MySQL 安装 启动 基本语法概述 MySQL安装和配置 我是直接使用安装包:mysql-installer-community-5.6.10.1.msi 安装的时候其中有几点要注意: 1.记住端口 ...

  8. MySQL的启动脚本

    MySQL的启动脚本#!/bin/bashmysql_port=3308mysql_username="admin"mysql_password="password&qu ...

  9. mysql无法启动

    当在安装mysql服务时,有时会遇到恶心的PID错误而导致安装后无法启动以下为针对mysql-5.5版本在安装mysql时所遇到的问题的解决方法. 1.可能是/usr/local/mysql/data ...

随机推荐

  1. ES忽略TF-IDF评分——使用constant_score

    Ignoring TF/IDF Sometimes we just don’t care about TF/IDF. All we want to know is that a certain wor ...

  2. java中路径的获取

    网上摘录 (1).request.getRealPath("/");//不推荐使用获取工程的根路径 (2).request.getRealPath(request.getReque ...

  3. leetcode 191 Number of 1 Bits(位运算)

    Write a function that takes an unsigned integer and returns the number of ’1' bits it has (also know ...

  4. STL中mem_fun和mem_fun_ref的用法

    例如:假设有如下的代码: class Employee { public: int DoSomething(){} } std::vector<Employee> Emps; 假设我们要调 ...

  5. k8s-创建node节点kubeconfig配置文件

    Kubeconfig 需要配置如下 TLS Bootstrapping Token kubelet kubeconfig kube-proxy kubeconfig 下载kubectl kubectl ...

  6. shell 统计词频脚本

    #!/bin/bash if [ $# -ne 1 ]; then echo "Usage:$0 filename"; exit -1 fi filename=$1 egrep - ...

  7. SQLServer中连接个数及超时问题

    超时时间已到.超时时间已到,但是尚未从池中获取连接.出现这种情况可能是因为所有池连接均在使用,并且达到了最大池大小. 解决办法1.在代码里面,把未关闭的连接关闭2.扩大共享池,方法如下:解决方法可以是 ...

  8. 条款32:确定你的public继承塑模出is-a的关系

    Make sure public inheritance models "is –a " 如果令clsss D 以public的形式继承class B,你便是告诉编译器说,每一个类 ...

  9. HDU - 5950 Recursive sequence(二项式+矩阵合并+矩阵快速幂)

    Recursive sequence Farmer John likes to play mathematics games with his N cows. Recently, they are a ...

  10. HDU - 1535 Invitation Cards 前向星SPFA

    Invitation Cards In the age of television, not many people attend theater performances. Antique Come ...