php-fpm的pool、php-fpm慢执行日志、open_basedir、php-fpm进程管理
6月13日任务
12.21 php-fpm的pool
12.22 php-fpm慢执行日志
12.23 open_basedir
12.24 php-fpm进程管理
12.21 php-fpm的pool
php-fpm可以支持定义多个pool,分别监听不同的sock或IP和端口,比如Nginx有好几个站点,每一个站点都可以去使用一个pool,这样的好处是当其中一个php页面502了,这很有可能是资源不够了,如果所有的网站都使用了一个pool,其中一个网站发了一些故障,例如程序员写的程序有问题,就会把php资源耗尽,那么其他的站点也会502,所以有必要把每一个站点隔离开,每一个站点使用单独的pool。
添加多个pool的方法:
1、进入指定目录,编辑php-fpm.conf文件。
[root@jimmylinux- ~]# cd /usr/local/php-fpm/etc/ 进入指定目录 [root@jimmylinux- etc]# ls
pear.conf php-fpm.conf php-fpm.conf.default php.ini [root@jimmylinux- etc]# vim php-fpm.conf 编辑配置文件 添加以下内容 [jimmy]
listen = /tmp/jimmy.sock
#listen = 127.0.0.1:
listen.mode =
user = php-fpm
group = php-fpm
pm = dynamic
pm.max_children =
pm.start_servers =
pm.min_spare_servers =
pm.max_spare_servers =
pm.max_requests =
rlimit_files =
2、-t检查语法是否正确,然后重启php-fpm或者重新加载。
[root@jimmylinux- etc]# /usr/local/nginx/sbin/nginx -t 检查语法是否正确
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful [root@jimmylinux- etc]# /etc/init.d/php-fpm reload 重新加载php-fpm
Reload service php-fpm done [root@jimmylinux- etc]# ps aux |grep php-fpm 查看pool信息

3、如何去使用自定义的pool
[root@jimmylinux- etc]# cd /usr/local/nginx/conf/vhost/ [root@jimmylinux- vhost]# ls
aaa.com.conf ld.conf proxy.conf ssl.conf test.com.conf [root@jimmylinux- vhost]# vim test.com.conf 可以把test.com.conf定义成php-fcgi.sock [root@jimmylinux- vhost]# vim aaa.com.conf 再把aaa.com.conf定义成jimmy.sock

假如现在test.com.conf请求量很大,最终把php-fpm(www的pool进程耗尽了)最多可以启动50个,当50个启动完后所有的都在忙,又有新的请求来的时候就会把502,因为没有多的php-fpm进程提供服务了,而另外的站点不受影响,因为使用的是另外的pool,这就是为什么要定义多个pool的原因。

在Nginx.conf里面加了一条include,那php-fpm也是同样支持加include的。

[root@jimmylinux- vhost]# cd /usr/local/php-fpm/etc/ [root@jimmylinux- etc]# ls
pear.conf php-fpm.conf php-fpm.conf.default php.ini [root@jimmylinux- etc]# vim php-fpm.conf 在php-fpm.conf 主配置文件中也同样支持添加include
在global里面加入include,其他的内容都删除掉。

创建目录,然后新建配置文件。
[root@jimmylinux- etc]# mkdir php-fpm.d 创建目录 [root@jimmylinux- etc]# cd php-fpm.d [root@jimmylinux- php-fpm.d]# vim www.conf 新建配置文件 添加以下内容 [www]
listen = /tmp/php-fcgi.sock
#listen = 127.0.0.1:
listen.mode =
user = php-fpm
group = php-fpm
pm = dynamic
pm.max_children =
pm.start_servers =
pm.min_spare_servers =
pm.max_spare_servers =
pm.max_requests =
rlimit_files = 1024
[root@jimmylinux-001 php-fpm.d]# vim jimmy.conf 重新创建另一个配置文件 添加以下内容 [jimmy]
listen = /tmp/jimmy.sock
#listen = 127.0.0.1:9000
listen.mode = 666
user = php-fpm
group = php-fpm
pm = dynamic
pm.max_children = 50
pm.start_servers = 20
pm.min_spare_servers = 5
pm.max_spare_servers = 35
pm.max_requests = 500
rlimit_files = 1024

-t检查语法是否正确,然后重启php-fpm。
[root@jimmylinux- php-fpm.d]# /usr/local/nginx/sbin/nginx -t
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful [root@jimmylinux- php-fpm.d]# /etc/init.d/php-fpm restart
Gracefully shutting down php-fpm . done
Starting php-fpm done

12.22 php-fpm慢执行日志
做PHP网站,建议使用LNMP,其中有一个原因就是可以去分析php-fpm慢执行日志,比如网站访问慢,具体什么原因到底慢在什么地方,所以慢执行日志是非常有用的。
1、进入指定目录,编辑www.conf配置文件。
[root@jimmylinux- ~]# cd /usr/local/php-fpm/etc/php-fpm.d/ [root@jimmylinux- php-fpm.d]# vim www.conf 在配置文件最后加入以下2行内容 request_slowlog_timeout = 表示时间只要超过1秒的都记录
slowlog = /usr/local/php-fpm/var/log/www-slow.log 记录日志存放路径

2、重新加载php-fpm,然后查看日志文件路径。

3、模拟一个慢执行的php

如果遇到500报错,可以把php.ini配置文件中display_errors报告设置成on显示错误信息。

[root@jimmylinux- php-fpm.d]# vi /usr/local/php-fpm/etc/php.ini


把sleep.php配置文件中的标点符号全部改成半角的英文状态符合就可以了
[root@jimmylinux- php-fpm.d]# vim /data/wwwroot/test.com/sleep.php <?php
echo "test slow log";
sleep();
echo "done";
?>
4、重新执行curl就会看见执行过程中会有停顿

12.23 open_basedir
在php-fpm里面也可以定义open_basedir,之前讲过在php.ini定义open_basedir,如果服务器上有多个网站,在php.ini里面定义就不合适了,要么在Apache虚拟主机配置文件里面定义,要么就在php-fpm配置文件里面定义,我们可以针对每一个pool去定义不同的open_basedir。
1、编辑www.conf配置文件
[root@jimmylinux- php-fpm.d]# vim www.conf 在最后一行加入以下内容 php_admin_value[open_basedir]=/data/wwwroot/jimmy.com:/tmp/
2、重启php-fpm,然后curl访问,如果出现如下报错,可以分析并解决。

[root@jimmylinux- php-fpm.d]# ls /data/wwwroot/test.com/
.gif .js .php admin index.html sleep.php upload [root@jimmylinux- php-fpm.d]# curl -x127.0.0.: test.com/.php
No input file specified. 主要是因为open_basedir做了限制,所以会报错。
[root@jimmylinux- php-fpm.d]# vim www.conf 重新编辑配置文件 修改最后一行为正确的路径test.com php_admin_value[open_basedir]=/data/wwwroot/test.com:/tmp/
3、再次重启php-fpm,然后访问就正常了。
[root@jimmylinux- php-fpm.d]# /etc/init.d/php-fpm restart

如上操作,如果open_basedir定义不对,就会出问题。
生成环境中的服务器,php.ini的display_errors一定要设置成Off,不能够把错误信息显示到网站上来,而是把错误信息记录到日志存放到服务器指定的路径。


还要定义错误级别

在重启php-fpm之前,我们再故意改成一个错的路径。
[root@jimmylinux- php-fpm.d]# vim www.conf php_admin_value[open_basedir]=/data/wwwroot/11test.com:/tmp/ 故意把路径写错

[root@jimmylinux- php-fpm.d]# touch /usr/local/php-fpm/var/log/php_errors.log 创建一个错误日志文件 [root@jimmylinux- php-fpm.d]# chmod /usr/local/php-fpm/var/log/php_errors.log 设置成777权限
重启php-fpm,再访问看看结果。

查看日志

[root@jimmylinux- php-fpm.d]# vim www.conf php_admin_value[open_basedir]=/data/wwwroot/test.com:/tmp/ 修改成正确路径
这个时候重启php-fpm,再访问就正常了。

12.24 php-fpm进程管理


php-fpm的pool、php-fpm慢执行日志、open_basedir、php-fpm进程管理的更多相关文章
- Linux centosVMware php-fpm的pool、php-fpm慢执行日志、open_basedir
一.php-fpm的pool vim /usr/local/php/etc/php-fpm.conf//在[global]部分增加 include = etc/php-fpm.d/*.conf mkd ...
- php-fpm的pool php-fpm慢执行日志 open_basedir php-fpm进程管理
php-fpm的pool • vim /usr/local/php/etc/php-fpm.conf//在[global]部分增加 • include = etc/php-fpm.d/*.conf • ...
- Linux centosVMware LAMP php-fpm的pool、php-fpm慢执行日志、open_basedir、php-fpm进程管理
一.php-fpm的pool vim /usr/local/php/etc/php-fpm.conf//在[global]部分增加 include = etc/php-fpm.d/*.conf mkd ...
- php-fpm的pool池子、php慢日志记录、open_basedir、php-fpm进程管理
1.php-fpm的poo池子:目的:可以让不同的网站,对于不同的php解析,可以把不同的网站解析区分开.编辑:vim /usr/local/php5-fpm/etc/php-fpm.conf加入: ...
- FastCGI 进程管理器(FPM)
FPM(FastCGI 进程管理器)用于替换 PHP FastCGI 的大部分附加功能,对于高负载网站是非常有用的. 它的功能包括: 支持平滑停止/启动的高级进程管理功能: 可以工作于不同的 uid/ ...
- php-fpm 记录慢执行日志
有时候我们访问一个 php 的网站很慢,要想知道慢的原因,需要配置 php-fpm.conf,记录执行慢的日志: [root@localhost ~]$ cat /usr/local/php/etc/ ...
- 【PHP】善用php-fpm的慢执行日志slow log,分析php性能问题
(转)善用php-fpm的慢执行日志slow log,分析php性能问题 众所周知,mysql有slow query log,根据慢查询日志,我们可以知道那些sql语句有性能问题.作为mysql的好 ...
- .Net写txt文件-简单的记录执行日志信息代码
在执行一些批量操作时,想记录一些执行日志信息,越简单方便越好啊.提供一个常用的简单方法,将信息记录在txt文件里: public static void log(string content, str ...
- composer 安装依赖缓慢,查看 composer 的详细执行日志
在 windows WSL 上安装 composer 依赖 composer install 发现执行异常缓慢,怀疑没有走国内的镜像,而是直接访问的 github. 需要能看到 composer 的执 ...
随机推荐
- (转载)学校搭建使用nginx同时编译rtmp-module进行直播的技术文档
原文地址:学校搭建使用 nginx 同时编译 rtmp-module 进行直播的技术文档 转载自我的大佬同学 MetalkgLZH.学校有几次需要全校观看网络直播的情况,但是学校的带宽不允许所有的班一 ...
- USDT跑分系统开发
USDT跑分系统开发找[林生:178-7666-2415微/电],USDT跑分系统开发,USDT跑分系统解决方案,USDT跑分系统定制,小程序开发.APP.公众号等软件开发. 数字资产结算通道的特点: ...
- CSPS模拟99
555我原型笔录 T1 不会线段树维护单调栈被dalao们踩爆 T2 我要实现这样一个东西: 已知a,b,c,使a=a-b,b=b-c 结果我把代码弄成这样: b=b-c;a=a-b; 然后就被dal ...
- 7.30 NOIP模拟10
T1.辣鸡 考试的时候竟然被我以“麻烦”弃掉了,赛后发现这题好水啊,直接sort一下寻找四周即可. T2.模板 考试时期望得分70,实际得分5 首先看到这种题基本就是线段树,我们以时间为下标,对每一个 ...
- NOI导刊集训感言
圆溜溜,尤其首先,集训的收获很大,远远比自学要来的快 其次,新知识点到时没怎么讲(A*,数论除外,倒是真的学会不少以前碰都不敢碰的定理呀,结论之类的东西),但是还是深深地感受到了集训的困难,七天的节奏 ...
- Anaconda的安装和详细介绍(带图文)
Anacond的介绍 Anaconda指的是一个开源的Python发行版本,其包含了conda.Python等180多个科学包及其依赖项. 因为包含了大量的科学包,Anaconda 的下载文件比较大( ...
- Python3安装目录介绍
目录组织方式 关于如何组织一个较好的Python工程目录结构,已经有一些得到了共识的目录结构. 假设你的项目名为foo, 我比较建议的最方便快捷目录结构这样就足够了: Foo/ |-- bin/ | ...
- Spring Boot 配置 - Consul 配置中心
▶ Spring Boot 依赖与配置 Maven 依赖 <dependencyManagement> <dependencies> <dependency> &l ...
- 009-2010网络最热的 嵌入式学习|ARM|Linux|wince|ucos|经典资料与实例分析
前段时间做了一个关于ARM9 2440资料的汇总帖,很高兴看到21ic和CSDN等论坛朋友们的支持和鼓励.当年学单片机的时候datasheet和学习资料基本都是在论坛上找到的,也遇到很多好心的高手朋友 ...
- JVM 中你不得不知的一些参数
有的同学虽然写了一段时间 Java 了,但是对于 JVM 却不太关注.有的同学说,参数都是团队规定好的,部署的时候也不用我动手,关注它有什么用,而且,JVM 这东西,听上去就感觉很神秘很高深的样子,还 ...