问题

一直在研究ES的监控怎么做,想偷点懒,不去通过API获取然后计算,就想找个现成的插件或者监控软件,只要装个agent就可以,然后就找到了x-pack,插件装好了之后,需要重启ES集群,线上的ES集群我想着既然是集群一台一台重启应该不会有问题的,太高估了,重启一台后,整个集群挂了......
 

操作过程

1、系统
[centos@ip---- bin]$ cat /etc/redhat-release
CentOS Linux release 7.6. (Core)
2、ES版本
[centos@ip---- bin]$ ./elasticsearch --version
Version: 5.0., Build: f6b4951/--24T10::.101Z, JVM: 1.8.0_131

3、杀进程

ps -ef | grep pid
kill - pid

这样操作完就后悔了,不是每个服务都是这么杀的,不知道这步操作对集群挂了有没有一定的影响。

4、报错信息

[--17T08::,][INFO ][o.e.p.PluginsService     ] [node-] loaded module [lang-painless]
[--17T08::,][INFO ][o.e.p.PluginsService ] [node-] loaded module [percolator]
[--17T08::,][INFO ][o.e.p.PluginsService ] [node-] loaded module [reindex]
[--17T08::,][INFO ][o.e.p.PluginsService ] [node-] loaded module [transport-netty3]
[--17T08::,][INFO ][o.e.p.PluginsService ] [node-] loaded module [transport-netty4]
[--17T08::,][INFO ][o.e.p.PluginsService ] [node-] no plugins loaded
[--17T08::,][INFO ][o.e.n.Node ] [node-] initialized
[--17T08::,][INFO ][o.e.n.Node ] [node-] starting ...
[--17T08::,][INFO ][o.e.t.TransportService ] [node-] publish_address {172.0.0.16:}, bound_addresses {172.30.36.146:}
[--17T08::,][INFO ][o.e.b.BootstrapCheck ] [node-] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks [--17T08::,][WARN ][o.e.n.Node ] [node-] timed out while waiting for initial discovery state - timeout: 30s
[--17T08::,][INFO ][o.e.h.HttpServer ] [node-] publish_address {172.0.0.16:}, bound_addresses {172.30.36.146:}
[--17T08::,][INFO ][o.e.n.Node ] [node-] started
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.i.c.TransportCreateIndexAction] [node-] no known master node, scheduling a retry
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] timed out while retrying [cluster:monitor/state] after failure (timeout [30s])
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] timed out while retrying [cluster:monitor/state] after failure (timeout [30s])
[--17T08::,][WARN ][r.suppressed ] path: /_cluster/state/metadata, params: {metric=metadata}
org.elasticsearch.discovery.MasterNotDiscoveredException
at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$.onTimeout(TransportMasterNodeAction.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ContextPreservingListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.service.ClusterService$NotifyTimeout.run(ClusterService.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:) [elasticsearch-5.0..jar:5.0.]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.lang.Thread.run(Thread.java:) [?:1.8.0_151]
[--17T08::,][WARN ][r.suppressed ] path: /_cluster/state/metadata, params: {metric=metadata}
org.elasticsearch.discovery.MasterNotDiscoveredException
at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$.onTimeout(TransportMasterNodeAction.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ContextPreservingListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.service.ClusterService$NotifyTimeout.run(ClusterService.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:) [elasticsearch-5.0..jar:5.0.]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.lang.Thread.run(Thread.java:) [?:1.8.0_151]
[--17T08::,][DEBUG][o.e.a.a.c.s.TransportClusterStateAction] [node-] timed out while retrying [cluster:monitor/state] after failure (timeout [30s])
[--17T08::,][WARN ][r.suppressed ] path: /_cluster/state/metadata, params: {metric=metadata}
org.elasticsearch.discovery.MasterNotDiscoveredException
at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$.onTimeout(TransportMasterNodeAction.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ContextPreservingListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.cluster.service.ClusterService$NotifyTimeout.run(ClusterService.java:) [elasticsearch-5.0..jar:5.0.]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:) [elasticsearch-5.0..jar:5.0.]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:) [?:1.8.0_151]
at java.lang.Thread.run(Thread.java:) [?:1.8.0_151]
 
 
5、配置文件
cluster.name: lile
node.name: node-
bootstrap.memory_lock: true
network.host: 172.0.0.16
http.port:
discovery.zen.ping.unicast.hosts: ["172.0.0.16","172.0.0.17","172.0.0.18"]
discovery.zen.minimum_master_nodes:
http.cors.enabled: true
http.cors.allow-origin: "*"
path.data: /data/elasticsearch/data
path.logs: /data/elasticsearch/logs

三、解决办法

各种重启都没有,在网上查到的,都是重启就好了,但是使劲的重启也没好。但是当discovery.zen.minimum_master_nodes这个值设置为1的时候,可以启动成功,但是三台都成了master了。后来看到有个这个参数,加上然后全部重启就好了。
 
 
discovery.zen.ping_timeout: 60s

四、分析原因

还没细究,感觉是集群互相查找的时间太短了,没有找到对方,因为得2台才能形成集群
 

ES三节点重启后报错no known master node的更多相关文章

  1. oracle centos 重启后报错ORA-12514, TNS:listener does not currently know of service requested in connect descriptor

    oracle centos 重启后报错ORA-12514, TNS:listener does not currently know of service requested in connect d ...

  2. idea添加插件后重启后报错:cannot load project xxxx 解决方案

    问题原因:新安装的idea下载插件后重启报错 找到windows上c:\Users\.IntelliJIdea<版本>\config\plugins\这个目录,然后 将对应插件删除

  3. 运行.xcworkspace项目后报错:'React/RCTBundleURLProvider.h’ file not found

    情况:根据https://github.com/rebeccahughes/react-native-device-info添加依赖库,运行.xcworkspacea项目后报错 解决:Delete n ...

  4. 三节点搭建openstack-Mitaka版本

    前言: 现在的云计算平台已经非常火,也非常的稳定了.像阿里云平台,百度云平台等等,今天咱们基于openstack来搭建一个云平台 注意: 本次平台搭建为三节点搭建(没有外部存储节点,所有存储为本地存储 ...

  5. 部署elasticsearch(三节点)集群+filebeat+kibana

    用途 ▷ 通过各个beat实时收集日志.传输至elasticsearch集群 ▷ 通过kibana展示日志 实验架构 名称:IP地址:CPU:内存 kibana&cerebro:192.168 ...

  6. legend3---用Homestead配置后报错“No input file specified.”

    legend3---用Homestead配置后报错“No input file specified.” 一.总结 一句话总结: 自己项目上传到github的时候多增加了一层legend3的github ...

  7. OceanBase三节点部署&&扩容

    OceanBase三节点部署&&扩容 环境信息搭建三节点(1-1-1)创建资源池和租户查看数据分布 环境信息 IP OB目录 端口 192.168.43.89 /data/observ ...

  8. elasticsearch之节点重启

    Elasticsearch节点重启时背后发生的故事有哪些,应该注意哪些配置内容,本篇文章做一个简单的探讨. 节点离开 在elasticsearch集群中,假设NodeA因为种种原因退出集群,在Node ...

  9. 理解 OpenStack Swift (1):OpenStack + 三节点Swift 集群+ HAProxy + UCARP 安装和配置

    本系列文章着重学习和研究OpenStack Swift,包括环境搭建.原理.架构.监控和性能等. (1)OpenStack + 三节点Swift 集群+ HAProxy + UCARP 安装和配置 ( ...

随机推荐

  1. 前端自动化部署linux centOs + Jenkins + nignx + 单页面应用

    Jenkins是什么? Jenkins 是一款业界流行的开源持续集成工具,广泛用于项目开发,具有自动化构建.测试和部署等功能. 准备工作 Linux centOS系统阿里云服务器一个 码云一个存放vu ...

  2. 关于设置tomcat端口为80的事

    今天有人要求tomcat服务器的访问地址不能带端口访问, 也就是说只能用80端口访问网站. 那么问题来了, Ubuntu系统禁止root用户以外的用户访问1024以下的商品, 因此tomcat 默认为 ...

  3. logback配置方法

    logback是一个通用可靠.快速灵活的日志框架,它替代了log4j,和slf4j组成新的日志系统. slf4j是一个日志门面,为其他各种日志框架提供了统一的接口,代码中使用slf4j可以避免对某一种 ...

  4. Apache Hadoop集群安装(NameNode HA + SPARK + 机架感知)

    1.主机规划 序号 主机名 IP地址 角色 1 nn-1 192.168.9.21 NameNode.mr-jobhistory.zookeeper.JournalNode 2 nn-2 ).HA的集 ...

  5. 快速开始使用spark

    1.版本说明 在spark2.0版本以前,spakr编程接口是RDD(Resilient Distributed Dataset,弹性分布式数据集),spark2.0版本即以上,RDD被Dataset ...

  6. C++基础之关联容器

    关联容器 关联容器和顺序容器的本质区别:关联容器是通过键存取和读取元素.顺序容器通过元素在容器中的位置顺序存储和访问元素.因此,关联容器不提供front.push_front.pop_front.ba ...

  7. windows导出文件名列表

    新建txt文件,粘贴以下命令: DIR *.*  /B >LIST.TXT 将txt文件的后缀改为.bat 执行bat文件即可

  8. 在wxml中直接写js代码(wxs)

    我们在h5开发中,很多时候要在html中写到js代码,这个很容易实现.但是在微信小程序开发中,是不能直接在wxml中写js代码的,因此就有了wxs.在wxml中用wxs代码,有以下几种方式(在小程序文 ...

  9. JQuery学习笔记之手网琴效果

    这种东西在网上多的是,最近在学JQuery,所以就写了个随笔 <!DOCTYPE html> <html lang="en"> <head> & ...

  10. Maven 梳理-自动创建Maven项目(非web)

    mvn archetype:create和mvn archetype:generate create is deprecated in maven 3.0.5 and beyond,在maven3.0 ...