Centos6.5升级安装openssh7.7p1

 关于OpenSSH漏洞
 

2016年1月14日OpenSSH发布官方公告称, OpenSSH Client 5.4~7.1 版本中未公开说明的功能(Roaming)存在信息泄漏和缓冲区溢出漏洞,此漏洞可能导致您通过ssh等命令连接不可信服务器或被伪造服务器时,私钥等敏感信息会被恶意检索和利用,详情可参考:

 

排查方法

 

在被检查的Linux系统机器上执行:

  1. # ssh -v user@[server] 2>&1 | grep -i 'Roaming'

[server]为任一ssh开放的服务器。如输出信息显示,则本机的ssh client受影响:

  1. debug1: Roaming not allowed by server
 

升级过程的参考

 
 

准备工作

 

因centos7自带的ssh版本较低,存在高危漏洞,故升级到最新版本(目前是7.7pl)。

注:升级ssh存在一定的危险性,一旦不成功可能无法通过远程连接到系统,因此在升级之前最好先安装vnc或者telnet等远程服务

查看下当前SSH版本:

  1. # ssh -V
  2. # rpm -qa | grep openssh
 
 

备份ssh配置

  1. # mv /etc/ssh/ /lee/bak/ssh.bak
 

编译安装openssh

 

1、 解压安装包:

  1. # tar -zxf openssh-7.7p1.tar.gz

2、编译

需要gcc编译器的

  1. # ./configure --prefix=/usr --sysconfdir=/etc/ssh

如果报错:

  1. configure: error: *** zlib.h missing - please install first or check config.log ***

需要安装zlib-devel

  1. # yum install -y zlib-devel

如果报错:

  1. configure: error: *** OpenSSL headers missing - please install first or check config.log ***

需要安装openssl-devel

  1. # yum -y install openssl-devel

解决完报错后重新执行

  1. # ./configure --prefix=/usr --sysconfdir=/etc/ssh
  2. # make

需要测试:make完成后先不要make install,先卸载旧版的openssh

# rpm -e --nodeps `rpm -qa | grep openssh`

完成后执行make install:

  1. # make install

查看下安装结果:

  1. # ssh -V

至此编译安装完成。

配置sshd服务

复制启动文件到/etc/init.d/下并命名为sshd,加入开机启动

  1. # cp contrib/redhat/sshd.init /etc/init.d/sshd
  2. # chkconfig --add sshd

允许root使用ssh:

openssh7.5默认root用户是不能用ssh远程登录的,需要修改配置文件:

  1. # vim /etc/ssh/sshd_config

找到#PermitRootLogin prohibit-password项,去掉注释并把prohibit-password改为yes

  1. PermitRootLogin yes

重启ssh服务:

  1. # service sshd restart

至此升级/安装完成。

Centos6.5升级安装openssh7.7p1的更多相关文章

  1. centos6 升级安装openssh7

    1.准备工作: 查看下当前SSH版本: [root@bogon ~]# ssh -V OpenSSH_5.3p1, OpenSSL 1.0.1e-fips 11 Feb 2013 或者 [root@b ...

  2. centos6.5升级安装openssl1.0.2h

    最新漏洞通报: Openssl多个漏洞安全预警 2016-05-05 18:05:39 一.概述 在OpenSSL官方昨日(2016/5/3)发布的安全公告中,公开了两个新的高危漏洞CVE-2016- ...

  3. centos6.6升级安装MySQL5.5(2015/3/4)

    使用系统CentOS 6.6本来已经系统自带安装了mysql 5.1,但是奈何5.1不支持utf8mb4字符集(详见:http://blog.csdn.net/shootyou/article/det ...

  4. centos6.5 升级安装pcre 8.39版本

    1.查看系统pcre安装情况 rpm -qa pcre 2.卸载系统自带的旧版本 rpm -e --nodeps pcre 3.下载新版安装 地址:ftp://ftp.csx.cam.ac.uk/pu ...

  5. [Linux] centos6.5升级安装的supervisor

    因为我要用它来管理多个PHP进程去执行任务,在默认版本下的配置多个子进程不起作用 默认版本的supervisor版本比较低2.1.9,对于运行多个子进程貌似有问题,最新版的supervisor4.1的 ...

  6. ubuntu-14.04.5 升级sshd到指定版本openssh-7.7p1,openssl-1.1.0h。

    升级步骤 wget https://wps-oss.oss-cn-shenzhen.aliyuncs.com/openssh_update.tar.gz tar xvf openssh_update. ...

  7. 【PHP升级】CentOS6.3编译安装 PHP5.4.38

    先前安装的PHP5.3.28(参考:CentOS6.3编译安装Nginx1.4.7 + MySQL5.5.25a + PHP5.3.28),现在准备升级PHP到5.4.38,有如下几个地方需要重新编译 ...

  8. CentOS6.5升级手动安装GCC4.8.2 与 CentOS 6.4 编译安装 gcc 4.8.1

    http://blog.163.com/zhu329599788@126/blog/static/6669335020161179259975 http://www.cnblogs.com/codem ...

  9. CentOS openssh升级到openssh-7.2版本

    查看现在的版本SSH -V 一.准备 备份ssh目录(重要) cp -rf /etc/ssh /etc/ssh.bak [ 可以现场处理的,不用设置 安装telnet,避免ssh升级出现问题,导致无法 ...

随机推荐

  1. 牛客多校第六场-H-Pair

    链接:https://ac.nowcoder.com/acm/contest/887/H来源:牛客网 题目描述 Given three integers A, B, C. Count the numb ...

  2. kubernetes报错

    错误信息:执行yaml文件后,服务在运行,但是提示命令找不到 原因:没有环境,相当于只有一个快捷方式 环境目录为/usr/local/bin 解决办法:将/etc/ansible/bin下的文件都拷贝 ...

  3. mongodb的学习 (1)

    1. 启动服务 (1)在D盘下新建mongodb 文件夹,在mongodb 文件夹里面新建db; (2)win+R 启动cmd ,输入 `mongod --dbpath "D:/mongod ...

  4. SDK打开模拟器遇到SDK包里缺少API组件,附上我的解决历程,心累

    背景描述:之前一直用真机做自动化,突然被要求用模拟器,就开始准备环境,发现模拟器里少很多配置,前提:配置了Android环境变量,且配置了代理如下:大连东软信息学院镜像服务器地址:http://mir ...

  5. (微服务架构)Security + Oauth2 + Jwt + Zuul解决微服务系统的安全问题

    前言 之前零零散散的学习过一点鉴权这方面的玩意儿,但自我感觉净他妈整些没用的,看代码还是看不懂,这次我们再统一对其进行学习一下,希望自己掌握这个技能,也希望屏幕面前的你能有点收获 此次的学习周期可能有 ...

  6. Flex布局(二)

    接上一篇,说一下flex布局的实例,转自阮一峰老师的博客

  7. AngularJS 指令实践指南(一)

    指令(Directives)是所有AngularJS应用最重要的部分.尽管AngularJS已经提供了非常丰富的指令,但还是经常需要创建应用特定的指令.这篇教程会为你讲述如何自定义指令,以及介绍如何在 ...

  8. nodejs 内存泄漏

    This looks OK at first glance. We could think that theThing get's overwritten with every invocation ...

  9. Tomcat运行错误示例二

    Tomcat运行错误示例二 当遇到这种错误时,一般是构建路径的问题,按步骤来就好.如图: 点击---->库---->Add Library---->下一步---->选择tomc ...

  10. 利用爬虫爬取指定用户的CSDN博客文章转为md格式,目的是完成博客迁移博文到Hexo等静态博客

    文章目录 功能 爬取的方式: 设置生成的md文件命名规则: 设置md文件的头部信息 是否显示csdn中的锚点"文章目录"字样,以及下面具体的锚点 默认false(因为csdn中是集 ...