关于LegacyExchangeDN的问题
IMCEAEX i NDR
This problem is not common but quite annoying and usually hard to understood by users.
In most cases problem occurs If you remove mailbox and re-create it with the same AD account , for an example after firing and re-hiring of the employee after some time.
It also occurs after migrations.
When user sends an email to a recipient, to which earlier messages was delivered without any problem. Sudennly gets an Non Delivery Report with this content:
Delivery has failed to these recipients or distribution lists::
Test User
The recipient's e-mail address was not found in the recipient's e-mail system. Microsoft Exchange will not try to redeliver this message for you. Please check the e-mail address and try resending this message, or provide the following diagnostic text to your system administrator..
Diagnostic information for administrators:
Generating server: server01.exchange
IMCEAEX_O=Company_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT29_CN=RECIPIENTS_CN=user@xxx.xx
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
And now the question is: Why?
Mailbox exists , got a valid SMTP address, emails from other senders are delivered without any problems …
The trail leads to Outlook and auto completion of addresses. In the cache of sender’s Outlook is stored a old recipient address. When addressing a message, Outlook automatically suggests the address to which was previously sent messages.
For a internal addresses Outlook uses LegacyExchangeDN, and these addresses are stored in Outlook cache. And our recipient has the same SMTP addres , but different LegacyExchangeDN
What is the way out of this situation?
The easiest solution is to delete an old entry from Outlook suggested contacts.
Reselecting recipient from GAL or manual typing address will save correct LegacyExchangeDN to Outlook cache. And the problem wil be solved.
Well, yes but this solution is a bit annoying for users. and, not really works well with a larger number of affected senders.
Second option is to add old legacyExchangeDN as a X500 address to the new mailbox.
In proactive approach we should write down and save this atribute. We can check this with folowing command:
Get-Mailbox user |fl legacyExchangeDN
But usually we do not have such information.
In this case, we can reconstruct the address from NDR.
IMCEAEX_O=Company_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT29_CN=RECIPIENTS_CN=user@xxx.xx
And the X500 address will be look like:
/o=Company/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user
如上内容来自博客:http://exchangeblog.pl/
关于LegacyExchangeDN的问题的更多相关文章
- Exchange Server 2013就地存档
9.1就地存档 就地存档有助于重新获得对组织邮件数据的控制,而无需个人存储 (.pst) 文件,并且允许用户在可通过 Microsoft Outlook 2010及更高版本和 Microsoft Of ...
- User Attributes - Inside Active Directory
User Attributes - Inside Active Directory Related to the book Inside Active Directory, ISBN 0-201-61 ...
- AD属性常量类
参考:http://www.selfadsi.org/user-attributes.htm namespace Common { /// <summary> /// AD中的属性,没有出 ...
- Active Domain中的用户属性
/// <summary> /// AD中的属性,没有出现的后续接着补充 /// </summary> public class LdapUserEntryProperty { ...
- Exchange 退信550 5.1.11 RESOLVER.ADR.ExRecipNotFound
问题描述: 在Exchange 2013环境下,某客户将一个用户的邮箱test@abc.com禁用,过了几天又想连接该邮箱,但是却没有找到禁用的邮箱,然后客户就Enable-MailBox重新创建了一 ...
- Exchange 2013 中 NDR 常见的失败返回状态代码
增强状态代码 描述 可能的原因 其他信息 4.3.1 Insufficient system resources 发生内存不足错误.资源问题(例如磁盘已满)可能导致该问题.您可能会收到内存不足错误,而 ...
- 邮箱的代理发送Send as权限不生效
邮箱的代理发送Sendas权限不生效 最近,有需求为用户添加其它邮箱的代理发送Sendas权限.在Exchange的管理单元里添加完毕后,发现没有效果,客户端提示你没有权限以用户的名义发送邮件 ...
随机推荐
- dataGridViewX操作
private void dataGridView1_RowStateChanged(object sender, DataGridViewRowStateChangedEventArgs e) { ...
- C#实现麦克风採集与播放
在网络聊天系统中.採集麦克风的声音并将其播放出来.是最基础的模块之中的一个.本文我们就介绍怎样高速地实现这个基础模块. 一. 基础知识 有几个与声音採集和播放相关的专业术语必需要先了解一下,否则.后面 ...
- JAVA多线程之Synchronized、wait、notify实例讲解
一.Synchronized synchronized中文解释是同步,那么什么是同步呢,解释就是程序中用于控制不同线程间操作发生相对顺序的机制,通俗来讲就是2点,第一要有多线程,第二当多个线程同时竞争 ...
- C# fixed详解
相信很多人在这样或那样的项目中,或者无意间看到了fixed语句块,看到之后你肯定会疑问: 1.这个fixed关键字是做什么用的? 2.什么情况下需要该关键字? 3.这个关键字该怎么用? 我相信解决了上 ...
- sass 的使用
普通变量 ? 1 $fontSize:12px; 默认变量 ? 1 $fontSize:12px; !default; 变量覆盖:只需要在默认变量之前重新声明下变量即可 ? 1 2 $fontSize ...
- 部署静态页面到nginx
1.将页面上传到某个位置.比如:/home/myapp/navi 2. server_name localhost; localhost 更换为自己的域名 3.更改配置文件./usr/local/n ...
- NSURLErrorDomain Code=-999(转)
原文:http://www.henishuo.com/nsurlerrordomain-code-999/ 前言 今天有一个线上bug,是分配给提供H5的团队的,但是后台查不出来原因.于是让前端iOS ...
- core2.1独立布署,报错的原因。
除了所有的.dll和exe 还有一个特别重要的文件.deps.json,
- php7 安装扩展
安装mongodb扩展 前提:安装好php7,位置:/usr/local/php 方法一: /usr/local/php7/bin/pecl install mongodb service php-f ...
- php7 扩展模块添加
php 扩展模块添加 1. 新增安装扩展模块的位置 [root@node_22 ~]# ls /usr/local/php7/lib/php/extensions/no-debug-non-zts ...